]> git.pld-linux.org Git - packages/cacti-spine.git/blob - cacti-spine.spec
- fix amd64
[packages/cacti-spine.git] / cacti-spine.spec
1 Summary:        A backend data gatherer for cacti
2 Name:           cacti-cactid
3 Version:        0.8.6f
4 Release:        0.1
5 License:        GPL
6 Group:          Applications
7 Source0:        http://www.cacti.net/downloads/cactid/%{name}-%{version}.tar.gz
8 # Source0-md5:  2b102f9029ffaa4fb0e186c6640b1851
9 Source1:        %{name}.init
10 Source2:        %{name}.sysconfig
11 URL:            http://www.cacti.net/
12 BuildRequires:  automake
13 BuildRequires:  mysql-devel
14 BuildRequires:  net-snmp-devel
15 BuildRequires:  openssl-devel
16 BuildRequires:  zlib-devel
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 A backend data gatherer for cacti. This package represents the future
21 replacement for cacti's cmd.php. It is almost 100% compatible with the
22 legacy cmd.php processor.
23
24 %prep
25 %setup -q
26
27 %build
28 install /usr/share/automake/config.* config
29 %configure \
30         --with-mysql \
31         --with-snmp=%{_prefix}
32 %{__make}
33
34 %install
35 rm -rf $RPM_BUILD_ROOT
36 install -d $RPM_BUILD_ROOT%{_sysconfdir}/{rc.d/init.d,sysconfig}
37
38 %{__make} install \
39         DESTDIR=$RPM_BUILD_ROOT
40
41 install cactid.conf $RPM_BUILD_ROOT%{_sysconfdir}
42 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/cactid
43 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/cactid
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %post
49 /sbin/chkconfig --add cactid
50 if [ -f /var/lock/subsys/cactid ]; then
51         /etc/rc.d/init.d/cactid restart 1>&2
52 else
53         echo "Run \"/etc/rc.d/init.d/cactid start\" to start cactid daemon."
54 fi
55
56 %preun
57 if [ "$1" = "0" ]; then
58         if [ -f /var/lock/subsys/cactid ]; then
59                 /etc/rc.d/init.d/cactid stop 1>&2
60         fi
61         /sbin/chkconfig --del cactid
62 fi
63
64
65 %files
66 %defattr(644,root,root,755)
67 %doc CHANGELOG README
68 %attr(755,root,root) %{_bindir}/*
69 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cactid.conf
70 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sysconfig/cactid
71 %attr(754,root,root) /etc/rc.d/init.d/cactid
This page took 0.081155 seconds and 4 git commands to generate.