]> git.pld-linux.org Git - packages/bullet.git/blob - bullet.spec
- initial,
[packages/bullet.git] / bullet.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %bcond_without  tests           # build without tests
5 #
6 %define         patch   -beta1
7
8 Summary:        Bullet
9 Summary(pl.UTF-8):      Bullet
10 Name:           bullet
11 Version:        2.74
12 Release:        0.1
13 License:        GPL
14 Group:          Applications
15 Source0:        http://bullet.googlecode.com/files/%{name}-%{version}%{patch}.tgz
16 # Source0-md5:  7c3daad95d1a07be0fea35aaa9c67db7
17 #Source1:       -
18 # Source1-md5:  -
19 #Patch0:                %{name}-DESTDIR.patch
20 URL:            -
21 %if %{with initscript}
22 BuildRequires:  rpmbuild(macros) >= 1.228
23 Requires(post,preun):   /sbin/chkconfig
24 %endif
25 #BuildRequires: -
26 #BuildRequires: autoconf
27 #BuildRequires: automake
28 #BuildRequires: intltool
29 #BuildRequires: libtool
30 #Requires(postun):      -
31 #Requires(pre,post):    -
32 #Requires(preun):       -
33 #Requires:      -
34 #Provides:      -
35 #Provides:      group(foo)
36 #Provides:      user(foo)
37 #Obsoletes:     -
38 #Conflicts:     -
39 #BuildArch:     noarch
40 #ExclusiveArch: %{ix86}
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44
45 %description -l pl.UTF-8
46
47 %package subpackage
48 Summary:        -
49 Summary(pl.UTF-8):      -
50 Group:          -
51
52 %description subpackage
53
54 %description subpackage -l pl.UTF-8
55
56 %package libs
57 Summary:        -
58 Summary(pl.UTF-8):      -
59 Group:          Libraries
60
61 %description libs
62
63 %description libs -l pl.UTF-8
64
65 %package devel
66 Summary:        Header files for ... library
67 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki ...
68 Group:          Development/Libraries
69 # if base package contains shared library for which these headers are
70 #Requires:      %{name} = %{version}-%{release}
71 # if -libs package contains shared library for which these headers are
72 #Requires:      %{name}-libs = %{version}-%{release}
73
74 %description devel
75 Header files for ... library.
76
77 %description devel -l pl.UTF-8
78 Pliki nagłówkowe biblioteki ....
79
80 %package static
81 Summary:        Static ... library
82 Summary(pl.UTF-8):      Statyczna biblioteka ...
83 Group:          Development/Libraries
84 Requires:       %{name}-devel = %{version}-%{release}
85
86 %description static
87 Static ... library.
88
89 %description static -l pl.UTF-8
90 Statyczna biblioteka ....
91
92 %prep
93 %setup -q
94
95 %build
96 ./autogen.sh
97 %configure
98 %{__make}
99
100 #%{__make} \
101 #       CFLAGS="%{rpmcflags}" \
102 #       LDFLAGS="%{rpmldflags}"
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106 # create directories if necessary
107 #install -d $RPM_BUILD_ROOT
108 #install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
109
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %pre
117 %groupadd -g xxx %{name}
118 %useradd -u xxx -d /var/lib/%{name} -g %{name} -c "XXX User" %{name}
119
120 %post
121
122 %preun
123
124 %postun
125 if [ "$1" = "0" ]; then
126         %userremove %{name}
127         %groupremove %{name}
128 fi
129
130 %if %{with ldconfig}
131 %post   -p /sbin/ldconfig
132 %postun -p /sbin/ldconfig
133 %endif
134
135 %if %{with initscript}
136 %post init
137 /sbin/chkconfig --add %{name}
138 %service %{name} restart
139
140 %preun init
141 if [ "$1" = "0" ]; then
142         %service -q %{name} stop
143         /sbin/chkconfig --del %{name}
144 fi
145 %endif
146
147 %files
148 %defattr(644,root,root,755)
149 %doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
150
151 %if 0
152 # if _sysconfdir != /etc:
153 #%%dir %{_sysconfdir}
154 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
155 %attr(755,root,root) %{_bindir}/*
156 %{_datadir}/%{name}
157 %endif
158
159 # initscript and its config
160 %if %{with initscript}
161 %attr(754,root,root) /etc/rc.d/init.d/%{name}
162 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
163 %endif
164
165 #%{_examplesdir}/%{name}-%{version}
166
167 %if %{with subpackage}
168 %files subpackage
169 %defattr(644,root,root,755)
170 #%doc extras/*.gz
171 #%{_datadir}/%{name}-ext
172 %endif
This page took 0.08722 seconds and 4 git commands to generate.