]> git.pld-linux.org Git - packages/boost.git/blob - boost.spec
- next part of cleanups
[packages/boost.git] / boost.spec
1 #
2 # Conditional build:
3 %bcond_without  python  # with boost-python support (not working now)
4 #
5 %define _ver    1.31.0
6 %define _fver   %(echo %{_ver} | tr . _)
7
8 Summary:        The Boost C++ Libraries
9 Summary(pl):    Biblioteki C++ "Boost"
10 Name:           boost
11 Version:        %{_ver}
12 Release:        0.1
13 License:        Boost Software License and others
14 Group:          Libraries
15 Source0:        http://dl.sourceforge.net/boost/%{name}_%{_fver}.tar.bz2
16 # Source0-md5:  8cc183538eaa5cfc53d88d0e94bd2fd4
17 URL:            http://www.boost.org/
18 BuildRequires:  boost-jam >= 3.1.3
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  perl-base
21 %{?with_python:BuildRequires:   python-devel >= 2.2}
22 BuildConflicts: gcc = 5:3.3.1
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 The Boost web site provides free peer-reviewed portable C++ source
27 libraries. The emphasis is on libraries which work well with the C++
28 Standard Library. One goal is to establish "existing practice" and
29 provide reference implementations so that the Boost libraries are
30 suitable for eventual standardization. Some of the libraries have
31 already been proposed for inclusion in the C++ Standards Committee's
32 upcoming C++ Standard Library Technical Report.
33
34 %description -l pl
35 Strona http://www.boost.org/ dostarcza darmowe biblioteki C++ wraz z
36 kodem ¼ród³owym. Nacisk po³o¿ono na biblioteki, które dobrze
37 wspó³pracuj± ze standardow± bibliotek± C++. Celem jest ustanowienie
38 "isniej±cej praktyki" i dostarczenie implementacji, tak ¿e biblioteki
39 "Boost" nadaj± siê do ewentualnej standaryzacji. Niektóre z bibliotek
40 ju¿ zosta³y zg³oszone do komitetu standaryzacyjnego C++ w nadchodz±cym
41 Raporcie Technicznym Biblioteki Standardowej C++
42
43 %package devel
44 Summary:        Boost C++ development libraries and headers
45 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne Boost C++
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 # req'd by <boost/iterator_adaptors.hpp> (also included by <boost/signal.h>)
49 Requires:       %{name}-compressed_pair-devel = %{version}-%{release}
50 Requires:       %{name}-concept_check-devel = %{version}-%{release}
51 Requires:       libstdc++-devel
52
53 %description devel
54 Headers and static libraries for the Boost C++ libraries.
55
56 %description devel -l pl
57 Pliki nag³ówkowe i biblioteki statyczne bibliotek Boost C++.
58
59 %package static
60 Summary:        Static versions of Boost libraries
61 Summary(pl):    Statyczne wersje bibliotek Boost
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{version}-%{release}
64
65 %description static
66 Static versions of Boost libraries.
67
68 %description static -l pl
69 Statyczne wersje bibliotek Boost.
70
71 %package python
72 Summary:        Boost.Python library
73 Summary(pl):    biblioteka Boost.Python
74 Group:          Libraries
75 Requires:       %{name} = %{version}-%{release}
76 %pyrequires_eq  python
77
78 %description python
79 Use the Boost Python Library to quickly and easily export a C++
80 library to Python such that the Python interface is very similar to
81 the C++ interface. It is designed to be minimally intrusive on your
82 C++ design. In most cases, you should not have to alter your C++
83 classes in any way in order to use them with Boost.Python. The system
84 should simply ``reflect'' your C++ classes and functions into Python.
85
86 %description python -l pl
87 Biblioteka Boost Python s³u¿y do szybkiego i prostego eksportu
88 biblioteki C++ do Pythona, tak ¿e interfejs Pythona jest bardzo
89 podobny do interfejsu C++. Biblioteka jest zaprojektowana tak, ¿eby
90 narzucaæ jak najmniej wymagañ dotycz±cych konstrukcjii C++. W
91 wiêkszo¶ci przypadków nie trzeba w ogóle zmieniaæ w³asnych klas C++,
92 ¿eby u¿ywaæ ich z Boost.Python. System powinien po prostu ,,odbiæ''
93 klasy C++ i funkcje do Pythona.
94
95 %package python-devel
96 Summary:        Boost.Python development headers
97 Summary(pl):    Pliki nag³ówkowe dla Boost.Python
98 Group:          Development/Libraries
99 Requires:       %{name}-devel = %{version}-%{release}
100 Requires:       %{name}-python = %{version}-%{release}
101
102 %description python-devel
103 Headers for the Boost.Python library.
104
105 %description python-devel -l pl
106 Pliki nag³ówkowe dla biblioteki Boost.Python.
107
108 %package python-static
109 Summary:        Static version of Boost.Python library
110 Summary(pl):    Statyczna wersja biblioteki Boost.Python
111 Group:          Development/Libraries
112 Requires:       %{name}-python-devel = %{version}-%{release}
113
114 %description python-static
115 Static version of Boost.Python library.
116
117 %description python-static -l pl
118 Statyczna wersja biblioteki Boost.Python.
119
120 %package regex
121 Summary:        Boost C++ regular expressions library
122 Summary(pl):    Biblioteka wyra¿eñ regularnych Boost C++
123 Group:          Libraries
124 Requires:       %{name} = %{version}-%{release}
125
126 %description regex
127 Shared library for Boost C++ regular expressions.
128
129 %description regex -l pl
130 Biblioteka wyra¿eñ regularnych dla C++, biblioteki dzielone.
131
132 %package regex-devel
133 Summary:        Boost C++ Regex library headers
134 Summary(pl):    Pliki nag³ówkowe Boost C++ Regex
135 Group:          Development/Libraries
136 Requires:       %{name}-devel = %{version}-%{release}
137 Requires:       %{name}-regex = %{version}-%{release}
138
139 %description regex-devel
140 Boost C++ Regex headers.
141
142 %description regex-devel -l pl
143 Pliki nag³ówkowe dla Boost C++ Regex.
144
145 %package regex-static
146 Summary:        Boost C++ Regex static libraries
147 Summary(pl):    Biblioteki statyczne Boost C++ Regex
148 Group:          Development/Libraries
149 Requires:       %{name}-devel = %{version}-%{release}
150 Requires:       %{name}-regex = %{version}-%{release}
151
152 %description regex-static
153 Boost C++ Regex static libraries.
154
155 %description regex-static -l pl
156 Biblioteki statyczne dla Boost C++ Regex.
157
158 %package any-devel
159 Summary:        Header for Boost C++ "Any" Library
160 Summary(pl):    Plik nag³ówkowy dla biblioteki Boost C++ "Any"
161 Group:          Development/Libraries
162 Requires:       %{name}-devel = %{version}-%{release}
163
164 %description any-devel
165 The boost::any class, is a variant value type, which supports copying
166 of any value type and safe checked extraction of that value strictly
167 against that type.
168
169 I.e. 5 is held strictly as an int and is not implicitly convertible
170 either to "5" or to 5.0.
171
172 %description any-devel -l pl
173 Klasa boost::any jest typem, który umo¿liwia kopiowanie ze zmiennej
174 dowolnego typu i bezpieczne, sprawdzone wydobycie jej warto¶ci
175 dok³adnie tego samego typu.
176
177 Np. 5 jest trzymane jako int i nie jest niejawnie konwertowalne ani do
178 "5" ani do 5.0.
179
180 %package array-devel
181 Summary:        STL compliant container wrapper for arrays of constant size
182 Summary(pl):    Wrapper na STLowe kontenery dla tablic o sta³ym rozmiarze
183 Group:          Development/Libraries
184 Requires:       %{name}-devel = %{version}-%{release}
185
186 %description array-devel
187 As replacement for ordinary arrays, the STL provides class vector<>.
188 However, vector<> provides the semantics of dynamic arrays. Thus, it
189 manages data to be able to change the number of elements. This results
190 in some overhead in case only arrays with static size are needed. This
191 library provides support for such static size arrays.
192
193 %description array-devel -l pl
194 STL dostarcza klasê vector<> jako zamiennik zwyk³ej tablicy. Jednak
195 vector<> dostarcza semantykê dynamicznych tablic. Zatem zarz±dza
196 danymi tak, by by³a mo¿liwa zmiana ilo¶ci elementów. To skutkuje
197 pewnym nadmiarem w przypadku kiedy tylko tablice o sta³ym rozmiarze s±
198 potrzebne. Ta biblioteka dostarcza wsparcie dla takich w³a¶nie tablic
199 o sta³ym rozmiarze.
200
201 %package bind-devel
202 Summary:        Generalized binders for function/object/pointers
203 Summary(pl):    Uogólnione bindery dla funkcji/obiektów/wska¼ników
204 Group:          Development/Libraries
205 Requires:       %{name}-mem_fn-devel = %{version}-%{release}
206 Requires:       %{name}-ref-devel = %{version}-%{release}
207
208 %description bind-devel
209 boost::bind is a generalization of the standard functions std::bind1st
210 and std::bind2nd.
211
212 %description bind-devel -l pl
213 boost::bind jest uogólnieniem standardowych funkcji std::bind1st i
214 std::bind2nd.
215
216 %package call_traits-devel
217 Summary:        Defines types for passing parameters
218 Summary(pl):    Definiowanie typów dla przekazywania parametrów
219 Group:          Development/Libraries
220 Requires:       %{name}-devel = %{version}-%{release}
221 Requires:       %{name}-type_traits-devel = %{version}-%{release}
222
223 %description call_traits-devel
224 boost::call_traits<T> encapsulates the "best" method to pass a
225 parameter of some type T to or from a function. The purpose of
226 call_traits is to ensure that problems like "references to references"
227 never occur, and that parameters are passed in the most efficient
228 manner possible.
229
230 %description call_traits-devel -l pl
231 boost::call_traits<T> zawiera "najlepsz±" metodê przekazywania
232 parametrów jakiego¶ typu T do lub z funkcji. Celem call_traits jest
233 zapewnienie ¿e problemy takie jak "referencja referencji" nigdy nie
234 wyst±pi± i ¿e parametry s± przekazywane w mo¿liwie najbardziej
235 efektywny sposób.
236
237 %package compatibility-devel
238 Summary:        Help for non-conforming standard libraries
239 Summary(pl):    Pomoc dla nie trzymaj±cych standardu bibliotek
240 Group:          Development/Libraries
241 Requires:       %{name}-devel = %{version}-%{release}
242
243 %description compatibility-devel
244 This library provides workarounds which allow the other Boost
245 libraries to be used on otherwise non-conforming platforms.
246
247 %description compatibility-devel -l pl
248 Biblioteka dostarcza obej¶cie problemu platform nie trzymaj±cych
249 standardu C++, pozwalaj±ce na u¿ywanie bibliotek Boost na tych
250 platformach.
251
252 %package compose-devel
253 Summary:        Functional composition adapters for the STL
254 Summary(pl):    Funkcjonalne adaptery kompozycji dla STL
255 Group:          Development/Libraries
256 Requires:       %{name}-devel = %{version}-%{release}
257
258 %description compose-devel
259 The boost::compose provides compose function object adapter extensions
260 for use with the Standard Template Library (STL) portion of the C++
261 Standard Library. If you aren't currently using the STL, this library
262 won't be of any interest, but hard-core STL users will appreciate its
263 usefulness.
264
265 %description compose-devel -l pl
266 boost::compose dostarcza rozszerzenie adaptera obiektu funkcji compose
267 do u¿ytku z STL-ow± czê¶ci± Standardu C++. Je¿eli nie u¿ywasz STL,
268 biblioteka bêdzie poza twoim zainteresowaniem, lecz hardkorowi
269 u¿ytkownicy STL-a doceni± jej u¿yteczno¶æ.
270
271 %package compressed_pair-devel
272 Summary:        Empty member optimization
273 Summary(pl):    Optymalizacja pustego elementu
274 Group:          Development/Libraries
275 Requires:       %{name}-call_traits-devel = %{version}-%{release}
276 Requires:       %{name}-devel = %{version}-%{release}
277
278 %description compressed_pair-devel
279 The class boost::compressed_pair is very similar to std::pair, but if
280 either of the template arguments are empty classes, then the "empty
281 base-class optimisation" is applied to compress the size of the pair.
282
283 %description compressed_pair-devel -l pl
284 Klasa boost::compressed_pair jest bardzo podobna do std::pair, ale
285 je¿eli który¶ z argumentów wzorca jest pust± klas±, wtedy stosowana
286 jest "optymalizacja pustej klasy bazowej" do kompresji pary.
287
288 %package concept_check-devel
289 Summary:        Tools for generic programming
290 Summary(pl):    Narzêdzia dla programowania generycznego
291 Group:          Development/Libraries
292 Requires:       %{name}-static_assert-devel = %{version}-%{release}
293 Requires:       %{name}-type_traits-devel = %{version}-%{release}
294
295 %description concept_check-devel
296 The boost::concept_check library provides various tools for generic
297 programming.
298
299 %description concept_check-devel -l pl
300 Biblioteka boost::concept_check dostarcza ró¿ne narzêdzia dla
301 programowania generycznego.
302
303 %package conversion-devel
304 Summary:        Numeric, polymorphic, and lexical casts
305 Summary(pl):    Numeryczne, polimorficzne i leksykalne rzutowania
306 Group:          Development/Libraries
307 Requires:       %{name}-type_traits-devel = %{version}-%{release}
308
309 %description conversion-devel
310 The boost::conversion library improves program safety and clarity by
311 performing otherwise messy conversions. It includes cast-style
312 function templates designed to complement the C++ Standard's built-in
313 casts.
314
315 %description conversion-devel -l pl
316 Biblioteka boost::conversion zwiêksza bezpieczeñstwo i klarowno¶æ
317 programu dokonuj±c konwersji które s± w innych przypadkach niechlujne.
318 Biblioteka zawiera "rzutopodobne" wzorce funkcji uzupe³niaj±ce
319 wbudowane w Standard C++ rzutowania.
320
321 %package crc-devel
322 Summary:        CRC computing library
323 Summary(pl):    Biblioteka obliczaj±ca CRC
324 Group:          Development/Libraries
325 Requires:       %{name}-devel = %{version}-%{release}
326
327 %description crc-devel
328 The boost::crc library provides two implementations of CRC computation
329 objects and functions. The implementations are template-based.
330
331 %description crc-devel -l pl
332 Bibliteka boost::crc dostarcza dwie implementacje obiektów i funkcji
333 obliczaj±cych CRC. Implementacje s± oparte na wzorcach.
334
335 %package date_time
336 Summary:        Date-Time library
337 Summary(pl):    Biblioteka daty-czasu
338 Group:          Libraries
339
340 %description date_time
341 A set of date-time libraries.
342
343 %description date_time -l pl
344 Zbiór bibliotek daty-czasu.
345
346 %package date_time-devel
347 Summary:        Header files for boost::date_time library
348 Summary(pl):    Pliki nag³ówkowe dla biblioteki boost::date_time
349 Group:          Development/Libraries
350 Requires:       %{name}-date_time = %{version}-%{release}
351 #TODO: make decision if do separate packages include it to main devel package
352 #Requires:      %{name}-operators-devel = %{version}-%{release}
353 #Requires:      %{name}-integer-devel = %{version}-%{release}
354 #Requires:      %{name}-tokenizer-devel = %{version}-%{release}
355 Requires:       %{name}-conversion-devel = %{version}-%{release}
356
357 %description date_time-devel
358 Header files for boost::date_time library.
359
360 %description date_time-devel -l pl
361 Pliki nag³ówkowe dla biblioteki boost::date_time
362
363 %package date_time-static
364 Summary:        Static boost::date_time library
365 Summary(pl):    Statyczna biblioteka boost::date_time
366 Group:          Development/Libraries
367 Requires:       %{name}-date_time-devel = %{version}-%{release}
368
369 %description date_time-static
370 Static boost::date_time library.
371
372 %description date_time-devel -l pl
373 Statyczna biblioteka boost::date_time.
374
375 %package mem_fn-devel
376 Summary:        Generalized binders for member functions
377 Summary(pl):    Uogólnione bindery dla metod
378 Group:          Development/Libraries
379 Requires:       %{name}-bind-devel = %{version}-%{release}
380
381 %description mem_fn-devel
382 boost::mem_fn is a generalization of the standard functions
383 std::mem_fun and std::mem_fun_ref.
384
385 %description mem_fn-devel -l pl
386 boost::mem_fn jest uogólnieniem standardowych funkcji std::mem_fun i
387 std::mem_fun_ref.
388
389 %package mpl-devel
390 Summary:        Compile-time algorithms, sequences and metafunction classes
391 Summary(pl):    Algorytmy czasu kompilacji, sekwencji i klas metafunkcji
392 Group:          Development/Libraries
393 Requires:       %{name}-devel = %{version}-%{release}
394 Requires:       %{name}-preprocessor-devel = %{version}-%{release}
395 Requires:       %{name}-type_traits-devel = %{version}-%{release}
396 Requires:       %{name}-utility-devel = %{version}-%{release}
397
398 %description mpl-devel
399 The boost-mpl library is a C++ template metaprogramming framework of
400 compile-time algorithms, sequences and metafunction classes.
401
402 %description mpl-devel -l pl
403 Biblioteka boost-mpl jest szkieletem wzorców C++ dla algorytmów czasu
404 kompilacji, sekwencji i klas metafunkcji.
405
406 %package preprocessor-devel
407 Summary:        Preprocessor metaprogramming tools including repetition and recursion
408 Summary(pl):    Narzêdzia metaprogramowania preprocesora razem z repetycj± i rekursj±
409 Group:          Development/Libraries
410 Requires:       %{name}-devel = %{version}-%{release}
411
412 %description preprocessor-devel
413 This library provides preprocessor metaprogramming tools, including
414 repetition and recursion.
415
416 %description preprocessor-devel -l pl
417 Biblioteka udostêpnia narzêdzia metaprogramowania preprocesora,
418 w³±czaj±c w to repetycje i rekursjê.
419
420 %package ref-devel
421 Summary:        Small library useful for passing references to function templates
422 Summary(pl):    Ma³a biblioteka u¿yteczna przy przekazywaniu referencji do wzorców funkcji
423 Group:          Development/Libraries
424 Requires:       %{name}-devel = %{version}-%{release}
425 Requires:       %{name}-mpl-devel = %{version}-%{release}
426 Requires:       %{name}-utility-devel = %{version}-%{release}
427
428 %description ref-devel
429 boost::ref library is a small library that is useful for passing
430 references to function templates (algorithms) that would usually take
431 copies of their arguments.
432
433 %description ref-devel -l pl
434 Biblioteka boost::ref jest ma³± bibliotek± która jest u¿yteczna w
435 przypadku przekazywania referencji do wzorców funkcji (algorytmów)
436 które zazwyczaj bior± kopiê swoich argumentów.
437
438 %package signals
439 Summary:        signals & slots callback implementation
440 Summary(pl):    implementacja sygna³ów i slotów
441 Group:          Libraries
442
443 %description signals
444 The boost::signals library is an implementation of a signals and slots
445 system.
446
447 %description signals -l pl
448 Biblioteka boost::signals jest implementacj± systemu sygna³ów i
449 slotów.
450
451 %package signals-devel
452 Summary:        Header files for boost::signals library
453 Summary(pl):    Pliki nag³ówkowe dla biblioteki boost::signals
454 Group:          Development/Libraries
455 Requires:       %{name}-any-devel = %{version}-%{release}
456 #TODO: separate smart_ptr or include to the main devel package
457 #Requires:      %{name}-iterator_adaptors-devel = %{version}-%{release}
458 #Requires:      %{name}-operators-devel = %{version}-%{release}
459 #Requires:      %{name}-smart_ptr-devel = %{version}-%{release}
460 Requires:       %{name}-mem_fn-devel = %{version}-%{release}
461 Requires:       %{name}-ref-devel = %{version}-%{release}
462 Requires:       %{name}-type_traits-devel = %{version}-%{release}
463 Requires:       %{name}-utility-devel = %{version}-%{release}
464
465 %description signals-devel
466 Header files for boost::signals library.
467
468 %description signals-devel -l pl
469 Pliki nag³ówkowe dla biblioteki boost::signals.
470
471 %package signals-static
472 Summary:        Static library for boost::signals
473 Summary(pl):    Biblioteka statyczna dla boost::signals
474 Group:          Development/Libraries
475 Requires:       %{name}-signals-devel = %{version}-%{release}
476
477 %description signals-static
478 Static library for boost::signals.
479
480 %description signals-static -l pl
481 Biblioteka statyczna dla boost::signals.
482
483 %package static_assert-devel
484 Summary:        Static assertions (compile time assertions)
485 Summary(pl):    Statyczne asercje (asercje kompilacyjne)
486 Group:          Development/Libraries
487 Requires:       %{name}-devel = %{version}
488
489 %description static_assert-devel
490 The header <boost/static_assert.hpp> supplies a single macro
491 BOOST_STATIC_ASSERT(x), which generates a compile time error message
492 if the integral-constant-expression x is not true. In other words it
493 is the compile time equivalent of the assert macro; this is sometimes
494 known as a "compile-time-assertion"
495
496 One of the aims of BOOST_STATIC_ASSERT is to generate readable error
497 messages. These immediately tell the user that a library is being used
498 in a manner that is not supported.
499
500 %description static_assert-devel -l pl
501 Plik nag³ówkowy <boost/static_assert.hpp> dostarcza pojedyncze makro
502 BOOST_STATIC_ASSERT(x), które generuje komunikat b³êdu kompilacji
503 je¿eli sta³e wyra¿enie x nie jest prawdziwe. Innymi s³owy jest to
504 kompilacyjny ekwiwalent makra 'assert'; czasami znane jest jako
505 "asercja czasu kompilacji"
506
507 Jednym z celów BOOST_STATIC_ASSERT jest generowanie czytelnych
508 komunikatów o b³êdach. One b³yskawicznie powiedz± u¿ytkownikowi ¿e
509 biblioteka zosta³a u¿yta w sposób który nie jest zalecany.
510
511 %package thread
512 Summary:        Portable C++ threads library
513 Summary(pl):    Przeno¶na biblioteka w±tków C++
514 Group:          Libraries
515
516 %description thread
517 Portable C++ threads library - shared library.
518
519 %description thread -l pl
520 Przeno¶na biblioteka w±tków dla C++ - biblioteka dzielona.
521
522 %package thread-devel
523 Summary:        Header files for boost::thread library
524 Summary(pl):    Pliki nag³ówkowe dla biblioteki boost::thread
525 Group:          Development/Libraries
526 Requires:       %{name}-thread = %{version}-%{release}
527 Requires:       %{name}-utility-devel = %{version}-%{release}
528 #TODO:requires boost::function or boost::function to boost-devel
529
530 %description thread-devel
531 Header files for boost::thread library.
532
533 %description thread-devel -l pl
534 Pliki nag³ówkowe dla biblioteki boost::thread.
535
536 %package type_traits-devel
537 Summary:        Templates for fundamental properties of types
538 Summary(pl):    Wzorce dla fundamentalnych w³a¶ciwo¶ci typów
539 Group:          Development/Libraries
540 Requires:       %{name}-devel = %{version}-%{release}
541 Requires:       %{name}-mpl-devel = %{version}-%{release}
542 Requires:       %{name}-preprocessor-devel = %{version}-%{release}
543 Requires:       %{name}-static_assert-devel = %{version}-%{release}
544 Requires:       %{name}-utility-devel = %{version}-%{release}
545
546 %description type_traits-devel
547 The boost-type_traits library defines three kinds of type trait:
548  1. The properties of a specific type.
549  2. The relationship between two types.
550  3. A transformation from one type to another.
551
552 %description type_traits-devel -l pl
553 Biblioteka boost-type_traits definiuje trzy rodzaje cech typów:
554  1. w³a¶ciwo¶ci konkretnego typu.
555  2. powi±zania miêdzy dwoma typami.
556  3. transformacjê z jednego typu do drugiego.
557
558 %package utility-devel
559 Summary:        Useful utilities: classes and function templates
560 Summary(pl):    U¿yteczne narzêdzia: klasy i wzorce funkcji
561 Group:          Development/Libraries
562 Requires:       %{name}-type_traits-devel = %{version}
563
564 %description utility-devel
565 Class noncopyable plus checked_delete(), checked_array_delete(),
566 next(), prior() function templates, plus base-from-member idiom.
567
568 %description utility-devel -l pl
569 Klasy noncopyable i checked_delete, funkcje checked_array_delete(),
570 next(), prior() oraz idiom base-from-member.
571
572 %package doc
573 Summary:        Boost C++ Library documentation
574 Summary(pl):    Dokumentacja dla biblioteki Boost C++
575 Group:          Documentation
576 Requires:       %{name}-devel = %{version}-%{release}
577
578 %description doc
579 Documentation for the Boost C++ Library.
580
581 %description doc -l pl
582 Dokumentacja dla biblioteki Boost C++.
583
584 %prep
585 %setup -q -n %{name}_%{_fver}
586
587 # don't know how to pass it through (b)jam -s (no way?)
588 # due to oversophisticated build flags system
589 %{__perl} -pi -e 's/ -O3 / %{rpmcflags} /' tools/build/gcc-tools.jam
590
591 %build
592 %if %{with python}
593 PYTHON_VERSION=`python -V 2>&1 | sed 's,.* \([0-9]\.[0-9]\)\(\.[0-9]\)\?.*,\1,'`
594 PYTHON_ROOT=%{_prefix}
595 %else
596 PYTHON_ROOT=
597 PYTHON_VERSION=
598 %endif
599 bjam \
600         -d2 \
601         -sBUILD=release \
602         -sPYTHON_ROOT=$PYTHON_ROOT \
603         -sPYTHON_VERSION=$PYTHON_VERSION
604
605 %install
606 rm -rf $RPM_BUILD_ROOT
607 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}}
608
609 cp -rf boost $RPM_BUILD_ROOT%{_includedir}
610
611 install bin/boost/libs/*/build/*.a/*/release/lib*.a $RPM_BUILD_ROOT%{_libdir}
612 install bin/boost/libs/*/build/*.so/*/release/*/{*/,}lib*.so.*.*.* $RPM_BUILD_ROOT%{_libdir}
613 install bin/boost/libs/*/build/*.so/*/release/*/{*/,}lib*.so $RPM_BUILD_ROOT%{_libdir}
614
615 #cp -df libs/*/build/bin/*.so/*/*/*/*/{,*/}lib*.so $RPM_BUILD_ROOT%{_libdir}
616
617 # documentation
618 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}
619 install README $RPM_BUILD_ROOT%{_docdir}/boost-%{version}
620
621 # as the documentation doesn't completely reside in a directory of its
622 # own, we need to find out ourselves... this looks for HTML files and
623 # then collects everything linked from those.  this is certainly quite
624 # unoptimized wrt mkdir calls, but does it really matter?
625 for i in `find -type f -name '*.htm*'`; do
626         # bjam docu is included in the boost-jam RPM
627         if test "`echo $i | sed 's,jam_src,,'`" = "$i"; then
628                 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/`dirname $i`
629                 for LINKED in `%{__perl} - $i $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$i <<'EOT'
630                         sub rewrite_link
631                         {
632                                 my $link = shift;
633                                 # rewrite links from boost/* to %{_includedir}/boost/* and
634                                 # ignore external links as well as document-internal ones.
635                                 # HTML files are also ignored as they get installed anyway.
636                                 if (!($link =~ s,^(?:../)*boost/,%{_includedir}/boost/,) && !($link =~ m,(?:^[^/]+:|^\#|\.html?(?:$|\#)),))
637                                 {
638                                         (my $file = $link) =~ s/\#.*//;
639                                         print "$file\n";
640                                 }
641                                 $link;
642                         }
643                         open IN, @ARGV[0];
644                         open OUT, ">@ARGV[1]";
645                         my $in_link;
646                         while (<IN>)
647                         {
648                                 $in_link and s/^\s*"([^"> ]*)"/'"' . rewrite_link($1) . '"'/e;
649                                 s/(href|src)="([^"> ]*)"/"$1=\"" . rewrite_link($2) . '"'/eig;
650                                 print OUT;
651                                 $in_link = /href|src=\s*$/;
652                         }
653 EOT`; do
654                         TARGET=`dirname $i`/$LINKED
655                         # ignore non-existant linked files
656                         if test -f $TARGET; then
657                                 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/`dirname $TARGET`
658                                 install -m 644 $TARGET $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$TARGET
659                         fi
660                 done
661         fi
662 done
663
664 %clean
665 rm -rf $RPM_BUILD_ROOT
666
667 %post   -p /sbin/ldconfig
668 %postun -p /sbin/ldconfig
669
670 %post   python  -p /sbin/ldconfig
671 %postun python  -p /sbin/ldconfig
672
673 %post   regex   -p /sbin/ldconfig
674 %postun regex   -p /sbin/ldconfig
675
676 %files
677 %defattr(644,root,root,755)
678 %attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor-gcc-1_31.so.*.*.*
679 %attr(755,root,root) %{_libdir}/libboost_test_exec_monitor-gcc-1_31.so.*.*.*
680 %attr(755,root,root) %{_libdir}/libboost_unit_test_framework-gcc-1_31.so.*.*.*
681 %attr(755,root,root) %{_libdir}/libboost_filesystem-gcc-1_31.so.*.*.*
682
683 %files devel
684 %defattr(644,root,root,755)
685 %attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor-gcc-1_31.so
686 %attr(755,root,root) %{_libdir}/libboost_test_exec_monitor-gcc-1_31.so
687 %attr(755,root,root) %{_libdir}/libboost_unit_test_framework-gcc-1_31.so
688 %attr(755,root,root) %{_libdir}/libboost_filesystem-gcc-1_31.so
689 %dir %{_includedir}/boost
690 %{_includedir}/boost/assert.hpp
691 %{_includedir}/boost/blank_fwd.hpp
692 %{_includedir}/boost/config
693 %{_includedir}/boost/config.hpp
694 %{_includedir}/boost/iterator/counting_iterator.hpp
695 %{_includedir}/boost/cstd*.hpp
696 %{_includedir}/boost/current_function.hpp
697 %dir %{_includedir}/boost/detail
698 %{_includedir}/boost/detail/algorithm.hpp
699 %{_includedir}/boost/detail/allocator.hpp
700 %{_includedir}/boost/detail/atomic_count*.hpp
701 %{_includedir}/boost/detail/binary_search.hpp
702 %{_includedir}/boost/detail/catch_exceptions.hpp
703 %{_includedir}/boost/detail/dynamic_bitset.hpp
704 %{_includedir}/boost/detail/is_incrementable.hpp
705 %{_includedir}/boost/detail/iterator.hpp
706 %{_includedir}/boost/detail/lightweight_*.hpp
707 %{_includedir}/boost/detail/limits.hpp
708 %{_includedir}/boost/detail/lwm_*.hpp
709 %{_includedir}/boost/detail/named_template_params.hpp
710 %{_includedir}/boost/detail/numeric_traits.hpp
711 %{_includedir}/boost/detail/reference_content.hpp
712 %{_includedir}/boost/detail/quick_allocator.hpp
713 %{_includedir}/boost/detail/select_type.hpp
714 %{_includedir}/boost/detail/shared_*.hpp
715 %{_includedir}/boost/detail/workaround.hpp
716 %{_includedir}/boost/dynamic_bitset*.hpp
717 %{_includedir}/boost/enable_shared_from_this.hpp
718 %{_includedir}/boost/filesystem
719 %{_includedir}/boost/format
720 %{_includedir}/boost/format.hpp
721 %{_includedir}/boost/function
722 %{_includedir}/boost/function.hpp
723 %{_includedir}/boost/function_output_iterator.hpp
724 %{_includedir}/boost/functional.hpp
725 %{_includedir}/boost/generator_iterator.hpp
726 %{_includedir}/boost/graph
727 %{_includedir}/boost/half_open_range.hpp
728 %{_includedir}/boost/indirect_reference.hpp
729 %{_includedir}/boost/integer
730 %{_includedir}/boost/integer*.hpp
731 %{_includedir}/boost/intrusive_ptr.hpp
732 %{_includedir}/boost/io
733 %{_includedir}/boost/io_fwd.hpp
734 %{_includedir}/boost/iterator*.hpp
735 %{_includedir}/boost/iterator
736 %{_includedir}/boost/lambda
737 %{_includedir}/boost/limits.hpp
738 %{_includedir}/boost/math
739 %{_includedir}/boost/math_fwd.hpp
740 %{_includedir}/boost/multi_array
741 %{_includedir}/boost/multi_array.hpp
742 %{_includedir}/boost/nondet_random.hpp
743 %{_includedir}/boost/non_type.hpp
744 %{_includedir}/boost/numeric
745 %{_includedir}/boost/operators.hpp
746 %{_includedir}/boost/optional.hpp
747 %{_includedir}/boost/pending
748 %{_includedir}/boost/iterator/permutation_iterator.hpp
749 %{_includedir}/boost/pool
750 %{_includedir}/boost/pointee.hpp
751 %{_includedir}/boost/progress.hpp
752 %{_includedir}/boost/property_map*.hpp
753 %{_includedir}/boost/random
754 %{_includedir}/boost/random.hpp
755 %{_includedir}/boost/rational.hpp
756 %{_includedir}/boost/scoped_*.hpp
757 %{_includedir}/boost/shared_*.hpp
758 %{_includedir}/boost/smart_ptr.hpp
759 %{_includedir}/boost/spirit
760 %{_includedir}/boost/spirit.hpp
761 %{_includedir}/boost/test
762 %{_includedir}/boost/throw_exception.hpp
763 %{_includedir}/boost/timer.hpp
764 %{_includedir}/boost/token*.hpp
765 %{_includedir}/boost/tuple
766 %{_includedir}/boost/type.hpp
767 %{_includedir}/boost/type_traits
768 %{_includedir}/boost/utility
769 %{_includedir}/boost/version.hpp
770 %{_includedir}/boost/vector_property_map.hpp
771 %{_includedir}/boost/weak_ptr.hpp
772 #boost::enable_if
773 %{_includedir}/boost/utility/enable_if.hpp
774 #boost::variant
775 %{_includedir}/boost/variant.hpp
776 %{_includedir}/boost/variant
777 %{_includedir}/boost/blank.hpp
778 %{_includedir}/boost/detail/templated_streams.hpp
779 #boost::optional
780 %{_includedir}/boost/aligned_storage.hpp
781 %{_includedir}/boost/detail/in_place_factory*.hpp
782 %{_includedir}/boost/detail/none.hpp
783 %{_includedir}/boost/detail/none_t.hpp
784 %{_includedir}/boost/detail/typed_in_place_factory.hpp
785
786 %files static
787 %defattr(644,root,root,755)
788 %{_libdir}/libboost_prg_exec_monitor-gcc-1_31.a
789 %{_libdir}/libboost_test_exec_monitor-gcc-1_31.a
790 %{_libdir}/libboost_unit_test_framework-gcc-1_31.a
791 %{_libdir}/libboost_filesystem-gcc-1_31.a
792
793 %if %{with python}
794 %files python
795 %defattr(644,root,root,755)
796 %attr(755,root,root) %{_libdir}/libboost_python-gcc-1_31.so.*.*.*
797
798 %files python-devel
799 %defattr(644,root,root,755)
800 %attr(755,root,root) %{_libdir}/libboost_python-gcc-1_31.so
801 %{_includedir}/boost/python
802 %{_includedir}/boost/python.hpp
803
804 %files python-static
805 %defattr(644,root,root,755)
806 %{_libdir}/libboost_python-gcc-1_31.a
807 %endif
808
809 %files regex
810 %defattr(644,root,root,755)
811 %attr(755,root,root) %{_libdir}/libboost_regex-gcc-1_31.so.*.*.*
812
813 %files regex-devel
814 %defattr(644,root,root,755)
815 %attr(755,root,root) %{_libdir}/libboost_regex-gcc-1_31.so
816 %{_includedir}/boost/cregex.hpp
817 %{_includedir}/boost/regex.h
818 %{_includedir}/boost/regex*.hpp
819 %{_includedir}/boost/regex
820
821 %files regex-static
822 %defattr(644,root,root,755)
823 %{_libdir}/libboost_regex-gcc-1_31.a
824
825 %files any-devel
826 %defattr(644,root,root,755)
827 %{_includedir}/boost/any.hpp
828
829 %files array-devel
830 %defattr(644,root,root,755)
831 %{_includedir}/boost/array.hpp
832
833 %files bind-devel
834 %defattr(644,root,root,755)
835 %{_includedir}/boost/bind
836 %{_includedir}/boost/bind.hpp
837
838 %files call_traits-devel
839 %defattr(644,root,root,755)
840 %{_includedir}/boost/call_traits.hpp
841 %{_includedir}/boost/detail/call_traits.hpp
842 %{_includedir}/boost/detail/ob_call_traits.hpp
843
844 %files compatibility-devel
845 %defattr(644,root,root,755)
846 %{_includedir}/boost/compatibility
847
848 %files compose-devel
849 %defattr(644,root,root,755)
850 %{_includedir}/boost/compose.hpp
851
852 %files compressed_pair-devel
853 %defattr(644,root,root,755)
854 %{_includedir}/boost/compressed_pair.hpp
855 %{_includedir}/boost/detail/compressed_pair.hpp
856 %{_includedir}/boost/detail/ob_compressed_pair.hpp
857
858 %files concept_check-devel
859 %defattr(644,root,root,755)
860 %{_includedir}/boost/concept_archetype.hpp
861 %{_includedir}/boost/concept_check.hpp
862
863 %files conversion-devel
864 %defattr(644,root,root,755)
865 %{_includedir}/boost/cast.hpp
866 %{_includedir}/boost/implicit_cast.hpp
867 %{_includedir}/boost/lexical_cast.hpp
868
869 %files crc-devel
870 %defattr(644,root,root,755)
871 %{_includedir}/boost/crc.hpp
872
873 %files date_time
874 %defattr(644,root,root,755)
875 %attr(755,root,root) %{_libdir}/libboost_date_time-gcc-1_31.so.*.*.*
876
877 %files date_time-devel
878 %defattr(644,root,root,755)
879 %attr(755,root,root) %{_libdir}/libboost_date_time-gcc-1_31.so
880 %{_includedir}/boost/date_time
881
882 %files date_time-static
883 %defattr(644,root,root,755)
884 %{_libdir}/libboost_date_time-gcc-1_31.a
885
886 %files mem_fn-devel
887 %defattr(644,root,root,755)
888 %{_includedir}/boost/get_pointer.hpp
889 %{_includedir}/boost/mem_fn.hpp
890
891 %files mpl-devel
892 %defattr(644,root,root,755)
893 %{_includedir}/boost/mpl
894
895 %files preprocessor-devel
896 %defattr(644,root,root,755)
897 %{_includedir}/boost/preprocessor
898 %{_includedir}/boost/preprocessor.hpp
899
900 %files ref-devel
901 %defattr(644,root,root,755)
902 %{_includedir}/boost/ref.hpp
903
904 %files signals
905 %defattr(644,root,root,755)
906 %attr(755,root,root) %{_libdir}/libboost_signals-gcc-1_31.so.*.*.*
907
908 %files signals-devel
909 %defattr(644,root,root,755)
910 %attr(755,root,root) %{_libdir}/libboost_signals-gcc-1_31.so
911 %{_includedir}/boost/signal*.hpp
912 %{_includedir}/boost/signals
913 %{_includedir}/boost/last_value.hpp
914 %{_includedir}/boost/visit_each.hpp
915
916 %files signals-static
917 %defattr(644,root,root,755)
918 %{_libdir}/libboost_signals-gcc-1_31.a
919
920 %files static_assert-devel
921 %defattr(644,root,root,755)
922 %{_includedir}/boost/static_assert.hpp
923
924 %files thread
925 %defattr(644,root,root,755)
926 %attr(755,root,root) %{_libdir}/libboost_thread-gcc-mt-1_31.so.*.*.*
927
928 %files thread-devel
929 %defattr(644,root,root,755)
930 %attr(755,root,root) %{_libdir}/libboost_thread-gcc-mt-1_31.so
931 %{_includedir}/boost/thread
932 %{_includedir}/boost/thread.hpp
933
934 %files type_traits-devel
935 %defattr(644,root,root,755)
936 %{_includedir}/boost/type_traits.hpp
937 %{_includedir}/boost/type_traits
938
939 %files utility-devel
940 %defattr(644,root,root,755)
941 %{_includedir}/boost/checked_delete.hpp
942 %{_includedir}/boost/next_prior.hpp
943 %{_includedir}/boost/noncopyable.hpp
944 %{_includedir}/boost/utility*.hpp
945 %{_includedir}/boost/utility
946
947 %files doc
948 %defattr(644,root,root,755)
949 %{_docdir}/boost-%{version}
This page took 0.520018 seconds and 4 git commands to generate.