]> git.pld-linux.org Git - packages/boost.git/blob - boost.spec
- release 3 (by relup.sh)
[packages/boost.git] / boost.spec
1 #
2 # TODO:
3 #       - think about building MPI.
4 #       - split shared libs from core package into -iostreams/-serialization.
5 #
6 # Conditional build:
7 %bcond_without  python2         # without boost-python2 support
8 %bcond_without  python3         # without boost-python3 support
9
10 %define         fver    %(echo %{version} | tr . _)
11 Summary:        The Boost C++ Libraries
12 Summary(pl.UTF-8):      Biblioteki C++ "Boost"
13 Name:           boost
14 Version:        1.59.0
15 Release:        3
16 License:        Boost Software License and others
17 Group:          Libraries
18 Source0:        http://downloads.sourceforge.net/boost/%{name}_%{fver}.tar.bz2
19 # Source0-md5:  6aa9a5c6a4ca1016edd0ed1178e3cb87
20 Patch0:         %{name}-link.patch
21 Patch1:         %{name}-x32-context.patch
22 Patch2:         %{name}-clean-gcc-flags.patch
23 # FC Patches:
24 # https://svn.boost.org/trac/boost/ticket/5637
25 Patch203:       %{name}-1.54.0-mpl-print.patch
26 # https://svn.boost.org/trac/boost/ticket/8870
27 Patch212:       %{name}-1.54.0-spirit-unused_typedef-2.patch
28 # https://svn.boost.org/trac/boost/ticket/8878
29 Patch218:       %{name}-1.54.0-locale-unused_typedef.patch
30 # https://svn.boost.org/trac/boost/ticket/8881
31 Patch221:       %{name}-1.54.0-mpi-unused_typedef.patch
32 URL:            http://www.boost.org/
33 BuildRequires:  bzip2-devel
34 BuildRequires:  expat-devel
35 BuildRequires:  libicu-devel
36 BuildRequires:  libstdc++-devel
37 BuildRequires:  perl-base
38 %{?with_python:BuildRequires:   python-devel >= 2.2}
39 %{?with_python3:BuildRequires:  python3-devel}
40 BuildRequires:  rpm-pythonprov
41 BuildRequires:  zlib-devel
42 BuildConflicts: gcc = 5:3.3.1
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %define         specflags       -DBOOST_IOSTREAMS_USE_DEPRECATED=1
46
47 %description
48 The Boost web site provides free peer-reviewed portable C++ source
49 libraries. The emphasis is on libraries which work well with the C++
50 Standard Library. One goal is to establish "existing practice" and
51 provide reference implementations so that the Boost libraries are
52 suitable for eventual standardization. Some of the libraries have
53 already been proposed for inclusion in the C++ Standards Committee's
54 upcoming C++ Standard Library Technical Report.
55
56 %description -l pl.UTF-8
57 Strona http://www.boost.org/ dostarcza darmowe biblioteki C++ wraz z
58 kodem źródłowym. Nacisk położono na biblioteki, które dobrze
59 współpracują ze standardową biblioteką C++. Celem jest ustanowienie
60 "istniejącej praktyki" i dostarczenie implementacji, tak że biblioteki
61 "Boost" nadają się do ewentualnej standaryzacji. Niektóre z bibliotek
62 już zostały zgłoszone do komitetu standaryzacyjnego C++ w nadchodzącym
63 Raporcie Technicznym Biblioteki Standardowej C++.
64
65 %package devel
66 Summary:        Boost C++ development headers
67 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek C++ Boost
68 Group:          Development/Libraries
69 Requires:       %{name} = %{version}-%{release}
70 Requires:       %{name}-chrono = %{version}-%{release}
71 Requires:       %{name}-context = %{version}-%{release}
72 Requires:       %{name}-date_time = %{version}-%{release}
73 Requires:       %{name}-filesystem = %{version}-%{release}
74 Requires:       %{name}-graph = %{version}-%{release}
75 Requires:       %{name}-locale = %{version}-%{release}
76 Requires:       %{name}-log = %{version}-%{release}
77 Requires:       %{name}-program_options = %{version}-%{release}
78 Requires:       %{name}-regex = %{version}-%{release}
79 Requires:       %{name}-signals = %{version}-%{release}
80 Requires:       %{name}-system = %{version}-%{release}
81 Requires:       %{name}-test = %{version}-%{release}
82 Requires:       %{name}-thread = %{version}-%{release}
83 Requires:       %{name}-timer = %{version}-%{release}
84 Requires:       %{name}-wave = %{version}-%{release}
85 Requires:       libstdc++-devel
86 Obsoletes:      boost-any-devel
87 Obsoletes:      boost-array-devel
88 Obsoletes:      boost-asio
89 Obsoletes:      boost-bind-devel
90 Obsoletes:      boost-call_traits-devel
91 Obsoletes:      boost-compatibility-devel
92 Obsoletes:      boost-compose-devel
93 Obsoletes:      boost-compressed_pair-devel
94 Obsoletes:      boost-concept_check-devel
95 Obsoletes:      boost-conversion-devel
96 Obsoletes:      boost-crc-devel
97 Obsoletes:      boost-date_time-devel
98 Obsoletes:      boost-filesystem-devel
99 Obsoletes:      boost-graph-devel
100 Obsoletes:      boost-mem_fn-devel
101 Obsoletes:      boost-mpl-devel
102 Obsoletes:      boost-preprocessor-devel
103 Obsoletes:      boost-program_options-devel
104 Obsoletes:      boost-ref-devel
105 Obsoletes:      boost-regex-devel
106 Obsoletes:      boost-signals-devel
107 Obsoletes:      boost-spirit-devel
108 Obsoletes:      boost-statechart-devel
109 Obsoletes:      boost-static_assert-devel
110 Obsoletes:      boost-test-devel
111 Obsoletes:      boost-thread-devel
112 Obsoletes:      boost-tr1-devel
113 Obsoletes:      boost-type_traits-devel
114 Obsoletes:      boost-typeof-devel
115 Obsoletes:      boost-uBLAS-devel
116 Obsoletes:      boost-utility-devel
117 Obsoletes:      boost-wave-devel
118 Obsoletes:      boost-xpressive-devel
119
120 %description devel
121 Header files for the Boost C++ libraries.
122
123 %description devel -l pl.UTF-8
124 Pliki nagłówkowe bibliotek C++ Boost.
125
126 %package static
127 Summary:        Static version of base Boost C++ libraries
128 Summary(pl.UTF-8):      Statyczne wersje podstawowych bibliotek C++ Boost
129 Group:          Development/Libraries
130 Requires:       %{name}-devel = %{version}-%{release}
131 Obsoletes:      boost-static < 1.33
132
133 %description static
134 Static version of base Boost C++ libraries.
135
136 %description static -l pl.UTF-8
137 Statyczne wersje podstawowych bibliotek C++ Boost.
138
139 %package python-devel-common
140 Summary:        Boost.Python development headers
141 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Boost.Python
142 Group:          Development/Libraries
143 Requires:       %{name}-devel = %{version}-%{release}
144
145 %description python-devel-common
146 Headers for the Boost.Python library.
147
148 %description python-devel-common -l pl.UTF-8
149 Pliki nagłówkowe biblioteki Boost.Python.
150
151 %package python
152 Summary:        Boost.Python library for Python 2
153 Summary(pl.UTF-8):      Biblioteka Boost.Python dla Pythona 2
154 Group:          Libraries
155 Requires:       python-libs
156
157 %description python
158 Use the Boost Python Library to quickly and easily export a C++
159 library to Python 2 such that the Python 2 interface is very similar
160 to the C++ interface. It is designed to be minimally intrusive on your
161 C++ design. In most cases, you should not have to alter your C++
162 classes in any way in order to use them with Boost.Python. The system
163 should simply ``reflect'' your C++ classes and functions into Python
164 3.
165
166 %description python -l pl.UTF-8
167 Biblioteka Boost Python służy do szybkiego i prostego eksportu
168 biblioteki C++ do Pythona 2, tak że interfejs Pythona 2 jest bardzo
169 podobny do interfejsu C++. Biblioteka jest zaprojektowana tak, żeby
170 narzucać jak najmniej wymagań dotyczących konstrukcjii C++. W
171 większości przypadków nie trzeba w ogóle zmieniać własnych klas C++,
172 żeby używać ich z Boost.Python. System powinien po prostu ,,odbić''
173 klasy C++ i funkcje do Pythona 3.
174
175 %package python-devel
176 Summary:        Boost.Python development files for Python 2
177 Summary(pl.UTF-8):      Pliki programistyczne biblioteki Boost.Python dla Pythona 2
178 Group:          Development/Libraries
179 Requires:       %{name}-devel = %{version}-%{release}
180 Requires:       %{name}-python = %{version}-%{release}
181 Requires:       %{name}-python-devel-common = %{version}-%{release}
182
183 %description python-devel
184 Boost.Python development files for Python 2.
185
186 %description python-devel -l pl.UTF-8
187 Pliki programistyczne biblioteki Boost.Python dla Pythona 2.
188
189 %package python-static
190 Summary:        Static version of Boost.Python library for Python 2
191 Summary(pl.UTF-8):      Statyczna wersja biblioteki Boost.Python dla Pythona 2
192 Group:          Development/Libraries
193 Requires:       %{name}-python-devel = %{version}-%{release}
194
195 %description python-static
196 Static version of Boost.Python library for Python 2.
197
198 %description python-static -l pl.UTF-8
199 Statyczna wersja biblioteki Boost.Python dla Pythona 2.
200
201 %package python3
202 Summary:        Boost.Python library for Python 3
203 Summary(pl.UTF-8):      biblioteka Boost.Python dla Pythona 3
204 Group:          Libraries
205 Requires:       python3-libs
206
207 %description python3
208 Use the Boost Python Library to quickly and easily export a C++
209 library to Python 3 such that the Python 3 interface is very similar
210 to the C++ interface. It is designed to be minimally intrusive on your
211 C++ design. In most cases, you should not have to alter your C++
212 classes in any way in order to use them with Boost.Python. The system
213 should simply ``reflect'' your C++ classes and functions into Python
214 3.
215
216 %description python3 -l pl.UTF-8
217 Biblioteka Boost Python służy do szybkiego i prostego eksportu
218 biblioteki C++ do Pythona 3, tak że interfejs Pythona 3 jest bardzo
219 podobny do interfejsu C++. Biblioteka jest zaprojektowana tak, żeby
220 narzucać jak najmniej wymagań dotyczących konstrukcjii C++. W
221 większości przypadków nie trzeba w ogóle zmieniać własnych klas C++,
222 żeby używać ich z Boost.Python. System powinien po prostu ,,odbić''
223 klasy C++ i funkcje do Pythona 3.
224
225 %package python3-devel
226 Summary:        Boost.Python development files for Python 3
227 Summary(pl.UTF-8):      Pliki programistyczne biblioteki Boost.Python dla Pythona 3
228 Group:          Development/Libraries
229 Requires:       %{name}-devel = %{version}-%{release}
230 Requires:       %{name}-python3 = %{version}-%{release}
231 Requires:       %{name}-python-devel-common = %{version}-%{release}
232
233 %description python3-devel
234 Boost.Python development files for Python 3.
235
236 %description python3-devel -l pl.UTF-8
237 Pliki programistyczne biblioteki Boost.Python dla Pythona 3.
238
239 %package python3-static
240 Summary:        Static version of Boost.Python library for Python 3
241 Summary(pl.UTF-8):      Statyczna wersja biblioteki Boost.Python dla Pythona 3
242 Group:          Development/Libraries
243 Requires:       %{name}-python3-devel = %{version}-%{release}
244
245 %description python3-static
246 Static version of Boost.Python library for Python 3.
247
248 %description python3-static -l pl.UTF-8
249 Statyczna wersja biblioteki Boost.Python dla Pythona 3.
250
251 %package chrono
252 Summary:        Useful time utilities
253 Summary(pl.UTF-8):      Przydatne funkcje związane z czasem
254 Group:          Libraries
255 Obsoletes:      boost < 1.33
256
257 %description chrono
258 Useful time utilities.
259
260 %description chrono -l pl.UTF-8
261 Przydatne funkcje związane z czasem.
262
263 %package context
264 Summary:        Boost.Context - context switching library
265 Summary(pl.UTF-8):      Boost.Context - biblioteka do zmiany kontekstu
266 Group:          Libraries
267
268 %description context
269 Boost.Context - context switching library, providing a sort of
270 cooperative multitasking on a single thread.
271
272 %description context -l pl.UTF-8
273 Boost.Context - biblioteka do zmiany kontekstu, zapewniająca pewną
274 wielozadaniowość kooperatywnąw ramach pojedynczego wątku.
275
276 %package date_time
277 Summary:        Date-Time library
278 Summary(pl.UTF-8):      Biblioteka daty-czasu
279 Group:          Libraries
280 Obsoletes:      boost < 1.33
281
282 %description date_time
283 A set of date-time libraries.
284
285 %description date_time -l pl.UTF-8
286 Zbiór bibliotek daty-czasu.
287
288 %package filesystem
289 Summary:        Portable paths, iteration over directories, and other useful filesystem operations
290 Summary(pl.UTF-8):      Przenośne ścieżki, iteracje katalogów i inne użyteczne operacje na systemie plików
291 Group:          Libraries
292 Requires:       %{name}-system = %{version}-%{release}
293 Obsoletes:      boost < 1.33
294
295 %description filesystem
296 The boost::filesystem library provides portable facilities to query
297 and manipulate paths, files, and directories.
298
299 %description filesystem -l pl.UTF-8
300 Przenośna biblioteka boost::filesystem dostarcza ułatwienia w
301 operacjach na ścieżkach, plikach i katalogach.
302
303 %package graph
304 Summary:        General purpose, generic C++ library for graph data structures and graph algorithms
305 Summary(pl.UTF-8):      Biblioteka ogólnego przeznaczenia w C++ dla struktur danych typu grafy oraz algorytmów związanych z grafami
306 Group:          Libraries
307
308 %description graph
309 The boost::graph library provides portable facilities to operate on
310 graph data structures using graph algorithms.
311
312 %description graph -l pl.UTF-8
313 Przenośna biblioteka boost::graph dostarcza ułatwienia w operacjach na
314 strukturach danych typu graf za pomocą algorytmów związanych z
315 grafami.
316
317 %package locale
318 Summary:        Provide localization and Unicode handling tools for C++
319 Summary(pl.UTF-8):      Narzędzia do obsługi lokalizacji i Unikodu w C++
320 Group:          Libraries
321
322 %description locale
323 Provide localization and Unicode handling tools for C++.
324
325 %description locale -l pl.UTF-8
326 Narzędzia do obsługi lokalizacji i Unikodu w C++.
327
328 %package log
329 Summary:        Provide logging tools for C++
330 Summary(pl.UTF-8):      Narzędzia do logowania w C++
331 Group:          Libraries
332
333 %description log
334 Provide logging tools for C++.
335
336 %description log -l pl.UTF-8
337 Narzędzia do logowania w C++.
338
339 %package program_options
340 Summary:        Access to program options, via conventional methods such as command line and config file
341 Summary(pl.UTF-8):      Dostęp do opcji programu za pomocą typowych metod, jak linia poleceń i plik konfiguracyjny
342 Group:          Libraries
343
344 %description program_options
345 The program_options library allows program developers to obtain
346 program options, that is (name, value) pairs from the user, via
347 conventional methods such as command line and config file.
348
349 %description program_options -l pl.UTF-8
350 Biblioteka program_options umożliwia uzyskanie od użytkownika opcji
351 programu, czyli par (nazwa, wartość), za pomocą typowych metod, takich
352 jak linia poleceń, czy plik konfiguracyjny.
353
354 %package regex
355 Summary:        Boost C++ regular expressions library
356 Summary(pl.UTF-8):      Biblioteka wyrażeń regularnych Boost C++
357 Group:          Libraries
358
359 %description regex
360 Shared library for Boost C++ regular expressions.
361
362 %description regex -l pl.UTF-8
363 Biblioteka współdzielona do obsługi wyrażeń regularnych w C++.
364
365 %package signals
366 Summary:        Signals & slots callback implementation
367 Summary(pl.UTF-8):      Implementacja sygnałów i slotów
368 Group:          Libraries
369 Obsoletes:      boost < 1.33
370
371 %description signals
372 The boost::signals library is an implementation of a signals and slots
373 system.
374
375 %description signals -l pl.UTF-8
376 Biblioteka boost::signals jest implementacją systemu sygnałów i
377 slotów.
378
379 %package system
380 Summary:        Support for getting system specific error codes
381 Summary(pl.UTF-8):      Wsparcie dla pobierania specyficznych dla systemu kodów błędów
382 Group:          Libraries
383
384 %description system
385 The Boost System library provides simple, light-weight error_code
386 objects that encapsulate system-specific error code values, yet also
387 provide access to more abstract and portable error conditions objects.
388
389 %description system -l pl.UTF-8
390 Biblioteka Boost System udostępnia proste, lekkie obiekty error_code
391 obudowujące wartości kodów błędów specyficznych dla systemu, dając
392 jednocześnie dostęp do bardziej abstrakcyjnych i przenośnych obiektów
393 błędów.
394
395 %package test
396 Summary:        Support for program testing and execution monitoring
397 Summary(pl.UTF-8):      Wsparcie dla testowania i monitorowania programu
398 Group:          Libraries
399 Obsoletes:      boost < 1.33
400
401 %description test
402 Support for simple program testing, full unit testing, and for program
403 execution monitoring.
404
405 %description test -l pl.UTF-8
406 Wsparcie dla prostego testowania programu, pełnego testowania i
407 monitorowania wykonania programu.
408
409 %package thread
410 Summary:        Portable C++ threads library
411 Summary(pl.UTF-8):      Przenośna biblioteka wątków C++
412 Group:          Libraries
413 Obsoletes:      boost < 1.33
414
415 %description thread
416 Portable C++ threads library - shared library.
417
418 %description thread -l pl.UTF-8
419 Przenośna biblioteka wątków dla C++ - biblioteka dzielona.
420
421 %package timer
422 Summary:        Event timer, progress timer, and progress display classes
423 Summary(pl.UTF-8):      Klasy do obsługi pomiarów czasu, postępu i wyświetlania postępu
424 Group:          Libraries
425 Obsoletes:      boost < 1.33
426
427 %description timer
428 Event timer, progress timer, and progress display classes.
429
430 %description timer -l pl.UTF-8
431 Klasy do obsługi pomiarów czasu, postępu i wyświetlania postępu.
432
433 %package wave
434 Summary:        Boost.Wave - a standard compliant C++ preprocessor library
435 Summary(pl.UTF-8):      Boost.Wave - zgodna ze standardem biblioteka preprocesora C++
436 Group:          Development/Libraries
437
438 %description wave
439 Boost.Wave - a standard compliant C++ preprocessor library.
440
441 %description wave -l pl.UTF-8
442 Boost.Wave - zgodna ze standardem biblioteka preprocesora C++.
443
444 %package doc
445 Summary:        Boost C++ Library documentation
446 Summary(pl.UTF-8):      Dokumentacja dla biblioteki Boost C++
447 Group:          Documentation
448 %if "%{_rpmversion}" >= "5"
449 BuildArch:      noarch
450 %endif
451
452 %description doc
453 Documentation for the Boost C++ Library.
454
455 %description doc -l pl.UTF-8
456 Dokumentacja dla biblioteki Boost C++.
457
458 %prep
459 %setup -q -n %{name}_%{fver}
460 %patch0 -p1
461 %patch1 -p1
462 %patch2 -p1
463
464 %patch203 -p0
465 %patch212 -p1
466 %patch218 -p1
467 %patch221 -p1
468
469 cat << EOF > tools/build/src/user-config.jam
470 using gcc : %{cxx_version} : %{__cxx} : <cflags>"%{rpmcflags} -fPIC" <cxxflags>"%{rpmcxxflags} -fPIC" <linkflags>"%{rpmldflags}" ;
471 EOF
472
473 # cleanup backups after patching
474 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
475
476 %build
477 EXPAT_INCLUDE=%{_includedir} \
478 EXPAT_LIBPATH=%{_libdir} \
479 ICU_PATH=%{_prefix} \
480 ./bootstrap.sh \
481         --prefix=%{_prefix} \
482         -without-libraries=python
483
484 ./b2 \
485         -d2 --toolset=gcc \
486         variant=release \
487         debug-symbols=on \
488         inlining=on \
489         link=static,shared \
490         threading=multi
491
492 %if %{with python3}
493 echo "using python : %{py3_ver}m : %{py3_prefix} : %{py3_incdir} ;" >> project-config.jam
494 ./b2 \
495         --with-python python=%{py3_ver}m \
496         -a -d2 --toolset=gcc \
497         variant=release \
498         debug-symbols=on \
499         inlining=on \
500         link=static,shared \
501         threading=multi
502 %endif
503
504 %if %{with python2}
505 echo "using python : %{py_ver} : %{py_prefix} : %{py_incdir} ;" >> project-config.jam
506 ./b2 \
507         --with-python python=%{py_ver} \
508         -a -d2 --toolset=gcc \
509         variant=release \
510         debug-symbols=on \
511         inlining=on \
512         link=static,shared \
513         threading=multi
514 %endif
515
516 %install
517 rm -rf $RPM_BUILD_ROOT
518 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}}
519
520 cp -rf boost $RPM_BUILD_ROOT%{_includedir}
521
522 install -p stage/lib/lib*.a $RPM_BUILD_ROOT%{_libdir}
523 install -p stage/lib/lib*.so.*.*.* $RPM_BUILD_ROOT%{_libdir}
524 cp -a stage/lib/lib*.so $RPM_BUILD_ROOT%{_libdir}
525
526 # documentation
527 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}
528
529 # as the documentation doesn't completely reside in a directory of its
530 # own, we need to find out ourselves... this looks for HTML files and
531 # then collects everything linked from those.  this is certainly quite
532 # unoptimized wrt mkdir calls, but does it really matter?
533 installdocs() {
534 for i in $(find -type f -name '*.htm*'); do
535         # bjam docu is included in the boost-jam RPM
536         if test "`echo $i | sed 's,jam_src,,'`" = "$i"; then
537                 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/${i%/*}
538                 for LINKED in `%{__perl} - $i $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$i <<'EOT'
539                         sub rewrite_link
540                         {
541                                 my $link = shift;
542                                 # rewrite links from boost/* to %{_includedir}/boost/* and
543                                 # ignore external links as well as document-internal ones.
544                                 # HTML files are also ignored as they get installed anyway.
545                                 if (!($link =~ s,^(?:../)*boost/,%{_includedir}/boost/,) && !($link =~ m,(?:^[^/]+:|^\#|\.html?(?:$|\#)),))
546                                 {
547                                         (my $file = $link) =~ s/\#.*//;
548                                         print "$file\n";
549                                 }
550                                 $link;
551                         }
552                         open IN, @ARGV[0];
553                         open OUT, ">@ARGV[1]";
554                         my $in_link;
555                         while (<IN>)
556                         {
557                                 $in_link and s/^\s*"([^"> ]*)"/'"' . rewrite_link($1) . '"'/e;
558                                 s/(href|src)="([^"> ]*)"/"$1=\"" . rewrite_link($2) . '"'/eig;
559                                 print OUT;
560                                 $in_link = /href|src=\s*$/;
561                         }
562 EOT`; do
563                         TARGET=${i%/*}/$LINKED
564                         # ignore non-existant linked files
565                         if test -f $TARGET; then
566                                 install -D -m 644 $TARGET $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$TARGET
567                         fi
568                 done
569         fi
570 done
571 }; installdocs
572
573 %clean
574 rm -rf $RPM_BUILD_ROOT
575
576 %post   -p /sbin/ldconfig
577 %postun -p /sbin/ldconfig
578
579 %post   chrono -p /sbin/ldconfig
580 %postun chrono -p /sbin/ldconfig
581
582 %post   context -p /sbin/ldconfig
583 %postun context -p /sbin/ldconfig
584
585 %post   date_time -p /sbin/ldconfig
586 %postun date_time -p /sbin/ldconfig
587
588 %post   filesystem -p /sbin/ldconfig
589 %postun filesystem -p /sbin/ldconfig
590
591 %post   graph -p /sbin/ldconfig
592 %postun graph -p /sbin/ldconfig
593
594 %post   locale -p /sbin/ldconfig
595 %postun locale -p /sbin/ldconfig
596
597 %post   python -p /sbin/ldconfig
598 %postun python -p /sbin/ldconfig
599
600 %post   python3 -p /sbin/ldconfig
601 %postun python3 -p /sbin/ldconfig
602
603 %post   program_options -p /sbin/ldconfig
604 %postun program_options -p /sbin/ldconfig
605
606 %post   regex -p /sbin/ldconfig
607 %postun regex -p /sbin/ldconfig
608
609 %post   signals -p /sbin/ldconfig
610 %postun signals -p /sbin/ldconfig
611
612 %post   system -p /sbin/ldconfig
613 %postun system -p /sbin/ldconfig
614
615 %post   test -p /sbin/ldconfig
616 %postun test -p /sbin/ldconfig
617
618 %post   thread -p /sbin/ldconfig
619 %postun thread -p /sbin/ldconfig
620
621 %post   timer -p /sbin/ldconfig
622 %postun timer -p /sbin/ldconfig
623
624 %post   wave -p /sbin/ldconfig
625 %postun wave -p /sbin/ldconfig
626
627 %files
628 %defattr(644,root,root,755)
629 %attr(755,root,root) %{_libdir}/libboost_atomic.so.*.*.*
630 %attr(755,root,root) %{_libdir}/libboost_container.so.*.*.*
631 %attr(755,root,root) %{_libdir}/libboost_coroutine.so.*.*.*
632 %attr(755,root,root) %{_libdir}/libboost_iostreams.so.*.*.*
633 %attr(755,root,root) %{_libdir}/libboost_math_*.so.*.*.*
634 %attr(755,root,root) %{_libdir}/libboost_random.so.*.*.*
635 %attr(755,root,root) %{_libdir}/libboost_serialization.so.*.*.*
636 %attr(755,root,root) %{_libdir}/libboost_wserialization.so.*.*.*
637
638 %files devel
639 %defattr(644,root,root,755)
640 %attr(755,root,root) %{_libdir}/libboost_atomic.so
641 %attr(755,root,root) %{_libdir}/libboost_chrono.so
642 %attr(755,root,root) %{_libdir}/libboost_container.so
643 %attr(755,root,root) %{_libdir}/libboost_context.so
644 %attr(755,root,root) %{_libdir}/libboost_coroutine.so
645 %attr(755,root,root) %{_libdir}/libboost_date_time.so
646 %attr(755,root,root) %{_libdir}/libboost_filesystem.so
647 %attr(755,root,root) %{_libdir}/libboost_graph.so
648 %attr(755,root,root) %{_libdir}/libboost_iostreams.so
649 %attr(755,root,root) %{_libdir}/libboost_locale.so
650 %attr(755,root,root) %{_libdir}/libboost_log.so
651 %attr(755,root,root) %{_libdir}/libboost_log_setup.so
652 %attr(755,root,root) %{_libdir}/libboost_math_*.so
653 %attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor.so
654 %attr(755,root,root) %{_libdir}/libboost_program_options.so
655 %attr(755,root,root) %{_libdir}/libboost_regex.so
656 %attr(755,root,root) %{_libdir}/libboost_random.so
657 %attr(755,root,root) %{_libdir}/libboost_serialization.so
658 %attr(755,root,root) %{_libdir}/libboost_signals.so
659 %attr(755,root,root) %{_libdir}/libboost_system.so
660 %attr(755,root,root) %{_libdir}/libboost_thread.so
661 %attr(755,root,root) %{_libdir}/libboost_timer.so
662 %attr(755,root,root) %{_libdir}/libboost_unit_test_framework.so
663 %attr(755,root,root) %{_libdir}/libboost_wave.so
664 %attr(755,root,root) %{_libdir}/libboost_wserialization.so
665 %{_includedir}/boost
666 %exclude %{_includedir}/boost/python
667 %exclude %{_includedir}/boost/python.hpp
668
669 %files static
670 %defattr(644,root,root,755)
671 %{_libdir}/libboost_atomic.a
672 %{_libdir}/libboost_chrono.a
673 %{_libdir}/libboost_container.a
674 %{_libdir}/libboost_context.a
675 %{_libdir}/libboost_coroutine.a
676 %{_libdir}/libboost_date_time.a
677 %{_libdir}/libboost_exception.a
678 %{_libdir}/libboost_filesystem.a
679 %{_libdir}/libboost_graph.a
680 %{_libdir}/libboost_iostreams.a
681 %{_libdir}/libboost_locale.a
682 %{_libdir}/libboost_log.a
683 %{_libdir}/libboost_log_setup.a
684 %{_libdir}/libboost_math_*.a
685 %{_libdir}/libboost_prg_exec_monitor.a
686 %{_libdir}/libboost_program_options.a
687 %{_libdir}/libboost_random.a
688 %{_libdir}/libboost_regex.a
689 %{_libdir}/libboost_serialization.a
690 %{_libdir}/libboost_signals.a
691 %{_libdir}/libboost_system.a
692 %{_libdir}/libboost_test_exec_monitor.a
693 %{_libdir}/libboost_timer.a
694 %{_libdir}/libboost_thread.a
695 %{_libdir}/libboost_unit_test_framework.a
696 %{_libdir}/libboost_wave.a
697 %{_libdir}/libboost_wserialization.a
698
699 %if %{with python2} || %{with python3}
700 %files python-devel-common
701 %defattr(644,root,root,755)
702 %{_includedir}/boost/python
703 %{_includedir}/boost/python.hpp
704 %endif
705
706 %if %{with python2}
707 %files python
708 %defattr(644,root,root,755)
709 %attr(755,root,root) %{_libdir}/libboost_python.so.*.*.*
710
711 %files python-devel
712 %defattr(644,root,root,755)
713 %attr(755,root,root) %{_libdir}/libboost_python.so
714
715 %files python-static
716 %defattr(644,root,root,755)
717 %{_libdir}/libboost_python.a
718 %endif
719
720 %if %{with python3}
721 %files python3
722 %defattr(644,root,root,755)
723 %attr(755,root,root) %{_libdir}/libboost_python3.so.*.*.*
724
725 %files python3-devel
726 %defattr(644,root,root,755)
727 %attr(755,root,root) %{_libdir}/libboost_python3.so
728
729 %files python3-static
730 %defattr(644,root,root,755)
731 %{_libdir}/libboost_python3.a
732 %endif
733
734 %files chrono
735 %defattr(644,root,root,755)
736 %attr(755,root,root) %{_libdir}/libboost_chrono.so.*.*.*
737
738 %files context
739 %defattr(644,root,root,755)
740 %attr(755,root,root) %{_libdir}/libboost_context.so.*.*.*
741
742 %files date_time
743 %defattr(644,root,root,755)
744 %attr(755,root,root) %{_libdir}/libboost_date_time.so.*.*.*
745
746 %files filesystem
747 %defattr(644,root,root,755)
748 %attr(755,root,root) %{_libdir}/libboost_filesystem.so.*.*.*
749
750 %files graph
751 %defattr(644,root,root,755)
752 %attr(755,root,root) %{_libdir}/libboost_graph.so.*.*.*
753
754 %files locale
755 %defattr(644,root,root,755)
756 %attr(755,root,root) %{_libdir}/libboost_locale.so.*.*.*
757
758 %files log
759 %defattr(644,root,root,755)
760 %attr(755,root,root) %{_libdir}/libboost_log.so.*.*.*
761 %attr(755,root,root) %{_libdir}/libboost_log_setup.so.*.*.*
762
763 %files program_options
764 %defattr(644,root,root,755)
765 %attr(755,root,root) %{_libdir}/libboost_program_options.so.*.*.*
766
767 %files regex
768 %defattr(644,root,root,755)
769 %attr(755,root,root) %{_libdir}/libboost_regex.so.*.*.*
770
771 %files signals
772 %defattr(644,root,root,755)
773 %attr(755,root,root) %{_libdir}/libboost_signals.so.*.*.*
774
775 %files system
776 %defattr(644,root,root,755)
777 %attr(755,root,root) %{_libdir}/libboost_system.so.*.*.*
778
779 %files test
780 %defattr(644,root,root,755)
781 %attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor.so.*.*.*
782 %attr(755,root,root) %{_libdir}/libboost_unit_test_framework.so.*.*.*
783
784 %files thread
785 %defattr(644,root,root,755)
786 %attr(755,root,root) %{_libdir}/libboost_thread.so.*.*.*
787
788 %files timer
789 %defattr(644,root,root,755)
790 %attr(755,root,root) %{_libdir}/libboost_timer.so.*.*.*
791
792 %files wave
793 %defattr(644,root,root,755)
794 %attr(755,root,root) %{_libdir}/libboost_wave.so.*.*.*
795
796 %files doc
797 %defattr(644,root,root,755)
798 %{_docdir}/%{name}-%{version}
This page took 0.083498 seconds and 4 git commands to generate.