]> git.pld-linux.org Git - packages/boost.git/blob - boost.spec
- boost::call_traits goes to separate package
[packages/boost.git] / boost.spec
1 #
2 # Conditional build:
3 %bcond_with     python  # with boost-python support (not working now)
4 #
5 Summary:        The Boost C++ Libraries
6 Summary(pl):    Biblioteki C++ "Boost"
7 Name:           boost
8 Version:        1.30.2
9 Release:        0.1
10 License:        Freely distributable
11 Group:          Libraries
12 Source0:        http://dl.sourceforge.net/boost/%{name}-%{version}.tar.bz2
13 # Source0-md5:  4aed692a863bb4beaa0b70d6dc53bda5
14 URL:            http://www.boost.org/
15 BuildRequires:  boost-jam >= 3.1.3
16 BuildRequires:  libstdc++-devel
17 %{?with_python:BuildRequires:   python-devel}
18 BuildConflicts: gcc = 5:3.3.1
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 The Boost web site provides free peer-reviewed portable C++ source
23 libraries. The emphasis is on libraries which work well with the C++
24 Standard Library. One goal is to establish "existing practice" and
25 provide reference implementations so that the Boost libraries are
26 suitable for eventual standardization. Some of the libraries have
27 already been proposed for inclusion in the C++ Standards Committee's
28 upcoming C++ Standard Library Technical Report.
29
30 %description -l pl
31 Strona http://www.boost.org/ dostarcza darmowe biblioteki C++ wraz z
32 kodem ¼ród³owym. Nacisk po³o¿ono na biblioteki, które dobrze
33 wspó³pracuj± ze standardow± bibliotek± C++. Celem jest ustanowienie
34 "isniej±cej praktyki" i dostarczenie implementacji, tak ¿e biblioteki
35 "Boost" nadaj± siê do ewentualnej standaryzacji. Niektóre z bibliotek
36 ju¿ zosta³y zg³oszone do komitetu standaryzacyjnego C++ w nadchodz±cym
37 Raporcie Technicznym Biblioteki Standardowej C++
38
39 %package devel
40 Summary:        Boost C++ development libraries and headers
41 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne Boost C++
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44 Requires:       libstdc++-devel
45
46 %description devel
47 Headers and static libraries for the Boost C++ libraries.
48
49 %description devel -l pl
50 Pliki nag³ówkowe i biblioteki statyczne bibliotek Boost C++.
51
52 #according to ldd (and automatically generated RPM dependencies) it
53 #doesn't strictly require python, but IMHO it's cleaner to split it
54 #this way
55 %package python
56 Summary:        Boost.Python library
57 Summary(pl):    biblioteka Boost.Python
58 Group:          Libraries
59 Requires:       %{name} = %{version}-%{release}
60 Requires:       python
61
62 %description python
63 Use the Boost Python Library to quickly and easily export a C++
64 library to Python such that the Python interface is very similar to
65 the C++ interface. It is designed to be minimally intrusive on your
66 C++ design. In most cases, you should not have to alter your C++
67 classes in any way in order to use them with Boost.Python. The system
68 should simply ``reflect'' your C++ classes and functions into Python.
69
70 %description python -l pl
71 Biblioteka Boost Python s³u¿y do szybkiego i prostego eksportu
72 biblioteki C++ do Pythona, tak ¿e interfejs Pythona jest bardzo
73 podobny do interfejsu C++. Biblioteka jest zaprojektowana tak, ¿eby
74 narzucaæ jak najmniej wymagañ dotycz±cych konstrukcjii C++. W
75 wiêkszo¶ci przypadków nie trzeba w ogóle zmieniaæ w³asnych klas C++,
76 ¿eby u¿ywaæ ich z Boost.Python. System powinien po prostu ,,odbiæ''
77 klasy C++ i funkcje do Pythona.
78
79 %package python-devel
80 Summary:        Boost.Python development headers
81 Summary(pl):    Pliki nag³ówkowe dla Boost.Python
82 Group:          Development/Libraries
83 Requires:       %{name}-devel = %{version}-%{release}
84
85 %description python-devel
86 Headers for the Boost.Python library.
87
88 %description python-devel -l pl
89 Pliki nag³ówkowe dla biblioteki Boost.Python.
90
91 %package regex
92 Summary:        Boost C++ regular expressions library
93 Summary(pl):    Biblioteka wyra¿eñ regularnych Boost C++
94 Group:          Libraries
95 Requires:       %{name} = %{version}-%{release}
96
97 %description regex
98 Shared library for Boost C++ regular expressions.
99
100 %description regex -l pl
101 Biblioteka wyra¿eñ regularnych dla C++, biblioteki dzielone.
102
103 %package regex-devel
104 Summary:        Boost C++ Regex library headers and static libraries
105 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne Boost C++ Regex
106 Group:          Development/Libraries
107 Requires:       %{name}-devel = %{version}-%{release}
108 Requires:       %{name}-regex = %{version}-%{release}
109
110 %description regex-devel
111 Boost C++ Regex headers and static libraries.
112
113 %description regex-devel -l pl
114 Pliki nag³ówkowe i biblioteki statyczne dla Boost C++ Regex.
115
116 %package any-devel
117 Summary:        Header for Boost C++ "Any" Library
118 Summary(pl):    Plik nag³ówkowy dla biblioteki Boost C++ "Any"
119 Group:          Development/Libraries
120 Requires:       %{name}-devel = %{version}-%{release}
121
122 %description any-devel
123 The boost::any class, is a variant value type, which supports copying
124 of any value type and safe checked extraction of that value strictly
125 against that type.
126
127 I.e. 5 is held strictly as an int and is not implicitly convertible
128 either to "5" or to 5.0.
129
130 %description any-devel -l pl
131 Klasa boost::any jest typem, który umo¿liwia kopiowanie ze zmiennej
132 dowolnego typu i bezpieczne, sprawdzone wydobycie jej warto¶ci
133 dok³adnie tego samego typu.
134
135 Np. 5 jest trzymane jako int i nie jest niejawnie konwertowalne ani do
136 "5" ani do 5.0.
137
138 %package array-devel
139 Summary:        STL compliant container wrapper for arrays of constant size
140 Summary(pl):    Wrapper na STLowe kontenery dla tablic o sta³ym rozmiarze
141 Group:          Development/Libraries
142 Requires:       %{name}-devel = %{version}-%{release}
143
144 %description array-devel
145 As replacement for ordinary arrays, the STL provides class vector<>.
146 However, vector<> provides the semantics of dynamic arrays. Thus, it
147 manages data to be able to change the number of elements. This results
148 in some overhead in case only arrays with static size are needed. This
149 library provides support for such static size arrays.
150
151 %description array-devel -l pl
152 STL dostarcza klasê vector<> jako zamiennik zwyk³ej tablicy. Jednak
153 vector<> dostarcza semantykê dynamicznych tablic. Zatem zarz±dza
154 danymi tak, by by³a mo¿liwa zmiana ilo¶ci elementów. To skutkuje
155 pewnym nadmiarem w przypadku kiedy tylko tablice o sta³ym rozmiarze s±
156 potrzebne. Ta biblioteka dostarcza wsparcie dla takich w³a¶nie tablic
157 o sta³ym rozmiarze.
158
159
160 %package preprocessor-devel
161 Summary:        Preprocessor metaprogramming tools including repetition and recursion
162 Summary(pl):    Narzêdzia metaprogramowania preprocesora razem z repetycj± i rekursj±
163 Group:          Development/Libraries
164 Requires:       %{name}-devel = %{version}-%{release}
165
166 %description preprocessor-devel
167 This library provides preprocessor metaprogramming tools, including
168 repetition and recursion.
169
170 %description preprocessor-devel -l pl
171 Biblioteka udostêpnia narzêdzia metaprogramowania preprocesora,
172 w³±czaj±c w to repetycje i rekursjê.
173
174 %package mpl-devel
175 Summary:        Compile-time algorithms, sequences and metafunction classes
176 Summary(pl):    Algorytmy czasu kompilacji, sekwencji i klas metafunkcji
177 Group:          Development/Libraries
178 Requires:       %{name}-devel = %{version}-%{release}
179 Requires:       %{name}-preprocessor-devel = %{version}-%{release}
180 Requires:       %{name}-type_traits-devel = %{version}-%{release}
181 Requires:       %{name}-utility-devel = %{version}-%{release}
182
183 %description mpl-devel
184 The boost-mpl library is a C++ template metaprogramming framework of
185 compile-time algorithms, sequences and metafunction classes.
186
187 %description mpl-devel -l pl
188 Biblioteka boost-mpl jest szkieletem wzorców C++ dla algorytmów czasu
189 kompilacji, sekwencji i klas metafunkcji.
190
191 %package type_traits-devel
192 Summary:        Templates for fundamental properties of types
193 Summary(pl):    Wzorce dla fundamentalnych w³a¶ciwo¶ci typów
194 Group:          Development/Libraries
195 Requires:       %{name}-devel = %{version}-%{release}
196 Requires:       %{name}-mpl-devel = %{version}-%{release}
197 Requires:       %{name}-preprocessor-devel = %{version}-%{release}
198 Requires:       %{name}-utility-devel = %{version}-%{release}
199 Requires:       %{name}-static_assert-devel = %{version}-%{release}
200
201 %description type_traits-devel
202 The boost-type_traits library defines three kinds of type trait: 
203         1. The properties of a specific type. 
204         2. The relationship between two types. 
205         3. A transformation from one type to another.
206
207 %description type_traits-devel -l pl
208 Biblioteka boost-type_traits definiuje trzy rodzaje cech typów: 
209         1. w³a¶ciwo¶ci konkretnego typu. 
210         2. powi±zania miêdzy dwoma typami. 
211         3. transformacjê z jednego typu do drugiego.
212
213 %package utility-devel
214 Summary:        Useful utilities: classes and function templates.
215 Summary(pl):    U¿yteczne narzêdzia: klasy i wzorce funkcji
216 Group:          Development/Libraries
217 Requires:       %{name}-type_traits-devel = %{version}
218
219 %description utility-devel
220 Class noncopyable plus checked_delete(), checked_array_delete(),
221 next(), prior() function templates, plus base-from-member idiom.
222
223 %description utility-devel -l pl
224 Klasy noncopyable i checked_delete, funkcje checked_array_delete(),
225 next(), prior() oraz idiom base-from-member.
226
227 %package static_assert-devel
228 Summary:        Static assertions (compile time assertions)
229 Summary(pl):    Statyczne asercje (asercje kompilacyjne)
230 Group:          Development/Libraries
231 Requires:       %{name}-devel = %{version}
232
233 %description static_assert-devel
234 The header <boost/static_assert.hpp> supplies a single macro
235 BOOST_STATIC_ASSERT(x), which generates a compile time error message
236 if the integral-constant-expression x is not true. In other words it
237 is the compile time equivalent of the assert macro; this is sometimes
238 known as a "compile-time-assertion"
239
240 One of the aims of BOOST_STATIC_ASSERT is to generate readable error
241 messages. These immediately tell the user that a library is being used
242 in a manner that is not supported.
243
244 %description static_assert-devel -l pl
245 Plik nag³ówkowy <boost/static_assert.hpp> dostarcza pojedyncze makro
246 BOOST_STATIC_ASSERT(x), które generuje komunikat b³êdu kompilacji
247 je¿eli sta³e wyra¿enie x nie jest prawdziwe. Innymi s³owy jest to
248 kompilacyjny ekwiwalent makra 'assert'; czasami znane jest jako
249 "asercja czasu kompilacji"
250
251 Jednym z celów BOOST_STATIC_ASSERT jest generowanie czytelnych
252 komunikatów o b³êdach. One b³yskawicznie powiedz± u¿ytkownikowi ¿e
253 biblioteka zosta³a u¿yta w sposób który nie jest zalecany.
254
255
256 %package bind-devel
257 Group:          Development/Libraries
258 Summary:        Generalized binders for function/object/pointers.
259 Summary(pl):    Uogólnione bindery dla funkcji/obiektów/wska¼ników.
260 Requires:       boost-ref-devel = %{version}-%{release}
261 Requires:       boost-mem_fn-devel = %{version}-%{release}
262
263 %description bind-devel
264 boost::bind is a generalization of the standard functions std::bind1st
265 and std::bind2nd.
266
267 %description bind-devel -l pl
268 boost::bind jest uogólnieniem standardowych funkcji std::bind1st i
269 std::bind2nd.
270
271
272 %package mem_fn-devel
273 Group:          Development/Libraries
274 Summary:        Generalized binders for member functions.
275 Summary(pl):    Uogólnione bindery dla metod.
276 Requires:       boost-devel = %{version}-%{release}
277
278 %description mem_fn-devel
279 boost::mem_fn is a generalization of the standard functions
280 std::mem_fun and std::mem_fun_ref.
281
282 %description mem_fn-devel -l pl
283 boost::mem_fn jest uogólnieniem standardowych funkcji std::mem_fun i
284 std::mem_fun_ref.
285
286
287 %package ref-devel
288 Group:          Development/Libraries
289 Summary:        Small library useful for passing references to function templates.
290 Summary(pl):    Ma³a biblioteka u¿yteczna przy przekazywaniu referencji do wzorców funkcjii.
291 Requires:       boost-devel = %{version}-%{release}
292 Requires:       boost-utility-devel = %{version}-%{release}
293 Requires:       boost-mpl-devel = %{version}-%{release}
294
295 %description ref-devel
296 boost::ref library is a small library that is useful for passing
297 references to function templates (algorithms) that would usually take
298 copies of their arguments.
299
300 %description ref-devel -l pl
301 Biblioteka boost::ref jest ma³± bibliotek± która jest u¿yteczna w
302 przypadku przekazywania referencji do wzorców funkcji (algorytmów)
303 które zazwyczaj bior± kopiê swoich argumentów.
304
305
306 %package call_traits-devel
307 Group:          Development/Libraries
308 Summary:        Defines types for passing parameters.
309 Summary(pl):    Definiuje typy dla przekazywania parametrów.
310 Requires:       boost-devel = %{version}-%{release}
311 Requires:       boost-type_traits-devel = %{version}-%{release}
312
313 %description call_traits-devel
314 boost::call_traits<T> encapsulates the "best" method to pass a
315 parameter of some type T to or from a function. The purpose of
316 call_traits is to ensure that problems like "references to references"
317 never occur, and that parameters are passed in the most efficient
318 manner possible.
319
320 %description call_traits-devel -l pl
321 boost::call_traits<T> zawiera "najlepsz±" metodê przekazywania
322 parametrów jakiego¶ typu T do lub z funkcji. Celem call_traits jest
323 zapewnienie ¿e problemy takie jak "referencja referencji" nigdy nie
324 wyst±pi± i ¿e parametry s± przekazywane w mo¿liwie najbardziej
325 efektywny sposób.
326
327 %package doc
328 Summary:        Boost C++ Library documentation
329 Summary(pl):    Dokumentacja dla biblioteki Boost C++
330 Group:          Documentation
331 Requires:       %{name}-devel = %{version}
332
333 %description doc
334 Documentation for the Boost C++ Library.
335
336 %description doc -l pl
337 Dokumentacja dla biblioteki Boost C++.
338
339 %prep
340 %setup -q
341
342 %build
343 %if %{with python}
344 PYTHON_VERSION=`python -V 2>&1 | sed 's,.* \([0-9]\.[0-9]\)\(\.[0-9]\)\?.*,\1,'`
345 PYTHON_ROOT=%{_prefix}
346 %else
347 PYTHON_ROOT=
348 PYTHON_VERSION=
349 %endif
350 bjam \
351         -sBUILD=release \
352         -sPYTHON_ROOT=$PYTHON_ROOT \
353         -sPYTHON_VERSION=$PYTHON_VERSION
354
355 %install
356 rm -rf $RPM_BUILD_ROOT
357 rm -f master.list regex.list regex-devel.list python.list devel.list python-devel.list doc.list any.list
358 # include files
359 install -d $RPM_BUILD_ROOT%{_includedir}
360 for i in `find boost -type d`; do
361         install -d $RPM_BUILD_ROOT%{_includedir}/$i
362 done
363 for i in `find boost -type f`; do
364         install -m 644 $i $RPM_BUILD_ROOT%{_includedir}/$i
365         if test "`echo $i | sed 's,python,,g'`" = "$i"; then
366                 echo %{_includedir}/$i >> devel.list
367         else
368                 echo %{_includedir}/$i >> python-devel.list
369         fi
370 done
371 # static libraries
372 install -d $RPM_BUILD_ROOT%{_libdir}
373 for i in `find libs -type f -name '*.a' | grep gcc`; do
374         install -m 644 $i $RPM_BUILD_ROOT%{_libdir}/`basename $i`
375         if test "`echo $i | sed 's,python,,g'`" = "$i"; then
376                 echo %{_libdir}/`basename $i` >> devel.list
377         else
378                 echo %{_libdir}/`basename $i` >> python-devel.list
379         fi
380 done
381
382
383 # dynamic libraries
384 for i in `find libs -type f -name '*.so.%{version}' | grep gcc`; do
385         install -m 755 $i $RPM_BUILD_ROOT%{_libdir}/`basename $i`
386         #ldconfig fails to generate the symlinks for boost libs :-(
387         LINK=`basename $i | sed 's,\.so\..*,.so,'`
388         (cd $RPM_BUILD_ROOT%{_libdir} && ln -s `basename $i` $LINK)
389         if test "`echo $i | sed 's,python,,g'`" = "$i"; then
390                 echo %{_libdir}/`basename $i` >> master.list
391                 echo %{_libdir}/$LINK >> master.list
392         else
393                 echo %{_libdir}/`basename $i` >> python.list
394                 echo %{_libdir}/$LINK >> python.list
395         fi
396 done
397
398 #regex library
399 grep libboost_regex.so master.list > regex.list
400 grep -v libboost_regex.so master.list >_master.list
401 mv {_,}master.list
402 #regex-devel
403 RFILES="%{_includedir}/boost/cregex.hpp|"
404 RFILES="$RFILES%{_includedir}/boost/regex/|"
405 RFILES="$RFILES%{_includedir}/boost/regex.h(pp){0,1}|"
406 RFILES="$RFILES%{_includedir}/boost/regex_fwd.hpp|"
407 RFILES="$RFILES%{_libdir}/libboost_regex.a"
408
409 egrep "$RFILES" devel.list > regex-devel.list
410 egrep -v "$RFILES" devel.list > _devel.list
411 mv {_,}devel.list
412
413 #any-devel library
414 grep any.hpp devel.list > any.list
415 grep -v any.hpp devel.list > _devel.list
416 mv {_,}devel.list
417
418 #array-devel library
419 egrep '/boost/array.hpp$' devel.list >array.list
420 egrep -v '/boost/array.hpp$' devel.list > _devel.list
421 mv {_,}devel.list
422
423 #preprocessor-devel
424 RFILES="%{_includedir}/boost/preprocessor"
425 egrep "$RFILES" devel.list > preprocessor.list
426 egrep -v $RFILES devel.list > _devel.list
427 mv {_,}devel.list
428
429 #mpl-devel
430 RFILES="%{_includedir}/boost/mpl/"
431 egrep "$RFILES" devel.list > mpl.list
432 egrep -v "$RFILES" devel.list >_devel.list
433 mv {_,}devel.list
434
435 #type_traits-devel
436 RFILES="%{_includedir}/boost/type_traits/"
437 RFILES="$RFILES|%{_includedir}/boost/type_traits.hpp"
438 egrep "$RFILES" devel.list > type_traits.list
439 egrep -v "$RFILES" devel.list >_devel.list
440 mv {_,}devel.list
441
442 #utility-devel
443 RFILES="%{_includedir}/boost/noncopyable.hpp"
444 RFILES="$RFILES|%{_includedir}/boost/checked_delete.hpp"
445 RFILES="$RFILES|%{_includedir}/boost/next_prior.hpp"
446 RFILES="$RFILES|%{_includedir}/boost/utility(_fwd){0,1}.hpp"
447 RFILES="$RFILES|%{_includedir}/boost/utility/"
448 egrep "$RFILES" devel.list > utility.list
449 egrep -v "$RFILES" devel.list >_devel.list
450 mv {_,}devel.list
451
452 #static_assert-devel
453 RFILES="%{_includedir}/boost/static_assert.hpp"
454 egrep "$RFILES" devel.list > static_assert.list
455 egrep -v "$RFILES" devel.list >_devel.list
456 mv {_,}devel.list
457
458 #bind-devel
459 RFILES="%{_includedir}/boost/bind.hpp"
460 RFILES="$RFILES|%{_includedir}/boost/bind/"
461 egrep "$RFILES" devel.list > bind.list
462 egrep -v "$RFILES" devel.list >_devel.list
463 mv {_,}devel.list
464
465 #mem_fn-devel
466 RFILES="%{_includedir}/boost/mem_fn.hpp"
467 RFILES="$RFILES|%{_includedir}/boost/get_pointer.hpp"
468 egrep "$RFILES" devel.list > mem_fn.list
469 egrep -v "$RFILES" devel.list >_devel.list
470 mv {_,}devel.list
471
472 #ref-devel
473 RFILES="%{_includedir}/boost/ref.hpp"
474 egrep "$RFILES" devel.list > ref.list
475 egrep -v "$RFILES" devel.list >_devel.list
476 mv {_,}devel.list
477
478
479 #call_traits-devel
480 RFILES="%{_includedir}/boost/call_traits.hpp"
481 RFILES="$RFILES|%{_includedir}/detail/call_traits.hpp"
482 RFILES="$RFILES|%{_includedir}/detail/ob_call_traits.hpp"
483 egrep "$RFILES" devel.list > call_traits.list
484 egrep -v "$RFILES" devel.list >_devel.list
485 mv {_,}devel.list
486
487
488
489 # documentation
490 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}
491 install README $RPM_BUILD_ROOT%{_docdir}/boost-%{version}
492
493 # as the documentation doesn't completely reside in a directory of its
494 # own, we need to find out ourselves... this looks for HTML files and
495 # then collects everything linked from those.  this is certainly quite
496 # unoptimized wrt mkdir calls, but does it really matter?
497 for i in `find -type f -name '*.htm*'`; do
498         # bjam docu is included in the boost-jam RPM
499         if test "`echo $i | sed 's,jam_src,,'`" = "$i"; then
500                 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/`dirname $i`
501                 for LINKED in `perl - $i $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$i <<'EOT'
502                         sub rewrite_link
503                         {
504                                 my $link = shift;
505                                 # rewrite links from boost/* to %{_includedir}/boost/* and
506                                 # ignore external links as well as document-internal ones.
507                                 # HTML files are also ignored as they get installed anyway.
508                                 if (!($link =~ s,^(?:../)*boost/,%{_includedir}/boost/,) && !($link =~ m,(?:^[^/]+:|^\#|\.html?(?:$|\#)),))
509                                 {
510                                         (my $file = $link) =~ s/\#.*//;
511                                         print "$file\n";
512                                 }
513                                 $link;
514                         }
515                         open IN, @ARGV[0];
516                         open OUT, ">@ARGV[1]";
517                         my $in_link;
518                         while (<IN>)
519                         {
520                                 $in_link and s/^\s*"([^"> ]*)"/'"' . rewrite_link($1) . '"'/e;
521                                 s/(href|src)="([^"> ]*)"/"$1=\"" . rewrite_link($2) . '"'/eig;
522                                 print OUT;
523                                 $in_link = /href|src=\s*$/;
524                         }
525 EOT`; do
526                         TARGET=`dirname $i`/$LINKED
527                         # ignore non-existant linked files
528                         if test -f $TARGET; then
529                                 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/`dirname $TARGET`
530                                 install -m 644 $TARGET $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$TARGET
531                         fi
532                 done
533         fi
534 done
535
536 %clean
537 rm -rf $RPM_BUILD_ROOT
538
539 %post   -p /sbin/ldconfig
540 %postun -p /sbin/ldconfig
541
542 %post python    -p /sbin/ldconfig
543 %postun python  -p /sbin/ldconfig
544
545 %files -f master.list
546 %defattr(644,root,root,755)
547
548 %files devel -f devel.list
549 %defattr(644,root,root,755)
550 %dir %{_includedir}/boost
551 %dir %{_includedir}/boost/compatibility
552 %dir %{_includedir}/boost/compatibility/cpp_c_headers
553 %dir %{_includedir}/boost/config
554 %dir %{_includedir}/boost/config/compiler
555 %dir %{_includedir}/boost/config/platform
556 %dir %{_includedir}/boost/config/stdlib
557 %dir %{_includedir}/boost/date_time
558 %dir %{_includedir}/boost/date_time/gregorian
559 %dir %{_includedir}/boost/date_time/posix_time
560 %dir %{_includedir}/boost/filesystem
561 %dir %{_includedir}/boost/format
562 %dir %{_includedir}/boost/function
563 %dir %{_includedir}/boost/function/detail
564 %dir %{_includedir}/boost/graph
565 %dir %{_includedir}/boost/graph/detail
566 %dir %{_includedir}/boost/integer
567 %dir %{_includedir}/boost/io
568 %dir %{_includedir}/boost/lambda
569 %dir %{_includedir}/boost/lambda/detail
570 %dir %{_includedir}/boost/math
571 %dir %{_includedir}/boost/math/special_functions
572 %dir %{_includedir}/boost/multi_array
573 %dir %{_includedir}/boost/numeric
574 %dir %{_includedir}/boost/numeric/interval
575 %dir %{_includedir}/boost/numeric/interval/compare
576 %dir %{_includedir}/boost/numeric/interval/detail
577 %dir %{_includedir}/boost/numeric/interval/ext
578 %dir %{_includedir}/boost/numeric/ublas
579 %dir %{_includedir}/boost/pending
580 %dir %{_includedir}/boost/pending/detail
581 %dir %{_includedir}/boost/pool
582 %dir %{_includedir}/boost/pool/detail
583 %dir %{_includedir}/boost/random
584 %dir %{_includedir}/boost/random/detail
585 %dir %{_includedir}/boost/signals
586 %dir %{_includedir}/boost/signals/detail
587 %dir %{_includedir}/boost/spirit
588 %dir %{_includedir}/boost/spirit/attribute
589 %dir %{_includedir}/boost/spirit/core
590 %dir %{_includedir}/boost/spirit/core/composite
591 %dir %{_includedir}/boost/spirit/core/composite/impl
592 %dir %{_includedir}/boost/spirit/core/impl
593 %dir %{_includedir}/boost/spirit/core/meta
594 %dir %{_includedir}/boost/spirit/core/meta/impl
595 %dir %{_includedir}/boost/spirit/core/non_terminal
596 %dir %{_includedir}/boost/spirit/core/non_terminal/impl
597 %dir %{_includedir}/boost/spirit/core/primitives
598 %dir %{_includedir}/boost/spirit/core/primitives/impl
599 %dir %{_includedir}/boost/spirit/core/scanner
600 %dir %{_includedir}/boost/spirit/core/scanner/impl
601 %dir %{_includedir}/boost/spirit/debug
602 %dir %{_includedir}/boost/spirit/debug/impl
603 %dir %{_includedir}/boost/spirit/dynamic
604 %dir %{_includedir}/boost/spirit/dynamic/impl
605 %dir %{_includedir}/boost/spirit/error_handling
606 %dir %{_includedir}/boost/spirit/error_handling/impl
607 %dir %{_includedir}/boost/spirit/iterator
608 %dir %{_includedir}/boost/spirit/iterator/impl
609 %dir %{_includedir}/boost/spirit/phoenix
610 %dir %{_includedir}/boost/spirit/symbols
611 %dir %{_includedir}/boost/spirit/symbols/impl
612 %dir %{_includedir}/boost/spirit/tree
613 %dir %{_includedir}/boost/spirit/tree/impl
614 %dir %{_includedir}/boost/spirit/utility
615 %dir %{_includedir}/boost/spirit/utility/impl
616 %dir %{_includedir}/boost/spirit/utility/impl/chset
617 %dir %{_includedir}/boost/test
618 %dir %{_includedir}/boost/test/detail
619 %dir %{_includedir}/boost/test/included
620 %dir %{_includedir}/boost/thread
621 %dir %{_includedir}/boost/thread/detail
622 %dir %{_includedir}/boost/tuple
623 %dir %{_includedir}/boost/tuple/detail
624 %dir %{_includedir}/boost/type_traits
625 %dir %{_includedir}/boost/type_traits/detail
626 %dir %{_includedir}/boost/utility
627
628 %if %{with python}
629 %files python -f python.list
630 %defattr(644,root,root,755)
631
632 %files python-devel -f python-devel.list
633 %defattr(644,root,root,755)
634 %endif
635
636 %files doc
637 %defattr(644,root,root,755)
638 %doc %{_docdir}/boost-%{version}
639
640 %files bind-devel -f bind.list
641 %defattr(644,root,root,755)
642
643 %files regex -f regex.list
644 %defattr(644,root,root,755)
645
646 %files regex-devel -f regex-devel.list
647 %defattr(644,root,root,755)
648
649 %files any-devel -f any.list
650 %defattr(644,root,root,755)
651
652 %files array-devel -f array.list
653 %defattr(644,root,root,755)
654
655 %files preprocessor-devel -f preprocessor.list
656 %defattr(644,root,root,755)
657
658 %files mpl-devel -f mpl.list
659 %defattr(644,root,root,755)
660
661 %files type_traits-devel -f type_traits.list
662 %defattr(644,root,root,755)
663
664 %files utility-devel -f utility.list
665 %defattr(644,root,root,755)
666
667 %files static_assert-devel -f static_assert.list
668 %defattr(644,root,root,755)
669
670 %files mem_fn-devel -f mem_fn.list
671 %defattr(644,root,root,755)
672
673 %files ref-devel -f ref.list
674 %defattr(644,root,root,755)
675
676 %files call_traits-devel -f call_traits.list
677 %defattr(644,root,root,755)
This page took 0.090808 seconds and 4 git commands to generate.