]> git.pld-linux.org Git - packages/boost.git/blob - boost.spec
- cosmetics
[packages/boost.git] / boost.spec
1 #
2 # Conditional build:
3 %bcond_without  python  # with boost-python support (not working now)
4 #
5 Summary:        The Boost C++ Libraries
6 Summary(pl):    Biblioteki C++ "Boost"
7 Name:           boost
8 Version:        1.30.2
9 Release:        0.1
10 License:        Freely distributable
11 Group:          Libraries
12 Source0:        http://dl.sourceforge.net/boost/%{name}-%{version}.tar.bz2
13 # Source0-md5:  4aed692a863bb4beaa0b70d6dc53bda5
14 Patch0:         %{name}-python.patch
15 URL:            http://www.boost.org/
16 BuildRequires:  boost-jam >= 3.1.3
17 BuildRequires:  libstdc++-devel
18 BuildRequires:  perl-base
19 %{?with_python:BuildRequires:   python-devel >= 2.2}
20 BuildConflicts: gcc = 5:3.3.1
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 The Boost web site provides free peer-reviewed portable C++ source
25 libraries. The emphasis is on libraries which work well with the C++
26 Standard Library. One goal is to establish "existing practice" and
27 provide reference implementations so that the Boost libraries are
28 suitable for eventual standardization. Some of the libraries have
29 already been proposed for inclusion in the C++ Standards Committee's
30 upcoming C++ Standard Library Technical Report.
31
32 %description -l pl
33 Strona http://www.boost.org/ dostarcza darmowe biblioteki C++ wraz z
34 kodem ¼ród³owym. Nacisk po³o¿ono na biblioteki, które dobrze
35 wspó³pracuj± ze standardow± bibliotek± C++. Celem jest ustanowienie
36 "isniej±cej praktyki" i dostarczenie implementacji, tak ¿e biblioteki
37 "Boost" nadaj± siê do ewentualnej standaryzacji. Niektóre z bibliotek
38 ju¿ zosta³y zg³oszone do komitetu standaryzacyjnego C++ w nadchodz±cym
39 Raporcie Technicznym Biblioteki Standardowej C++
40
41 %package devel
42 Summary:        Boost C++ development libraries and headers
43 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne Boost C++
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46 # req'd by <boost/signal.hpp>
47 Requires:       %{name}-any-devel = %{version}-%{release}
48 Requires:       %{name}-mem_fn-devel = %{version}-%{release}
49 Requires:       %{name}-ref-devel = %{version}-%{release}
50 # req'd by <boost/iterator_adaptors.hpp> (also included by <boost/signal.h>)
51 Requires:       %{name}-compressed_pair-devel = %{version}-%{release}
52 Requires:       %{name}-concept_check-devel = %{version}-%{release}
53 Requires:       libstdc++-devel
54
55 %description devel
56 Headers and static libraries for the Boost C++ libraries.
57
58 %description devel -l pl
59 Pliki nag³ówkowe i biblioteki statyczne bibliotek Boost C++.
60
61 %package python
62 Summary:        Boost.Python library
63 Summary(pl):    biblioteka Boost.Python
64 Group:          Libraries
65 Requires:       %{name} = %{version}-%{release}
66 %pyrequires_eq  python
67
68 %description python
69 Use the Boost Python Library to quickly and easily export a C++
70 library to Python such that the Python interface is very similar to
71 the C++ interface. It is designed to be minimally intrusive on your
72 C++ design. In most cases, you should not have to alter your C++
73 classes in any way in order to use them with Boost.Python. The system
74 should simply ``reflect'' your C++ classes and functions into Python.
75
76 %description python -l pl
77 Biblioteka Boost Python s³u¿y do szybkiego i prostego eksportu
78 biblioteki C++ do Pythona, tak ¿e interfejs Pythona jest bardzo
79 podobny do interfejsu C++. Biblioteka jest zaprojektowana tak, ¿eby
80 narzucaæ jak najmniej wymagañ dotycz±cych konstrukcjii C++. W
81 wiêkszo¶ci przypadków nie trzeba w ogóle zmieniaæ w³asnych klas C++,
82 ¿eby u¿ywaæ ich z Boost.Python. System powinien po prostu ,,odbiæ''
83 klasy C++ i funkcje do Pythona.
84
85 %package python-devel
86 Summary:        Boost.Python development headers
87 Summary(pl):    Pliki nag³ówkowe dla Boost.Python
88 Group:          Development/Libraries
89 Requires:       %{name}-devel = %{version}-%{release}
90 Requires:       %{name}-python = %{version}-%{release}
91
92 %description python-devel
93 Headers for the Boost.Python library.
94
95 %description python-devel -l pl
96 Pliki nag³ówkowe dla biblioteki Boost.Python.
97
98 %package python-static
99 Summary:        Static version of Boost.Python library
100 Summary(pl):    Statyczna wersja biblioteki Boost.Python
101 Group:          Development/Libraries
102 Requires:       %{name}-python-devel = %{version}-%{release}
103
104 %description python-static
105 Static version of Boost.Python library.
106
107 %description python-static -l pl
108 Statyczna wersja biblioteki Boost.Python.
109
110 %package regex
111 Summary:        Boost C++ regular expressions library
112 Summary(pl):    Biblioteka wyra¿eñ regularnych Boost C++
113 Group:          Libraries
114 Requires:       %{name} = %{version}-%{release}
115
116 %description regex
117 Shared library for Boost C++ regular expressions.
118
119 %description regex -l pl
120 Biblioteka wyra¿eñ regularnych dla C++, biblioteki dzielone.
121
122 %package regex-devel
123 Summary:        Boost C++ Regex library headers
124 Summary(pl):    Pliki nag³ówkowe Boost C++ Regex
125 Group:          Development/Libraries
126 Requires:       %{name}-devel = %{version}-%{release}
127 Requires:       %{name}-regex = %{version}-%{release}
128
129 %description regex-devel
130 Boost C++ Regex headers.
131
132 %description regex-devel -l pl
133 Pliki nag³ówkowe dla Boost C++ Regex.
134
135 %package regex-static
136 Summary:        Boost C++ Regex static libraries
137 Summary(pl):    Biblioteki statyczne Boost C++ Regex
138 Group:          Development/Libraries
139 Requires:       %{name}-devel = %{version}-%{release}
140 Requires:       %{name}-regex = %{version}-%{release}
141
142 %description regex-static
143 Boost C++ Regex static libraries.
144
145 %description regex-static -l pl
146 Biblioteki statyczne dla Boost C++ Regex.
147
148 %package any-devel
149 Summary:        Header for Boost C++ "Any" Library
150 Summary(pl):    Plik nag³ówkowy dla biblioteki Boost C++ "Any"
151 Group:          Development/Libraries
152 Requires:       %{name}-devel = %{version}-%{release}
153
154 %description any-devel
155 The boost::any class, is a variant value type, which supports copying
156 of any value type and safe checked extraction of that value strictly
157 against that type.
158
159 I.e. 5 is held strictly as an int and is not implicitly convertible
160 either to "5" or to 5.0.
161
162 %description any-devel -l pl
163 Klasa boost::any jest typem, który umo¿liwia kopiowanie ze zmiennej
164 dowolnego typu i bezpieczne, sprawdzone wydobycie jej warto¶ci
165 dok³adnie tego samego typu.
166
167 Np. 5 jest trzymane jako int i nie jest niejawnie konwertowalne ani do
168 "5" ani do 5.0.
169
170 %package array-devel
171 Summary:        STL compliant container wrapper for arrays of constant size
172 Summary(pl):    Wrapper na STLowe kontenery dla tablic o sta³ym rozmiarze
173 Group:          Development/Libraries
174 Requires:       %{name}-devel = %{version}-%{release}
175
176 %description array-devel
177 As replacement for ordinary arrays, the STL provides class vector<>.
178 However, vector<> provides the semantics of dynamic arrays. Thus, it
179 manages data to be able to change the number of elements. This results
180 in some overhead in case only arrays with static size are needed. This
181 library provides support for such static size arrays.
182
183 %description array-devel -l pl
184 STL dostarcza klasê vector<> jako zamiennik zwyk³ej tablicy. Jednak
185 vector<> dostarcza semantykê dynamicznych tablic. Zatem zarz±dza
186 danymi tak, by by³a mo¿liwa zmiana ilo¶ci elementów. To skutkuje
187 pewnym nadmiarem w przypadku kiedy tylko tablice o sta³ym rozmiarze s±
188 potrzebne. Ta biblioteka dostarcza wsparcie dla takich w³a¶nie tablic
189 o sta³ym rozmiarze.
190
191 %package bind-devel
192 Summary:        Generalized binders for function/object/pointers
193 Summary(pl):    Uogólnione bindery dla funkcji/obiektów/wska¼ników
194 Group:          Development/Libraries
195 Requires:       %{name}-mem_fn-devel = %{version}-%{release}
196 Requires:       %{name}-ref-devel = %{version}-%{release}
197
198 %description bind-devel
199 boost::bind is a generalization of the standard functions std::bind1st
200 and std::bind2nd.
201
202 %description bind-devel -l pl
203 boost::bind jest uogólnieniem standardowych funkcji std::bind1st i
204 std::bind2nd.
205
206 %package call_traits-devel
207 Summary:        Defines types for passing parameters
208 Summary(pl):    Definiowanie typów dla przekazywania parametrów
209 Group:          Development/Libraries
210 Requires:       %{name}-devel = %{version}-%{release}
211 Requires:       %{name}-type_traits-devel = %{version}-%{release}
212
213 %description call_traits-devel
214 boost::call_traits<T> encapsulates the "best" method to pass a
215 parameter of some type T to or from a function. The purpose of
216 call_traits is to ensure that problems like "references to references"
217 never occur, and that parameters are passed in the most efficient
218 manner possible.
219
220 %description call_traits-devel -l pl
221 boost::call_traits<T> zawiera "najlepsz±" metodê przekazywania
222 parametrów jakiego¶ typu T do lub z funkcji. Celem call_traits jest
223 zapewnienie ¿e problemy takie jak "referencja referencji" nigdy nie
224 wyst±pi± i ¿e parametry s± przekazywane w mo¿liwie najbardziej
225 efektywny sposób.
226
227 %package compatibility-devel
228 Summary:        Help for non-conforming standard libraries
229 Summary(pl):    Pomoc dla nie trzymaj±cych standardu bibliotek
230 Group:          Development/Libraries
231 Requires:       %{name}-devel = %{version}-%{release}
232
233 %description compatibility-devel
234 This library provides workarounds which allow the other Boost
235 libraries to be used on otherwise non-conforming platforms.
236
237 %description compatibility-devel -l pl
238 Biblioteka dostarcza obej¶cie problemu platform nie trzymaj±cych
239 standardu C++, pozwalaj±ce na u¿ywanie bibliotek Boost na tych
240 platformach.
241
242 %package compose-devel
243 Summary:        Functional composition adapters for the STL
244 Summary(pl):    Funkcjonalne adaptery kompozycji dla STL
245 Group:          Development/Libraries
246 Requires:       %{name}-devel = %{version}-%{release}
247
248 %description compose-devel
249 The boost::compose provides compose function object adapter extensions
250 for use with the Standard Template Library (STL) portion of the C++
251 Standard Library. If you aren't currently using the STL, this library
252 won't be of any interest, but hard-core STL users will appreciate its
253 usefulness.
254
255 %description compose-devel -l pl
256 boost::compose dostarcza rozszerzenie adaptera obiektu funkcji compose
257 do u¿ytku z STL-ow± czê¶ci± Standardu C++. Je¿eli nie u¿ywasz STL,
258 biblioteka bêdzie poza twoim zainteresowaniem, lecz hardkorowi
259 u¿ytkownicy STL-a doceni± jej u¿yteczno¶æ.
260
261 %package compressed_pair-devel
262 Summary:        Empty member optimization
263 Summary(pl):    Optymalizacja pustego elementu
264 Group:          Development/Libraries
265 Requires:       %{name}-call_traits-devel = %{version}-%{release}
266 Requires:       %{name}-devel = %{version}-%{release}
267
268 %description compressed_pair-devel
269 The class boost::compressed_pair is very similar to std::pair, but if
270 either of the template arguments are empty classes, then the "empty
271 base-class optimisation" is applied to compress the size of the pair.
272
273 %description compressed_pair-devel -l pl
274 Klasa boost::compressed_pair jest bardzo podobna do std::pair, ale
275 je¿eli który¶ z argumentów wzorca jest pust± klas±, wtedy stosowana
276 jest "optymalizacja pustej klasy bazowej" do kompresji pary.
277
278 %package concept_check-devel
279 Summary:        Tools for generic programming
280 Summary(pl):    Narzêdzia dla programowania generycznego
281 Group:          Development/Libraries
282 Requires:       %{name}-static_assert-devel = %{version}-%{release}
283 Requires:       %{name}-type_traits-devel = %{version}-%{release}
284
285 %description concept_check-devel
286 The boost::concept_check library provides various tools for generic
287 programming.
288
289 %description concept_check-devel -l pl
290 Biblioteka boost::concept_check dostarcza ró¿ne narzêdzia dla
291 programowania generycznego.
292
293 %package conversion-devel
294 Summary:        Numeric, polymorphic, and lexical casts
295 Summary(pl):    Numeryczne, polimorficzne i leksykalne rzutowania
296 Group:          Development/Libraries
297 Requires:       %{name}-type_traits-devel = %{version}-%{release}
298
299 %description conversion-devel
300 The boost::conversion library improves program safety and clarity by
301 performing otherwise messy conversions. It includes cast-style
302 function templates designed to complement the C++ Standard's built-in
303 casts.
304
305 %description conversion-devel -l pl
306 Biblioteka boost::conversion zwiêksza bezpieczeñstwo i klarowno¶æ
307 programu dokonuj±c konwersji które s± w innych przypadkach niechlujne.
308 Biblioteka zawiera "rzutopodobne" wzorce funkcji uzupe³niaj±ce
309 wbudowane w Standard C++ rzutowania.
310
311 %package crc-devel
312 Summary:        CRC computing library
313 Summary(pl):    Biblioteka obliczaj±ca CRC
314 Group:          Development/Libraries
315 Requires:       %{name}-devel = %{version}-%{release}
316
317 %description crc-devel
318 The boost::crc library provides two implementations of CRC computation
319 objects and functions. The implementations are template-based.
320
321 %description crc-devel -l pl
322 Bibliteka boost::crc dostarcza dwie implementacje obiektów i funkcji
323 obliczaj±cych CRC. Implementacje s± oparte na wzorcach.
324
325 %package date_time
326 Summary:        Date-Time library
327 Summary(pl):    Biblioteka daty-czasu
328 Group:          Libraries
329
330 %description date_time
331 A set of date-time libraries.
332
333 %description date_time -l pl
334 Zbiór bibliotek daty-czasu.
335
336 %package date_time-devel
337 Summary:        Header files for boost::date_time library
338 Summary(pl):    Pliki nag³ówkowe dla biblioteki boost::date_time
339 Group:          Development/Libraries
340 Requires:       %{name}-date_time = %{version}-%{release}
341 #TODO: make decision if do separate packages include it to main devel package
342 #Requires:      %{name}-operators-devel = %{version}-%{release}
343 #Requires:      %{name}-integer-devel = %{version}-%{release}
344 #Requires:      %{name}-tokenizer-devel = %{version}-%{release}
345 Requires:       %{name}-conversion-devel = %{version}-%{release}
346
347 %description date_time-devel
348 Header files for boost::date_time library.
349
350 %description date_time-devel -l pl
351 Pliki nag³ówkowe dla biblioteki boost::date_time
352
353 %package date_time-static
354 Summary:        Static boost::date_time library
355 Summary(pl):    Statyczna biblioteka boost::date_time
356 Group:          Development/Libraries
357 Requires:       %{name}-date_time-devel = %{version}-%{release}
358
359 %description date_time-static
360 Static boost::date_time library.
361
362 %description date_time-devel -l pl
363 Statyczna biblioteka boost::date_time.
364
365 %package mem_fn-devel
366 Summary:        Generalized binders for member functions
367 Summary(pl):    Uogólnione bindery dla metod
368 Group:          Development/Libraries
369 Requires:       %{name}-bind-devel = %{version}-%{release}
370
371 %description mem_fn-devel
372 boost::mem_fn is a generalization of the standard functions
373 std::mem_fun and std::mem_fun_ref.
374
375 %description mem_fn-devel -l pl
376 boost::mem_fn jest uogólnieniem standardowych funkcji std::mem_fun i
377 std::mem_fun_ref.
378
379 %package mpl-devel
380 Summary:        Compile-time algorithms, sequences and metafunction classes
381 Summary(pl):    Algorytmy czasu kompilacji, sekwencji i klas metafunkcji
382 Group:          Development/Libraries
383 Requires:       %{name}-devel = %{version}-%{release}
384 Requires:       %{name}-preprocessor-devel = %{version}-%{release}
385 Requires:       %{name}-type_traits-devel = %{version}-%{release}
386 Requires:       %{name}-utility-devel = %{version}-%{release}
387
388 %description mpl-devel
389 The boost-mpl library is a C++ template metaprogramming framework of
390 compile-time algorithms, sequences and metafunction classes.
391
392 %description mpl-devel -l pl
393 Biblioteka boost-mpl jest szkieletem wzorców C++ dla algorytmów czasu
394 kompilacji, sekwencji i klas metafunkcji.
395
396 %package preprocessor-devel
397 Summary:        Preprocessor metaprogramming tools including repetition and recursion
398 Summary(pl):    Narzêdzia metaprogramowania preprocesora razem z repetycj± i rekursj±
399 Group:          Development/Libraries
400 Requires:       %{name}-devel = %{version}-%{release}
401
402 %description preprocessor-devel
403 This library provides preprocessor metaprogramming tools, including
404 repetition and recursion.
405
406 %description preprocessor-devel -l pl
407 Biblioteka udostêpnia narzêdzia metaprogramowania preprocesora,
408 w³±czaj±c w to repetycje i rekursjê.
409
410 %package ref-devel
411 Summary:        Small library useful for passing references to function templates
412 Summary(pl):    Ma³a biblioteka u¿yteczna przy przekazywaniu referencji do wzorców funkcji
413 Group:          Development/Libraries
414 Requires:       %{name}-devel = %{version}-%{release}
415 Requires:       %{name}-mpl-devel = %{version}-%{release}
416 Requires:       %{name}-utility-devel = %{version}-%{release}
417
418 %description ref-devel
419 boost::ref library is a small library that is useful for passing
420 references to function templates (algorithms) that would usually take
421 copies of their arguments.
422
423 %description ref-devel -l pl
424 Biblioteka boost::ref jest ma³± bibliotek± która jest u¿yteczna w
425 przypadku przekazywania referencji do wzorców funkcji (algorytmów)
426 które zazwyczaj bior± kopiê swoich argumentów.
427
428 %package static_assert-devel
429 Summary:        Static assertions (compile time assertions)
430 Summary(pl):    Statyczne asercje (asercje kompilacyjne)
431 Group:          Development/Libraries
432 Requires:       %{name}-devel = %{version}
433
434 %description static_assert-devel
435 The header <boost/static_assert.hpp> supplies a single macro
436 BOOST_STATIC_ASSERT(x), which generates a compile time error message
437 if the integral-constant-expression x is not true. In other words it
438 is the compile time equivalent of the assert macro; this is sometimes
439 known as a "compile-time-assertion"
440
441 One of the aims of BOOST_STATIC_ASSERT is to generate readable error
442 messages. These immediately tell the user that a library is being used
443 in a manner that is not supported.
444
445 %description static_assert-devel -l pl
446 Plik nag³ówkowy <boost/static_assert.hpp> dostarcza pojedyncze makro
447 BOOST_STATIC_ASSERT(x), które generuje komunikat b³êdu kompilacji
448 je¿eli sta³e wyra¿enie x nie jest prawdziwe. Innymi s³owy jest to
449 kompilacyjny ekwiwalent makra 'assert'; czasami znane jest jako
450 "asercja czasu kompilacji"
451
452 Jednym z celów BOOST_STATIC_ASSERT jest generowanie czytelnych
453 komunikatów o b³êdach. One b³yskawicznie powiedz± u¿ytkownikowi ¿e
454 biblioteka zosta³a u¿yta w sposób który nie jest zalecany.
455
456 %package thread
457 Summary:        Portable C++ threads library
458 Summary(pl):    Przeno¶na biblioteka w±tków C++
459 Group:          Libraries
460
461 %description thread
462 Portable C++ threads library. Shared libraries.
463
464 %description thread -l pl
465 Przeno¶na biblioteka w±tków dla C++. Biblioteki dzielone.
466
467 %package thread-devel
468 Summary:        Header files for boost::thread library
469 Summary(pl):    Pliki nag³ówkowe dla biblioteki boost::thread
470 Group:          Development/Libraries
471 Requires:       %{name}-thread = %{version}-%{release}
472 Requires:       %{name}-utility-devel = %{version}-%{release}
473 #TODO:requires boost::function or boost::function to boost-devel
474
475 %description thread-devel
476 Header files for boost::thread library.
477
478 %description thread-devel -l pl
479 Pliki nag³ówkowe dla biblioteki boost::thread.
480
481 %package type_traits-devel
482 Summary:        Templates for fundamental properties of types
483 Summary(pl):    Wzorce dla fundamentalnych w³a¶ciwo¶ci typów
484 Group:          Development/Libraries
485 Requires:       %{name}-devel = %{version}-%{release}
486 Requires:       %{name}-mpl-devel = %{version}-%{release}
487 Requires:       %{name}-preprocessor-devel = %{version}-%{release}
488 Requires:       %{name}-utility-devel = %{version}-%{release}
489 Requires:       %{name}-static_assert-devel = %{version}-%{release}
490
491 %description type_traits-devel
492 The boost-type_traits library defines three kinds of type trait:
493  1. The properties of a specific type.
494  2. The relationship between two types.
495  3. A transformation from one type to another.
496
497 %description type_traits-devel -l pl
498 Biblioteka boost-type_traits definiuje trzy rodzaje cech typów:
499  1. w³a¶ciwo¶ci konkretnego typu.
500  2. powi±zania miêdzy dwoma typami.
501  3. transformacjê z jednego typu do drugiego.
502
503 %package utility-devel
504 Summary:        Useful utilities: classes and function templates
505 Summary(pl):    U¿yteczne narzêdzia: klasy i wzorce funkcji
506 Group:          Development/Libraries
507 Requires:       %{name}-type_traits-devel = %{version}
508
509 %description utility-devel
510 Class noncopyable plus checked_delete(), checked_array_delete(),
511 next(), prior() function templates, plus base-from-member idiom.
512
513 %description utility-devel -l pl
514 Klasy noncopyable i checked_delete, funkcje checked_array_delete(),
515 next(), prior() oraz idiom base-from-member.
516
517 %package static
518 Summary:        Static versions of Boost libraries
519 Summary(pl):    Statyczne wersje bibliotek Boost
520 Group:          Development/Libraries
521 Requires:       %{name}-devel = %{version}-%{release}
522
523 %description static
524 Static versions of Boost libraries.
525
526 %description static -l pl
527 Statyczne wersje bibliotek Boost.
528
529 %package doc
530 Summary:        Boost C++ Library documentation
531 Summary(pl):    Dokumentacja dla biblioteki Boost C++
532 Group:          Documentation
533 Requires:       %{name}-devel = %{version}-%{release}
534
535 %description doc
536 Documentation for the Boost C++ Library.
537
538 %description doc -l pl
539 Dokumentacja dla biblioteki Boost C++.
540
541 %prep
542 %setup -q
543 %patch0 -p1
544
545 # don't know how to pass it through (b)jam -s (no way?)
546 # due to oversophisticated build flags system
547 %{__perl} -pi -e 's/ -O3 / %{rpmcflags} /' tools/build/gcc-tools.jam
548
549 %build
550 %if %{with python}
551 PYTHON_VERSION=`python -V 2>&1 | sed 's,.* \([0-9]\.[0-9]\)\(\.[0-9]\)\?.*,\1,'`
552 PYTHON_ROOT=%{_prefix}
553 %else
554 PYTHON_ROOT=
555 PYTHON_VERSION=
556 %endif
557 bjam \
558         -d2 \
559         -sBUILD=release \
560         -sPYTHON_ROOT=$PYTHON_ROOT \
561         -sPYTHON_VERSION=$PYTHON_VERSION
562
563 %install
564 rm -rf $RPM_BUILD_ROOT
565 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}}
566
567 cp -rf boost $RPM_BUILD_ROOT%{_includedir}
568
569 install libs/*/build/bin/*.a/*/*/*/lib*.a $RPM_BUILD_ROOT%{_libdir}
570 install libs/*/build/bin/*.so/*/*/*/*/{,*/}lib*.so.*.*.* $RPM_BUILD_ROOT%{_libdir}
571 cp -df libs/*/build/bin/*.so/*/*/*/*/{,*/}lib*.so $RPM_BUILD_ROOT%{_libdir}
572
573 # documentation
574 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}
575 install README $RPM_BUILD_ROOT%{_docdir}/boost-%{version}
576
577 # as the documentation doesn't completely reside in a directory of its
578 # own, we need to find out ourselves... this looks for HTML files and
579 # then collects everything linked from those.  this is certainly quite
580 # unoptimized wrt mkdir calls, but does it really matter?
581 for i in `find -type f -name '*.htm*'`; do
582         # bjam docu is included in the boost-jam RPM
583         if test "`echo $i | sed 's,jam_src,,'`" = "$i"; then
584                 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/`dirname $i`
585                 for LINKED in `%{__perl} - $i $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$i <<'EOT'
586                         sub rewrite_link
587                         {
588                                 my $link = shift;
589                                 # rewrite links from boost/* to %{_includedir}/boost/* and
590                                 # ignore external links as well as document-internal ones.
591                                 # HTML files are also ignored as they get installed anyway.
592                                 if (!($link =~ s,^(?:../)*boost/,%{_includedir}/boost/,) && !($link =~ m,(?:^[^/]+:|^\#|\.html?(?:$|\#)),))
593                                 {
594                                         (my $file = $link) =~ s/\#.*//;
595                                         print "$file\n";
596                                 }
597                                 $link;
598                         }
599                         open IN, @ARGV[0];
600                         open OUT, ">@ARGV[1]";
601                         my $in_link;
602                         while (<IN>)
603                         {
604                                 $in_link and s/^\s*"([^"> ]*)"/'"' . rewrite_link($1) . '"'/e;
605                                 s/(href|src)="([^"> ]*)"/"$1=\"" . rewrite_link($2) . '"'/eig;
606                                 print OUT;
607                                 $in_link = /href|src=\s*$/;
608                         }
609 EOT`; do
610                         TARGET=`dirname $i`/$LINKED
611                         # ignore non-existant linked files
612                         if test -f $TARGET; then
613                                 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/`dirname $TARGET`
614                                 install -m 644 $TARGET $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$TARGET
615                         fi
616                 done
617         fi
618 done
619
620 %clean
621 rm -rf $RPM_BUILD_ROOT
622
623 %post   -p /sbin/ldconfig
624 %postun -p /sbin/ldconfig
625
626 %post   python  -p /sbin/ldconfig
627 %postun python  -p /sbin/ldconfig
628
629 %post   regex   -p /sbin/ldconfig
630 %postun regex   -p /sbin/ldconfig
631
632 %files
633 %defattr(644,root,root,755)
634 %attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor.so.*.*.*
635 %attr(755,root,root) %{_libdir}/libboost_signals.so.*.*.*
636 %attr(755,root,root) %{_libdir}/libboost_test_exec_monitor.so.*.*.*
637 %attr(755,root,root) %{_libdir}/libboost_unit_test_framework.so.*.*.*
638
639 %files devel
640 %defattr(644,root,root,755)
641 %attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor.so
642 %attr(755,root,root) %{_libdir}/libboost_signals.so
643 %attr(755,root,root) %{_libdir}/libboost_test_exec_monitor.so
644 %attr(755,root,root) %{_libdir}/libboost_unit_test_framework.so
645 %dir %{_includedir}/boost
646 %{_includedir}/boost/assert.hpp
647 %{_includedir}/boost/config
648 %{_includedir}/boost/config.hpp
649 %{_includedir}/boost/counting_iterator.hpp
650 %{_includedir}/boost/cstd*.hpp
651 %{_includedir}/boost/current_function.hpp
652 %dir %{_includedir}/boost/detail
653 %{_includedir}/boost/detail/algorithm.hpp
654 %{_includedir}/boost/detail/allocator.hpp
655 %{_includedir}/boost/detail/atomic_count*.hpp
656 %{_includedir}/boost/detail/binary_search.hpp
657 %{_includedir}/boost/detail/catch_exceptions.hpp
658 %{_includedir}/boost/detail/dynamic_bitset.hpp
659 %{_includedir}/boost/detail/iterator.hpp
660 %{_includedir}/boost/detail/lightweight_*.hpp
661 %{_includedir}/boost/detail/limits.hpp
662 %{_includedir}/boost/detail/lwm_*.hpp
663 %{_includedir}/boost/detail/named_template_params.hpp
664 %{_includedir}/boost/detail/numeric_traits.hpp
665 %{_includedir}/boost/detail/quick_allocator.hpp
666 %{_includedir}/boost/detail/select_type.hpp
667 %{_includedir}/boost/detail/shared_*.hpp
668 %{_includedir}/boost/detail/workaround.hpp
669 %{_includedir}/boost/dynamic_bitset*.hpp
670 %{_includedir}/boost/enable_shared_from_this.hpp
671 %{_includedir}/boost/filesystem
672 %{_includedir}/boost/format
673 %{_includedir}/boost/format.hpp
674 %{_includedir}/boost/function
675 %{_includedir}/boost/function.hpp
676 %{_includedir}/boost/function_output_iterator.hpp
677 %{_includedir}/boost/functional.hpp
678 %{_includedir}/boost/generator_iterator.hpp
679 %{_includedir}/boost/graph
680 %{_includedir}/boost/half_open_range.hpp
681 %{_includedir}/boost/integer
682 %{_includedir}/boost/integer*.hpp
683 %{_includedir}/boost/intrusive_ptr.hpp
684 %{_includedir}/boost/io
685 %{_includedir}/boost/io_fwd.hpp
686 %{_includedir}/boost/iterator*.hpp
687 %{_includedir}/boost/lambda
688 %{_includedir}/boost/last_value.hpp
689 %{_includedir}/boost/limits.hpp
690 %{_includedir}/boost/math
691 %{_includedir}/boost/math_fwd.hpp
692 %{_includedir}/boost/min_rand.hpp
693 %{_includedir}/boost/multi_array
694 %{_includedir}/boost/multi_array.hpp
695 %{_includedir}/boost/nondet_random.hpp
696 %{_includedir}/boost/numeric
697 %{_includedir}/boost/operators.hpp
698 %{_includedir}/boost/optional.hpp
699 %{_includedir}/boost/pending
700 %{_includedir}/boost/permutation_iterator.hpp
701 %{_includedir}/boost/pool
702 %{_includedir}/boost/progress.hpp
703 %{_includedir}/boost/property_map*.hpp
704 %{_includedir}/boost/random
705 %{_includedir}/boost/random.hpp
706 %{_includedir}/boost/rational.hpp
707 %{_includedir}/boost/scoped_*.hpp
708 %{_includedir}/boost/shared_*.hpp
709 %{_includedir}/boost/signal.hpp
710 %{_includedir}/boost/signals
711 %{_includedir}/boost/smart_ptr.hpp
712 %{_includedir}/boost/spirit
713 %{_includedir}/boost/spirit.hpp
714 %{_includedir}/boost/test
715 %{_includedir}/boost/throw_exception.hpp
716 %{_includedir}/boost/timer.hpp
717 %{_includedir}/boost/token*.hpp
718 %{_includedir}/boost/tuple
719 %{_includedir}/boost/type.hpp
720 %{_includedir}/boost/type_traits
721 %{_includedir}/boost/utility
722 %{_includedir}/boost/version.hpp
723 %{_includedir}/boost/visit_each.hpp
724 %{_includedir}/boost/weak_ptr.hpp
725
726 %files static
727 %defattr(644,root,root,755)
728 %{_libdir}/libboost_filesystem.a
729 %{_libdir}/libboost_prg_exec_monitor.a
730 %{_libdir}/libboost_signals.a
731 %{_libdir}/libboost_test_exec_monitor.a
732 %{_libdir}/libboost_unit_test_framework.a
733
734 %if %{with python}
735 %files python
736 %defattr(644,root,root,755)
737 %attr(755,root,root) %{_libdir}/libboost_python.so.*.*.*
738
739 %files python-devel
740 %defattr(644,root,root,755)
741 %attr(755,root,root) %{_libdir}/libboost_python.so
742 %{_includedir}/boost/python
743 %{_includedir}/boost/python.hpp
744
745 %files python-static
746 %defattr(644,root,root,755)
747 %{_libdir}/libboost_python.a
748 %endif
749
750 %files regex
751 %defattr(644,root,root,755)
752 %attr(755,root,root) %{_libdir}/libboost_regex.so.*.*.*
753
754 %files regex-devel
755 %defattr(644,root,root,755)
756 %attr(755,root,root) %{_libdir}/libboost_regex.so
757 %{_includedir}/boost/cregex.hpp
758 %{_includedir}/boost/regex.h
759 %{_includedir}/boost/regex*.hpp
760 %{_includedir}/boost/regex
761
762 %files regex-static
763 %defattr(644,root,root,755)
764 %{_libdir}/libboost_regex.a
765
766 %files any-devel
767 %defattr(644,root,root,755)
768 %{_includedir}/boost/any.hpp
769
770 %files array-devel
771 %defattr(644,root,root,755)
772 %{_includedir}/boost/array.hpp
773
774 %files bind-devel
775 %defattr(644,root,root,755)
776 %{_includedir}/boost/bind
777 %{_includedir}/boost/bind.hpp
778
779 %files call_traits-devel
780 %defattr(644,root,root,755)
781 %{_includedir}/boost/call_traits.hpp
782 %{_includedir}/boost/detail/call_traits.hpp
783 %{_includedir}/boost/detail/ob_call_traits.hpp
784
785 %files compatibility-devel
786 %defattr(644,root,root,755)
787 %{_includedir}/boost/compatibility
788
789 %files compose-devel
790 %defattr(644,root,root,755)
791 %{_includedir}/boost/compose.hpp
792
793 %files compressed_pair-devel
794 %defattr(644,root,root,755)
795 %{_includedir}/boost/compressed_pair.hpp
796 %{_includedir}/boost/detail/compressed_pair.hpp
797 %{_includedir}/boost/detail/ob_compressed_pair.hpp
798
799 %files concept_check-devel
800 %defattr(644,root,root,755)
801 %{_includedir}/boost/concept_archetype.hpp
802 %{_includedir}/boost/concept_check.hpp
803
804 %files conversion-devel
805 %defattr(644,root,root,755)
806 %{_includedir}/boost/cast.hpp
807 %{_includedir}/boost/lexical_cast.hpp
808
809 %files crc-devel
810 %defattr(644,root,root,755)
811 %{_includedir}/boost/crc.hpp
812
813 %files date_time
814 %defattr(644,root,root,755)
815 %attr(755,root,root) %{_libdir}/libboost_date_time.so.*.*.*
816
817 %files date_time-devel
818 %defattr(644,root,root,755)
819 %attr(755,root,root) %{_libdir}/libboost_date_time.so
820 %{_includedir}/boost/date_time
821
822 %files date_time-static
823 %defattr(644,root,root,755)
824 %{_libdir}/libboost_date_time.a
825
826 %files mem_fn-devel
827 %defattr(644,root,root,755)
828 %{_includedir}/boost/get_pointer.hpp
829 %{_includedir}/boost/mem_fn.hpp
830
831 %files mpl-devel
832 %defattr(644,root,root,755)
833 %{_includedir}/boost/mpl
834
835 %files preprocessor-devel
836 %defattr(644,root,root,755)
837 %{_includedir}/boost/preprocessor
838 %{_includedir}/boost/preprocessor.hpp
839
840 %files ref-devel
841 %defattr(644,root,root,755)
842 %{_includedir}/boost/ref.hpp
843
844 %files static_assert-devel
845 %defattr(644,root,root,755)
846 %{_includedir}/boost/static_assert.hpp
847
848 %files thread
849 %defattr(644,root,root,755)
850 %attr(755,root,root) %{_libdir}/libboost_thread.so.*.*.*
851
852 %files thread-devel
853 %defattr(644,root,root,755)
854 %attr(755,root,root) %{_libdir}/libboost_thread.so
855 %{_includedir}/boost/thread
856 %{_includedir}/boost/thread.hpp
857
858 %files type_traits-devel
859 %defattr(644,root,root,755)
860 %{_includedir}/boost/type_traits.hpp
861 %{_includedir}/boost/type_traits
862
863 %files utility-devel
864 %defattr(644,root,root,755)
865 %{_includedir}/boost/checked_delete.hpp
866 %{_includedir}/boost/next_prior.hpp
867 %{_includedir}/boost/noncopyable.hpp
868 %{_includedir}/boost/utility*.hpp
869 %{_includedir}/boost/utility
870
871 %files doc
872 %defattr(644,root,root,755)
873 %{_docdir}/boost-%{version}
This page took 0.120886 seconds and 4 git commands to generate.