]> git.pld-linux.org Git - packages/boost.git/blob - boost.spec
- cleanup junk in gcc flags
[packages/boost.git] / boost.spec
1 #
2 # TODO:
3 #       - think about building MPI.
4 #       - split shared libs from core package into -iostreams/-serialization.
5 #       - fix building context and corouting on x32 (patch1)
6 #
7 # Conditional build:
8 %bcond_without  python2         # without boost-python2 support
9 %bcond_without  python3         # without boost-python3 support
10
11 %define         fver    %(echo %{version} | tr . _)
12 Summary:        The Boost C++ Libraries
13 Summary(pl.UTF-8):      Biblioteki C++ "Boost"
14 Name:           boost
15 Version:        1.58.0
16 Release:        1
17 License:        Boost Software License and others
18 Group:          Libraries
19 Source0:        http://downloads.sourceforge.net/boost/%{name}_%{fver}.tar.bz2
20 # Source0-md5:  b8839650e61e9c1c0a89f371dd475546
21 Patch0:         %{name}-link.patch
22 Patch1:         %{name}-x32-context.patch
23 Patch2:         %{name}-clean-gcc-flags.patch
24 # FC Patches:
25 # https://svn.boost.org/trac/boost/ticket/5637
26 Patch203:       %{name}-1.54.0-mpl-print.patch
27 # https://svn.boost.org/trac/boost/ticket/8870
28 Patch211:       %{name}-1.54.0-spirit-unused_typedef.patch
29 Patch212:       %{name}-1.54.0-spirit-unused_typedef-2.patch
30 # https://svn.boost.org/trac/boost/ticket/8878
31 Patch218:       %{name}-1.54.0-locale-unused_typedef.patch
32 # https://svn.boost.org/trac/boost/ticket/8881
33 Patch221:       %{name}-1.54.0-mpi-unused_typedef.patch
34 # https://svn.boost.org/trac/boost/ticket/8888
35 Patch222:       %{name}-1.54.0-python-unused_typedef.patch
36 URL:            http://www.boost.org/
37 BuildRequires:  bzip2-devel
38 BuildRequires:  expat-devel
39 BuildRequires:  libicu-devel
40 BuildRequires:  libstdc++-devel
41 BuildRequires:  perl-base
42 %{?with_python:BuildRequires:   python-devel >= 2.2}
43 %{?with_python3:BuildRequires:  python3-devel}
44 BuildRequires:  rpm-pythonprov
45 BuildRequires:  zlib-devel
46 BuildConflicts: gcc = 5:3.3.1
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %define         specflags       -DBOOST_IOSTREAMS_USE_DEPRECATED=1
50
51 %description
52 The Boost web site provides free peer-reviewed portable C++ source
53 libraries. The emphasis is on libraries which work well with the C++
54 Standard Library. One goal is to establish "existing practice" and
55 provide reference implementations so that the Boost libraries are
56 suitable for eventual standardization. Some of the libraries have
57 already been proposed for inclusion in the C++ Standards Committee's
58 upcoming C++ Standard Library Technical Report.
59
60 %description -l pl.UTF-8
61 Strona http://www.boost.org/ dostarcza darmowe biblioteki C++ wraz z
62 kodem źródłowym. Nacisk położono na biblioteki, które dobrze
63 współpracują ze standardową biblioteką C++. Celem jest ustanowienie
64 "istniejącej praktyki" i dostarczenie implementacji, tak że biblioteki
65 "Boost" nadają się do ewentualnej standaryzacji. Niektóre z bibliotek
66 już zostały zgłoszone do komitetu standaryzacyjnego C++ w nadchodzącym
67 Raporcie Technicznym Biblioteki Standardowej C++.
68
69 %package devel
70 Summary:        Boost C++ development headers
71 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek C++ Boost
72 Group:          Development/Libraries
73 Requires:       %{name} = %{version}-%{release}
74 Requires:       %{name}-chrono = %{version}-%{release}
75 %ifnarch x32
76 Requires:       %{name}-context = %{version}-%{release}
77 %endif
78 Requires:       %{name}-date_time = %{version}-%{release}
79 Requires:       %{name}-filesystem = %{version}-%{release}
80 Requires:       %{name}-graph = %{version}-%{release}
81 Requires:       %{name}-locale = %{version}-%{release}
82 Requires:       %{name}-log = %{version}-%{release}
83 Requires:       %{name}-program_options = %{version}-%{release}
84 Requires:       %{name}-regex = %{version}-%{release}
85 Requires:       %{name}-signals = %{version}-%{release}
86 Requires:       %{name}-system = %{version}-%{release}
87 Requires:       %{name}-test = %{version}-%{release}
88 Requires:       %{name}-thread = %{version}-%{release}
89 Requires:       %{name}-timer = %{version}-%{release}
90 Requires:       %{name}-wave = %{version}-%{release}
91 Requires:       libstdc++-devel
92 Obsoletes:      boost-any-devel
93 Obsoletes:      boost-array-devel
94 Obsoletes:      boost-asio
95 Obsoletes:      boost-bind-devel
96 Obsoletes:      boost-call_traits-devel
97 Obsoletes:      boost-compatibility-devel
98 Obsoletes:      boost-compose-devel
99 Obsoletes:      boost-compressed_pair-devel
100 Obsoletes:      boost-concept_check-devel
101 Obsoletes:      boost-conversion-devel
102 Obsoletes:      boost-crc-devel
103 Obsoletes:      boost-date_time-devel
104 Obsoletes:      boost-filesystem-devel
105 Obsoletes:      boost-graph-devel
106 Obsoletes:      boost-mem_fn-devel
107 Obsoletes:      boost-mpl-devel
108 Obsoletes:      boost-preprocessor-devel
109 Obsoletes:      boost-program_options-devel
110 Obsoletes:      boost-ref-devel
111 Obsoletes:      boost-regex-devel
112 Obsoletes:      boost-signals-devel
113 Obsoletes:      boost-spirit-devel
114 Obsoletes:      boost-statechart-devel
115 Obsoletes:      boost-static_assert-devel
116 Obsoletes:      boost-test-devel
117 Obsoletes:      boost-thread-devel
118 Obsoletes:      boost-tr1-devel
119 Obsoletes:      boost-type_traits-devel
120 Obsoletes:      boost-typeof-devel
121 Obsoletes:      boost-uBLAS-devel
122 Obsoletes:      boost-utility-devel
123 Obsoletes:      boost-wave-devel
124 Obsoletes:      boost-xpressive-devel
125
126 %description devel
127 Header files for the Boost C++ libraries.
128
129 %description devel -l pl.UTF-8
130 Pliki nagłówkowe bibliotek C++ Boost.
131
132 %package static
133 Summary:        Static version of base Boost C++ libraries
134 Summary(pl.UTF-8):      Statyczne wersje podstawowych bibliotek C++ Boost
135 Group:          Development/Libraries
136 Requires:       %{name}-devel = %{version}-%{release}
137 Obsoletes:      boost-static < 1.33
138
139 %description static
140 Static version of base Boost C++ libraries.
141
142 %description static -l pl.UTF-8
143 Statyczne wersje podstawowych bibliotek C++ Boost.
144
145 %package python-devel-common
146 Summary:        Boost.Python development headers
147 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Boost.Python
148 Group:          Development/Libraries
149 Requires:       %{name}-devel = %{version}-%{release}
150
151 %description python-devel-common
152 Headers for the Boost.Python library.
153
154 %description python-devel-common -l pl.UTF-8
155 Pliki nagłówkowe biblioteki Boost.Python.
156
157 %package python
158 Summary:        Boost.Python library for Python 2
159 Summary(pl.UTF-8):      Biblioteka Boost.Python dla Pythona 2
160 Group:          Libraries
161 Requires:       python-libs
162
163 %description python
164 Use the Boost Python Library to quickly and easily export a C++
165 library to Python 2 such that the Python 2 interface is very similar
166 to the C++ interface. It is designed to be minimally intrusive on your
167 C++ design. In most cases, you should not have to alter your C++
168 classes in any way in order to use them with Boost.Python. The system
169 should simply ``reflect'' your C++ classes and functions into Python
170 3.
171
172 %description python -l pl.UTF-8
173 Biblioteka Boost Python służy do szybkiego i prostego eksportu
174 biblioteki C++ do Pythona 2, tak że interfejs Pythona 2 jest bardzo
175 podobny do interfejsu C++. Biblioteka jest zaprojektowana tak, żeby
176 narzucać jak najmniej wymagań dotyczących konstrukcjii C++. W
177 większości przypadków nie trzeba w ogóle zmieniać własnych klas C++,
178 żeby używać ich z Boost.Python. System powinien po prostu ,,odbić''
179 klasy C++ i funkcje do Pythona 3.
180
181 %package python-devel
182 Summary:        Boost.Python development files for Python 2
183 Summary(pl.UTF-8):      Pliki programistyczne biblioteki Boost.Python dla Pythona 2
184 Group:          Development/Libraries
185 Requires:       %{name}-devel = %{version}-%{release}
186 Requires:       %{name}-python = %{version}-%{release}
187 Requires:       %{name}-python-devel-common = %{version}-%{release}
188
189 %description python-devel
190 Boost.Python development files for Python 2.
191
192 %description python-devel -l pl.UTF-8
193 Pliki programistyczne biblioteki Boost.Python dla Pythona 2.
194
195 %package python-static
196 Summary:        Static version of Boost.Python library for Python 2
197 Summary(pl.UTF-8):      Statyczna wersja biblioteki Boost.Python dla Pythona 2
198 Group:          Development/Libraries
199 Requires:       %{name}-python-devel = %{version}-%{release}
200
201 %description python-static
202 Static version of Boost.Python library for Python 2.
203
204 %description python-static -l pl.UTF-8
205 Statyczna wersja biblioteki Boost.Python dla Pythona 2.
206
207 %package python3
208 Summary:        Boost.Python library for Python 3
209 Summary(pl.UTF-8):      biblioteka Boost.Python dla Pythona 3
210 Group:          Libraries
211 Requires:       python3-libs
212
213 %description python3
214 Use the Boost Python Library to quickly and easily export a C++
215 library to Python 3 such that the Python 3 interface is very similar
216 to the C++ interface. It is designed to be minimally intrusive on your
217 C++ design. In most cases, you should not have to alter your C++
218 classes in any way in order to use them with Boost.Python. The system
219 should simply ``reflect'' your C++ classes and functions into Python
220 3.
221
222 %description python3 -l pl.UTF-8
223 Biblioteka Boost Python służy do szybkiego i prostego eksportu
224 biblioteki C++ do Pythona 3, tak że interfejs Pythona 3 jest bardzo
225 podobny do interfejsu C++. Biblioteka jest zaprojektowana tak, żeby
226 narzucać jak najmniej wymagań dotyczących konstrukcjii C++. W
227 większości przypadków nie trzeba w ogóle zmieniać własnych klas C++,
228 żeby używać ich z Boost.Python. System powinien po prostu ,,odbić''
229 klasy C++ i funkcje do Pythona 3.
230
231 %package python3-devel
232 Summary:        Boost.Python development files for Python 3
233 Summary(pl.UTF-8):      Pliki programistyczne biblioteki Boost.Python dla Pythona 3
234 Group:          Development/Libraries
235 Requires:       %{name}-devel = %{version}-%{release}
236 Requires:       %{name}-python3 = %{version}-%{release}
237 Requires:       %{name}-python-devel-common = %{version}-%{release}
238
239 %description python3-devel
240 Boost.Python development files for Python 3.
241
242 %description python3-devel -l pl.UTF-8
243 Pliki programistyczne biblioteki Boost.Python dla Pythona 3.
244
245 %package python3-static
246 Summary:        Static version of Boost.Python library for Python 3
247 Summary(pl.UTF-8):      Statyczna wersja biblioteki Boost.Python dla Pythona 3
248 Group:          Development/Libraries
249 Requires:       %{name}-python3-devel = %{version}-%{release}
250
251 %description python3-static
252 Static version of Boost.Python library for Python 3.
253
254 %description python3-static -l pl.UTF-8
255 Statyczna wersja biblioteki Boost.Python dla Pythona 3.
256
257 %package chrono
258 Summary:        Useful time utilities
259 Summary(pl.UTF-8):      Przydatne funkcje związane z czasem
260 Group:          Libraries
261 Obsoletes:      boost < 1.33
262
263 %description chrono
264 Useful time utilities.
265
266 %description chrono -l pl.UTF-8
267 Przydatne funkcje związane z czasem.
268
269 %package context
270 Summary:        Boost.Context - context switching library
271 Summary(pl.UTF-8):      Boost.Context - biblioteka do zmiany kontekstu
272 Group:          Libraries
273
274 %description context
275 Boost.Context - context switching library, providing a sort of
276 cooperative multitasking on a single thread.
277
278 %description context -l pl.UTF-8
279 Boost.Context - biblioteka do zmiany kontekstu, zapewniająca pewną
280 wielozadaniowość kooperatywnąw ramach pojedynczego wątku.
281
282 %package date_time
283 Summary:        Date-Time library
284 Summary(pl.UTF-8):      Biblioteka daty-czasu
285 Group:          Libraries
286 Obsoletes:      boost < 1.33
287
288 %description date_time
289 A set of date-time libraries.
290
291 %description date_time -l pl.UTF-8
292 Zbiór bibliotek daty-czasu.
293
294 %package filesystem
295 Summary:        Portable paths, iteration over directories, and other useful filesystem operations
296 Summary(pl.UTF-8):      Przenośne ścieżki, iteracje katalogów i inne użyteczne operacje na systemie plików
297 Group:          Libraries
298 Requires:       %{name}-system = %{version}-%{release}
299 Obsoletes:      boost < 1.33
300
301 %description filesystem
302 The boost::filesystem library provides portable facilities to query
303 and manipulate paths, files, and directories.
304
305 %description filesystem -l pl.UTF-8
306 Przenośna biblioteka boost::filesystem dostarcza ułatwienia w
307 operacjach na ścieżkach, plikach i katalogach.
308
309 %package graph
310 Summary:        General purpose, generic C++ library for graph data structures and graph algorithms
311 Summary(pl.UTF-8):      Biblioteka ogólnego przeznaczenia w C++ dla struktur danych typu grafy oraz algorytmów związanych z grafami
312 Group:          Libraries
313
314 %description graph
315 The boost::graph library provides portable facilities to operate on
316 graph data structures using graph algorithms.
317
318 %description graph -l pl.UTF-8
319 Przenośna biblioteka boost::graph dostarcza ułatwienia w operacjach na
320 strukturach danych typu graf za pomocą algorytmów związanych z
321 grafami.
322
323 %package locale
324 Summary:        Provide localization and Unicode handling tools for C++
325 Summary(pl.UTF-8):      Narzędzia do obsługi lokalizacji i Unikodu w C++
326 Group:          Libraries
327
328 %description locale
329 Provide localization and Unicode handling tools for C++.
330
331 %description locale -l pl.UTF-8
332 Narzędzia do obsługi lokalizacji i Unikodu w C++.
333
334 %package log
335 Summary:        Provide logging tools for C++
336 Summary(pl.UTF-8):      Narzędzia do logowania w C++
337 Group:          Libraries
338
339 %description log
340 Provide logging tools for C++.
341
342 %description log -l pl.UTF-8
343 Narzędzia do logowania w C++.
344
345 %package program_options
346 Summary:        Access to program options, via conventional methods such as command line and config file
347 Summary(pl.UTF-8):      Dostęp do opcji programu za pomocą typowych metod, jak linia poleceń i plik konfiguracyjny
348 Group:          Libraries
349
350 %description program_options
351 The program_options library allows program developers to obtain
352 program options, that is (name, value) pairs from the user, via
353 conventional methods such as command line and config file.
354
355 %description program_options -l pl.UTF-8
356 Biblioteka program_options umożliwia uzyskanie od użytkownika opcji
357 programu, czyli par (nazwa, wartość), za pomocą typowych metod, takich
358 jak linia poleceń, czy plik konfiguracyjny.
359
360 %package regex
361 Summary:        Boost C++ regular expressions library
362 Summary(pl.UTF-8):      Biblioteka wyrażeń regularnych Boost C++
363 Group:          Libraries
364
365 %description regex
366 Shared library for Boost C++ regular expressions.
367
368 %description regex -l pl.UTF-8
369 Biblioteka współdzielona do obsługi wyrażeń regularnych w C++.
370
371 %package signals
372 Summary:        Signals & slots callback implementation
373 Summary(pl.UTF-8):      Implementacja sygnałów i slotów
374 Group:          Libraries
375 Obsoletes:      boost < 1.33
376
377 %description signals
378 The boost::signals library is an implementation of a signals and slots
379 system.
380
381 %description signals -l pl.UTF-8
382 Biblioteka boost::signals jest implementacją systemu sygnałów i
383 slotów.
384
385 %package system
386 Summary:        Support for getting system specific error codes
387 Summary(pl.UTF-8):      Wsparcie dla pobierania specyficznych dla systemu kodów błędów
388 Group:          Libraries
389
390 %description system
391 The Boost System library provides simple, light-weight error_code
392 objects that encapsulate system-specific error code values, yet also
393 provide access to more abstract and portable error conditions objects.
394
395 %description system -l pl.UTF-8
396 Biblioteka Boost System udostępnia proste, lekkie obiekty error_code
397 obudowujące wartości kodów błędów specyficznych dla systemu, dając
398 jednocześnie dostęp do bardziej abstrakcyjnych i przenośnych obiektów
399 błędów.
400
401 %package test
402 Summary:        Support for program testing and execution monitoring
403 Summary(pl.UTF-8):      Wsparcie dla testowania i monitorowania programu
404 Group:          Libraries
405 Obsoletes:      boost < 1.33
406
407 %description test
408 Support for simple program testing, full unit testing, and for program
409 execution monitoring.
410
411 %description test -l pl.UTF-8
412 Wsparcie dla prostego testowania programu, pełnego testowania i
413 monitorowania wykonania programu.
414
415 %package thread
416 Summary:        Portable C++ threads library
417 Summary(pl.UTF-8):      Przenośna biblioteka wątków C++
418 Group:          Libraries
419 Obsoletes:      boost < 1.33
420
421 %description thread
422 Portable C++ threads library - shared library.
423
424 %description thread -l pl.UTF-8
425 Przenośna biblioteka wątków dla C++ - biblioteka dzielona.
426
427 %package timer
428 Summary:        Event timer, progress timer, and progress display classes
429 Summary(pl.UTF-8):      Klasy do obsługi pomiarów czasu, postępu i wyświetlania postępu
430 Group:          Libraries
431 Obsoletes:      boost < 1.33
432
433 %description timer
434 Event timer, progress timer, and progress display classes.
435
436 %description timer -l pl.UTF-8
437 Klasy do obsługi pomiarów czasu, postępu i wyświetlania postępu.
438
439 %package wave
440 Summary:        Boost.Wave - a standard compliant C++ preprocessor library
441 Summary(pl.UTF-8):      Boost.Wave - zgodna ze standardem biblioteka preprocesora C++
442 Group:          Development/Libraries
443
444 %description wave
445 Boost.Wave - a standard compliant C++ preprocessor library.
446
447 %description wave -l pl.UTF-8
448 Boost.Wave - zgodna ze standardem biblioteka preprocesora C++.
449
450 %package doc
451 Summary:        Boost C++ Library documentation
452 Summary(pl.UTF-8):      Dokumentacja dla biblioteki Boost C++
453 Group:          Documentation
454 %if "%{_rpmversion}" >= "5"
455 BuildArch:      noarch
456 %endif
457
458 %description doc
459 Documentation for the Boost C++ Library.
460
461 %description doc -l pl.UTF-8
462 Dokumentacja dla biblioteki Boost C++.
463
464 %prep
465 %setup -q -n %{name}_%{fver}
466 %patch0 -p1
467 %patch1 -p1
468 %patch2 -p1
469
470 %patch203 -p0
471 %patch211 -p1
472 %patch212 -p1
473 %patch218 -p1
474 %patch221 -p1
475 %patch222 -p1
476
477 cat << EOF > tools/build/src/user-config.jam
478 using gcc : %{cxx_version} : %{__cxx} : <cflags>"%{rpmcflags} -fPIC" <cxxflags>"%{rpmcxxflags} -fPIC" <linkflags>"%{rpmldflags}" ;
479 EOF
480
481 # cleanup backups after patching
482 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
483
484 %build
485 EXPAT_INCLUDE=%{_includedir} \
486 EXPAT_LIBPATH=%{_libdir} \
487 ICU_PATH=%{_prefix} \
488 ./bootstrap.sh \
489         --prefix=%{_prefix} \
490         -without-libraries=python
491
492 ./b2 \
493         -d2 --toolset=gcc \
494         variant=release \
495         debug-symbols=on \
496         inlining=on \
497         link=static,shared \
498         threading=multi
499
500 %if %{with python3}
501 echo "using python : %{py3_ver}m : %{py3_prefix} : %{py3_incdir} ;" >> project-config.jam
502 ./b2 \
503         --with-python python=%{py3_ver}m \
504         -a -d2 --toolset=gcc \
505         variant=release \
506         debug-symbols=on \
507         inlining=on \
508         link=static,shared \
509         threading=multi
510 %endif
511
512 %if %{with python2}
513 echo "using python : %{py_ver} : %{py_prefix} : %{py_incdir} ;" >> project-config.jam
514 ./b2 \
515         --with-python python=%{py_ver} \
516         -a -d2 --toolset=gcc \
517         variant=release \
518         debug-symbols=on \
519         inlining=on \
520         link=static,shared \
521         threading=multi
522 %endif
523
524 %install
525 rm -rf $RPM_BUILD_ROOT
526 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}}
527
528 cp -rf boost $RPM_BUILD_ROOT%{_includedir}
529
530 install -p stage/lib/lib*.a $RPM_BUILD_ROOT%{_libdir}
531 install -p stage/lib/lib*.so.*.*.* $RPM_BUILD_ROOT%{_libdir}
532 cp -a stage/lib/lib*.so $RPM_BUILD_ROOT%{_libdir}
533
534 # documentation
535 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}
536
537 # as the documentation doesn't completely reside in a directory of its
538 # own, we need to find out ourselves... this looks for HTML files and
539 # then collects everything linked from those.  this is certainly quite
540 # unoptimized wrt mkdir calls, but does it really matter?
541 installdocs() {
542 for i in $(find -type f -name '*.htm*'); do
543         # bjam docu is included in the boost-jam RPM
544         if test "`echo $i | sed 's,jam_src,,'`" = "$i"; then
545                 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/${i%/*}
546                 for LINKED in `%{__perl} - $i $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$i <<'EOT'
547                         sub rewrite_link
548                         {
549                                 my $link = shift;
550                                 # rewrite links from boost/* to %{_includedir}/boost/* and
551                                 # ignore external links as well as document-internal ones.
552                                 # HTML files are also ignored as they get installed anyway.
553                                 if (!($link =~ s,^(?:../)*boost/,%{_includedir}/boost/,) && !($link =~ m,(?:^[^/]+:|^\#|\.html?(?:$|\#)),))
554                                 {
555                                         (my $file = $link) =~ s/\#.*//;
556                                         print "$file\n";
557                                 }
558                                 $link;
559                         }
560                         open IN, @ARGV[0];
561                         open OUT, ">@ARGV[1]";
562                         my $in_link;
563                         while (<IN>)
564                         {
565                                 $in_link and s/^\s*"([^"> ]*)"/'"' . rewrite_link($1) . '"'/e;
566                                 s/(href|src)="([^"> ]*)"/"$1=\"" . rewrite_link($2) . '"'/eig;
567                                 print OUT;
568                                 $in_link = /href|src=\s*$/;
569                         }
570 EOT`; do
571                         TARGET=${i%/*}/$LINKED
572                         # ignore non-existant linked files
573                         if test -f $TARGET; then
574                                 install -D -m 644 $TARGET $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$TARGET
575                         fi
576                 done
577         fi
578 done
579 }; installdocs
580
581 %clean
582 rm -rf $RPM_BUILD_ROOT
583
584 %post   -p /sbin/ldconfig
585 %postun -p /sbin/ldconfig
586
587 %post   chrono -p /sbin/ldconfig
588 %postun chrono -p /sbin/ldconfig
589
590 %post   context -p /sbin/ldconfig
591 %postun context -p /sbin/ldconfig
592
593 %post   date_time -p /sbin/ldconfig
594 %postun date_time -p /sbin/ldconfig
595
596 %post   filesystem -p /sbin/ldconfig
597 %postun filesystem -p /sbin/ldconfig
598
599 %post   graph -p /sbin/ldconfig
600 %postun graph -p /sbin/ldconfig
601
602 %post   locale -p /sbin/ldconfig
603 %postun locale -p /sbin/ldconfig
604
605 %post   python -p /sbin/ldconfig
606 %postun python -p /sbin/ldconfig
607
608 %post   python3 -p /sbin/ldconfig
609 %postun python3 -p /sbin/ldconfig
610
611 %post   program_options -p /sbin/ldconfig
612 %postun program_options -p /sbin/ldconfig
613
614 %post   regex -p /sbin/ldconfig
615 %postun regex -p /sbin/ldconfig
616
617 %post   signals -p /sbin/ldconfig
618 %postun signals -p /sbin/ldconfig
619
620 %post   system -p /sbin/ldconfig
621 %postun system -p /sbin/ldconfig
622
623 %post   test -p /sbin/ldconfig
624 %postun test -p /sbin/ldconfig
625
626 %post   thread -p /sbin/ldconfig
627 %postun thread -p /sbin/ldconfig
628
629 %post   timer -p /sbin/ldconfig
630 %postun timer -p /sbin/ldconfig
631
632 %post   wave -p /sbin/ldconfig
633 %postun wave -p /sbin/ldconfig
634
635 %files
636 %defattr(644,root,root,755)
637 %attr(755,root,root) %{_libdir}/libboost_atomic.so.*.*.*
638 %attr(755,root,root) %{_libdir}/libboost_container.so.*.*.*
639 %ifnarch x32
640 %attr(755,root,root) %{_libdir}/libboost_coroutine.so.*.*.*
641 %endif
642 %attr(755,root,root) %{_libdir}/libboost_iostreams.so.*.*.*
643 %attr(755,root,root) %{_libdir}/libboost_math_*.so.*.*.*
644 %attr(755,root,root) %{_libdir}/libboost_random.so.*.*.*
645 %attr(755,root,root) %{_libdir}/libboost_serialization.so.*.*.*
646 %attr(755,root,root) %{_libdir}/libboost_wserialization.so.*.*.*
647
648 %files devel
649 %defattr(644,root,root,755)
650 %attr(755,root,root) %{_libdir}/libboost_atomic.so
651 %attr(755,root,root) %{_libdir}/libboost_chrono.so
652 %attr(755,root,root) %{_libdir}/libboost_container.so
653 %ifnarch x32
654 %attr(755,root,root) %{_libdir}/libboost_context.so
655 %attr(755,root,root) %{_libdir}/libboost_coroutine.so
656 %endif
657 %attr(755,root,root) %{_libdir}/libboost_date_time.so
658 %attr(755,root,root) %{_libdir}/libboost_filesystem.so
659 %attr(755,root,root) %{_libdir}/libboost_graph.so
660 %attr(755,root,root) %{_libdir}/libboost_iostreams.so
661 %attr(755,root,root) %{_libdir}/libboost_locale.so
662 %attr(755,root,root) %{_libdir}/libboost_log.so
663 %attr(755,root,root) %{_libdir}/libboost_log_setup.so
664 %attr(755,root,root) %{_libdir}/libboost_math_*.so
665 %attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor.so
666 %attr(755,root,root) %{_libdir}/libboost_program_options.so
667 %attr(755,root,root) %{_libdir}/libboost_regex.so
668 %attr(755,root,root) %{_libdir}/libboost_random.so
669 %attr(755,root,root) %{_libdir}/libboost_serialization.so
670 %attr(755,root,root) %{_libdir}/libboost_signals.so
671 %attr(755,root,root) %{_libdir}/libboost_system.so
672 %attr(755,root,root) %{_libdir}/libboost_thread.so
673 %attr(755,root,root) %{_libdir}/libboost_timer.so
674 %attr(755,root,root) %{_libdir}/libboost_unit_test_framework.so
675 %attr(755,root,root) %{_libdir}/libboost_wave.so
676 %attr(755,root,root) %{_libdir}/libboost_wserialization.so
677 %{_includedir}/boost
678 %exclude %{_includedir}/boost/python
679 %exclude %{_includedir}/boost/python.hpp
680
681 %files static
682 %defattr(644,root,root,755)
683 %{_libdir}/libboost_atomic.a
684 %{_libdir}/libboost_chrono.a
685 %{_libdir}/libboost_container.a
686 %ifnarch x32
687 %{_libdir}/libboost_context.a
688 %{_libdir}/libboost_coroutine.a
689 %endif
690 %{_libdir}/libboost_date_time.a
691 %{_libdir}/libboost_exception.a
692 %{_libdir}/libboost_filesystem.a
693 %{_libdir}/libboost_graph.a
694 %{_libdir}/libboost_iostreams.a
695 %{_libdir}/libboost_locale.a
696 %{_libdir}/libboost_log.a
697 %{_libdir}/libboost_log_setup.a
698 %{_libdir}/libboost_math_*.a
699 %{_libdir}/libboost_prg_exec_monitor.a
700 %{_libdir}/libboost_program_options.a
701 %{_libdir}/libboost_random.a
702 %{_libdir}/libboost_regex.a
703 %{_libdir}/libboost_serialization.a
704 %{_libdir}/libboost_signals.a
705 %{_libdir}/libboost_system.a
706 %{_libdir}/libboost_test_exec_monitor.a
707 %{_libdir}/libboost_timer.a
708 %{_libdir}/libboost_thread.a
709 %{_libdir}/libboost_unit_test_framework.a
710 %{_libdir}/libboost_wave.a
711 %{_libdir}/libboost_wserialization.a
712
713 %if %{with python2} || %{with python3}
714 %files python-devel-common
715 %defattr(644,root,root,755)
716 %{_includedir}/boost/python
717 %{_includedir}/boost/python.hpp
718 %endif
719
720 %if %{with python2}
721 %files python
722 %defattr(644,root,root,755)
723 %attr(755,root,root) %{_libdir}/libboost_python.so.*.*.*
724
725 %files python-devel
726 %defattr(644,root,root,755)
727 %attr(755,root,root) %{_libdir}/libboost_python.so
728
729 %files python-static
730 %defattr(644,root,root,755)
731 %{_libdir}/libboost_python.a
732 %endif
733
734 %if %{with python3}
735 %files python3
736 %defattr(644,root,root,755)
737 %attr(755,root,root) %{_libdir}/libboost_python3.so.*.*.*
738
739 %files python3-devel
740 %defattr(644,root,root,755)
741 %attr(755,root,root) %{_libdir}/libboost_python3.so
742
743 %files python3-static
744 %defattr(644,root,root,755)
745 %{_libdir}/libboost_python3.a
746 %endif
747
748 %files chrono
749 %defattr(644,root,root,755)
750 %attr(755,root,root) %{_libdir}/libboost_chrono.so.*.*.*
751
752 %ifnarch x32
753 %files context
754 %defattr(644,root,root,755)
755 %attr(755,root,root) %{_libdir}/libboost_context.so.*.*.*
756 %endif
757
758 %files date_time
759 %defattr(644,root,root,755)
760 %attr(755,root,root) %{_libdir}/libboost_date_time.so.*.*.*
761
762 %files filesystem
763 %defattr(644,root,root,755)
764 %attr(755,root,root) %{_libdir}/libboost_filesystem.so.*.*.*
765
766 %files graph
767 %defattr(644,root,root,755)
768 %attr(755,root,root) %{_libdir}/libboost_graph.so.*.*.*
769
770 %files locale
771 %defattr(644,root,root,755)
772 %attr(755,root,root) %{_libdir}/libboost_locale.so.*.*.*
773
774 %files log
775 %defattr(644,root,root,755)
776 %attr(755,root,root) %{_libdir}/libboost_log.so.*.*.*
777 %attr(755,root,root) %{_libdir}/libboost_log_setup.so.*.*.*
778
779 %files program_options
780 %defattr(644,root,root,755)
781 %attr(755,root,root) %{_libdir}/libboost_program_options.so.*.*.*
782
783 %files regex
784 %defattr(644,root,root,755)
785 %attr(755,root,root) %{_libdir}/libboost_regex.so.*.*.*
786
787 %files signals
788 %defattr(644,root,root,755)
789 %attr(755,root,root) %{_libdir}/libboost_signals.so.*.*.*
790
791 %files system
792 %defattr(644,root,root,755)
793 %attr(755,root,root) %{_libdir}/libboost_system.so.*.*.*
794
795 %files test
796 %defattr(644,root,root,755)
797 %attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor.so.*.*.*
798 %attr(755,root,root) %{_libdir}/libboost_unit_test_framework.so.*.*.*
799
800 %files thread
801 %defattr(644,root,root,755)
802 %attr(755,root,root) %{_libdir}/libboost_thread.so.*.*.*
803
804 %files timer
805 %defattr(644,root,root,755)
806 %attr(755,root,root) %{_libdir}/libboost_timer.so.*.*.*
807
808 %files wave
809 %defattr(644,root,root,755)
810 %attr(755,root,root) %{_libdir}/libboost_wave.so.*.*.*
811
812 %files doc
813 %defattr(644,root,root,755)
814 %{_docdir}/%{name}-%{version}
This page took 0.114636 seconds and 4 git commands to generate.