]> git.pld-linux.org Git - packages/boost.git/blob - boost.spec
- updated to 1.57.0 (new sonames as usual)
[packages/boost.git] / boost.spec
1 #
2 # TODO:
3 #       - think about building MPI.
4 #       - split shared libs from core package into -iostreams/-serialization.
5 #       - fix building context and corouting on x32 (patch1)
6 #
7 # Conditional build:
8 %bcond_without  python  # without boost-python support
9
10 %define         fver    %(echo %{version} | tr . _)
11 Summary:        The Boost C++ Libraries
12 Summary(pl.UTF-8):      Biblioteki C++ "Boost"
13 Name:           boost
14 Version:        1.57.0
15 Release:        1
16 License:        Boost Software License and others
17 Group:          Libraries
18 Source0:        http://downloads.sourceforge.net/boost/%{name}_%{fver}.tar.bz2
19 # Source0-md5:  1be49befbdd9a5ce9def2983ba3e7b76
20 Patch0:         %{name}-link.patch
21 Patch1:         %{name}-x32-context.patch
22 # FC Patches:
23 # https://svn.boost.org/trac/boost/ticket/5637
24 Patch203:       %{name}-1.54.0-mpl-print.patch
25 # https://svn.boost.org/trac/boost/ticket/8870
26 Patch211:       %{name}-1.54.0-spirit-unused_typedef.patch
27 Patch212:       %{name}-1.54.0-spirit-unused_typedef-2.patch
28 # https://svn.boost.org/trac/boost/ticket/8878
29 Patch218:       %{name}-1.54.0-locale-unused_typedef.patch
30 # https://svn.boost.org/trac/boost/ticket/8881
31 Patch221:       %{name}-1.54.0-mpi-unused_typedef.patch
32 # https://svn.boost.org/trac/boost/ticket/8888
33 Patch222:       %{name}-1.54.0-python-unused_typedef.patch
34 # https://svn.boost.org/trac/boost/ticket/9038
35 Patch224:       %{name}-1.54.0-pool-test_linking.patch
36 URL:            http://www.boost.org/
37 BuildRequires:  bzip2-devel
38 BuildRequires:  expat-devel
39 BuildRequires:  libicu-devel
40 BuildRequires:  libstdc++-devel
41 BuildRequires:  perl-base
42 %{?with_python:BuildRequires:   python-devel >= 2.2}
43 BuildRequires:  rpm-pythonprov
44 BuildRequires:  zlib-devel
45 BuildConflicts: gcc = 5:3.3.1
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %define         specflags       -DBOOST_IOSTREAMS_USE_DEPRECATED=1
49
50 %description
51 The Boost web site provides free peer-reviewed portable C++ source
52 libraries. The emphasis is on libraries which work well with the C++
53 Standard Library. One goal is to establish "existing practice" and
54 provide reference implementations so that the Boost libraries are
55 suitable for eventual standardization. Some of the libraries have
56 already been proposed for inclusion in the C++ Standards Committee's
57 upcoming C++ Standard Library Technical Report.
58
59 %description -l pl.UTF-8
60 Strona http://www.boost.org/ dostarcza darmowe biblioteki C++ wraz z
61 kodem źródłowym. Nacisk położono na biblioteki, które dobrze
62 współpracują ze standardową biblioteką C++. Celem jest ustanowienie
63 "istniejącej praktyki" i dostarczenie implementacji, tak że biblioteki
64 "Boost" nadają się do ewentualnej standaryzacji. Niektóre z bibliotek
65 już zostały zgłoszone do komitetu standaryzacyjnego C++ w nadchodzącym
66 Raporcie Technicznym Biblioteki Standardowej C++.
67
68 %package devel
69 Summary:        Boost C++ development headers
70 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek C++ Boost
71 Group:          Development/Libraries
72 Requires:       %{name} = %{version}-%{release}
73 Requires:       %{name}-chrono = %{version}-%{release}
74 %ifnarch x32
75 Requires:       %{name}-context = %{version}-%{release}
76 %endif
77 Requires:       %{name}-date_time = %{version}-%{release}
78 Requires:       %{name}-filesystem = %{version}-%{release}
79 Requires:       %{name}-graph = %{version}-%{release}
80 Requires:       %{name}-locale = %{version}-%{release}
81 Requires:       %{name}-log = %{version}-%{release}
82 Requires:       %{name}-program_options = %{version}-%{release}
83 Requires:       %{name}-regex = %{version}-%{release}
84 Requires:       %{name}-signals = %{version}-%{release}
85 Requires:       %{name}-system = %{version}-%{release}
86 Requires:       %{name}-test = %{version}-%{release}
87 Requires:       %{name}-thread = %{version}-%{release}
88 Requires:       %{name}-timer = %{version}-%{release}
89 Requires:       %{name}-wave = %{version}-%{release}
90 Requires:       libstdc++-devel
91 Obsoletes:      boost-any-devel
92 Obsoletes:      boost-array-devel
93 Obsoletes:      boost-asio
94 Obsoletes:      boost-bind-devel
95 Obsoletes:      boost-call_traits-devel
96 Obsoletes:      boost-compatibility-devel
97 Obsoletes:      boost-compose-devel
98 Obsoletes:      boost-compressed_pair-devel
99 Obsoletes:      boost-concept_check-devel
100 Obsoletes:      boost-conversion-devel
101 Obsoletes:      boost-crc-devel
102 Obsoletes:      boost-date_time-devel
103 Obsoletes:      boost-filesystem-devel
104 Obsoletes:      boost-graph-devel
105 Obsoletes:      boost-mem_fn-devel
106 Obsoletes:      boost-mpl-devel
107 Obsoletes:      boost-preprocessor-devel
108 Obsoletes:      boost-program_options-devel
109 Obsoletes:      boost-ref-devel
110 Obsoletes:      boost-regex-devel
111 Obsoletes:      boost-signals-devel
112 Obsoletes:      boost-spirit-devel
113 Obsoletes:      boost-statechart-devel
114 Obsoletes:      boost-static_assert-devel
115 Obsoletes:      boost-test-devel
116 Obsoletes:      boost-thread-devel
117 Obsoletes:      boost-tr1-devel
118 Obsoletes:      boost-type_traits-devel
119 Obsoletes:      boost-typeof-devel
120 Obsoletes:      boost-uBLAS-devel
121 Obsoletes:      boost-utility-devel
122 Obsoletes:      boost-wave-devel
123 Obsoletes:      boost-xpressive-devel
124
125 %description devel
126 Header files for the Boost C++ libraries.
127
128 %description devel -l pl.UTF-8
129 Pliki nagłówkowe bibliotek C++ Boost.
130
131 %package static
132 Summary:        Static version of base Boost C++ libraries
133 Summary(pl.UTF-8):      Statyczne wersje podstawowych bibliotek C++ Boost
134 Group:          Development/Libraries
135 Requires:       %{name}-devel = %{version}-%{release}
136 Obsoletes:      boost-static < 1.33
137
138 %description static
139 Static version of base Boost C++ libraries.
140
141 %description static -l pl.UTF-8
142 Statyczne wersje podstawowych bibliotek C++ Boost.
143
144 %package python
145 Summary:        Boost.Python library
146 Summary(pl.UTF-8):      biblioteka Boost.Python
147 Group:          Libraries
148 Requires:       python
149
150 %description python
151 Use the Boost Python Library to quickly and easily export a C++
152 library to Python such that the Python interface is very similar to
153 the C++ interface. It is designed to be minimally intrusive on your
154 C++ design. In most cases, you should not have to alter your C++
155 classes in any way in order to use them with Boost.Python. The system
156 should simply ``reflect'' your C++ classes and functions into Python.
157
158 %description python -l pl.UTF-8
159 Biblioteka Boost Python służy do szybkiego i prostego eksportu
160 biblioteki C++ do Pythona, tak że interfejs Pythona jest bardzo
161 podobny do interfejsu C++. Biblioteka jest zaprojektowana tak, żeby
162 narzucać jak najmniej wymagań dotyczących konstrukcjii C++. W
163 większości przypadków nie trzeba w ogóle zmieniać własnych klas C++,
164 żeby używać ich z Boost.Python. System powinien po prostu ,,odbić''
165 klasy C++ i funkcje do Pythona.
166
167 %package python-devel
168 Summary:        Boost.Python development headers
169 Summary(pl.UTF-8):      Pliki nagłówkowe dla Boost.Python
170 Group:          Development/Libraries
171 Requires:       %{name}-devel = %{version}-%{release}
172 Requires:       %{name}-python = %{version}-%{release}
173
174 %description python-devel
175 Headers for the Boost.Python library.
176
177 %description python-devel -l pl.UTF-8
178 Pliki nagłówkowe dla biblioteki Boost.Python.
179
180 %package python-static
181 Summary:        Static version of Boost.Python library
182 Summary(pl.UTF-8):      Statyczna wersja biblioteki Boost.Python
183 Group:          Development/Libraries
184 Requires:       %{name}-python-devel = %{version}-%{release}
185
186 %description python-static
187 Static version of Boost.Python library.
188
189 %description python-static -l pl.UTF-8
190 Statyczna wersja biblioteki Boost.Python.
191
192 %package chrono
193 Summary:        Useful time utilities
194 Summary(pl.UTF-8):      Przydatne funkcje związane z czasem
195 Group:          Libraries
196 Obsoletes:      boost < 1.33
197
198 %description chrono
199 Useful time utilities.
200
201 %description chrono -l pl.UTF-8
202 Przydatne funkcje związane z czasem.
203
204 %package context
205 Summary:        Boost.Context - context switching library
206 Summary(pl.UTF-8):      Boost.Context - biblioteka do zmiany kontekstu
207 Group:          Libraries
208
209 %description context
210 Boost.Context - context switching library, providing a sort of
211 cooperative multitasking on a single thread.
212
213 %description context -l pl.UTF-8
214 Boost.Context - biblioteka do zmiany kontekstu, zapewniająca pewną
215 wielozadaniowość kooperatywnąw ramach pojedynczego wątku.
216
217 %package date_time
218 Summary:        Date-Time library
219 Summary(pl.UTF-8):      Biblioteka daty-czasu
220 Group:          Libraries
221 Obsoletes:      boost < 1.33
222
223 %description date_time
224 A set of date-time libraries.
225
226 %description date_time -l pl.UTF-8
227 Zbiór bibliotek daty-czasu.
228
229 %package filesystem
230 Summary:        Portable paths, iteration over directories, and other useful filesystem operations
231 Summary(pl.UTF-8):      Przenośne ścieżki, iteracje katalogów i inne użyteczne operacje na systemie plików
232 Group:          Libraries
233 Requires:       %{name}-system = %{version}-%{release}
234 Obsoletes:      boost < 1.33
235
236 %description filesystem
237 The boost::filesystem library provides portable facilities to query
238 and manipulate paths, files, and directories.
239
240 %description filesystem -l pl.UTF-8
241 Przenośna biblioteka boost::filesystem dostarcza ułatwienia w
242 operacjach na ścieżkach, plikach i katalogach.
243
244 %package graph
245 Summary:        General purpose, generic C++ library for graph data structures and graph algorithms
246 Summary(pl.UTF-8):      Biblioteka ogólnego przeznaczenia w C++ dla struktur danych typu grafy oraz algorytmów związanych z grafami
247 Group:          Libraries
248
249 %description graph
250 The boost::graph library provides portable facilities to operate on
251 graph data structures using graph algorithms.
252
253 %description graph -l pl.UTF-8
254 Przenośna biblioteka boost::graph dostarcza ułatwienia w operacjach na
255 strukturach danych typu graf za pomocą algorytmów związanych z
256 grafami.
257
258 %package locale
259 Summary:        Provide localization and Unicode handling tools for C++
260 Summary(pl.UTF-8):      Narzędzia do obsługi lokalizacji i Unikodu w C++
261 Group:          Libraries
262
263 %description locale
264 Provide localization and Unicode handling tools for C++.
265
266 %description locale -l pl.UTF-8
267 Narzędzia do obsługi lokalizacji i Unikodu w C++.
268
269 %package log
270 Summary:        Provide logging tools for C++
271 Summary(pl.UTF-8):      Narzędzia do logowania w C++
272 Group:          Libraries
273
274 %description log
275 Provide logging tools for C++.
276
277 %description log -l pl.UTF-8
278 Narzędzia do logowania w C++.
279
280 %package program_options
281 Summary:        Access to program options, via conventional methods such as command line and config file
282 Summary(pl.UTF-8):      Dostęp do opcji programu za pomocą typowych metod, jak linia poleceń i plik konfiguracyjny
283 Group:          Libraries
284
285 %description program_options
286 The program_options library allows program developers to obtain
287 program options, that is (name, value) pairs from the user, via
288 conventional methods such as command line and config file.
289
290 %description program_options -l pl.UTF-8
291 Biblioteka program_options umożliwia uzyskanie od użytkownika opcji
292 programu, czyli par (nazwa, wartość), za pomocą typowych metod, takich
293 jak linia poleceń, czy plik konfiguracyjny.
294
295 %package regex
296 Summary:        Boost C++ regular expressions library
297 Summary(pl.UTF-8):      Biblioteka wyrażeń regularnych Boost C++
298 Group:          Libraries
299
300 %description regex
301 Shared library for Boost C++ regular expressions.
302
303 %description regex -l pl.UTF-8
304 Biblioteka współdzielona do obsługi wyrażeń regularnych w C++.
305
306 %package signals
307 Summary:        Signals & slots callback implementation
308 Summary(pl.UTF-8):      Implementacja sygnałów i slotów
309 Group:          Libraries
310 Obsoletes:      boost < 1.33
311
312 %description signals
313 The boost::signals library is an implementation of a signals and slots
314 system.
315
316 %description signals -l pl.UTF-8
317 Biblioteka boost::signals jest implementacją systemu sygnałów i
318 slotów.
319
320 %package system
321 Summary:        Support for getting system specific error codes
322 Summary(pl.UTF-8):      Wsparcie dla pobierania specyficznych dla systemu kodów błędów
323 Group:          Libraries
324
325 %description system
326 The Boost System library provides simple, light-weight error_code
327 objects that encapsulate system-specific error code values, yet also
328 provide access to more abstract and portable error conditions objects.
329
330 %description system -l pl.UTF-8
331 Biblioteka Boost System udostępnia proste, lekkie obiekty error_code
332 obudowujące wartości kodów błędów specyficznych dla systemu, dając
333 jednocześnie dostęp do bardziej abstrakcyjnych i przenośnych obiektów
334 błędów.
335
336 %package test
337 Summary:        Support for program testing and execution monitoring
338 Summary(pl.UTF-8):      Wsparcie dla testowania i monitorowania programu
339 Group:          Libraries
340 Obsoletes:      boost < 1.33
341
342 %description test
343 Support for simple program testing, full unit testing, and for program
344 execution monitoring.
345
346 %description test -l pl.UTF-8
347 Wsparcie dla prostego testowania programu, pełnego testowania i
348 monitorowania wykonania programu.
349
350 %package thread
351 Summary:        Portable C++ threads library
352 Summary(pl.UTF-8):      Przenośna biblioteka wątków C++
353 Group:          Libraries
354 Obsoletes:      boost < 1.33
355
356 %description thread
357 Portable C++ threads library - shared library.
358
359 %description thread -l pl.UTF-8
360 Przenośna biblioteka wątków dla C++ - biblioteka dzielona.
361
362 %package timer
363 Summary:        Event timer, progress timer, and progress display classes
364 Summary(pl.UTF-8):      Klasy do obsługi pomiarów czasu, postępu i wyświetlania postępu
365 Group:          Libraries
366 Obsoletes:      boost < 1.33
367
368 %description timer
369 Event timer, progress timer, and progress display classes.
370
371 %description timer -l pl.UTF-8
372 Klasy do obsługi pomiarów czasu, postępu i wyświetlania postępu.
373
374 %package wave
375 Summary:        Boost.Wave - a standard compliant C++ preprocessor library
376 Summary(pl.UTF-8):      Boost.Wave - zgodna ze standardem biblioteka preprocesora C++
377 Group:          Development/Libraries
378
379 %description wave
380 Boost.Wave - a standard compliant C++ preprocessor library.
381
382 %description wave -l pl.UTF-8
383 Boost.Wave - zgodna ze standardem biblioteka preprocesora C++.
384
385 %package doc
386 Summary:        Boost C++ Library documentation
387 Summary(pl.UTF-8):      Dokumentacja dla biblioteki Boost C++
388 Group:          Documentation
389 Requires:       %{name}-devel = %{version}-%{release}
390
391 %description doc
392 Documentation for the Boost C++ Library.
393
394 %description doc -l pl.UTF-8
395 Dokumentacja dla biblioteki Boost C++.
396
397 %prep
398 %setup -q -n %{name}_%{fver}
399 %patch0 -p1
400 #patch1 -p0
401
402 %patch203 -p0
403 %patch211 -p1
404 %patch212 -p1
405 %patch218 -p1
406 %patch221 -p1
407 %patch222 -p1
408 %patch224 -p1
409
410 # - don't know how to pass it through (b)jam -s (no way?)
411 #   due to oversophisticated build flags system.
412 # - pass -fPIC due to <shared-linkable> removal.
413 %{__sed} -i "s/<optimization>speed : -O3/<optimization>speed : ${CXXFLAGS:-%rpmcxxflags} -fPIC/" tools/build/src/tools/gcc.jam
414
415 # cleanup -g switch to avoid override debuginfocflags.
416 %{__sed} -i 's/<debug-symbols>on : -g/<debug-symbols>on :/' tools/build/src/tools/gcc.jam
417 # link against shared expat library.
418 #%{__sed} -i 's:find-static:find-shared:' libs/graph/build/Jamfile.v2
419
420 cat << EOF > tools/build/src/user-config.jam
421 using gcc : %{cxx_version} : %{__cxx} ;
422 EOF
423
424 # cleanup backups after patching
425 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
426
427 %build
428 %if %{with python}
429 PYTHON_VERSION=$(%{__python} -c 'import sys; print sys.version[0:3]')
430 PYTHON_ROOT=%{_prefix}
431 %else
432 PYTHON_ROOT=
433 PYTHON_VERSION=
434 %endif
435 EXPAT_INCLUDE=%{_includedir} \
436 EXPAT_LIBPATH=%{_libdir} \
437 ICU_PATH=%{_prefix} \
438 ./bootstrap.sh \
439         --prefix=%{_prefix}
440
441 ./b2 \
442 %ifarch x32
443         --without-context \
444         --without-coroutine \
445 %endif
446         -d2 --toolset=gcc \
447         variant=release \
448         debug-symbols=on \
449         inlining=on \
450         link=static,shared \
451         threading=multi
452
453 %install
454 rm -rf $RPM_BUILD_ROOT
455 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}}
456
457 cp -rf boost $RPM_BUILD_ROOT%{_includedir}
458
459 install -p stage/lib/lib*.a $RPM_BUILD_ROOT%{_libdir}
460 install -p stage/lib/lib*.so.*.*.* $RPM_BUILD_ROOT%{_libdir}
461 cp -a stage/lib/lib*.so $RPM_BUILD_ROOT%{_libdir}
462
463 # documentation
464 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}
465
466 # as the documentation doesn't completely reside in a directory of its
467 # own, we need to find out ourselves... this looks for HTML files and
468 # then collects everything linked from those.  this is certainly quite
469 # unoptimized wrt mkdir calls, but does it really matter?
470 installdocs() {
471 for i in $(find -type f -name '*.htm*'); do
472         # bjam docu is included in the boost-jam RPM
473         if test "`echo $i | sed 's,jam_src,,'`" = "$i"; then
474                 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/${i%/*}
475                 for LINKED in `%{__perl} - $i $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$i <<'EOT'
476                         sub rewrite_link
477                         {
478                                 my $link = shift;
479                                 # rewrite links from boost/* to %{_includedir}/boost/* and
480                                 # ignore external links as well as document-internal ones.
481                                 # HTML files are also ignored as they get installed anyway.
482                                 if (!($link =~ s,^(?:../)*boost/,%{_includedir}/boost/,) && !($link =~ m,(?:^[^/]+:|^\#|\.html?(?:$|\#)),))
483                                 {
484                                         (my $file = $link) =~ s/\#.*//;
485                                         print "$file\n";
486                                 }
487                                 $link;
488                         }
489                         open IN, @ARGV[0];
490                         open OUT, ">@ARGV[1]";
491                         my $in_link;
492                         while (<IN>)
493                         {
494                                 $in_link and s/^\s*"([^"> ]*)"/'"' . rewrite_link($1) . '"'/e;
495                                 s/(href|src)="([^"> ]*)"/"$1=\"" . rewrite_link($2) . '"'/eig;
496                                 print OUT;
497                                 $in_link = /href|src=\s*$/;
498                         }
499 EOT`; do
500                         TARGET=${i%/*}/$LINKED
501                         # ignore non-existant linked files
502                         if test -f $TARGET; then
503                                 install -D -m 644 $TARGET $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$TARGET
504                         fi
505                 done
506         fi
507 done
508 }; installdocs
509
510 %clean
511 rm -rf $RPM_BUILD_ROOT
512
513 %post   -p /sbin/ldconfig
514 %postun -p /sbin/ldconfig
515
516 %post   chrono -p /sbin/ldconfig
517 %postun chrono -p /sbin/ldconfig
518
519 %post   context -p /sbin/ldconfig
520 %postun context -p /sbin/ldconfig
521
522 %post   date_time -p /sbin/ldconfig
523 %postun date_time -p /sbin/ldconfig
524
525 %post   filesystem -p /sbin/ldconfig
526 %postun filesystem -p /sbin/ldconfig
527
528 %post   graph -p /sbin/ldconfig
529 %postun graph -p /sbin/ldconfig
530
531 %post   locale -p /sbin/ldconfig
532 %postun locale -p /sbin/ldconfig
533
534 %post   python -p /sbin/ldconfig
535 %postun python -p /sbin/ldconfig
536
537 %post   program_options -p /sbin/ldconfig
538 %postun program_options -p /sbin/ldconfig
539
540 %post   regex -p /sbin/ldconfig
541 %postun regex -p /sbin/ldconfig
542
543 %post   signals -p /sbin/ldconfig
544 %postun signals -p /sbin/ldconfig
545
546 %post   system -p /sbin/ldconfig
547 %postun system -p /sbin/ldconfig
548
549 %post   test -p /sbin/ldconfig
550 %postun test -p /sbin/ldconfig
551
552 %post   thread -p /sbin/ldconfig
553 %postun thread -p /sbin/ldconfig
554
555 %post   timer -p /sbin/ldconfig
556 %postun timer -p /sbin/ldconfig
557
558 %post   wave -p /sbin/ldconfig
559 %postun wave -p /sbin/ldconfig
560
561 %files
562 %defattr(644,root,root,755)
563 %attr(755,root,root) %{_libdir}/libboost_atomic.so.*.*.*
564 %attr(755,root,root) %{_libdir}/libboost_container.so.*.*.*
565 %ifnarch x32
566 %attr(755,root,root) %{_libdir}/libboost_coroutine.so.*.*.*
567 %endif
568 %attr(755,root,root) %{_libdir}/libboost_iostreams.so.*.*.*
569 %attr(755,root,root) %{_libdir}/libboost_math_*.so.*.*.*
570 %attr(755,root,root) %{_libdir}/libboost_random.so.*.*.*
571 %attr(755,root,root) %{_libdir}/libboost_serialization.so.*.*.*
572 %attr(755,root,root) %{_libdir}/libboost_wserialization.so.*.*.*
573
574 %files devel
575 %defattr(644,root,root,755)
576 %attr(755,root,root) %{_libdir}/libboost_atomic.so
577 %attr(755,root,root) %{_libdir}/libboost_chrono.so
578 %attr(755,root,root) %{_libdir}/libboost_container.so
579 %ifnarch x32
580 %attr(755,root,root) %{_libdir}/libboost_context.so
581 %attr(755,root,root) %{_libdir}/libboost_coroutine.so
582 %endif
583 %attr(755,root,root) %{_libdir}/libboost_date_time.so
584 %attr(755,root,root) %{_libdir}/libboost_filesystem.so
585 %attr(755,root,root) %{_libdir}/libboost_graph.so
586 %attr(755,root,root) %{_libdir}/libboost_iostreams.so
587 %attr(755,root,root) %{_libdir}/libboost_locale.so
588 %attr(755,root,root) %{_libdir}/libboost_log.so
589 %attr(755,root,root) %{_libdir}/libboost_log_setup.so
590 %attr(755,root,root) %{_libdir}/libboost_math_*.so
591 %attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor.so
592 %attr(755,root,root) %{_libdir}/libboost_program_options.so
593 %attr(755,root,root) %{_libdir}/libboost_regex.so
594 %attr(755,root,root) %{_libdir}/libboost_random.so
595 %attr(755,root,root) %{_libdir}/libboost_serialization.so
596 %attr(755,root,root) %{_libdir}/libboost_signals.so
597 %attr(755,root,root) %{_libdir}/libboost_system.so
598 %attr(755,root,root) %{_libdir}/libboost_thread.so
599 %attr(755,root,root) %{_libdir}/libboost_timer.so
600 %attr(755,root,root) %{_libdir}/libboost_unit_test_framework.so
601 %attr(755,root,root) %{_libdir}/libboost_wave.so
602 %attr(755,root,root) %{_libdir}/libboost_wserialization.so
603 %{_includedir}/boost
604 %exclude %{_includedir}/boost/python
605 %exclude %{_includedir}/boost/python.hpp
606
607 %files static
608 %defattr(644,root,root,755)
609 %{_libdir}/libboost_atomic.a
610 %{_libdir}/libboost_chrono.a
611 %{_libdir}/libboost_container.a
612 %ifnarch x32
613 %{_libdir}/libboost_context.a
614 %{_libdir}/libboost_coroutine.a
615 %endif
616 %{_libdir}/libboost_date_time.a
617 %{_libdir}/libboost_exception.a
618 %{_libdir}/libboost_filesystem.a
619 %{_libdir}/libboost_graph.a
620 %{_libdir}/libboost_iostreams.a
621 %{_libdir}/libboost_locale.a
622 %{_libdir}/libboost_log.a
623 %{_libdir}/libboost_log_setup.a
624 %{_libdir}/libboost_math_*.a
625 %{_libdir}/libboost_prg_exec_monitor.a
626 %{_libdir}/libboost_program_options.a
627 %{_libdir}/libboost_random.a
628 %{_libdir}/libboost_regex.a
629 %{_libdir}/libboost_serialization.a
630 %{_libdir}/libboost_signals.a
631 %{_libdir}/libboost_system.a
632 %{_libdir}/libboost_test_exec_monitor.a
633 %{_libdir}/libboost_timer.a
634 %{_libdir}/libboost_thread.a
635 %{_libdir}/libboost_unit_test_framework.a
636 %{_libdir}/libboost_wave.a
637 %{_libdir}/libboost_wserialization.a
638
639 %if %{with python}
640 %files python
641 %defattr(644,root,root,755)
642 %attr(755,root,root) %{_libdir}/libboost_python.so.*.*.*
643
644 %files python-devel
645 %defattr(644,root,root,755)
646 %attr(755,root,root) %{_libdir}/libboost_python.so
647 %{_includedir}/boost/python
648 %{_includedir}/boost/python.hpp
649
650 %files python-static
651 %defattr(644,root,root,755)
652 %{_libdir}/libboost_python.a
653 %endif
654
655 %files chrono
656 %defattr(644,root,root,755)
657 %attr(755,root,root) %{_libdir}/libboost_chrono.so.*.*.*
658
659 %ifnarch x32
660 %files context
661 %defattr(644,root,root,755)
662 %attr(755,root,root) %{_libdir}/libboost_context.so.*.*.*
663 %endif
664
665 %files date_time
666 %defattr(644,root,root,755)
667 %attr(755,root,root) %{_libdir}/libboost_date_time.so.*.*.*
668
669 %files filesystem
670 %defattr(644,root,root,755)
671 %attr(755,root,root) %{_libdir}/libboost_filesystem.so.*.*.*
672
673 %files graph
674 %defattr(644,root,root,755)
675 %attr(755,root,root) %{_libdir}/libboost_graph.so.*.*.*
676
677 %files locale
678 %defattr(644,root,root,755)
679 %attr(755,root,root) %{_libdir}/libboost_locale.so.*.*.*
680
681 %files log
682 %defattr(644,root,root,755)
683 %attr(755,root,root) %{_libdir}/libboost_log.so.*.*.*
684 %attr(755,root,root) %{_libdir}/libboost_log_setup.so.*.*.*
685
686 %files program_options
687 %defattr(644,root,root,755)
688 %attr(755,root,root) %{_libdir}/libboost_program_options.so.*.*.*
689
690 %files regex
691 %defattr(644,root,root,755)
692 %attr(755,root,root) %{_libdir}/libboost_regex.so.*.*.*
693
694 %files signals
695 %defattr(644,root,root,755)
696 %attr(755,root,root) %{_libdir}/libboost_signals.so.*.*.*
697
698 %files system
699 %defattr(644,root,root,755)
700 %attr(755,root,root) %{_libdir}/libboost_system.so.*.*.*
701
702 %files test
703 %defattr(644,root,root,755)
704 %attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor.so.*.*.*
705 %attr(755,root,root) %{_libdir}/libboost_unit_test_framework.so.*.*.*
706
707 %files thread
708 %defattr(644,root,root,755)
709 %attr(755,root,root) %{_libdir}/libboost_thread.so.*.*.*
710
711 %files timer
712 %defattr(644,root,root,755)
713 %attr(755,root,root) %{_libdir}/libboost_timer.so.*.*.*
714
715 %files wave
716 %defattr(644,root,root,755)
717 %attr(755,root,root) %{_libdir}/libboost_wave.so.*.*.*
718
719 %files doc
720 %defattr(644,root,root,755)
721 %{_docdir}/%{name}-%{version}
This page took 0.105247 seconds and 4 git commands to generate.