]> git.pld-linux.org Git - packages/boost.git/blob - boost.spec
- up to 1.42.0
[packages/boost.git] / boost.spec
1 #
2 # TODO:
3 #       - think about building MPI.
4 #       - split shared libs from core package into -iostreams/-serialization.
5 #
6 # Conditional build:
7 %bcond_without  python  # without boost-python support
8 #
9 %define         _fver   %(echo %{version} | tr . _)
10 Summary:        The Boost C++ Libraries
11 Summary(pl.UTF-8):      Biblioteki C++ "Boost"
12 Name:           boost
13 Version:        1.42.0
14 Release:        1
15 License:        Boost Software License and others
16 Group:          Libraries
17 Source0:        http://dl.sourceforge.net/boost/%{name}_%{_fver}.tar.bz2
18 # Source0-md5:  7bf3b4eb841b62ffb0ade2b82218ebe6
19 Patch0:         %{name}-climits.patch
20 Patch1:         %{name}-link.patch
21 URL:            http://www.boost.org/
22 BuildRequires:  boost-jam >= 3.1.12
23 BuildRequires:  bzip2-devel
24 BuildRequires:  expat-devel
25 BuildRequires:  libicu-devel
26 BuildRequires:  libstdc++-devel
27 BuildRequires:  perl-base
28 %{?with_python:BuildRequires:   python-devel >= 2.2}
29 BuildRequires:  rpm-pythonprov
30 BuildRequires:  zlib-devel
31 BuildConflicts: gcc = 5:3.3.1
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 The Boost web site provides free peer-reviewed portable C++ source
36 libraries. The emphasis is on libraries which work well with the C++
37 Standard Library. One goal is to establish "existing practice" and
38 provide reference implementations so that the Boost libraries are
39 suitable for eventual standardization. Some of the libraries have
40 already been proposed for inclusion in the C++ Standards Committee's
41 upcoming C++ Standard Library Technical Report.
42
43 %description -l pl.UTF-8
44 Strona http://www.boost.org/ dostarcza darmowe biblioteki C++ wraz z
45 kodem źródłowym. Nacisk położono na biblioteki, które dobrze
46 współpracują ze standardową biblioteką C++. Celem jest ustanowienie
47 "istniejącej praktyki" i dostarczenie implementacji, tak że biblioteki
48 "Boost" nadają się do ewentualnej standaryzacji. Niektóre z bibliotek
49 już zostały zgłoszone do komitetu standaryzacyjnego C++ w nadchodzącym
50 Raporcie Technicznym Biblioteki Standardowej C++.
51
52 %package devel
53 Summary:        Boost C++ development headers
54 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek C++ Boost
55 Group:          Development/Libraries
56 Requires:       %{name} = %{version}-%{release}
57 Requires:       %{name}-date_time = %{version}-%{release}
58 Requires:       %{name}-filesystem = %{version}-%{release}
59 Requires:       %{name}-graph = %{version}-%{release}
60 Requires:       %{name}-program_options = %{version}-%{release}
61 Requires:       %{name}-regex = %{version}-%{release}
62 Requires:       %{name}-signals = %{version}-%{release}
63 Requires:       %{name}-system = %{version}-%{release}
64 Requires:       %{name}-test = %{version}-%{release}
65 Requires:       %{name}-thread = %{version}-%{release}
66 Requires:       %{name}-wave = %{version}-%{release}
67 Requires:       libstdc++-devel
68 Obsoletes:      boost-any-devel
69 Obsoletes:      boost-array-devel
70 Obsoletes:      boost-asio
71 Obsoletes:      boost-bind-devel
72 Obsoletes:      boost-call_traits-devel
73 Obsoletes:      boost-compatibility-devel
74 Obsoletes:      boost-compose-devel
75 Obsoletes:      boost-compressed_pair-devel
76 Obsoletes:      boost-concept_check-devel
77 Obsoletes:      boost-conversion-devel
78 Obsoletes:      boost-crc-devel
79 Obsoletes:      boost-date_time-devel
80 Obsoletes:      boost-filesystem-devel
81 Obsoletes:      boost-graph-devel
82 Obsoletes:      boost-mem_fn-devel
83 Obsoletes:      boost-mpl-devel
84 Obsoletes:      boost-preprocessor-devel
85 Obsoletes:      boost-program_options-devel
86 Obsoletes:      boost-ref-devel
87 Obsoletes:      boost-regex-devel
88 Obsoletes:      boost-signals-devel
89 Obsoletes:      boost-spirit-devel
90 Obsoletes:      boost-statechart-devel
91 Obsoletes:      boost-static_assert-devel
92 Obsoletes:      boost-test-devel
93 Obsoletes:      boost-thread-devel
94 Obsoletes:      boost-tr1-devel
95 Obsoletes:      boost-type_traits-devel
96 Obsoletes:      boost-typeof-devel
97 Obsoletes:      boost-uBLAS-devel
98 Obsoletes:      boost-utility-devel
99 Obsoletes:      boost-wave-devel
100 Obsoletes:      boost-xpressive-devel
101
102 %description devel
103 Header files for the Boost C++ libraries.
104
105 %description devel -l pl.UTF-8
106 Pliki nagłówkowe bibliotek C++ Boost.
107
108 %package static
109 Summary:        Static version of base Boost C++ libraries
110 Summary(pl.UTF-8):      Statyczne wersje podstawowych bibliotek C++ Boost
111 Group:          Development/Libraries
112 Requires:       %{name}-devel = %{version}-%{release}
113 Obsoletes:      boost-static < 1.33
114
115 %description static
116 Static version of base Boost C++ libraries.
117
118 %description static -l pl.UTF-8
119 Statyczne wersje podstawowych bibliotek C++ Boost.
120
121 %package python
122 Summary:        Boost.Python library
123 Summary(pl.UTF-8):      biblioteka Boost.Python
124 Group:          Libraries
125 %pyrequires_eq  python
126
127 %description python
128 Use the Boost Python Library to quickly and easily export a C++
129 library to Python such that the Python interface is very similar to
130 the C++ interface. It is designed to be minimally intrusive on your
131 C++ design. In most cases, you should not have to alter your C++
132 classes in any way in order to use them with Boost.Python. The system
133 should simply ``reflect'' your C++ classes and functions into Python.
134
135 %description python -l pl.UTF-8
136 Biblioteka Boost Python służy do szybkiego i prostego eksportu
137 biblioteki C++ do Pythona, tak że interfejs Pythona jest bardzo
138 podobny do interfejsu C++. Biblioteka jest zaprojektowana tak, żeby
139 narzucać jak najmniej wymagań dotyczących konstrukcjii C++. W
140 większości przypadków nie trzeba w ogóle zmieniać własnych klas C++,
141 żeby używać ich z Boost.Python. System powinien po prostu ,,odbić''
142 klasy C++ i funkcje do Pythona.
143
144 %package python-devel
145 Summary:        Boost.Python development headers
146 Summary(pl.UTF-8):      Pliki nagłówkowe dla Boost.Python
147 Group:          Development/Libraries
148 Requires:       %{name}-devel = %{version}-%{release}
149 Requires:       %{name}-python = %{version}-%{release}
150
151 %description python-devel
152 Headers for the Boost.Python library.
153
154 %description python-devel -l pl.UTF-8
155 Pliki nagłówkowe dla biblioteki Boost.Python.
156
157 %package python-static
158 Summary:        Static version of Boost.Python library
159 Summary(pl.UTF-8):      Statyczna wersja biblioteki Boost.Python
160 Group:          Development/Libraries
161 Requires:       %{name}-python-devel = %{version}-%{release}
162
163 %description python-static
164 Static version of Boost.Python library.
165
166 %description python-static -l pl.UTF-8
167 Statyczna wersja biblioteki Boost.Python.
168
169 %package date_time
170 Summary:        Date-Time library
171 Summary(pl.UTF-8):      Biblioteka daty-czasu
172 Group:          Libraries
173 Obsoletes:      boost < 1.33
174
175 %description date_time
176 A set of date-time libraries.
177
178 %description date_time -l pl.UTF-8
179 Zbiór bibliotek daty-czasu.
180
181 %package filesystem
182 Summary:        Portable paths, iteration over directories, and other useful filesystem operations
183 Summary(pl.UTF-8):      Przenośne ścieżki, iteracje katalogów i inne użyteczne operacje na systemie plików
184 Group:          Libraries
185 Requires:       %{name}-system = %{version}-%{release}
186 Obsoletes:      boost < 1.33
187
188 %description filesystem
189 The boost::filesystem library provides portable facilities to query
190 and manipulate paths, files, and directories.
191
192 %description filesystem -l pl.UTF-8
193 Przenośna biblioteka boost::filesystem dostarcza ułatwienia w
194 operacjach na ścieżkach, plikach i katalogach.
195
196 %package graph
197 Summary:        General purpose, generic C++ library for graph data structures and graph algorithms
198 Summary(pl.UTF-8):      Biblioteka ogólnego przeznaczenia w C++ dla struktur danych typu grafy oraz algorytmów związanych z grafami
199 Group:          Libraries
200
201 %description graph
202 The boost::graph library provides portable facilities to operate on
203 graph data structures using graph algorithms.
204
205 %description graph -l pl.UTF-8
206 Przenośna biblioteka boost::graph dostarcza ułatwienia w operacjach na
207 strukturach danych typu graf za pomocą algorytmów związanych z
208 grafami.
209
210 %package program_options
211 Summary:        Access to program options, via conventional methods such as command line and config file
212 Summary(pl.UTF-8):      Dostęp do opcji programu za pomocą typowych metod, jak linia poleceń i plik konfiguracyjny
213 Group:          Libraries
214
215 %description program_options
216 The program_options library allows program developers to obtain
217 program options, that is (name, value) pairs from the user, via
218 conventional methods such as command line and config file.
219
220 %description program_options -l pl.UTF-8
221 Biblioteka program_options umożliwia uzyskanie od użytkownika opcji
222 programu, czyli par (nazwa, wartość), za pomocą typowych metod, takich
223 jak linia poleceń, czy plik konfiguracyjny.
224
225 %package regex
226 Summary:        Boost C++ regular expressions library
227 Summary(pl.UTF-8):      Biblioteka wyrażeń regularnych Boost C++
228 Group:          Libraries
229
230 %description regex
231 Shared library for Boost C++ regular expressions.
232
233 %description regex -l pl.UTF-8
234 Biblioteka wyrażeń regularnych dla C++, biblioteki dzielone.
235
236 %package signals
237 Summary:        Signals & slots callback implementation
238 Summary(pl.UTF-8):      Implementacja sygnałów i slotów
239 Group:          Libraries
240 Obsoletes:      boost < 1.33
241
242 %description signals
243 The boost::signals library is an implementation of a signals and slots
244 system.
245
246 %description signals -l pl.UTF-8
247 Biblioteka boost::signals jest implementacją systemu sygnałów i
248 slotów.
249
250 %package system
251 Summary:        Support for getting system specific error codes
252 Summary(pl.UTF-8):      Wsparcie dla pobierania specyficznych dla systemu kodów błędów
253 Group:          Libraries
254
255 %description system
256 The Boost System library provides simple, light-weight error_code
257 objects that encapsulate system-specific error code values, yet also
258 provide access to more abstract and portable error conditions objects.
259
260 %description system -l pl.UTF-8
261 Biblioteka Boost System udostępnia proste, lekkie obiekty error_code
262 obudowujące wartości kodów błędów specyficznych dla systemu, dając
263 jednocześnie dostęp do bardziej abstrakcyjnych i przenośnych obiektów
264 błędów.
265
266 %package test
267 Summary:        Support for program testing and execution monitoring
268 Summary(pl.UTF-8):      Wsparcie dla testowania i monitorowania programu
269 Group:          Libraries
270 Obsoletes:      boost < 1.33
271
272 %description test
273 Support for simple program testing, full unit testing, and for program
274 execution monitoring.
275
276 %description test -l pl.UTF-8
277 Wsparcie dla prostego testowania programu, pełnego testowania i
278 monitorowania wykonania programu.
279
280 %package thread
281 Summary:        Portable C++ threads library
282 Summary(pl.UTF-8):      Przenośna biblioteka wątków C++
283 Group:          Libraries
284 Obsoletes:      boost < 1.33
285
286 %description thread
287 Portable C++ threads library - shared library.
288
289 %description thread -l pl.UTF-8
290 Przenośna biblioteka wątków dla C++ - biblioteka dzielona.
291
292 %package wave
293 Summary:        Boost.Wave - a standard compliant C++ preprocessor library
294 Summary(pl.UTF-8):      Boost.Wave - zgodna ze standardem biblioteka preprocesora C++
295 Group:          Development/Libraries
296
297 %description wave
298 Boost.Wave - a standard compliant C++ preprocessor library.
299
300 %description wave -l pl.UTF-8
301 Boost.Wave - zgodna ze standardem biblioteka preprocesora C++.
302
303 %package doc
304 Summary:        Boost C++ Library documentation
305 Summary(pl.UTF-8):      Dokumentacja dla biblioteki Boost C++
306 Group:          Documentation
307 Requires:       %{name}-devel = %{version}-%{release}
308
309 %description doc
310 Documentation for the Boost C++ Library.
311
312 %description doc -l pl.UTF-8
313 Dokumentacja dla biblioteki Boost C++.
314
315 %prep
316 %setup -q -n %{name}_%{_fver}
317 %patch0 -p1
318 %patch1 -p1
319
320 # - don't know how to pass it through (b)jam -s (no way?)
321 #   due to oversophisticated build flags system.
322 # - pass -fPIC due to <shared-linkable> removal.
323 %{__sed} -i "s/<optimization>speed : -O3/<optimization>speed : ${CXXFLAGS:-%rpmcxxflags} -fPIC/" tools/build/v2/tools/gcc.jam
324
325 # cleanup -g switch to avoid override debuginfocflags.
326 %{__sed} -i 's/<debug-symbols>on : -g/<debug-symbols>on :/' tools/build/v2/tools/gcc.jam
327 # link against shared expat library.
328 %{__sed} -i 's:find-static:find-shared:' libs/graph/build/Jamfile.v2
329
330 %ifarch alpha
331 # -pthread gcc parameter doesn't add _REENTRANT to cpp macros on alpha (only)
332 # don't know, is it gcc bug or intentional omission?
333 # anyway, boost check of -D_REENTRANT in its headers, so it's needed here
334 %{__perl} -pi -e 's/(CFLAGS.*-pthread)/$1 -D_REENTRANT/' tools/build/v1/gcc-tools.jam
335 %endif
336
337 cat << EOF > tools/build/v2/user-config.jam
338 using gcc : %(%{__cxx} -dumpversion) : %{__cxx} ;
339 EOF
340
341 %build
342 %if %{with python}
343 PYTHON_VERSION=$(%{__python} -c 'import sys; print sys.version[0:3]')
344 PYTHON_ROOT=%{_prefix}
345 %else
346 PYTHON_ROOT=
347 PYTHON_VERSION=
348 %endif
349 EXPAT_INCLUDE=%{_includedir} \
350 EXPAT_LIBPATH=%{_libdir} \
351 ICU_PATH=%{_prefix} \
352 bjam \
353         -d2 --toolset=gcc \
354         variant=release debug-symbols=on inlining=on link=static,shared threading=multi
355
356 %install
357 rm -rf $RPM_BUILD_ROOT
358 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}}
359
360 cp -rf boost $RPM_BUILD_ROOT%{_includedir}
361
362 install bin.v2/libs/*/build/gcc-*/release/debug-symbols-on/inlining-on/link-static/threading-multi/lib*.a $RPM_BUILD_ROOT%{_libdir}
363 install bin.v2/libs/*/build/gcc-*/release/debug-symbols-on/inlining-on/threading-multi/lib*.so.*.*.* $RPM_BUILD_ROOT%{_libdir}
364
365 # create symlinks without -gccXX-mt-* things in names
366 for f in $RPM_BUILD_ROOT%{_libdir}/*.so.*.*.*; do
367         [ -f "$f" ] || continue
368         f=$(basename "$f")
369         soname=$(basename "$f" | sed -e 's#-gcc..-mt-.*#.so#g')
370         [ ! -f "$RPM_BUILD_ROOT%{_libdir}/$soname" ] && ln -s "$f" "$RPM_BUILD_ROOT%{_libdir}/$soname"
371         rawsoname=$(basename "$f" | sed -e 's#\.so.*#.so#g')
372         [ ! -f "$RPM_BUILD_ROOT%{_libdir}/$rawsoname" ] && ln -s "$f" "$RPM_BUILD_ROOT%{_libdir}/$rawsoname"
373
374 done
375 for f in $RPM_BUILD_ROOT%{_libdir}/*.a; do
376         [ -f "$f" ] || continue
377         f=$(basename "$f")
378         soname=$(basename "$f" | sed -e 's#-gcc..-mt-.*#.a#g')
379         [ ! -f "$RPM_BUILD_ROOT%{_libdir}/$soname" ] && ln -s "$f" "$RPM_BUILD_ROOT%{_libdir}/$soname"
380         rawsoname=$(basename "$f" | sed -e 's#\.so.*#.so#g')
381         [ ! -f "$RPM_BUILD_ROOT%{_libdir}/$rawsoname" ] && ln -s "$f" "$RPM_BUILD_ROOT%{_libdir}/$rawsoname"
382 done
383
384 # documentation
385 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}
386
387 # as the documentation doesn't completely reside in a directory of its
388 # own, we need to find out ourselves... this looks for HTML files and
389 # then collects everything linked from those.  this is certainly quite
390 # unoptimized wrt mkdir calls, but does it really matter?
391 installdocs() {
392 for i in $(find -type f -name '*.htm*'); do
393         # bjam docu is included in the boost-jam RPM
394         if test "`echo $i | sed 's,jam_src,,'`" = "$i"; then
395                 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/${i%/*}
396                 for LINKED in `%{__perl} - $i $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$i <<'EOT'
397                         sub rewrite_link
398                         {
399                                 my $link = shift;
400                                 # rewrite links from boost/* to %{_includedir}/boost/* and
401                                 # ignore external links as well as document-internal ones.
402                                 # HTML files are also ignored as they get installed anyway.
403                                 if (!($link =~ s,^(?:../)*boost/,%{_includedir}/boost/,) && !($link =~ m,(?:^[^/]+:|^\#|\.html?(?:$|\#)),))
404                                 {
405                                         (my $file = $link) =~ s/\#.*//;
406                                         print "$file\n";
407                                 }
408                                 $link;
409                         }
410                         open IN, @ARGV[0];
411                         open OUT, ">@ARGV[1]";
412                         my $in_link;
413                         while (<IN>)
414                         {
415                                 $in_link and s/^\s*"([^"> ]*)"/'"' . rewrite_link($1) . '"'/e;
416                                 s/(href|src)="([^"> ]*)"/"$1=\"" . rewrite_link($2) . '"'/eig;
417                                 print OUT;
418                                 $in_link = /href|src=\s*$/;
419                         }
420 EOT`; do
421                         TARGET=${i%/*}/$LINKED
422                         # ignore non-existant linked files
423                         if test -f $TARGET; then
424                                 install -D -m 644 $TARGET $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$TARGET
425                         fi
426                 done
427         fi
428 done
429 }; installdocs
430
431 %clean
432 rm -rf $RPM_BUILD_ROOT
433
434 %post   -p /sbin/ldconfig
435 %postun -p /sbin/ldconfig
436
437 %post   date_time -p /sbin/ldconfig
438 %postun date_time -p /sbin/ldconfig
439
440 %post   filesystem -p /sbin/ldconfig
441 %postun filesystem -p /sbin/ldconfig
442
443 %post   graph -p /sbin/ldconfig
444 %postun graph -p /sbin/ldconfig
445
446 %post   python -p /sbin/ldconfig
447 %postun python -p /sbin/ldconfig
448
449 %post   program_options -p /sbin/ldconfig
450 %postun program_options -p /sbin/ldconfig
451
452 %post   regex -p /sbin/ldconfig
453 %postun regex -p /sbin/ldconfig
454
455 %post   signals -p /sbin/ldconfig
456 %postun signals -p /sbin/ldconfig
457
458 %post   system -p /sbin/ldconfig
459 %postun system -p /sbin/ldconfig
460
461 %post   test -p /sbin/ldconfig
462 %postun test -p /sbin/ldconfig
463
464 %post   wave -p /sbin/ldconfig
465 %postun wave -p /sbin/ldconfig
466
467 %post   thread -p /sbin/ldconfig
468 %postun thread -p /sbin/ldconfig
469
470 %files
471 %defattr(644,root,root,755)
472 %attr(755,root,root) %{_libdir}/libboost_iostreams*.so.*.*.*
473 %attr(755,root,root) %{_libdir}/libboost_math_*.so.*.*.*
474 %attr(755,root,root) %{_libdir}/libboost_serialization*.so.*.*.*
475 %attr(755,root,root) %{_libdir}/libboost_wserialization*.so.*.*.*
476
477 %files devel
478 %defattr(644,root,root,755)
479 %{_includedir}/boost
480 %attr(755,root,root) %{_libdir}/libboost_date_time*.so
481 %attr(755,root,root) %{_libdir}/libboost_filesystem*.so
482 %attr(755,root,root) %{_libdir}/libboost_graph*.so
483 %attr(755,root,root) %{_libdir}/libboost_iostreams*.so
484 %attr(755,root,root) %{_libdir}/libboost_math_*.so
485 %attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor*.so
486 %attr(755,root,root) %{_libdir}/libboost_program_options*.so
487 %attr(755,root,root) %{_libdir}/libboost_regex*.so
488 %attr(755,root,root) %{_libdir}/libboost_serialization*.so
489 %attr(755,root,root) %{_libdir}/libboost_signals*.so
490 %attr(755,root,root) %{_libdir}/libboost_system*.so
491 %attr(755,root,root) %{_libdir}/libboost_thread*.so
492 %attr(755,root,root) %{_libdir}/libboost_unit_test_framework*.so
493 %attr(755,root,root) %{_libdir}/libboost_wave*.so
494 %attr(755,root,root) %{_libdir}/libboost_wserialization*.so
495
496 %files static
497 %defattr(644,root,root,755)
498 %{_libdir}/libboost_date_time*.a
499 %{_libdir}/libboost_filesystem*.a
500 %{_libdir}/libboost_grap*.a
501 %{_libdir}/libboost_iostreams*.a
502 %{_libdir}/libboost_math_*.a
503 %{_libdir}/libboost_prg_exec_monitor*.a
504 %{_libdir}/libboost_program_options*.a
505 %{_libdir}/libboost_regex*.a
506 %{_libdir}/libboost_serialization*.a
507 %{_libdir}/libboost_signals*.a
508 %{_libdir}/libboost_system*.a
509 %{_libdir}/libboost_test_exec_monitor*.a
510 %{_libdir}/libboost_thread*.a
511 %{_libdir}/libboost_unit_test_framework*.a
512 %{_libdir}/libboost_wave*.a
513 %{_libdir}/libboost_wserialization*.a
514
515 %if %{with python}
516 %files python
517 %defattr(644,root,root,755)
518 %attr(755,root,root) %{_libdir}/libboost_python*.so.*.*.*
519
520 %files python-devel
521 %defattr(644,root,root,755)
522 %attr(755,root,root) %{_libdir}/libboost_python*.so
523 %{_includedir}/boost/python
524 %{_includedir}/boost/python.hpp
525
526 %files python-static
527 %defattr(644,root,root,755)
528 %{_libdir}/libboost_python*.a
529 %endif
530
531 %files date_time
532 %defattr(644,root,root,755)
533 %attr(755,root,root) %{_libdir}/libboost_date_time*.so.*.*.*
534
535 %files filesystem
536 %defattr(644,root,root,755)
537 %attr(755,root,root) %{_libdir}/libboost_filesystem*.so.*.*.*
538
539 %files graph
540 %defattr(644,root,root,755)
541 %attr(755,root,root) %{_libdir}/libboost_graph*.so.*.*.*
542
543 %files program_options
544 %defattr(644,root,root,755)
545 %attr(755,root,root) %{_libdir}/libboost_program_options*.so.*.*.*
546
547 %files regex
548 %defattr(644,root,root,755)
549 %attr(755,root,root) %{_libdir}/libboost_regex*.so.*.*.*
550
551 %files signals
552 %defattr(644,root,root,755)
553 %attr(755,root,root) %{_libdir}/libboost_signals*.so.*.*.*
554
555 %files system
556 %defattr(644,root,root,755)
557 %attr(755,root,root) %{_libdir}/libboost_system*.so.*.*.*
558
559 %files test
560 %defattr(644,root,root,755)
561 %attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor*.so.*.*.*
562 %attr(755,root,root) %{_libdir}/libboost_unit_test_framework*.so.*.*.*
563
564 %files thread
565 %defattr(644,root,root,755)
566 %attr(755,root,root) %{_libdir}/libboost_thread*.so.*.*.*
567
568 %files wave
569 %defattr(644,root,root,755)
570 %attr(755,root,root) %{_libdir}/libboost_wave*.so.*.*.*
571
572 %files doc
573 %defattr(644,root,root,755)
574 %{_docdir}/%{name}-%{version}
This page took 0.067803 seconds and 3 git commands to generate.