]> git.pld-linux.org Git - packages/blender.git/blob - blender.spec
- prep stuff moved to %prep
[packages/blender.git] / blender.spec
1 # TODO:
2 # - enable internalization support (BR libftgl)
3 # - enable OpenAL support
4 # - libsolid/libqhull/libode BR ?
5 # - package python scripts
6 Summary:        3D modeling, rendering, animation and game creation package
7 Summary(pl):    Pakiet do tworzenia animacji 3D oraz gier
8 Name:           blender
9 Version:        2.42a
10 Release:        0.1
11 License:        GPL
12 Group:          X11/Applications/Graphics
13 Source0:        http://download.blender.org/source/%{name}-%{version}.tar.gz
14 # Source0-md5:  3d60b7ebe0dea47da12744fe2462d96c
15 Source1:        %{name}.desktop
16 Source2:        %{name}.png
17 Source4:        %{name}-wrapper
18 Source5:        %{name}.manpage
19 Patch0:         %{name}-po_and_locale_names.patch
20 Patch1:         %{name}-noxml-yafray.patch
21 Patch2:         %{name}-python-fix.patch
22 URL:            http://www.blender.org/
23 BuildRequires:  OpenEXR-devel
24 BuildRequires:  OpenGL-devel
25 BuildRequires:  SDL-devel
26 BuildRequires:  freealut-devel
27 BuildRequires:  freetype-devel
28 BuildRequires:  ftgl-devel
29 BuildRequires:  gettext-devel
30 #BuildRequires: esound-devel
31 BuildRequires:  libjpeg-devel
32 BuildRequires:  libpng-devel
33 BuildRequires:  libstdc++-devel
34 BuildRequires:  libtiff-devel
35 BuildRequires:  libtool
36 BuildRequires:  libvorbis-devel
37 BuildRequires:  openssl-devel >= 0.9.7d
38 BuildRequires:  python-devel >= 1:2.3
39 BuildRequires:  scons
40 BuildRequires:  sed >= 4.0
41 #BuildRequires: smpeg-devel
42 BuildRequires:  zlib-devel
43 Requires:       OpenGL
44 Requires:       freetype
45 Requires:       python-modules
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
49
50 %description
51 Blender is a free and fully functional 3D modeling, rendering,
52 animation and game creation package for Unix, Windows and BeOS
53 systems.
54
55 %description -l pl
56 Blender to darmowy i w pe³ni funkcjonalny pakiet do tworzenia animacji
57 3D oraz gier, dostêpny dla systemów Unix, Windows i BeOS.
58
59 %prep
60 %setup -q
61 %patch0 -p1
62 %patch1 -p1
63 %patch2 -p1
64 mv -f po/pt_{br,BR}.po
65
66 rm -f missing
67 rm -f user-config.py
68
69 RPMCFLAGS="\"`echo %{rpmcflags}|sed 's/ /\",\"/g'`\""
70 RPMLDFLAGS="\"`echo %{rpmldflags}|sed 's/ /\",\"/g'`\""
71
72 cat > user-config.py <<END
73 CCFLAGS           = [$RPMCFLAGS]
74 CXXFLAGS          = [$RPMCFLAGS]
75 LDFLAGS           = [$RPMLDFLAGS]
76 TARGET_CC         = '%{__cc}'
77 TARGET_CXX        = '%{__cxx}'
78
79 BF_PYTHON_VERSION = '2.5'
80
81 LCGDIR            = 'lib/linux2'
82 BF_BUILDDIR       = 'build/linux2'
83 BF_INSTALLDIR     = 'install/linux2'
84 END
85
86 %build
87 scons
88 %{__make} -C po OCGDIR=..
89
90 install -d release/plugins/include
91 install source/blender/blenpluginapi/*.h release/plugins/include
92 chmod +x release/plugins/bmake
93 %{__make} -C release/plugins/
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97 install -d $RPM_BUILD_ROOT{%{_datadir},%{_desktopdir},%{_pixmapsdir},%{_bindir}} \
98         $RPM_BUILD_ROOT%{_datadir}/blender/bpydata
99
100 install ./install/linux2/blender $RPM_BUILD_ROOT%{_bindir}/blender-bin
101 install %{SOURCE4} $RPM_BUILD_ROOT%{_bindir}/blender
102 #install blenderplayer $RPM_BUILD_ROOT%{_bindir}
103 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
104 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
105 install -d $RPM_BUILD_ROOT%{_libdir}/blender/plugins/sequence
106 install -d $RPM_BUILD_ROOT%{_libdir}/blender/plugins/texture
107 install ./release/plugins/sequence/*.so $RPM_BUILD_ROOT%{_libdir}/blender/plugins/sequence
108 install ./release/plugins/texture/*.so $RPM_BUILD_ROOT%{_libdir}/blender/plugins/texture
109 install -d $RPM_BUILD_ROOT%{_datadir}/blender
110 cp -aR ./release/scripts $RPM_BUILD_ROOT%{_datadir}/blender
111 install ./release/VERSION $RPM_BUILD_ROOT%{_datadir}/blender
112 install ./bin/.blender/.Blanguages $RPM_BUILD_ROOT%{_datadir}/blender
113 install ./bin/.blender/.bfont.ttf $RPM_BUILD_ROOT%{_datadir}/blender
114 cp -a bin/.blender/locale $RPM_BUILD_ROOT%{_datadir}/blender
115 install -d $RPM_BUILD_ROOT%{_mandir}/man1
116 install %{SOURCE5} $RPM_BUILD_ROOT%{_mandir}/man1/blender.1
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %files
122 %defattr(644,root,root,755)
123 %doc README doc/bf-members.txt doc/python-dev-guide.txt doc/oldbugs.txt doc/interface_API.txt
124 %doc release/text/{blender.html,release*.txt}
125 %attr(755,root,root) %{_bindir}/*
126 %attr(755,root,root) %{_datadir}/%{name}
127 %attr(755,root,root) %{_libdir}/%{name}
128 %{_desktopdir}/*.desktop
129 %{_pixmapsdir}/*.png
130 %{_mandir}/man1/*
This page took 0.120133 seconds and 4 git commands to generate.