]> git.pld-linux.org Git - packages/blender.git/blob - blender.spec
- use ftgl for freetype2
[packages/blender.git] / blender.spec
1 # TODO:
2 # - enable internalization support (BR libftgl)
3 # - enable OpenAL support
4 # - libsolid/libqhull/libode BR ?
5 # - package python scripts
6
7 Summary:        3D modeling, rendering, animation and game creation package
8 Summary(pl):    Pakiet do tworzenia animacji 3D oraz gier
9 Name:           blender
10 Version:        2.36
11 Release:        1
12 License:        GPL
13 Group:          X11/Applications/Graphics
14 Source0:        http://download.blender.org/source/%{name}-%{version}.tar.gz
15 # Source0-md5:  8e2237c86b12e6061935632495aec875
16 Source1:        %{name}.desktop
17 Source2:        %{name}.png
18 Source3:        %{name}-config.opts
19 Patch0:         %{name}-po_and_locale_names.patch
20 URL:            http://www.blender.org/
21 BuildRequires:  OpenAL-devel
22 BuildRequires:  OpenGL-devel
23 BuildRequires:  SDL-devel
24 BuildRequires:  ftgl-devel
25 #BuildRequires: autoconf
26 #BuildRequires: automake
27 #BuildRequires: esound-devel
28 BuildRequires:  libjpeg-devel
29 BuildRequires:  libpng-devel
30 BuildRequires:  libstdc++-devel
31 BuildRequires:  freetype-devel
32 BuildRequires:  libtool
33 BuildRequires:  libvorbis-devel
34 BuildRequires:  openssl-devel >= 0.9.7d
35 BuildRequires:  python-devel >= 1:2.3
36 BuildRequires:  scons
37 #BuildRequires: smpeg-devel
38 BuildRequires:  zlib-devel
39 Requires:       OpenGL
40 Requires:       python-modules
41 Requires:       freetype
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
45
46 %description
47 Blender is a free and fully functional 3D modeling, rendering,
48 animation and game creation package for Unix, Windows and BeOS
49 systems.
50
51 %description -l pl
52 Blender to darmowy i w pe³ni funkcjonalny pakiet do tworzenia animacji
53 3D oraz gier, dostêpny dla systemów Unix, Windows i BeOS.
54
55 %prep
56 %setup -q -n %{name}
57 %patch0 -p1
58
59 mv -f po/pt_{br,BR}.po
60 rm -rf bin/.blender/locale
61 install %{SOURCE3} config.opts
62
63 %build
64 rm -f missing
65
66 RPMCFLAGS="\"`echo %{rpmcflags}|sed 's/ /\",\"/g'`\""
67 RPMLDFLAGS="\"`echo %{rpmldflags}|sed 's/ /\",\"/g'`\""
68
69 sed -i -e "s|^CCFLAGS =.*|CCFLAGS = [$RPMCFLAGS]|" \
70         -e "s|^CXXFLAGS =.*|CXXFLAGS = [$RPMCFLAGS]|" \
71         -e "s|^LDFLAGS =.*|LDFLAGS = [$RPMLDFLAGS]|" \
72         config.opts
73 sed -i -e "s|TARGET_CC =.*|TARGET_CC = '%{__cc}'|" \
74         -e "s|TARGET_CXX =.*|TARGET_CXX = '%{__cxx}'|" \
75         config.opts
76 sed -i 's/python2\.3/python%{py_ver}/' config.opts
77
78 scons
79 %{__make} -C po OCGDIR=..
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83 install -d $RPM_BUILD_ROOT{%{_datadir},%{_desktopdir},%{_pixmapsdir},%{_bindir}}
84
85 install -m755 blender $RPM_BUILD_ROOT%{_bindir}
86 install -m755 blenderplayer $RPM_BUILD_ROOT%{_bindir}
87 install -c %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
88 install -c %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
89 cp -a bin/.blender/locale $RPM_BUILD_ROOT%{_datadir}
90
91 %find_lang %{name} --all-name
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %files -f %{name}.lang
97 %defattr(644,root,root,755)
98 %doc README doc/bf-members.txt doc/python-dev-guide.txt doc/oldbugs.txt doc/interface_API.txt 
99 %doc release/text/{blender.html,release*.txt}
100 %attr(755,root,root) %{_bindir}/*
101 %{_desktopdir}/*.desktop
102 %{_pixmapsdir}/*.png
This page took 0.070033 seconds and 3 git commands to generate.