]> git.pld-linux.org Git - packages/bitlbee.git/blob - bitlbee.spec
- up to 3.0.5, add -devel and -otr subpackages
[packages/bitlbee.git] / bitlbee.spec
1 # TODO
2 # - sync pl
3 # - bilbee user
4 #
5 # Conditional build:
6 %bcond_without  otr             # build without OTR
7
8 Summary:        An IRC to other chat networks gateway
9 Summary(pl.UTF-8):      Bramka pomiędzy IRC-em i innymi sieciami komunikacyjnymi
10 Name:           bitlbee
11 Version:        3.0.5
12 Release:        0.1
13 License:        GPL v2+ and MIT
14 Group:          Daemons
15 Source0:        http://get.bitlbee.org/src/%{name}-%{version}.tar.gz
16 # Source0-md5:  9ff97260a2a7f3a7d102db158a8d9887
17 URL:            http://www.bitlbee.org/
18 BuildRequires:  gnutls-devel
19 %{?with_otr:BuildRequires:      libotr-devel >= 3.2.0}
20 BuildRequires:  systemd-units
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Bitlbee is an IRC to other chat networks gateway. Bitlbee can be used
25 as an IRC server which forwards everything you say to people on other
26 chat networks like ICQ/AIM, MSN, XMPP/Jabber (including Google Talk),
27 Yahoo or Twitter!
28
29 %description -l pl.UTF-8
30 Bramka pomiędzy IRC-em i innymi sieciami komunikacyjnymi. Ten program
31 może być używany jako serwer IRC przekazujący wszystko co się mówi do
32 ludzi korzystających z innych sieci komunikacyjnych, takich jak
33 MSN/ICQ/Jabber.
34
35 %package devel
36 Summary:        Development files for bitlbee
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39
40 %description devel
41 The bitlbee-devel package includes header files necessary for building
42 and developing programs and plugins which use bitlbee.
43
44 %package otr
45 Summary:        OTR plugin for bitlbee
46 Group:          Daemons
47 Requires:       %{name} = %{version}-%{release}
48
49 %description otr
50 The bitlbee-otr package includes OTR plugin for bitlbee. Not
51 completely stable and not 100% foolproof so use at your own risk.
52
53 %prep
54 %setup -q
55
56 # fix wrong assumption with $DESTDIR
57 %{__sed} -i -e 's,$(shell id -u),0,' Makefile
58
59 %build
60 CFLAGS="%{rpmcflags}" \
61 ./configure \
62         --prefix=%{_prefix} \
63         --bindir=%{_sbindir} \
64         --etcdir=%{_sysconfdir}/%{name} \
65         --mandir=%{_mandir} \
66         --datadir=%{_datadir}/%{name} \
67         --config=%{_localstatedir}/lib/%{name} \
68         --pcdir=%{_pkgconfigdir} \
69         --plugindir=%{_libdir}/%{name} \
70         --strip=0 \
71         --plugins=1 \
72         --ssl=gnutls \
73 %if %{with otr}
74         --otr=plugin \
75 %endif
76
77 %{__make}
78
79 ### FIXME: Documentation needs old sgmltools tool, deprecated.
80 #%{__make} -C doc
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 install -d $RPM_BUILD_ROOT%{_localstatedir}/lib/%{name}
85
86 %{__make} install install-dev install-etc install-systemd \
87         DESTDIR=$RPM_BUILD_ROOT
88
89 # Install some files manually to their correct destination
90 #install -d $RPM_BUILD_ROOT{%{_localstatedir}/lib,%{_libdir}}/%{name}
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %files
96 %defattr(644,root,root,755)
97 %doc doc/{AUTHORS,CHANGES,CREDITS,FAQ,README}
98 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/bitlbee.conf
99 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/motd.txt
100 %attr(755,root,root) %{_sbindir}/bitlbee
101 %{_mandir}/man5/bitlbee.conf.5*
102 %{_mandir}/man8/bitlbee.8*
103 %{_datadir}/bitlbee
104 %attr(700,root,root) %{_localstatedir}/lib/bitlbee
105 %{systemdunitdir}/bitlbee.service
106 %{systemdunitdir}/bitlbee.socket
107 %{systemdunitdir}/bitlbee@.service
108
109 %files devel
110 %defattr(644,root,root,755)
111 %doc doc/example_plugin.c
112 %{_includedir}/%{name}
113 %{_pkgconfigdir}/%{name}.pc
114
115 %if %{with otr}
116 %files otr
117 %defattr(644,root,root,755)
118 %attr(755,root,root) %{_libdir}/%{name}/otr.so
119 %endif
This page took 0.074616 seconds and 4 git commands to generate.