]> git.pld-linux.org Git - packages/belle-sip.git/blob - belle-sip.spec
- updated to 1.4.2
[packages/belle-sip.git] / belle-sip.spec
1 # TODO: switch to mbledtls when 2.x is supported (mbed_ssl_init instead of ssl_init)
2 # TODO: tunnel? (BR: pkgconfig(tunnel))
3 #
4 # Conditional build:
5 %bcond_without  static_libs     # don't build static libraries
6 %bcond_with     tests           # enable tests
7 #
8 Summary:        SIP (RFC3261) object-oriented implementation in C
9 Summary(pl.UTF-8):      Implementacja SIP (RFC3261) w C
10 Name:           belle-sip
11 Version:        1.4.2
12 Release:        1
13 License:        GPL v2+
14 Group:          Libraries
15 Source0:        http://download-mirror.savannah.gnu.org/releases/linphone/belle-sip/%{name}-%{version}.tar.gz
16 # Source0-md5:  dbb58649225adefbad87241141fbea93
17 Patch0:         antlr_jar.patch
18 URL:            http://www.linphone.org/
19 %{?with_tests:BuildRequires:    CUnit >= 2.0}
20 BuildRequires:  autoconf >= 2.63
21 BuildRequires:  automake >= 1:1.11
22 BuildRequires:  java-antlr3 >= 3.2
23 BuildRequires:  jre
24 BuildRequires:  libantlr3c-devel >= 3.4
25 BuildRequires:  libstdc++-devel
26 BuildRequires:  libtool >= 2:2
27 BuildRequires:  polarssl-devel >= 1.2
28 BuildRequires:  pkgconfig
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Belle-sip is a SIP (RFC3261) implementation written in C, with an
33 object oriented API.
34
35 %description -l pl.UTF-8
36 Belle-sip to implementacja SIP (RFC3261) napisana w C z API
37 zorientowanym obiektowo.
38
39 %package devel
40 Summary:        Header files for %{name} library
41 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44
45 %description devel
46 Header files for %{name} library.
47
48 %description devel -l pl.UTF-8
49 Pliki nagłówkowe biblioteki %{name}.
50
51 %package static
52 Summary:        Static %{name} library
53 Summary(pl.UTF-8):      Statyczna biblioteka %{name}
54 Group:          Development/Libraries
55 Requires:       %{name}-devel = %{version}-%{release}
56
57 %description static
58 Static %{name} library.
59
60 %description static -l pl.UTF-8
61 Statyczna biblioteka %{name}.
62
63 %prep
64 %setup -q
65 %patch0 -p1
66
67 %build
68 %{__libtoolize}
69 %{__aclocal}
70 %{__autoconf}
71 %{__autoheader}
72 %{__automake}
73 %configure \
74         CFLAGS="%{rpmcflags} -Wno-error=pragmas" \
75         --disable-silent-rules \
76         %{!?with_static_libs:--disable-static}
77
78 %{__make}
79
80 %{?with_tests:%{__make} test}
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84
85 %{__make} install \
86         DESTDIR=$RPM_BUILD_ROOT
87
88 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libbellesip.la
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post   -p /sbin/ldconfig
94 %postun -p /sbin/ldconfig
95
96 %files
97 %defattr(644,root,root,755)
98 %doc AUTHORS NEWS README
99 %attr(755,root,root) %{_libdir}/libbellesip.so.*.*.*
100 %attr(755,root,root) %ghost %{_libdir}/libbellesip.so.0
101
102 %files devel
103 %defattr(644,root,root,755)
104 %attr(755,root,root) %{_libdir}/libbellesip.so
105 %{_includedir}/%{name}
106 %{_pkgconfigdir}/%{name}.pc
107
108 %if %{with static_libs}
109 %files static
110 %defattr(644,root,root,755)
111 %{_libdir}/libbellesip.a
112 %endif
This page took 0.08091 seconds and 3 git commands to generate.