]> git.pld-linux.org Git - packages/bakefile.git/blob - bakefile.spec
- pl, BR: ac,am
[packages/bakefile.git] / bakefile.spec
1 %include        /usr/lib/rpm/macros.python
2 Summary:        Native makefiles generator
3 Summary(pl):    Generator natywnych plików typu Makefile
4 Name:           bakefile
5 Version:        0.1.1
6 %define         snap 20031009
7 Release:        0.%{snap}.1
8 License:        GPL v2+
9 Group:          Applications/Text
10 Source0:        http://bakefile.sourceforge.net/snapshot/bakefile-%{version}.%{snap}.tar.gz
11 # Source0-md5:  e4c3359d61b927dc1856f6e65a1dd86b
12 Patch0:         %{name}-empy.patch
13 Patch1:         %{name}-typo.patch
14 URL:            http://bakefile.sourceforge.net/
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  rpm-pythonprov
18 %pyrequires_eq  python-modules
19 Requires:       python-libxml2
20 Requires:       empy >= 3.1
21 Requires:       python-optik >= 1.2
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Bakefile is cross-platform, cross-compiler native makefiles generator.
26 It takes compiler-independent description of build tasks as input and
27 generate native makefile (autoconf's Makefile.in, Visual C++ project,
28 bcc makefile etc.).
29
30 %description -l pl
31 Bakefile to generator natywnych plików typu Makefile dla wielu
32 platform i kompilatorów. Przyjmuje na wej¶ciu niezale¿ny od
33 kompilatora opis zadañ budowania  i tworzy natywny plik (Makefile.in
34 dla autoconfa, projekt dla Visual C++, makefile dla bcc itd.).
35
36 %prep
37 %setup -q -n %{name}-%{version}.%{snap}
38 %patch0 -p1
39 %patch1 -p1
40
41 %build
42 %{__aclocal}
43 %{__autoconf}
44 %{__automake}
45 %configure
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 install -d $RPM_BUILD_ROOT{%{_examplesdir}/%{name}-%{version},%{_bindir}}
50
51 %{__make} \
52         DESTDIR=$RPM_BUILD_ROOT \
53         install
54
55 # use system available modules
56 rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/src/{empy,optik}
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc README THANKS doc/html
64 %attr(755,root,root) %{_bindir}/*
65 %{_aclocaldir}/*.m4
66 %dir %{_datadir}/%{name}
67 %{_datadir}/%{name}/output
68 %{_datadir}/%{name}/rules
69 %dir %{_datadir}/%{name}/src
70 %{_datadir}/%{name}/src/*.py[oc]
71 %attr(755,root,root) %{_datadir}/%{name}/src/bakefile.py
72 %attr(755,root,root) %{_datadir}/%{name}/src/bakefile_gen.py
73 %{_mandir}/man1/bakefile.1*
This page took 0.135868 seconds and 4 git commands to generate.