]> git.pld-linux.org Git - packages/audit.git/blob - audit.spec
- new; spec rewritten from one included with package
[packages/audit.git] / audit.spec
1 # TODO: fix build with current llh
2 Summary:        User space tools for 2.6 kernel auditing
3 Summary(pl):    Narzêdzia przestrzeni u¿ytkownika do audytu j±der 2.6
4 Name:           audit
5 Version:        0.9.2
6 Release:        1
7 License:        GPL
8 Group:          Daemons
9 Source0:        http://people.redhat.com/sgrubb/audit/%{name}-%{version}.tar.gz
10 # Source0-md5:  e31f3c554e9848a50afa6a119dc84d5c
11 URL:            http://people.redhat.com/sgrubb/audit/
12 BuildRequires:  autoconf >= 2.59
13 BuildRequires:  automake >= 1.9
14 BuildRequires:  libtool
15 BuildRequires:  linux-libc-headers >= 2.6.11
16 PreReq:         rc-scripts
17 Requires(post,preun):   /sbin/chkconfig
18 Requires:       %{name}-libs = %{version}-%{release}
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _sbindir        /sbin
22
23 %description
24 The audit package contains the user space utilities for storing and
25 processing the audit records generate by the audit subsystem in the
26 Linux 2.6 kernel.
27
28 %description -l pl
29 Ten pakiet zawiera narzêdzia przestrzeni u¿ytkownika do przechowywania
30 i przetwarzania rekordów audytu generowanych przez podsystem audytu w
31 j±drach Linuksa 2.6.
32
33 %package libs
34 Summary:        Dynamic libaudit library
35 Summary(pl):    Biblioteka dynamiczna libaudit
36 License:        LGPL
37 Group:          Libraries
38
39 %description libs
40 The audit-libs package contains the dynamic library needed for
41 applications to use the audit framework.
42
43 %description libs -l pl
44 Ten pakiet zawiera bibliotekê dynamiczn± potrzebn± dla aplikacji
45 u¿ywaj±cych ¶rodowiska audytu.
46
47 %package libs-devel
48 Summary:        Header files for libaudit library
49 Summary(pl):    Pliki nag³ówkowe biblioteki libaudio
50 License:        LGPL
51 Group:          Development/Libraries
52 Requires:       %{name}-libs = %{version}-%{release}
53
54 %description libs-devel
55 The audit-libs-devel package contains the header files needed for
56 developing applications that need to use the audit framework library.
57
58 %description libs-devel -l pl
59 Ten pakiet zawiera pliki nag³ówkowe potrzebne do tworzenia aplikacji
60 u¿ywaj±cych biblioteki ¶rodowiska audytu.
61
62 %package libs-static
63 Summary:        Static libaudit library
64 Summary(pl):    Statyczna biblioteka libaudit
65 License:        LGPL
66 Group:          Development/Libraries
67 Requires:       %{name}-libs-devel = %{version}-%{release}
68
69 %description libs-static
70 The audit-libs-static package contains the static library for
71 developing applications that need to use the audit framework library.
72
73 %description libs-static -l pl
74 Ten pakiet zawiera statyczn± bibliotekê do tworzenia aplikacji
75 u¿ywaj±cych ¶rodowiska audytu.
76
77 %prep
78 %setup -q
79
80 %build
81 %{__libtoolize}
82 %{__aclocal}
83 %{__autoconf}
84 %{__autoheader}
85 %{__automake}
86 %configure
87 %{__make}
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91 install -d $RPM_BUILD_ROOT%{_var}/log/audit
92
93 %{__make} install \
94         DESTDIR=$RPM_BUILD_ROOT
95
96 install -d $RPM_BUILD_ROOT/%{_lib}
97 mv -f $RPM_BUILD_ROOT%{_libdir}/libaudit.so.* $RPM_BUILD_ROOT/%{_lib}
98 ln -sf $(cd $RPM_BUILD_ROOT/%{_lib} ; echo libaudit.so.*.*.*) \
99         PM_BUILD_ROOT%{_libdir}/libaudit.so
100
101 # We manually install this since Makefile doesn't
102 install -d $RPM_BUILD_ROOT%{_includedir}
103 install lib/libaudit.h $RPM_BUILD_ROOT%{_includedir}
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %post   libs -p /sbin/ldconfig
109 %postun libs -p /sbin/ldconfig
110
111 %post
112 /sbin/chkconfig --add auditd
113 if [ -f /var/lock/subsys/auditd ]; then
114         /etc/rc.d/init.d/auditd restart >&2
115 else
116         echo "Run \"/etc/rc.d/init.d/auditd start\" to start audit daemon." >&2
117 fi
118
119 %preun
120 if [ "$1" = "0" ]; then
121         if [ -f /var/lock/subsys/auditd ]; then
122                 /etc/rc.d/init.d/auditd stop >&2
123         fi
124         /sbin/chkconfig --del auditd
125 fi
126
127 %files
128 %defattr(644,root,root,755)
129 %doc AUTHORS ChangeLog README THANKS TODO sample.rules
130 %attr(750,root,root) %{_sbindir}/auditctl
131 %attr(750,root,root) %{_sbindir}/auditd
132 %attr(750,root,root) %{_sbindir}/ausearch
133 %attr(750,root,root) %{_sbindir}/autrace
134 %attr(754,root,root) /etc/rc.d/init.d/auditd
135 %config(noreplace) %attr(640,root,root) %{_sysconfdir}/auditd.conf
136 %config(noreplace) %attr(640,root,root) %{_sysconfdir}/audit.rules
137 %config(noreplace) %attr(640,root,root) %verify(not md5 mtime size) /etc/sysconfig/auditd
138 %attr(750,root,root) %dir %{_var}/log/audit
139 %{_mandir}/man8/*
140
141 %files libs
142 %defattr(644,root,root,755)
143 %attr(755,root,root) /%{_lib}/libaudit.so.*.*.*
144
145 %files libs-devel
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_libdir}/libaudit.so
148 %{_libdir}/libaudit.la
149 %{_includedir}/libaudit.h
150 %{_mandir}/man3/*
151
152 %files libs-static
153 %defattr(644,root,root,755)
154 %{_libdir}/libaudit.a
This page took 0.107853 seconds and 4 git commands to generate.