]> git.pld-linux.org Git - packages/asterisk.git/blob - asterisk.spec
- require exact version of openh323
[packages/asterisk.git] / asterisk.spec
1 # TODO:
2 # - cgi-bin package - separate, because of suid-root
3 # - separate plugins into packages
4
5 Summary:        Asterisk PBX
6 Summary(pl):    Centralka (PBX) Asterisk
7 Name:           asterisk
8 Version:        0.4.0
9 Release:        0.5
10 License:        GPL v2
11 Group:          Applications/System
12 Source0:        ftp://ftp.asterisk.org/pub/telephony/asterisk/%{name}-%{version}.tar.gz
13 Patch0:         %{name}-destdir.patch
14 Patch1:         %{name}-Makefile.patch
15 URL:            http://www.asteriskpbx.com/
16 BuildRequires:  glib-devel
17 BuildRequires:  gtk+-devel
18 BuildRequires:  mysql-devel
19 BuildRequires:  openh323-devel >= 1.11.7
20 BuildRequires:  ncurses-devel
21 BuildRequires:  openssl-devel
22 BuildRequires:  pwlib-devel >= 1.4.11
23 BuildRequires:  speex-devel
24 BuildRequires:  zlib-devel
25 %requires_eq    openh323
26 %requires_eq    pwlib
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Asterisk is an Open Source PBX and telephony development platform that
31 can both replace a conventional PBX and act as a platform for
32 developing custom telephony applications for delivering dynamic
33 content over a telephone similarly to how one can deliver dynamic
34 content through a web browser using CGI and a web server.
35
36 Asterisk talks to a variety of telephony hardware including BRI, PRI,
37 POTS, and IP telephony clients using the Inter-Asterisk eXchange
38 protocol (e.g. gnophone or miniphone). For more information and a
39 current list of supported hardware, see http://www.asteriskpbx.com/.
40
41 %description -l pl
42 Asterisk to wolnodostêpna centralka (PBX) i platforma programistyczna
43 dla telefonii, mog±ca zast±piæ konwencjonalne PBX-y oraz s³u¿yæ jako
44 platforma do rozwijania w³asnych aplikacji telefonicznych do
45 przekazywania dynamicznej tre¶ci przez telefon, podobnie jak mo¿na
46 przekazywaæ dynamiczn± tre¶æ przez przegl±darkê WWW przy u¿yciu CGI i
47 serwera WWW.
48
49 Asterisk wspó³pracuje z wielorakim sprzêtem telefonicznym, w tym BRI,
50 PRI, POTS oraz klienty telefonii IP u¿ywaj±ce protoko³u Inter-Asterisk
51 eXchange (np. gnophone lub miniphone). Wiêcej informacji i listê
52 obs³ugiwanego sprzêtu mo¿na znale¼æ pod http://www.asteriskpbx.com/.
53
54 %package devel
55 Summary:        Header files for Asterisk platform
56 Summary(pl):    Pliki nag³ówkowe platformy Asterisk
57 Group:          Development
58 Requires:       %{name} = %{version}
59
60 %description devel
61 Header files for Asterisk development platform.
62
63 %description devel -l pl
64 Pliki nag³ówkowe platformy programistycznej Asterisk.
65
66 %prep
67 %setup -q
68 %patch0 -p1
69 %patch1 -p1
70
71 %build
72 %{__make}
73
74 # H323 plugin:
75 cd channels/h323/
76 %{__make} \
77         PWLIBDIR="/usr" \
78         OPENH323DIR="/usr"
79 cd ../../
80
81 # it requires doxygen - I don't know if we should do this...
82 #%{__make} progdocs
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86 install -d $RPM_BUILD_ROOT/var/log/asterisk
87
88 %{__make} install \
89         DESTDIR=$RPM_BUILD_ROOT
90 %{__make} samples \
91         DESTDIR=$RPM_BUILD_ROOT
92
93 cd channels/h323/
94 %{__make} install \
95         DESTDIR=$RPM_BUILD_ROOT
96 %{__make} samples \
97         DESTDIR=$RPM_BUILD_ROOT
98 cd ../../
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %files
104 %defattr(644,root,root,755)
105 %doc BUGS ChangeLog CREDITS HARDWARE README* SECURITY configs doc/{*.txt,linkedlists.README}
106 %attr(755,root,root) %{_sbindir}/*
107 %dir %{_sysconfdir}/asterisk
108 %attr(640,root,root) %config(noreplace) %{_sysconfdir}/asterisk/*.conf
109 %attr(640,root,root) %config(noreplace) %{_sysconfdir}/asterisk/*.adsi
110 %dir %{_libdir}/asterisk
111 %dir %{_libdir}/asterisk/modules
112 %attr(755,root,root) %{_libdir}/asterisk/modules/*.so
113 %dir /var/lib/asterisk
114 %dir /var/lib/asterisk/agi-bin
115 %dir /var/lib/asterisk/images
116 %dir /var/lib/asterisk/keys
117 %dir /var/lib/asterisk/sounds
118 %dir /var/lib/asterisk/sounds/digits
119 /var/lib/asterisk/images/*.jpg
120 /var/lib/asterisk/keys/*.pub
121 /var/lib/asterisk/sounds/*.gsm
122 /var/lib/asterisk/sounds/digits/*.gsm
123 %dir /var/spool/asterisk
124 %dir /var/spool/asterisk/vm
125 %dir /var/log/asterisk
126
127 # RedHat specific init script file
128 #%attr(754,root,root)       /etc/rc.d/init.d/asterisk
129 #%dir /var/lib/asterisk/agi-bin/*
130
131 %files devel
132 %defattr(644,root,root,755)
133 %dir %{_includedir}/asterisk
134 %{_includedir}/asterisk/*.h
This page took 0.083715 seconds and 4 git commands to generate.