]> git.pld-linux.org Git - packages/asterisk.git/blob - asterisk.spec
- started work with h323 plugin...
[packages/asterisk.git] / asterisk.spec
1 # TODO:
2 # - cgi-bin package - separate, because of suid-root
3
4 Summary:        Asterisk PBX
5 Summary(pl):    Centralka (PBX) Asterisk
6 Name:           asterisk
7 Version:        0.4.0
8 Release:        0.4
9 License:        GPL v2
10 Group:          Applications/System
11 Source0:        ftp://ftp.asterisk.org/pub/telephony/asterisk/%{name}-%{version}.tar.gz
12 Patch0:         asterisk-destdir.patch
13 URL:            http://www.asteriskpbx.com/
14 BuildRequires:  glib-devel
15 BuildRequires:  gtk+-devel
16 BuildRequires:  mysql-devel
17 BuildRequires:  openh323-devel >= 1.11.8
18 BuildRequires:  ncurses-devel
19 BuildRequires:  openssl-devel
20 BuildRequires:  pwlib >= 1.4.12
21 BuildRequires:  speex-devel
22 BuildRequires:  zlib-devel
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Asterisk is an Open Source PBX and telephony development platform that
27 can both replace a conventional PBX and act as a platform for
28 developing custom telephony applications for delivering dynamic
29 content over a telephone similarly to how one can deliver dynamic
30 content through a web browser using CGI and a web server.
31
32 Asterisk talks to a variety of telephony hardware including BRI, PRI,
33 POTS, and IP telephony clients using the Inter-Asterisk eXchange
34 protocol (e.g. gnophone or miniphone). For more information and a
35 current list of supported hardware, see http://www.asteriskpbx.com/.
36
37 %description -l pl
38 Asterisk to wolnodostêpna centralka (PBX) i platforma programistyczna
39 dla telefonii, mog±ca zast±piæ konwencjonalne PBX-y oraz s³u¿yæ jako
40 platforma do rozwijania w³asnych aplikacji telefonicznych do
41 przekazywania dynamicznej tre¶ci przez telefon, podobnie jak mo¿na
42 przekazywaæ dynamiczn± tre¶æ przez przegl±darkê WWW przy u¿yciu CGI i
43 serwera WWW.
44
45 Asterisk wspó³pracuje z wielorakim sprzêtem telefonicznym, w tym BRI,
46 PRI, POTS oraz klienty telefonii IP u¿ywaj±ce protoko³u Inter-Asterisk
47 eXchange (np. gnophone lub miniphone). Wiêcej informacji i listê
48 obs³ugiwanego sprzêtu mo¿na znale¼æ pod http://www.asteriskpbx.com/.
49
50 %package devel
51 Summary:        Header files for Asterisk platform
52 Summary(pl):    Pliki nag³ówkowe platformy Asterisk
53 Group:          Development
54 Requires:       %{name} = %{version}
55
56 %description devel
57 Header files for Asterisk development platform.
58
59 %description devel -l pl
60 Pliki nag³ówkowe platformy programistycznej Asterisk.
61
62 %prep
63 %setup -q
64 %patch0 -p1
65
66 %build
67 %{__make}
68
69 # H323 plugin:
70 cd channels/h323/
71 %{__make} \
72         PWLIBDIR="/usr" \
73         OPENH323DIR="/usr"
74 cd ../../
75
76 # it requires doxygen - I don't know if we should do this...
77 #%{__make} progdocs
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81 install -d $RPM_BUILD_ROOT/var/log/asterisk
82
83 %{__make} install \
84         DESTDIR=$RPM_BUILD_ROOT
85 %{__make} samples \
86         DESTDIR=$RPM_BUILD_ROOT
87
88 cd channels/h323/
89 %{__make} install \
90         DESTDIR=$RPM_BUILD_ROOT
91 %{__make} samples \
92         DESTDIR=$RPM_BUILD_ROOT
93 cd ../../
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %files
99 %defattr(644,root,root,755)
100 %doc BUGS ChangeLog CREDITS HARDWARE README* SECURITY configs doc/{*.txt,linkedlists.README}
101 %attr(755,root,root) %{_sbindir}/*
102 %dir %{_sysconfdir}/asterisk
103 %attr(640,root,root) %config(noreplace) %{_sysconfdir}/asterisk/*.conf
104 %attr(640,root,root) %config(noreplace) %{_sysconfdir}/asterisk/*.adsi
105 %dir %{_libdir}/asterisk
106 %dir %{_libdir}/asterisk/modules
107 %attr(755,root,root) %{_libdir}/asterisk/modules/*.so
108 %dir /var/lib/asterisk
109 %dir /var/lib/asterisk/agi-bin
110 %dir /var/lib/asterisk/sounds
111 %dir /var/lib/asterisk/sounds/digits
112 /var/lib/asterisk/sounds/digits/*.gsm
113 %dir /var/lib/asterisk/images
114 /var/lib/asterisk/images/*.jpg
115 %dir /var/lib/asterisk/keys
116 /var/lib/asterisk/keys/*.pub
117 %dir /var/lib/asterisk/sounds
118 /var/lib/asterisk/sounds/*.gsm
119 %dir /var/spool/asterisk
120 %dir /var/spool/asterisk/vm
121 %dir /var/log/asterisk
122
123 # RedHat specific init script file
124 #%attr(754,root,root)       /etc/rc.d/init.d/asterisk
125 #%dir /var/lib/asterisk/agi-bin/*
126
127 %files devel
128 %defattr(644,root,root,755)
129 %dir %{_includedir}/asterisk
130 %{_includedir}/asterisk/*.h
This page took 0.053249 seconds and 4 git commands to generate.