]> git.pld-linux.org Git - packages/aspell.git/blob - aspell.spec
- updated URLs, added patch from project
[packages/aspell.git] / aspell.spec
1 %define         ver     .33.7.1
2
3 Summary:        Aspell is an Open Source spell checker
4 Summary(pl):    Aspell jest kontrolerem pisowni
5 Name:           aspell
6 Version:        0%{ver}
7 Release:        2
8 Epoch:          1
9 License:        LGPL
10 Group:          Applications/Text
11 Vendor:         Kevin Atkinson <kevinatk@home.com>
12 Source0:        ftp://ftp.sourceforge.net/pub/sourceforge/aspell/%{name}-%{ver}.tar.gz
13 Patch0:         ftp://ftp.sourceforge.net/pub/sourceforge/aspell/%{name}-.33-fix2.diff
14 Patch1:         %{name}-noinstalled.patch
15 Patch2:         %{name}-amfix.patch
16 URL:            http://aspell.sourceforge.net/
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  libtool
21 BuildRequires:  pspell-devel
22 Provides:       ispell
23 Obsoletes:      ispell
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Aspell is an Open Source spell checker designed to eventually replace
28 Ispell. Its main feature is that it does a much better job of coming
29 up with possible suggestions than Ispell does. In fact recent tests
30 shows that it even does better than Microsoft Word 97's spell checker
31 in some cases. In addition it has both compile time and run time
32 support for other non English languages. Aspell also doubles as a
33 powerful C++ library with C and Perl interfaces in the works.
34
35 %description -l pl
36 Aspell jest kontrolerem pisowni zaprojektowanym tak, by móc zast±piæ
37 ispella. Dodatkowo zawiera wsparcie dla innych jêzyków ni¿ angielski.
38 Interfejs aspella napisany zosta³ w C++, a interfejsy w Perlu i C s±
39 aktualnie rozwijane.
40
41 %package devel
42 Summary:        Header files for aspell development
43 Summary(pl):    Pliki nag³ówkowe dla programistów u¿ywaj±cych aspella
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}
46
47 %description devel
48 Aspell is an Open Source spell checker. This package contains header
49 files for aspell development.
50
51 %description -l pl devel
52 Aspell jest kontrolerem pisowni. Ten pakiet zawiera pliki nag³ówkowe
53 dla programistów u¿ywaj±cych bibliotek aspella.
54
55 %package static
56 Summary:        Static libraries for aspell development
57 Summary(pl):    Biblioteki statyczne aspella
58 Group:          Development/Libraries
59 Requires:       %{name}-devel = %{version}
60
61 %description static
62 Aspell is an Open Source spell checker. This package contains static
63 aspell libraries.
64
65 %description -l pl static
66 Aspell jest kontrolerem pisowni. Pakiet ten zawiera biblioteki
67 statyczne aspella.
68
69 %prep
70 %setup -q -n %{name}-%{ver}
71 %patch0 -p0
72 %patch1 -p1
73 %patch2 -p1
74
75 %build
76 libtoolize --copy --force
77 aclocal
78 autoconf
79 automake -a -c -f --foreign
80 %configure \
81         --enable-shared \
82         --enable-static \
83         --enable-dict-dir=%{_datadir}/aspell
84
85 %{__make} 
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89
90 %{__make} install \
91         DESTDIR=$RPM_BUILD_ROOT
92
93 ln -sf aspell $RPM_BUILD_ROOT%{_bindir}/ispell
94 rm -rf $RPM_BUILD_ROOT%{_prefix}/{bin/run-with-aspell,share/aspell/ispell}
95
96 gzip -9nf manual/manual2.lyx manual/man-text/*.txt
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %post   -p /sbin/ldconfig
102 %postun -p /sbin/ldconfig
103
104 %files
105 %defattr(644,root,root,755)
106 %doc manual/{*,man-text/*.txt}.gz
107 %attr(755,root,root) %{_bindir}/*
108 %attr(755,root,root) %{_libdir}/libaspell.so.*.*
109 %attr(755,root,root) %{_libdir}/libpspell_aspell.so.*.*
110 %attr(755,root,root) %{_libdir}/libpspell_aspell.la
111 %{_datadir}/aspell
112 %{_datadir}/pspell/*
113
114 %files  devel
115 %defattr(644,root,root,755)
116 %attr(755,root,root) %{_libdir}/libaspell.so
117 %attr(755,root,root) %{_libdir}/libaspell.la
118 %{_includedir}/aspell
119
120 %files static
121 %defattr(644,root,root,755)
122 %{_libdir}/libaspell.a
This page took 0.048934 seconds and 4 git commands to generate.