]> git.pld-linux.org Git - packages/apr-compat.git/blob - apr-compat.spec
- use system autotools in -devel
[packages/apr-compat.git] / apr-compat.spec
1 Summary:        Apache Portable Runtime
2 Summary(pl):    Apache Portable Runtime - przeno¶na biblioteka uruchomieniowa
3 Name:           apr
4 Version:        1.2.2
5 Release:        1
6 Epoch:          1
7 License:        Apache v2.0
8 Group:          Libraries
9 Source0:        http://www.apache.org/dist/apr/%{name}-%{version}.tar.bz2
10 # Source0-md5:  c43d923b02cf1983106d694976be89c1
11 Patch0:         %{name}-link.patch
12 Patch1:         %{name}-metuxmpm.patch
13 # EPOLL PATCH: TO BE DROPPED AFTER AC
14 Patch2:         %{name}-no-epoll.patch
15 URL:            http://apr.apache.org/
16 BuildRequires:  autoconf >= 2.13
17 BuildRequires:  automake
18 BuildRequires:  libtool >= 1.3.3
19 BuildRequires:  libuuid-devel
20 BuildRequires:  perl-base
21 BuildRequires:  python
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _includedir     /usr/include/apr
25 %define         _datadir        /usr/share/apr
26
27 %description
28 The mission of the Apache Portable Runtime (APR) project is to create
29 and maintain software libraries that provide a predictable and
30 consistent interface to underlying platform-specific implementations.
31 The primary goal is to provide an API to which software developers may
32 code and be assured of predictable if not identical behaviour
33 regardless of the platform on which their software is built, relieving
34 them of the need to code special-case conditions to work around or
35 take advantage of platform-specific deficiencies or features.
36
37 %description -l pl
38 Celem projektu APR (Apache Portable Runtime) jest stworzenie i
39 utrzymywanie bibliotek dostarczaj±cych przewidywalnego i spójnego
40 interfejsu do le¿±cych u podstaw implementacji zale¿nych od platformy.
41 G³ównym celem jest dostarczenie API, którego mog± u¿ywaæ programi¶ci
42 maj±c pewno¶æ, ¿e zachowuje siê w sposób przewidywalny, je¶li nie
43 identyczny, niezale¿nie od platformy na jakiej oprogramowanie jest
44 budowane oraz bez potrzeby kodowania specjalnych warunków do
45 obchodzenia lub wykorzystywania specyficznych dla platform ró¿nic lub
46 mo¿liwo¶ci.
47
48 %package devel
49 Summary:        Header files and development documentation for apr
50 Summary(pl):    Pliki nag³ówkowe i dokumentacja programisty do apr
51 Group:          Development/Libraries
52 Requires:       %{name} = %{epoch}:%{version}-%{release}
53 Requires:       libuuid-devel
54 Requires:       automake
55 Requires:       libtool
56
57 %description devel
58 Header files and development documentation for apr.
59
60 %description devel -l pl
61 Pliki nag³ówkowe i dokumentacja programisty do apr.
62
63 %package static
64 Summary:        Static apr library
65 Summary(pl):    Statyczna biblioteka apr
66 Group:          Development/Libraries
67 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
68
69 %description static
70 Static apr library.
71
72 %description static -l pl
73 Statyczna biblioteka apr.
74
75 %prep
76 %setup -q
77 %patch0 -p1
78 %patch1 -p1
79 %patch2 -p1
80
81 %build
82 install /usr/share/automake/config.* build
83 ./buildconf
84 # disable TCP_NODELAY|TCP_CORK for 2.4.x compatibility (to be dropped after Ac)
85 # 2.4/2.6 kernels on sparc32 do not support sendfile64
86 %configure \
87         apr_cv_tcp_nodelay_with_cork=no \
88 %ifarch sparc sparcv9
89         ac_cv_func_sendfile64=no \
90 %endif
91         --with-devrandom=/dev/urandom \
92 %ifarch %{ix86}
93 %ifnarch i386
94         --enable-nonportable-atomics \
95 %endif
96 %endif
97         --enable-threads
98 %{__make}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 %{__make} install \
104         DESTDIR=$RPM_BUILD_ROOT
105
106 ln -sf %{_bindir}/libtool $RPM_BUILD_ROOT%{_datadir}/libtool
107
108 mv -f $RPM_BUILD_ROOT%{_datadir}/build-1 $RPM_BUILD_ROOT%{_datadir}/build
109 install build/{*apr*.m4,*.awk,*.sh} $RPM_BUILD_ROOT%{_datadir}/build
110 ln -snf /usr/share/automake/config.{guess,sub} $RPM_BUILD_ROOT%{_datadir}/build
111 ln -snf /usr/share/libtool/ltmain.sh $RPM_BUILD_ROOT%{_datadir}/build
112 ln -snf /usr/bin/libtool $RPM_BUILD_ROOT%{_datadir}/build
113 ln -sf build $RPM_BUILD_ROOT%{_datadir}/build-1
114
115 %{__perl} -pi -e 's@^(APR_SOURCE_DIR=).*@$1"%{_datadir}"@' $RPM_BUILD_ROOT%{_bindir}/apr-config
116 %{__perl} -pi -e 's@^(apr_builddir|apr_builders)=.*@$1=%{_datadir}/build-1@' \
117         $RPM_BUILD_ROOT%{_datadir}/build/apr_rules.mk
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %post   -p /sbin/ldconfig
123 %postun -p /sbin/ldconfig
124
125 %files
126 %defattr(644,root,root,755)
127 %doc CHANGES docs/*.html
128 %attr(755,root,root) %{_libdir}/lib*.so.*.*
129
130 %files devel
131 %defattr(644,root,root,755)
132 %attr(755,root,root) %{_bindir}/*
133 %attr(755,root,root) %{_libdir}/lib*.so
134 %{_libdir}/lib*.la
135 %{_libdir}/apr.exp
136 %{_includedir}
137 %dir %{_datadir}
138 %dir %{_datadir}/build
139 %{_datadir}/build/*.mk
140 %{_datadir}/build/*.m4
141 %{_datadir}/build/*.awk
142 %attr(755,root,root) %{_datadir}/build/config.*
143 %attr(755,root,root) %{_datadir}/build/*.sh
144 %attr(755,root,root) %{_datadir}/build/libtool
145 %{_datadir}/build-1
146 %{_pkgconfigdir}/apr-1.pc
147
148 %files static
149 %defattr(644,root,root,755)
150 %{_libdir}/lib*.a
This page took 0.074155 seconds and 4 git commands to generate.