]> git.pld-linux.org Git - packages/apr-compat.git/blob - apr-compat.spec
- BR: rpm-pythonprov
[packages/apr-compat.git] / apr-compat.spec
1 Summary:        Apache Portable Runtime
2 Summary(pl.UTF-8):      Apache Portable Runtime - przenośna biblioteka uruchomieniowa
3 Name:           apr
4 Version:        1.3.2
5 Release:        2
6 Epoch:          1
7 License:        Apache v2.0
8 Group:          Libraries
9 Source0:        http://www.apache.org/dist/apr/%{name}-%{version}.tar.bz2
10 # Source0-md5:  a0631c63640176371dd4a5bf13beeee8
11 Patch0:         %{name}-link.patch
12 Patch1:         %{name}-metuxmpm.patch
13 Patch2:         %{name}-libtool.patch
14 URL:            http://apr.apache.org/
15 BuildRequires:  autoconf >= 2.13
16 BuildRequires:  automake
17 BuildRequires:  libtool >= 2:2.2
18 BuildRequires:  libuuid-devel
19 BuildRequires:  sed >= 4.0
20 BuildRequires:  python
21 BuildRequires:  rpm-pythonprov
22 BuildRequires:  uname(release) >= 2.6
23 Requires:       uname(release) >= 2.6
24 Conflicts:      kernel24
25 Conflicts:      kernel24-smp
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _includedir     /usr/include/apr
29 %define         _datadir        /usr/share/apr
30
31 %description
32 The mission of the Apache Portable Runtime (APR) project is to create
33 and maintain software libraries that provide a predictable and
34 consistent interface to underlying platform-specific implementations.
35 The primary goal is to provide an API to which software developers may
36 code and be assured of predictable if not identical behaviour
37 regardless of the platform on which their software is built, relieving
38 them of the need to code special-case conditions to work around or
39 take advantage of platform-specific deficiencies or features.
40
41 %description -l pl.UTF-8
42 Celem projektu APR (Apache Portable Runtime) jest stworzenie i
43 utrzymywanie bibliotek dostarczających przewidywalnego i spójnego
44 interfejsu do leżących u podstaw implementacji zależnych od platformy.
45 Głównym celem jest dostarczenie API, którego mogą używać programiści
46 mając pewność, że zachowuje się w sposób przewidywalny, jeśli nie
47 identyczny, niezależnie od platformy na jakiej oprogramowanie jest
48 budowane oraz bez potrzeby kodowania specjalnych warunków do
49 obchodzenia lub wykorzystywania specyficznych dla platform różnic lub
50 możliwości.
51
52 %package devel
53 Summary:        Header files and development documentation for apr
54 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja programisty do apr
55 Group:          Development/Libraries
56 Requires:       %{name} = %{epoch}:%{version}-%{release}
57 Requires:       libuuid-devel
58 Requires:       automake
59 Requires:       libtool >= 2:2.2
60 Requires:       python-modules
61
62 %description devel
63 Header files and development documentation for apr.
64
65 %description devel -l pl.UTF-8
66 Pliki nagłówkowe i dokumentacja programisty do apr.
67
68 %package static
69 Summary:        Static apr library
70 Summary(pl.UTF-8):      Statyczna biblioteka apr
71 Group:          Development/Libraries
72 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
73
74 %description static
75 Static apr library.
76
77 %description static -l pl.UTF-8
78 Statyczna biblioteka apr.
79
80 %prep
81 %setup -q
82 %patch0 -p1
83 %patch1 -p1
84 %patch2 -p1
85
86 cat >> config.layout <<'EOF'
87 <Layout PLD>
88 sbindir:        %{_sbindir}
89 libexecdir:     %{_libdir}/apr
90 installbuilddir: ${datadir}/build-${APR_MAJOR_VERSION}
91 localstatedir:  /var/run
92 runtimedir:     /var/run
93 libsuffix:      -${APR_MAJOR_VERSION}
94 </Layout>
95 EOF
96
97 %build
98 install /usr/share/automake/config.* build
99
100 %configure \
101         --enable-layout=PLD \
102 %ifarch %{ix86} %{i8664}
103 %ifnarch i386
104         --enable-nonportable-atomics \
105 %endif
106 %endif
107         --enable-threads \
108         --with-devrandom=/dev/urandom
109 %{__make}
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113
114 %{__make} install \
115         DESTDIR=$RPM_BUILD_ROOT
116
117 ln -sf %{_bindir}/libtool $RPM_BUILD_ROOT%{_datadir}/libtool
118
119 mv -f $RPM_BUILD_ROOT%{_datadir}/build-1 $RPM_BUILD_ROOT%{_datadir}/build
120 install build/{*apr*.m4,*.awk,*.sh,gen-build.py} $RPM_BUILD_ROOT%{_datadir}/build
121 ln -snf /usr/share/automake/config.{guess,sub} $RPM_BUILD_ROOT%{_datadir}/build
122 ln -snf /usr/share/libtool/config/ltmain.sh $RPM_BUILD_ROOT%{_datadir}/build
123 ln -snf /usr/bin/libtool $RPM_BUILD_ROOT%{_datadir}/build
124 ln -sf build $RPM_BUILD_ROOT%{_datadir}/build-1
125
126 sed -i -e 's@^\(APR_SOURCE_DIR=\).*@\1"%{_datadir}"@' \
127         $RPM_BUILD_ROOT%{_bindir}/apr-1-config
128 sed -i -e 's@^\(apr_builddir\|apr_builders\)=.*@\1=%{_datadir}/build-1@' \
129         $RPM_BUILD_ROOT%{_datadir}/build/apr_rules.mk
130 sed -i -e '1s@#!.*python@#!%{__python}@' $RPM_BUILD_ROOT%{_datadir}/build/gen-build.py
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %post   -p /sbin/ldconfig
136 %postun -p /sbin/ldconfig
137
138 %files
139 %defattr(644,root,root,755)
140 %doc CHANGES docs/*.html
141 %attr(755,root,root) %{_libdir}/libapr-1.so.*.*.*
142 %attr(755,root,root) %ghost %{_libdir}/libapr-1.so.0
143
144 %files devel
145 %defattr(644,root,root,755)
146 %attr(755,root,root) %{_bindir}/apr-1-config
147 %attr(755,root,root) %{_libdir}/libapr-1.so
148 %{_libdir}/libapr-1.la
149 %{_libdir}/apr.exp
150 %{_includedir}
151 %dir %{_datadir}
152 %dir %{_datadir}/build
153 %{_datadir}/build/*.mk
154 %{_datadir}/build/*.m4
155 %{_datadir}/build/*.awk
156 %attr(755,root,root) %{_datadir}/build/config.*
157 %attr(755,root,root) %{_datadir}/build/*.sh
158 %attr(755,root,root) %{_datadir}/build/libtool
159 %attr(755,root,root) %{_datadir}/build/gen-build.py
160 %{_datadir}/build-1
161 %{_pkgconfigdir}/apr-1.pc
162
163 %files static
164 %defattr(644,root,root,755)
165 %{_libdir}/libapr-1.a
This page took 0.060936 seconds and 3 git commands to generate.