]> git.pld-linux.org Git - packages/apache.git/blob - apache.spec
- added ignoring errors on striping (||).
[packages/apache.git] / apache.spec
1 Summary:     HTTP server daemon to provide WWW services
2 Summary(de): Leading World Wide Web-Server
3 Summary(fr): Serveur Web leader du marché
4 Summary(pl): Serwer WWW (World Wide Web)
5 Summary(tr): Lider WWW tarayýcý
6 Name:        apache
7 Version:     1.3.2
8 Release:     1
9 Group:       Networking/Daemons
10 Source0:     ftp://ftp.apache.org/apache/dist/%{name}_%{version}.tar.gz
11 Source1:     httpd.init
12 Source2:     apache.log
13 Patch0:      apache-1.3.2-htdocs.patch
14 Patch1:      apache-1.3.2-suexec.patch
15 Patch2:      apache-1.3b7-perlpath.patch
16 Patch3:      apache-1.3b8-config.patch
17 Patch4:      apache-1.3b8-mimetypes.patch
18 Copyright:   BSD-like
19 Obsoletes:   apache-suexec apache-extra
20 Provides:    httpd
21 Requires:    /etc/mime.types, initscripts >= 3.25
22 Prereq:      /sbin/chkconfig
23 URL:         http://www.apache.org/
24 BuildRoot:   /tmp/%{name}-%{version}-root
25
26 %description
27 Apache is a full featured web server that is freely available, and also
28 happens to be the most widely used.
29
30 %description -l de
31 Apache ist ein voll funktionsfähiger Web-Server, der kostenlos
32 erhältlich und weit verbreitet ist.
33
34 %description -l fr
35 Apache est un serveur Web complet, disponible librement, et se trouve être
36 aussi le plus utilisé à travers le monde.
37
38 %description -l pl
39 Apache jest serwerem WWW (World Wide Web). Instaluj±c ten
40 pakiet bêdziesz móg³ prezentowaæ w³asne strony WWW w sieci internet
41 Apache umozliwia równie¿ konfigurowanie serwerów wirtualnych.
42
43 %description -l tr
44 Apache serbest daðýtýlan ve çok kullanýlan yetenekli bir web sunucusudur.
45
46 %package devel
47 Summary:     Apache include files
48 Summary(pl): Pliki nag³ówkowe do serwera www Apache
49 Group:       Networking/Development
50 Requires:    %{name} = %{version}
51
52 %description devel
53 Apache include files.
54
55 %description -l pl devel
56 Pliki nag³owkowe do serwera www Apache.
57
58 %prep 
59 %setup -q -n apache_%{version}
60
61 %patch0 -p1
62 %patch1 -p1
63 %patch2 -p1
64 %patch3 -p1
65 %patch4 -p1
66
67 %build
68 OPTIM="$RPM_OPT_FLAGS" ./configure --prefix=/usr --sysconfdir=/etc/httpd/conf \
69         --datadir=/home/httpd --libexecdir=/usr/libexec/apache \
70         --localstatedir=/var --runtimedir=/var/run \
71         --logfiledir=/var/log/httpd \
72         --without-confadjust \
73         --enable-module=auth_anon --enable-shared=auth_anon \
74         --enable-module=auth_db --enable-shared=auth_db \
75         --enable-module=digest --enable-shared=digest \
76         --enable-module=expires --enable-shared=expires \
77         --enable-module=headers --enable-shared=headers \
78         --enable-module=mime_magic --enable-shared=mime_magic \
79         --enable-module=mmap_static --enable-shared=mmap_static \
80         --enable-module=proxy --enable-shared=proxy \
81         --proxycachedir=/var/spool/proxy \
82         --enable-module=rewrite --enable-shared=rewrite \
83         --enable-module=speling --enable-shared=speling \
84         --enable-module=status --enable-shared=status \
85         --enable-module=unique_id --enable-shared=unique_id \
86         --enable-module=usertrack --enable-shared=usertrack \
87         --enable-suexec --suexec-caller=nobody \
88         --suexec-uidmin=500 --suexec-gidmin=500
89
90 make
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94 make install-quiet root="$RPM_BUILD_ROOT"
95
96 install -d $RPM_BUILD_ROOT/etc/{httpd/conf,logrotate.d,rc.d/{init,rc{0,1,2,3,4,5,6}}.d}
97 install -d $RPM_BUILD_ROOT/home/httpd/{html/manual,icons,cgi-bin}
98 install -d $RPM_BUILD_ROOT/{usr/{lib/apache,sbin,man/man{1,8}},var/log/httpd}
99
100 install $RPM_SOURCE_DIR/apache.log $RPM_BUILD_ROOT/etc/logrotate.d/apache
101 install $RPM_SOURCE_DIR/httpd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/httpd
102
103 # Only needed for from_cvs tarballs, but doesn't hurt otherwise
104 rm -f $RPM_BUILD_ROOT/home/httpd/html/manual/expand.pl
105
106 strip --strip-debug $RPM_BUILD_ROOT/usr/libexec/apache/*.so || :
107
108 for I in 0 1 2 6; do
109         ln -s ../init.d/httpd $RPM_BUILD_ROOT/etc/rc.d/rc$I.d/K15httpd
110 done
111 for I in 3 5; do
112         ln -s ../init.d/httpd $RPM_BUILD_ROOT/etc/rc.d/rc$I.d/S85httpd
113 done
114
115 touch $RPM_BUILD_ROOT/var/log/httpd/{access,error}_log
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %post
121 /sbin/chkconfig --add httpd
122
123 %preun
124 if [ $1 = 0 ]; then
125    if [ -f /var/lock/subsys/httpd ]; then
126        /etc/rc.d/init.d/httpd stop
127    fi
128    /sbin/chkconfig --del httpd
129 fi
130
131 %files
132 %defattr(644, root, root, 755)
133 %doc ABOUT_APACHE src/CHANGES KEYS LICENSE README
134 %doc src/support/suexec.[ch]
135 %doc /home/httpd/html/manual
136
137 %dir /etc/httpd
138 %dir /etc/httpd/conf
139 %config(noreplace) %verify(not size mtime md5) /etc/httpd/conf/*.conf
140 /etc/httpd/conf/*.conf.default
141 %config(missingok) /etc/rc.d/rc*.d/*
142 %attr(600, root, root) %config /etc/logrotate.d/*
143 %attr(755, root, root) %dir /home/httpd
144 %attr(755, root, root) %dir /home/httpd/html
145 %config(noreplace) /home/httpd/html/index.html
146 /home/httpd/html/apache_pb.gif
147 %attr(755, root, root) /etc/rc.d/init.d/httpd
148 %attr(755, root, root, 755) /home/httpd/cgi-bin
149 %attr(755, root, root, 755) /usr/libexec/apache
150 %dir /home/httpd/icons
151 /home/httpd/icons/*.gif
152 %attr(755, root, root) /usr/bin/*
153 %attr(755, root, root) /usr/sbin/ab
154 %attr(755, root, root) /usr/sbin/apachectl
155 %attr(755, root, root) /usr/sbin/apxs
156 %attr(755, root, root) /usr/sbin/httpd
157 %attr(755, root, root) /usr/sbin/logresolve
158 %attr(755, root, root) /usr/sbin/rotatelogs
159 %attr(4751,root, root) /usr/sbin/suexec
160 %attr(644, root,  man) /usr/man/man[18]/*
161 %attr(700, root, root) %dir /var/log/httpd
162 %ghost /var/log/httpd/*
163
164 %files devel
165 %attr(644, root, root, 755) /usr/include/apache
166
167 %changelog
168 * Fri Sep 25 1998 Konrad Stêpieñ <konrad@interdata.com.pl>
169   [1.3.2-1]
170 - reconfig to use /etc/mime.types (again),
171   orginal mime.types can be found in documentation directory
172 - restore orginal start page,
173 - added "Provides: httpd".
174
175 * Thu Sep  3 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
176   [1.3.1-2]
177 - removed /home/httpd/icons/README
178 - added devel subpackage,
179 - added pl translation (Wojtek ¦lusarczyk <wojtek@shadow.eu.org>),
180 - removed Serial: filed,
181 - removed Packager: field (this must be placed in private ~/.rpmrc),
182 - simplification in %files and %install,
183 - /home/httpd/html/manual is now marked as %doc,
184 - added /etc/rc.d/rc*.d/* symlinks as a %config(missingok),
185 - changed permidssion on logrotate config file to 600,
186 - changed permidssion on /var/log/httpd to 700,
187 - added %ghost /var/log/httpd/*
188 - added striping modules.
189 - added patch to defeat header dos attack
190
191 * Sat Jul 18 1998 Manoj Kasichainula <manojk@io.com>
192   [1.3.1-1]
193 some of the changes from 1.3.0-1 (mine was done independantly, so there are
194 probably other changes)
195 - /etc/rc.d/init.d/httpd includes reload
196 - logrotate doesn't kill all httpd processes, just one. This is recommended.
197 - Doesn't uses Red Hat MIME typesm since RH mime.types doesn't include .htm,
198   and there are other differences which will probably just cause lots of
199   annoying bug reports
200 - Don't change ServerAdmin (this fake address is on purpose according
201   to the Apache Group)
202 - don't enable mod_auth_dbm, since it can supposedly conflict with
203   mod_auth_db
204
205 * Sun May 31 1998 Manoj Kasichainula <manojk@io.com>
206   [1.3b8_dev-1]
207 - Updated to 1.3b8_dev
208 - Deleted some patchwork because of improvements in APACI
209 - Added translations from RH 5.1 Apache RPM
210 - Loosened permissions to match RH 5.1 Apache RPM in /home
211 - Allow index.htm
212 - Collapsed doc package into main package (partly inspired by RPM bug)
213
214 * Fri May 22 1998 Manoj Kasichainula <manojk@io.com>
215   [1.3b7-0]
216 - Upgraded to 1.3b7
217 - Uses APACI configuration interface -- radical rewrite
218 - No more apache-extra, at least for now
219 - more descriptive Copyright field
220 - Now builds suEXEC
221 - Explicitly decided not to use built-in mime.types, but included patch to do
222   so
223
224 * Thu Apr 16 1998 Manoj Kasichainula <manojk@io.com>
225   [1.3b6-4]
226 - Upgraded to 1.3b6
227 - Split perl path patch from other config (saves a little time when upgrading
228   packages)
229 - Started the process of separating out shared modules. So far, only the proxy
230   module has been done.
231 - Yeah, I'm aware of 1.3b6-3 RPM in contrib. It has problems that I would
232   discuss with the packager if I could find out who that was.
233
234 * Thu Mar 5 1998 Manoj Kasichainula <manojk@io.com>
235
236 - Upgraded to 1.3b5
237 - Buildable by non-root
238
239 * Fri Jan 2 1998 Manoj Kasichainula <manojk@io.com>
240
241 - Includes changes from Red Hat 5.0's Apache release
242   - added patch for backslash DoS attach
243   - made the default index.html be config(noreplace) so we no longer
244     blow away other folks' index.html
245   - added chkconfig support
246   - added restart|status options to initscript
247   - renamed httpd.init to httpd
248   - New index.html
249   - Now uses Red Hat's mime.types file (I may change my mind on this)
250   - No longer keeps an agent and referer log.
251   - Much more
252 - Upgraded to 1.3b3
253 - Fixed sillyness in /etc/rc.d/init.d/httpd
254 - Now require recent version of initscripts with killproc fix.
255 - Changed logrotate script
256 - Undid Red Hat's ServerAdmin change (Red Hat's choice results in a
257   seemingly valid but nonsensical address)
258 - suexec moved to /home/httpd/sbin/suexec
259 - Replaced a reference to apache_pb.gif to /icons/apache_pb.gif, to save a
260   bit of space)
261
262 * Thu Oct 16 1997 Manoj Kasichainula <manojk@io.com>
263 - Upgraded to 1.3b2
264 - MaxRequestsPerChild upped to 10000
265 - apache-suexec absorbed into apache
266 - Uncommented Serial: line. Now, it requires a recent version of RPM
This page took 0.046744 seconds and 4 git commands to generate.