]> git.pld-linux.org Git - packages/apache.git/blob - apache.spec
- fixed files permission,
[packages/apache.git] / apache.spec
1 Summary:        HTTP server daemon to provide WWW services
2 Name:           apache
3 Version:        1.3.4
4 Release:        3d
5 Group:          Networking/Daemons
6 Group(pl):      Sieci/Demony
7 Source0:        ftp://ftp.apache.org/apache/dist/%{name}_%{version}.tar.gz
8 Source1:        httpd.init
9 Source2:        %{name}.log
10 Source3:        %{name}-config.tar.gz
11 Source4:        httpd.conf
12 ########        http://www.eos.ncsu.edu/apache
13 Source5:        mod_auth_kerb-3.6.tar.gz
14 Patch0:         %{name}-1.3.2-suexec.patch
15 Patch1:         %{name}-ndbm.patch
16 Copyright:      BSD-like
17 Obsoletes:      apache-extra
18 Obsoletes:      apache6
19 Provides:       httpd
20 Prereq:         /sbin/chkconfig
21 URL:            http://www.apache.org/
22 BuildRoot:      /tmp/%{name}-%{version}-root
23 Summary(de):    Leading World Wide Web-Server
24 Summary(fr):    Serveur Web leader du marché
25 Summary(pl):    Serwer WWW (World Wide Web)
26 Summary(tr):    Lider WWW tarayýcý
27
28 %description
29 Apache is a full featured web server that is freely available, and also
30 happens to be the most widely used.
31
32 %description -l de
33 Apache ist ein voll funktionsfähiger Web-Server, der kostenlos
34 erhältlich und weit verbreitet ist.
35
36 %description -l fr
37 Apache est un serveur Web complet, disponible librement, et se trouve être
38 aussi le plus utilisé à travers le monde.
39
40 %description -l pl
41 Apache jest serwerem WWW (World Wide Web). Instaluj±c ten pakiet bêdziesz 
42 móg³ prezentowaæ w³asne strony WWW w sieci internet. Apache umo¿liwia równie¿
43 konfigurowanie serwerów wirtualnych.
44
45 %description -l tr
46 Apache serbest daðýtýlan ve çok kullanýlan yetenekli bir web sunucusudur.
47
48 %package suexec
49 Summary:        Apache suexec wrapper
50 Group:          Networking/Development
51 Group(pl):      Sieci/Programowanie
52 Requires:       %{name} = %{version}
53 Summary(pl):    Suexec wrapper do serwera www Apache
54
55 %description suexec
56 The suEXEC feature provides Apache users the ability to run CGI and SSI
57 programs under user IDs different from the user ID of the calling web-server.
58 Normally, when a CGI or SSI program executes, it runs as the same user 
59 who is running the web server. 
60
61 %description -l pl suexec
62 SuEXEC umo¿liwia serwerowi Apache uruchamianie programów CGI i SSI z innym
63 UID ni¿ wywo³uj±cy je serwer. Normalnie programy CGI i SSI s± wykonywane
64 jako taki sam u¿ytkownik jak serwer WWW.
65
66 %package devel
67 Summary:        Apache include files
68 Group:          Networking/Development
69 Group(pl):      Sieci/Programowanie
70 Requires:       %{name} = %{version}
71 Summary(pl):    Pliki nag³ówkowe do serwera www Apache
72
73 %description devel
74 Apache include files.
75
76 %description -l pl devel
77 Pliki nag³ówkowe do serwera www Apache.
78
79 %package doc
80 Summary:        Apache dokumentation
81 Group:          Documentation
82 Group(pl):      Dokumentacja
83 Requires:       %{name} = %{version}
84 URL:            http://www.apache.org/
85 Summary(pl):    Dokumentacja do Apache
86
87 %description doc
88 Documentation for apache in HTML format.
89
90 %description -l pl doc
91 Dokumentacja do Apache w formacie HTML
92
93 %prep 
94 %setup -q -n apache_%{version}
95 %patch0 -p1
96 %patch1 -p1
97
98 %build
99 OPTIM=$RPM_OPT_FLAGS \
100     ./configure \
101         --prefix=/usr \
102         --sysconfdir=/etc/httpd/conf \
103         --datadir=/home/httpd \
104         --libexecdir=/usr/libexec/apache \
105         --localstatedir=/var \
106         --runtimedir=/var/run \
107         --logfiledir=/var/log/httpd \
108         --without-confadjust \
109         --enable-module=all \
110         --enable-shared=max \
111         --disable-module=auth_db \
112         --proxycachedir=/var/spool/proxy \
113         --with-perl=/usr/bin/perl \
114         --enable-suexec \
115         --suexec-caller=http \
116         --suexec-uidmin=500 \
117         --suexec-gidmin=500 \
118         --sbindir=/usr/sbin \
119         --includedir=/usr/include/apache
120
121 make
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125 make install-quiet root="$RPM_BUILD_ROOT"
126
127 mv $RPM_BUILD_ROOT/home/httpd/htdocs $RPM_BUILD_ROOT/home/httpd/html
128
129 install -d $RPM_BUILD_ROOT/etc/{httpd/conf,logrotate.d,rc.d/init.d}
130 install -d $RPM_BUILD_ROOT/home/httpd/{html/manual,icons,cgi-bin}
131 install -d $RPM_BUILD_ROOT/{usr/{lib/apache,sbin,man/man{1,8}},var/log/httpd}
132
133 install %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/apache
134 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/httpd
135
136 install -d $RPM_BUILD_ROOT/usr/include/apache
137
138 tar zxf %{SOURCE3} -C $RPM_BUILD_ROOT/etc/httpd/conf
139
140 rm -f $RPM_BUILD_ROOT/etc/httpd/conf/httpd.conf
141 install %{SOURCE4} $RPM_BUILD_ROOT/etc/httpd/conf
142
143 rm -f $RPM_BUILD_ROOT/home/httpd/html/manual/expand.pl
144
145 touch $RPM_BUILD_ROOT/var/log/httpd/{access,error}_log
146  
147 bzip2 -9 $RPM_BUILD_ROOT/usr/man/{man1/*,man8/*}
148 bzip2 -9 ABOUT_APACHE src/CHANGES KEYS README
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %post
154 /sbin/chkconfig --add httpd
155
156 %preun
157 if [ $1 = 0 ]; then
158    if [ -f /var/lock/subsys/httpd ]; then
159        /etc/rc.d/init.d/httpd stop
160    fi
161    /sbin/chkconfig --del httpd
162 fi
163
164 %files
165 %defattr(644,root,root,755)
166 %doc ABOUT_APACHE.bz2 src/CHANGES.bz2 KEYS.bz2 README.bz2
167 %doc conf/mime.types
168
169 %attr(750,root,root) %dir /etc/httpd
170 %attr(750,root,root) %dir /etc/httpd/conf
171 %attr(640,root,root) %config %verify(not size mtime md5) /etc/httpd/conf/*
172
173 %attr(640,root,root) %config /etc/logrotate.d/*
174 %attr(755,root,root) %dir /home/httpd/html
175
176 %config(noreplace) /home/httpd/html/index.html
177
178 %attr(644,root,root) /home/httpd/html/*.gif
179 %attr(700,root,root) %config %verify(not size mtime md5) /etc/rc.d/init.d/*
180
181 %attr(755,root,root,755) /home/httpd/cgi-bin
182 %attr(755,root,root,755) /usr/libexec/apache
183 %attr(755,root,root,755) %dir /home/httpd/icons
184
185 %attr(644,root,root) /home/httpd/icons/*.gif
186
187 %attr(755,root,root) /usr/bin/dbmmanage 
188 %attr(755,root,root) /usr/bin/htdigest
189 %attr(755,root,root) /usr/bin/htpasswd
190
191 %attr(755,root,root) /usr/sbin/ab
192 %attr(755,root,root) /usr/sbin/apachectl
193 %attr(755,root,root) /usr/sbin/apxs
194 %attr(755,root,root) /usr/sbin/httpd
195 %attr(755,root,root) /usr/sbin/logresolve
196 %attr(755,root,root) /usr/sbin/rotatelogs
197
198 %attr(644,root, man) /usr/man/man[18]/*
199
200 %attr(750,root,root) %dir /var/log/httpd
201 %attr(640,root,root) %config %verify(not size mtime md5) /var/log/httpd/*
202
203 %files suexec
204 %attr(4711,root,root) /usr/sbin/suexec
205
206 %files devel
207 %defattr(644,root,root,755) 
208
209 %dir /usr/include/apache
210 /usr/include/apache/*
211
212 %files doc
213 %defattr(644,root,root,755)
214 /home/httpd/html/manual
215
216 %changelog
217 * Thu Jan 21 1999 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
218   [1.3.4-3d]
219 - fixed files permission,
220 - fixed apache.init,
221 - some other changes.
222
223 * Sun Jan 17 1999 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
224   [1.3.4-2d]
225 - fixed sbindir && apache includes (by Mirek Nowakowski <nowam@pg.gda.pl>),
226 - compressed documentation,
227 - fixed Group(pl).
228
229 * Wed Nov 13 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
230   [1.3.3-1]
231 - removed making symlinks in /etc/rc.d/rc?.d and in %install also
232   removed this symlinks from %files (/etc/rc.d/init.d/httpd suports
233   chkconfig),
234 - more simplifications in %install,
235 - added new apache-config.patch,
236 - added "%ghost /var/log/httpd/suexec_log" for suexec subpackage,
237 - added "Requires: setup >= 1.10.0" for proper install in enviroment with
238   http user/group.
239
240 * Wed Oct 14 1998 Konrad Stêpieñ <konrad@interdata.com.pl>
241   [1.3.3-1d]
242 - up to 1.3.3
243 - changed user/group to http
244 - added patch against GNU libc-2.1, 
245   prepared by Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
246 - enabled all modules (without auth_db ....)
247 - added magic (for mod_mime_magic)
248 - rebuild spec file to minimize number of patches
249 - suEXEC in separated package
250
251 * Wed Oct 14 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
252   [1.3.2-1d]
253 - build against Tornado (GNU libc-2.1),
254 - minor changes. 
255
256 * Fri Sep 25 1998 Konrad Stêpieñ <konrad@interdata.com.pl>
257   [1.3.2-1]
258 - up to 1.3.2
259 - reconfig to use /etc/mime.types (again)
260   orginal mime.types can be found in documentation directory
261 - changed to user/group httpd
262 - restore orginal start page
263 - documentation in separate package
264 - added "Provides:httpd"
265
266 * Thu Sep  3 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
267   [1.3.1-2]
268 - removed /home/httpd/icons/README
269 - added devel subpackage,
270 - added pl translation (Wojtek ¦lusarczyk <wojtek@shadow.eu.org>),
271 - removed Serial: filed,
272 - removed Packager: field (this must be placed in private ~/.rpmrc),
273 - simplification in %files and %install,
274 - /home/httpd/html/manual is now marked as %doc,
275 - added /etc/rc.d/rc*.d/* symlinks as a %config(missingok),
276 - changed permidssion on logrotate config file to 600,
277 - changed permidssion on /var/log/httpd to 700,
278 - added %ghost /var/log/httpd/*
279 - added striping modules.
280 - added patch to defeat header dos attack
281
282 * Sat Jul 18 1998 Manoj Kasichainula <manojk@io.com>
283   [1.3.1-1]
284   some of the changes from 1.3.0-1 (mine was done independantly, so there are
285   probably other changes)
286 - /etc/rc.d/init.d/httpd includes reload
287 - logrotate doesn't kill all httpd processes, just one. This is recommended.
288 - Doesn't uses Red Hat MIME typesm since RH mime.types doesn't include .htm,
289   and there are other differences which will probably just cause lots of
290   annoying bug reports
291 - Don't change ServerAdmin (this fake address is on purpose according
292   to the Apache Group)
293 - don't enable mod_auth_dbm, since it can supposedly conflict with
294   mod_auth_db
295
296 * Sun May 31 1998 Manoj Kasichainula <manojk@io.com>
297   [1.3b8_dev-1]
298 - Updated to 1.3b8_dev
299 - Deleted some patchwork because of improvements in APACI
300 - Added translations from RH 5.1 Apache RPM
301 - Loosened permissions to match RH 5.1 Apache RPM in /home
302 - Allow index.htm
303 - Collapsed doc package into main package (partly inspired by RPM bug)
304
305 * Fri May 22 1998 Manoj Kasichainula <manojk@io.com>
306   [1.3b7-0]
307 - Upgraded to 1.3b7
308 - Uses APACI configuration interface -- radical rewrite
309 - No more apache-extra, at least for now
310 - more descriptive Copyright field
311 - Now builds suEXEC
312 - Explicitly decided not to use built-in mime.types, but included patch to do
313   so
314
315 * Thu Apr 16 1998 Manoj Kasichainula <manojk@io.com>
316   [1.3b6-4]
317 - Upgraded to 1.3b6
318 - Split perl path patch from other config (saves a little time when upgrading
319   packages)
320 - Started the process of separating out shared modules. So far, only the proxy
321   module has been done.
322 - Yeah, I'm aware of 1.3b6-3 RPM in contrib. It has problems that I would
323   discuss with the packager if I could find out who that was.
324
325 * Thu Mar 5 1998 Manoj Kasichainula <manojk@io.com>
326
327 - Upgraded to 1.3b5
328 - Buildable by non-root
329
330 * Fri Jan 2 1998 Manoj Kasichainula <manojk@io.com>
331
332 - Includes changes from Red Hat 5.0's Apache release
333   - added patch for backslash DoS attach
334   - made the default index.html be config(noreplace) so we no longer
335     blow away other folks' index.html
336   - added chkconfig support
337   - added restart|status options to initscript
338   - renamed httpd.init to httpd
339   - New index.html
340   - Now uses Red Hat's mime.types file (I may change my mind on this)
341   - No longer keeps an agent and referer log.
342   - Much more
343 - Upgraded to 1.3b3
344 - Fixed sillyness in /etc/rc.d/init.d/httpd
345 - Now require recent version of initscripts with killproc fix.
346 - Changed logrotate script
347 - Undid Red Hat's ServerAdmin change (Red Hat's choice results in a
348   seemingly valid but nonsensical address)
349 - suexec moved to /home/httpd/sbin/suexec
350 - Replaced a reference to apache_pb.gif to /icons/apache_pb.gif, to save a
351   bit of space)
352
353 * Thu Oct 16 1997 Manoj Kasichainula <manojk@io.com>
354 - Upgraded to 1.3b2
355 - MaxRequestsPerChild upped to 10000
356 - apache-suexec absorbed into apache
357 - Uncommented Serial: line. Now, it requires a recent version of RPM
This page took 0.061823 seconds and 4 git commands to generate.