]> git.pld-linux.org Git - packages/apache-mod_wsgi.git/blob - apache-mod_wsgi.spec
- updated to 2.5
[packages/apache-mod_wsgi.git] / apache-mod_wsgi.spec
1 %define         mod_name        wsgi
2 %define         apxs            /usr/sbin/apxs
3 Summary:        WSGI interface for the Apache Web server
4 Summary(pl.UTF-8):      Interfejs WSGI dla serwera WWW Apache
5 Name:           apache-mod_%{mod_name}
6 Version:        2.5
7 Release:        1
8 License:        Apache
9 Group:          Networking/Daemons
10 Source0:        http://modwsgi.googlecode.com/files/mod_%{mod_name}-%{version}.tar.gz
11 # Source0-md5:  43ad11c477799e2f780c50197c420afd
12 Source1:        %{name}.conf
13 Patch0:         %{name}-apache-version.patch
14 URL:            http://code.google.com/p/modwsgi/
15 BuildRequires:  %{apxs}
16 BuildRequires:  apache-devel >= 2.0.52-7
17 BuildRequires:  apr-devel >= 1:1.0.0
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  python-devel >= 2.3
21 BuildRequires:  rpmbuild(macros) >= 1.268
22 Requires:       apache(modules-api) = %apache_modules_api
23 Requires:       apr >= 1:1.0.0
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
27 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
28
29 %description
30 The mod_wsgi adapter is an Apache module that provides a WSGI
31 compliant interface for hosting Python based web applications within
32 Apache. The adapter is written completely in C code against the Apache
33 C runtime and for hosting WSGI applications within Apache has a lower
34 overhead than using existing WSGI adapters for mod_python or CGI.
35
36 %description -l pl.UTF-8
37 Adapter mod_wsgi jest modułem udostępniającym interfejs WSGI dla
38 aplikacji WWW napisanych w języku Python i osadzonych w serwerze
39 Apache. Adapter jest w całości napisany w języku C w oparciu o
40 bibliotekę uruchomieniową Apache i ma mniejsze wymagania niż w
41 przypadku używania istniejących adapterów WSGI dla modułu mod_python
42 lub CGI.
43
44 %prep
45 %setup -q -n mod_%{mod_name}-%{version}
46 %patch0 -p1
47
48 %build
49 %{__aclocal}
50 %{__autoconf}
51 HTTPD_VERSION=$(rpm -q --qf '%{V}' apache-devel); export HTTPD_VERSION
52 %configure \
53         --with-apxs=%{apxs}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 install -d $RPM_BUILD_ROOT{%{apachelibdir},%{apacheconfdir}}
58
59 %{__make} install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/61_mod_wsgi.conf
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %post
68 %service -q httpd restart
69
70 %postun
71 if [ "$1" = "0" ]; then
72         %service -q httpd restart
73 fi
74
75 %files
76 %defattr(644,root,root,755)
77 %doc README
78 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_%{mod_name}.conf
79 %attr(755,root,root) %{apachelibdir}/*.so
This page took 0.050957 seconds and 3 git commands to generate.