]> git.pld-linux.org Git - packages/apache-mod_spdy.git/blob - apache-mod_spdy.spec
new, version 0.9.3.3
[packages/apache-mod_spdy.git] / apache-mod_spdy.spec
1 %define         mod_name        spdy
2 %define         apxs            %{_sbindir}/apxs
3 Summary:        Apache 2 module to enable SPDY support
4 Name:           apache-mod_%{mod_name}
5 Version:        0.9.3.3
6 Release:        0.1
7 License:        Apache v2.0
8 Group:          Daemons
9 Source0:        mod-spdy-%{version}.tar.xz
10 # Source0-md5:  35770e4855b2953440be5a56d9da3fa4
11 Source1:        get-source.sh
12 Source2:        gclient.conf
13 Patch0:         gyp.patch
14 Patch1:         log-constants.patch
15 URL:            http://code.google.com/p/mod-spdy/
16 BuildRequires:  %{apxs}
17 BuildRequires:  apache-devel >= 2.2
18 BuildRequires:  tar >= 1:1.22
19 BuildRequires:  xz
20 Requires:       apache(modules-api) = %apache_modules_api
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
24 %define         _pkgrootdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
25 %define         _sysconfdir     %{_pkgrootdir}/conf.d
26
27 %description
28 mod_spdy is an Apache module that allows an Apache server to support
29 the SPDY protocol for serving HTTP resources.
30
31 %prep
32 %setup -q -n mod-spdy-%{version}
33 %patch0 -p1
34 %patch1 -p1
35
36 %build
37 CC="%{__cc}" \
38 CXX="%{__cxx}" \
39 %{__python} build/gyp_chromium \
40         --format=make \
41         --depth=. \
42         build/all.gyp \
43         -Duse_openssl=1 \
44         -Duse_system_apache_dev=1 \
45         -Duse_system_libjpeg=1 \
46         -Duse_system_libpng=1 \
47         -Duse_system_opencv=1 \
48         -Duse_system_zlib=1 \
49         -Dsystem_include_path_apr=%{_includedir}/apr \
50         -Dsystem_include_path_aprutil=%{_includedir}/apr-util \
51         -Dsystem_include_path_httpd=%{_includedir}/apache \
52         %{nil}
53
54 %{__make} mod_spdy \
55         BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
56         %{?with_verbose:V=1} \
57         CC="%{__cc}" \
58         CXX="%{__cxx}" \
59         CC.host="%{__cc}" \
60         CXX.host="%{__cxx}" \
61         LINK.host="%{__cxx}" \
62         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
63         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
64         %{nil}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
69
70 out=out/%{!?debug:Release}%{?debug:Debug}
71 install -p $out/libmod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}/mod_%{mod_name}.so
72
73 cat > $RPM_BUILD_ROOT%{_sysconfdir}/90_mod_%{mod_name}.conf <<EOF
74 LoadModule %{mod_name}_module   modules/mod_%{mod_name}.so
75 EOF
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post
81 %service -q httpd restart
82
83 %postun
84 if [ "$1" = "0" ]; then
85         %service -q httpd restart
86 fi
87
88 %files
89 %defattr(644,root,root,755)
90 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
91 %attr(755,root,root) %{_pkglibdir}/mod_%{mod_name}.so
This page took 0.062678 seconds and 3 git commands to generate.