]> git.pld-linux.org Git - packages/anjuta.git/blob - anjuta.spec
- fix in %istall.
[packages/anjuta.git] / anjuta.spec
1 Summary:        Gnome integrated development environment
2 Summary(pl):    Zintegrowane ¶rodowisko programowania dla Gnome
3 Summary(pt_BR): Ambiente de desenvolvimento integrado C e C++
4 Name:           anjuta
5 Version:        0.1.9
6 Release:        9
7 License:        GPL
8 Group:          Development/Tools
9 Source0:        http://anjuta.sourceforge.net/packages/%{name}-%{version}.tar.gz
10 Patch0:         %{name}-ac_am.patch
11 Patch1:         %{name}-no_systemtags.patch
12 Patch2:         %{name}-omf.patch
13 Patch3:         %{name}-module_no_version.patch
14 Patch4:         %{name}-use_AM_CXXFLAGS.patch
15 Patch5:         %{name}-desktop_fix.patch
16 URL:            http://anjuta.sourceforge.net/
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  bonobo-devel
20 BuildRequires:  gettext-devel
21 BuildRequires:  gnome-vfs-devel
22 BuildRequires:  gtk+-devel >= 1.2.0
23 BuildRequires:  intltool
24 BuildRequires:  libtool
25 BuildRequires:  libxml-devel
26 BuildRequires:  pkgconfig
27 BuildRequires:  scrollkeeper
28 BuildRequires:  gnomemm-devel
29 Requires:       gnome-libs-devel
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         _prefix         /usr/X11R6
33 %define         _mandir         %{_prefix}/man
34 %define         _omf_dest_dir   %(scrollkeeper-config --omfdir)
35
36 %description
37 Anjuta is a very versatile integrated development environment for C
38 and C++ GNU/Linux. Written in GTK/Gnome and written for GTK/Gnome, it
39 features many advanced programming tools and utilities. Besides many
40 other, it has project management, application wizards, onboard
41 interactive debugger, and a powerful source editor with source
42 browsing.
43
44 %description -l pl
45 Anjuta to wszechstronne zintegrowane ¶rodowisko programowania dla
46 jêzyka C oraz C++. Zosta³o napisane z wykorzystaniem tandemu
47 GTK/Gnome, w³a¶nie po to by go w takim otoczeniu u¿ywaæ. Miêdzy innymi
48 posiada zarz±dcê projektów, kreator aplikacji, wbudowany interaktywny
49 odpluskwiacz oraz edytor z mo¿liwo¶ci± przegl±dania ¼róde³.
50
51 %description -l pt_BR
52 O Anjuta é um ambiente de desenvolvimento integrado (IDE) versátil
53 para as linguagens C e C++. Foi escrito para o GTK/GNOME e tem uma
54 série de características de programação avançadas. Basicamente é uma
55 interface gráfica com o usuário para um conjunto de utilitários de
56 linha de comando e ferramentas para programação para o Linux. Estas
57 são geralmente executadas em um console em modo texto e podem ser não
58 amigáveis.
59
60 %prep
61 %setup  -q
62 %patch0 -p1
63 %patch1 -p1
64 %patch2 -p1
65 %patch3 -p1
66 %patch4 -p1
67 %patch5 -p1
68
69 %build
70 rm -f missing
71 %{__libtoolize}
72 %{__gettextize}
73 xml-i18n-toolize --copy --force
74 %{__aclocal} -I macros
75 %{__autoconf}
76 %{__automake}
77 echo "all install:">plugins/sample1/Makefile.in
78 CXXFLAGS="%{rpmcflags} -fno-exceptions"
79 %configure \
80         --with-gnome \
81         --disable-static
82 %{__make}
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86
87 %{__make} install \
88         DESTDIR=$RPM_BUILD_ROOT \
89         omf_dest_dir=%{_omf_dest_dir}/%{name} \
90         gnomemenudir=%{_applnkdir}/Development
91
92 %find_lang %{name} --with-gnome
93
94 %post   -p /usr/bin/scrollkeeper-update
95 %postun -p /usr/bin/scrollkeeper-update
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %files -f %{name}.lang
101 %defattr(644,root,root,755)
102 %doc README ChangeLog NEWS TODO
103 %attr(755,root,root) %{_bindir}/*
104 %dir %{_libdir}/anjuta
105 %attr(755,root,root) %{_libdir}/anjuta/lib*.so
106 %{_omf_dest_dir}/%{name}
107 %{_datadir}/anjuta
108 %{_applnkdir}/Development/*
109 %{_pixmapsdir}/*
This page took 0.063861 seconds and 4 git commands to generate.