]> git.pld-linux.org Git - packages/anjuta.git/blob - anjuta.spec
- start work on gtk+2 version (nfy, dncy)
[packages/anjuta.git] / anjuta.spec
1 %define snap 2002-10-24-15
2 Summary:        Gnome integrated development environment
3 Summary(pl):    Zintegrowane ¶rodowisko programowania dla Gnome
4 Summary(pt_BR): Ambiente de desenvolvimento integrado C e C++
5 Name:           anjuta
6 Version:        1.0.
7 Release:        0.%(echo %{snap} | sed 's/-//g').1
8 License:        GPL
9 Group:          Development/Tools
10 Source0:        http://anjuta.sourceforge.net/cvs/anjuta-cvs-HEAD-hourly-%{snap}.tar.gz
11 Patch0:         %{name}-ac_am.patch
12 Patch1:         %{name}-no_systemtags.patch
13 Patch2:         %{name}-omf.patch
14 Patch3:         %{name}-module_no_version.patch
15 Patch4:         %{name}-use_AM_CXXFLAGS.patch
16 Patch5:         %{name}-desktop_fix.patch
17 URL:            http://anjuta.sourceforge.net/
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  intltool
21 BuildRequires:  libtool
22 BuildRequires:  pkgconfig
23 BuildRequires:  scrollkeeper
24 BuildRequires:  libgnomeui-devel >= 2.0.5
25 BuildRequires:  libgnomeprintui-devel >= 1.116.0
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _prefix         /usr/X11R6
29 %define         _mandir         %{_prefix}/man
30
31 %description
32 Anjuta is a very versatile integrated development environment for C
33 and C++ GNU/Linux. Written in GTK/Gnome and written for GTK/Gnome, it
34 features many advanced programming tools and utilities. Besides many
35 other, it has project management, application wizards, onboard
36 interactive debugger, and a powerful source editor with source
37 browsing.
38
39 %description -l pl
40 Anjuta to wszechstronne zintegrowane ¶rodowisko programowania dla
41 jêzyka C oraz C++. Zosta³o napisane z wykorzystaniem tandemu
42 GTK/Gnome, w³a¶nie po to by go w takim otoczeniu u¿ywaæ. Miêdzy innymi
43 posiada zarz±dcê projektów, kreator aplikacji, wbudowany interaktywny
44 odpluskwiacz oraz edytor z mo¿liwo¶ci± przegl±dania ¼róde³.
45
46 %description -l pt_BR
47 O Anjuta é um ambiente de desenvolvimento integrado (IDE) versátil
48 para as linguagens C e C++. Foi escrito para o GTK/GNOME e tem uma
49 série de características de programação avançadas. Basicamente é uma
50 interface gráfica com o usuário para um conjunto de utilitários de
51 linha de comando e ferramentas para programação para o Linux. Estas
52 são geralmente executadas em um console em modo texto e podem ser não
53 amigáveis.
54
55 %prep
56 %setup -q -n %{name}
57
58 %build
59 CXXFLAGS="%{rpmcflags} -fno-exceptions"
60 rm -f missing
61 glib-gettextize
62 intltoolize
63 %{__libtoolize}
64 %{__aclocal}
65 %{__autoheader}
66 %{__autoconf}
67 %{__automake}
68 %configure \
69         --with-gnome \
70         --disable-static
71 %{__make}
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75
76 %{__make} install \
77         DESTDIR=$RPM_BUILD_ROOT \
78         gnomemenudir=%{_applnkdir}/Development
79
80 %find_lang %{name} --with-gnome
81
82 %post   -p /usr/bin/scrollkeeper-update
83 %postun -p /usr/bin/scrollkeeper-update
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %files -f %{name}.lang
89 %defattr(644,root,root,755)
90 %doc README ChangeLog NEWS TODO
91 %attr(755,root,root) %{_bindir}/*
92 %dir %{_libdir}/anjuta
93 %attr(755,root,root) %{_libdir}/anjuta/lib*.so
94 %{_omf_dest_dir}/%{name}
95 %{_datadir}/anjuta
96 %{_applnkdir}/Development/*
97 %{_pixmapsdir}/*
This page took 0.079276 seconds and 4 git commands to generate.