]> git.pld-linux.org Git - packages/anjuta.git/blob - anjuta.spec
- updated to 20030412 snap
[packages/anjuta.git] / anjuta.spec
1 %define         snap    20030412
2
3 Summary:        Gnome integrated development environment
4 Summary(pl):    Zintegrowane ¶rodowisko programowania dla Gnome
5 Summary(pt_BR): Ambiente de desenvolvimento integrado C e C++
6 Name:           anjuta
7 Version:        1.2.0
8 Release:        0.%{snap}.1
9 License:        GPL
10 Group:          Development/Tools
11 #Source0:       http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
12 Source0:        %{name}-%{version}-%{snap}.tar.bz2
13 Patch0:         %{name}-am.patch
14 Patch1:         %{name}-gettext.patch
15 URL:            http://anjuta.sourceforge.net/
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  glib2-devel >= 2.0.6
19 BuildRequires:  intltool
20 BuildRequires:  gnome-common
21 BuildRequires:  libglade2-devel >= 2.0.0
22 BuildRequires:  libgnomeprintui-devel >= 2.2.0
23 BuildRequires:  libgnomeui-devel >= 2.2.0
24 BuildRequires:  libtool
25 BuildRequires:  libzvt-devel >= 2.0.0
26 BuildRequires:  ncurses-devel
27 BuildRequires:  pcre-devel
28 BuildRequires:  pkgconfig
29 BuildRequires:  vte-devel >= 0.9.0
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Anjuta is a very versatile integrated development environment for C
34 and C++ GNU/Linux. Written in GTK/Gnome and written for GTK/Gnome, it
35 features many advanced programming tools and utilities. Besides many
36 other, it has project management, application wizards, onboard
37 interactive debugger, and a powerful source editor with source
38 browsing.
39
40 %description -l pl
41 Anjuta to wszechstronne zintegrowane ¶rodowisko programowania dla
42 jêzyka C oraz C++. Zosta³o napisane z wykorzystaniem tandemu
43 GTK/Gnome, w³a¶nie po to by go w takim otoczeniu u¿ywaæ. Miêdzy innymi
44 posiada zarz±dcê projektów, kreator aplikacji, wbudowany interaktywny
45 odpluskwiacz oraz edytor z mo¿liwo¶ci± przegl±dania ¼róde³.
46
47 %description -l pt_BR
48 O Anjuta é um ambiente de desenvolvimento integrado (IDE) versátil
49 para as linguagens C e C++. Foi escrito para o GTK/GNOME e tem uma
50 série de características de programação avançadas. Basicamente é uma
51 interface gráfica com o usuário para um conjunto de utilitários de
52 linha de comando e ferramentas para programação para o Linux. Estas
53 são geralmente executadas em um console em modo texto e podem ser não
54 amigáveis.
55
56 %prep
57 %setup -q
58 %patch0 -p1
59 %patch1 -p0
60
61 %build
62 CXXFLAGS="%{rpmcflags} -fno-exceptions"
63 #rm -f missing
64 #%%{__gettextize}
65 #intltoolize
66 #%%{__libtoolize}
67 #%%{__aclocal} -I /usr/share/aclocal/gnome2-macros
68 #%%{__autoheader}
69 #%%{__autoconf}
70 #%%{__automake}
71 ./autogen.sh
72 %configure \
73         --disable-static
74 %{__make}
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78
79 %{__make} install \
80         DESTDIR=$RPM_BUILD_ROOT \
81         gnomemenudir=%{_datadir}/applications
82
83 %find_lang %{name} --with-gnome
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %files -f %{name}.lang
89 %defattr(644,root,root,755)
90 %doc README ChangeLog NEWS TODO AUTHORS COPYING 
91 %doc FUTURE INSTALL doc/ScintillaDoc.html
92 %attr(755,root,root) %{_bindir}/*
93 %dir %{_libdir}/anjuta
94 %attr(755,root,root) %{_libdir}/anjuta/lib*.so*
95 %{_libdir}/anjuta/lib*.la
96 %{_pixmapsdir}/anjuta
97 %{_datadir}/anjuta
98 %{_datadir}/applications/*
99 %{_datadir}/mime-info/*
100 %{_datadir}/mimelnk/application/*
101 %{_mandir}/man1/*
This page took 0.036952 seconds and 4 git commands to generate.