]> git.pld-linux.org Git - packages/anjuta.git/blob - anjuta.spec
- correctly commented out macros
[packages/anjuta.git] / anjuta.spec
1 %define         snap    20030307
2
3 Summary:        Gnome integrated development environment
4 Summary(pl):    Zintegrowane ¶rodowisko programowania dla Gnome
5 Summary(pt_BR): Ambiente de desenvolvimento integrado C e C++
6 Name:           anjuta
7 Version:        1.2.0
8 Release:        0.%{snap}
9 License:        GPL
10 Group:          Development/Tools
11 #Source0:       http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
12 Source0:        %{name}-%{version}-%{snap}.tar.bz2
13 Patch0:         %{name}-am.patch
14 URL:            http://anjuta.sourceforge.net/
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  intltool
18 BuildRequires:  libtool
19 BuildRequires:  pkgconfig
20 BuildRequires:  libglade2-devel
21 BuildRequires:  libgnomeprintui-devel >= 2.2.0
22 BuildRequires:  libgnomeui-devel >= 2.2.0
23 BuildRequires:  vte-devel
24 BuildRequires:  libzvt-devel
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27
28 %description
29 Anjuta is a very versatile integrated development environment for C
30 and C++ GNU/Linux. Written in GTK/Gnome and written for GTK/Gnome, it
31 features many advanced programming tools and utilities. Besides many
32 other, it has project management, application wizards, onboard
33 interactive debugger, and a powerful source editor with source
34 browsing.
35
36 %description -l pl
37 Anjuta to wszechstronne zintegrowane ¶rodowisko programowania dla
38 jêzyka C oraz C++. Zosta³o napisane z wykorzystaniem tandemu
39 GTK/Gnome, w³a¶nie po to by go w takim otoczeniu u¿ywaæ. Miêdzy innymi
40 posiada zarz±dcê projektów, kreator aplikacji, wbudowany interaktywny
41 odpluskwiacz oraz edytor z mo¿liwo¶ci± przegl±dania ¼róde³.
42
43 %description -l pt_BR
44 O Anjuta é um ambiente de desenvolvimento integrado (IDE) versátil
45 para as linguagens C e C++. Foi escrito para o GTK/GNOME e tem uma
46 série de características de programação avançadas. Basicamente é uma
47 interface gráfica com o usuário para um conjunto de utilitários de
48 linha de comando e ferramentas para programação para o Linux. Estas
49 são geralmente executadas em um console em modo texto e podem ser não
50 amigáveis.
51
52 %prep
53 %setup -q -n %{name}
54 %patch0 -p1
55
56 %build
57 CXXFLAGS="%{rpmcflags} -fno-exceptions"
58 #rm -f missing
59 #%%{__gettextize}
60 #intltoolize
61 #%%{__libtoolize}
62 #%%{__aclocal} -I /usr/share/aclocal/gnome2-macros
63 #%%{__autoheader}
64 #%%{__autoconf}
65 #%%{__automake}
66 ./autogen.sh
67 %configure \
68         --disable-static
69 %{__make}
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %{__make} install \
75         DESTDIR=$RPM_BUILD_ROOT \
76         gnomemenudir=%{_datadir}/applications
77
78 %find_lang %{name} --with-gnome
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %files -f %{name}.lang
84 %defattr(644,root,root,755)
85 %doc README ChangeLog NEWS TODO AUTHORS COPYING 
86 %doc FUTURE INSTALL doc/ScintillaDoc.html
87 %attr(755,root,root) %{_bindir}/*
88 %dir %{_libdir}/anjuta
89 %attr(755,root,root) %{_libdir}/anjuta/lib*.so*
90 %{_libdir}/anjuta/lib*.la
91 %{_pixmapsdir}/anjuta
92 %{_datadir}/anjuta
93 %{_datadir}/applications/*
94 %{_datadir}/mime-info
95 %{_datadir}/mimelnk
96 %{_mandir}/man1/*
This page took 0.062599 seconds and 4 git commands to generate.