]> git.pld-linux.org Git - packages/anjuta.git/blob - anjuta.spec
perl -pi -e "s/^gettextize --copy --force/\%%\{__gettextize\}/"
[packages/anjuta.git] / anjuta.spec
1 Summary:        Gnome integrated development environment
2 Summary(pl):    Zintegrowane ¶rodowisko programowania dla Gnome
3 Summary(pt_BR): Ambiente de desenvolvimento integrado C e C++
4 Name:           anjuta
5 Version:        0.1.9
6 Release:        4
7 License:        GPL
8 Group:          Development/Tools
9 Source0:        http://anjuta.sourceforge.net/packages/%{name}-%{version}.tar.gz
10 Source1:        %{name}.desktop
11 Patch0:         %{name}-ac_am.patch
12 URL:            http://anjuta.sourceforge.net/
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  bonobo-devel
16 BuildRequires:  gettext-devel
17 BuildRequires:  gnome-vfs-devel
18 BuildRequires:  gtk+-devel >= 1.2.0
19 BuildRequires:  intltool
20 BuildRequires:  libtool
21 BuildRequires:  libxml-devel
22 BuildRequires:  pkgconfig
23 BuildRequires:  scrollkeeper
24 BuildRequires:  gnomemm-devel
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         _prefix         /usr/X11R6
28 %define         _mandir         %{_prefix}/man
29 %define         _omf_dest_dir   %(scrollkeeper-config --omfdir)
30
31 %description
32 Anjuta is a very versatile integrated development environment for C
33 and C++ GNU/Linux. Written in GTK/Gnome and written for GTK/Gnome, it
34 features many advanced programming tools and utilities. Besides many
35 other, it has project management, application wizards, onboard
36 interactive debugger, and a powerful source editor with source
37 browsing.
38
39 %description -l pl
40 Anjuta to wszechstronne zintegrowane ¶rodowisko programowania dla
41 jêzyka C oraz C++. Zosta³o napisane z wykorzystaniem tandemu
42 GTK/Gnome, w³a¶nie po to by go w takim otoczeniu u¿ywaæ. Miêdzy innymi
43 posiada zarz±dcê projektów, kreator aplikacji, wbudowany interaktywny
44 odpluskwiacz oraz edytor z mo¿liwo¶ci± przegl±dania ¼róde³.
45
46 %description -l pt_BR
47 O Anjuta é um ambiente de desenvolvimento integrado (IDE) versátil
48 para as linguagens C e C++. Foi escrito para o GTK/GNOME e tem uma
49 série de características de programação avançadas. Basicamente é uma
50 interface gráfica com o usuário para um conjunto de utilitários de
51 linha de comando e ferramentas para programação para o Linux. Estas
52 são geralmente executadas em um console em modo texto e podem ser não
53 amigáveis.
54
55 %prep
56 %setup  -q
57 %patch0 -p1
58
59 %build
60 rm -f missing
61 %{__libtoolize}
62 %{__gettextize}
63 intltoolize --copy --force
64 xml-i18n-toolize --copy --force
65 aclocal -I macros
66 %{__autoconf}
67 %{__automake}
68 echo "all install:">plugins/sample1/Makefile.in
69 CXXFLAGS="%{rpmcflags} -fno-exceptions"
70 %configure \
71         --with-gnome
72 %{__make}
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76 install -d $RPM_BUILD_ROOT%{_applnkdir}/Development \
77         $RPM_BUILD_ROOT%{_datadir}/%{name}/gnome
78
79 install %{SOURCE1} $RPM_BUILD_ROOT%{_applnkdir}/Development
80
81 %{__make} install \
82         DESTDIR=$RPM_BUILD_ROOT \
83         omf_dest_dir=%{_omf_dest_dir}/%{name}
84
85 %find_lang %{name} --with-gnome
86
87 %post   -p /usr/bin/scrollkeeper-update
88 %postun -p /usr/bin/scrollkeeper-update
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %files -f %{name}.lang
94 %defattr(644,root,root,755)
95 %doc README ChangeLog NEWS TODO
96 %attr(755,root,root) %{_bindir}/*
97 %dir %{_libdir}/anjuta
98 %attr(755,root,root) %{_libdir}/anjuta/lib*.so.*.*
99 %attr(755,root,root) %{_libdir}/anjuta/lib*.??
100 %{_omf_dest_dir}/%{name}
101 %{_datadir}/anjuta
102 %{_applnkdir}/Development/*
103 %{_pixmapsdir}/anjuta
This page took 0.057865 seconds and 4 git commands to generate.