]> git.pld-linux.org Git - packages/anjuta.git/blob - anjuta.spec
- s/[Gg]nome/GNOME/
[packages/anjuta.git] / anjuta.spec
1 #%%define               snap    20030425
2
3 Summary:        GNOME integrated development environment
4 Summary(pl):    Zintegrowane ¶rodowisko programowania dla GNOME
5 Summary(pt_BR): Ambiente de desenvolvimento integrado C e C++
6 Name:           anjuta
7 Version:        1.1.97
8 Release:        2
9 Epoch:          1
10 License:        GPL
11 Group:          Development/Tools
12 #Source0:       %{name}-%{version}-%{snap}.tar.bz2
13 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
14 # Source0-md5:  fc938d304f29f62353ab5fdf48c93685
15 Patch0:         %{name}-am.patch
16 Patch1:         %{name}-gettext.patch
17 URL:            http://anjuta.sourceforge.net/
18 BuildRequires:  ORBit2-devel >= 2.7.5-1
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  glib2-devel >= 2.0.6
22 BuildRequires:  intltool
23 BuildRequires:  gnome-common
24 BuildRequires:  libglade2-devel >= 2.0.0
25 BuildRequires:  libgnomeprintui-devel >= 2.2.0
26 BuildRequires:  libgnomeui-devel >= 2.3.3.1-2
27 BuildRequires:  libtool
28 BuildRequires:  libzvt-devel >= 2.0.0
29 BuildRequires:  ncurses-devel
30 BuildRequires:  pcre-devel >= 3.9
31 BuildRequires:  pkgconfig
32 BuildRequires:  vte-devel >= 0.9.0
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Anjuta is a very versatile integrated development environment for C
37 and C++ GNU/Linux. Written in GTK/GNOME and written for GTK/GNOME, it
38 features many advanced programming tools and utilities. Besides many
39 other, it has project management, application wizards, onboard
40 interactive debugger, and a powerful source editor with source
41 browsing.
42
43 %description -l pl
44 Anjuta to wszechstronne zintegrowane ¶rodowisko programowania dla
45 jêzyka C oraz C++. Zosta³o napisane z wykorzystaniem tandemu
46 GTK/GNOME, w³a¶nie po to by go w takim otoczeniu u¿ywaæ. Miêdzy innymi
47 posiada zarz±dcê projektów, kreator aplikacji, wbudowany interaktywny
48 odpluskwiacz oraz edytor z mo¿liwo¶ci± przegl±dania ¼róde³.
49
50 %description -l pt_BR
51 O Anjuta é um ambiente de desenvolvimento integrado (IDE) versátil
52 para as linguagens C e C++. Foi escrito para o GTK/GNOME e tem uma
53 série de características de programação avançadas. Basicamente é uma
54 interface gráfica com o usuário para um conjunto de utilitários de
55 linha de comando e ferramentas para programação para o Linux. Estas
56 são geralmente executadas em um console em modo texto e podem ser não
57 amigáveis.
58
59 %prep
60 %setup -q
61 %patch0 -p1
62 %patch1 -p0
63
64 %build
65 CXXFLAGS="%{rpmcflags} -fno-exceptions"
66 rm -f missing
67 #%%{__gettextize}
68 #intltoolize
69 %{__libtoolize}
70 %{__aclocal} -I /usr/share/aclocal/gnome2-macros
71 %{__autoheader}
72 %{__autoconf}
73 %{__automake}
74 #./autogen.sh
75 %configure \
76         --disable-static
77 %{__make}
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81
82 %{__make} install \
83         DESTDIR=$RPM_BUILD_ROOT \
84         gnomemenudir=%{_desktopdir}
85
86 # *.la not needed - *.so loaded through libgmodule
87 rm -f $RPM_BUILD_ROOT%{_libdir}/anjuta/lib*.la
88
89 %find_lang %{name} --with-gnome
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %files -f %{name}.lang
95 %defattr(644,root,root,755)
96 %doc AUTHORS ChangeLog FUTURE NEWS README TODO doc/ScintillaDoc.html
97 %attr(755,root,root) %{_bindir}/*
98 %dir %{_libdir}/anjuta
99 %attr(755,root,root) %{_libdir}/anjuta/lib*.so*
100 %{_pixmapsdir}/anjuta
101 %{_datadir}/anjuta
102 %{_datadir}/mime-info/*
103 %{_datadir}/mimelnk/application/*
104 %{_desktopdir}/*
105 %{_mandir}/man1/*
This page took 0.068684 seconds and 4 git commands to generate.