]> git.pld-linux.org Git - packages/anjuta.git/blob - anjuta.spec
- converted to UTF-8
[packages/anjuta.git] / anjuta.spec
1 Summary:        GNOME integrated development environment
2 Summary(es.UTF-8):   Entorno integrado de desarrollo (IDE) de GNOME
3 Summary(pl.UTF-8):   Zintegrowane środowisko programowania dla GNOME
4 Summary(pt_BR.UTF-8):   Ambiente de desenvolvimento integrado C e C++
5 Name:           anjuta
6 Version:        2.0.2
7 Release:        6
8 Epoch:          1
9 License:        GPL
10 Group:          Development/Tools
11 Source0:        http://dl.sourceforge.net/anjuta/%{name}-%{version}.tar.gz
12 # Source0-md5:  e0d1e216da809df32816d233d7c55165
13 #Patch0: %{name}-home_etc.patch
14 Patch1:         %{name}-desktop.patch
15 Patch2:         %{name}-cflags.patch
16 URL:            http://anjuta.sourceforge.net/
17 BuildRequires:  ORBit2-devel >= 1:2.12.1
18 BuildRequires:  autoconf >= 2.52
19 BuildRequires:  autogen
20 BuildRequires:  automake
21 BuildRequires:  binutils-devel
22 BuildRequires:  devhelp-devel
23 BuildRequires:  gdl-devel >= 0.6.1
24 BuildRequires:  gettext-devel
25 BuildRequires:  gnome-build-devel
26 BuildRequires:  gnome-common >= 2.8.0
27 BuildRequires:  gnome-vfs2-devel >= 2.10.0-2
28 BuildRequires:  gtk-doc
29 BuildRequires:  intltool
30 BuildRequires:  libglade2-devel >= 1:2.5.1
31 BuildRequires:  libgnomeprintui-devel >= 2.10.2
32 BuildRequires:  libgnomeui-devel >= 2.10.0-2
33 BuildRequires:  libstdc++-devel
34 BuildRequires:  libtool
35 BuildRequires:  libwnck-devel
36 BuildRequires:  libxml2-devel >= 1:2.6.19
37 BuildRequires:  ncurses-devel
38 BuildRequires:  neon-devel
39 BuildRequires:  pcre-devel >= 3.9
40 BuildRequires:  pkgconfig
41 BuildRequires:  popt-devel
42 BuildRequires:  rpmbuild(macros) >= 1.197
43 BuildRequires:  scrollkeeper
44 BuildRequires:  subversion-devel
45 BuildRequires:  vte-devel >= 0.11.0
46 Requires(post,postun):  scrollkeeper
47 # Requires:     gnome-terminal
48 Requires:       libanjuta = %{epoch}:%{version}-%{release}
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %description
52 Anjuta is a very versatile integrated development environment for C
53 and C++ for GNU/Linux. Written in GTK/GNOME and written for GTK/GNOME,
54 it features many advanced programming tools and utilities. Besides
55 many other, it has project management, application wizards, onboard
56 interactive debugger, and a powerful source editor with source
57 browsing.
58
59 %description -l es.UTF-8
60 Anjuta es un entorno integrado de desarrollo para C y C++ para
61 GNU/Linux. Escrito en y para GTK/GNOME, proporciona muchas
62 herramientas de programación avanzadas. Entre otros, habilita
63 manejamiento de proyectos, wizards de aplicaciones, depurador
64 interactivo y un editador potente de código fuente que permite
65 hojearlo.
66
67 %description -l pl.UTF-8
68 Anjuta to wszechstronne zintegrowane środowisko programowania dla
69 języka C oraz C++. Zostało napisane z wykorzystaniem tandemu
70 GTK/GNOME, właśnie po to by go w takim otoczeniu używać. Między innymi
71 posiada zarządcę projektów, kreator aplikacji, wbudowany interaktywny
72 odpluskwiacz oraz edytor z możliwością przeglądania źródeł.
73
74 %description -l pt_BR.UTF-8
75 O Anjuta é um ambiente de desenvolvimento integrado (IDE) versátil
76 para as linguagens C e C++. Foi escrito para o GTK/GNOME e tem uma
77 série de características de programação avançadas. Basicamente é uma
78 interface gráfica com o usuário para um conjunto de utilitários de
79 linha de comando e ferramentas para programação para o Linux. Estas
80 são geralmente executadas em um console em modo texto e podem ser não
81 amigáveis.
82
83 %package -n libanjuta
84 Summary:        libanjuta library
85 Group:          Development/Libraries
86 Conflicts:      %{name} < 1:2.0.2-1
87
88 %description -n libanjuta
89 libanjuta library.
90
91 %package -n libanjuta-devel
92 Summary:        Header files and develpment documentation for libanjuta
93 Group:          Development/Libraries
94 Requires:       libanjuta-devel = %{epoch}:%{version}-%{release}
95
96 %description -n libanjuta-devel
97 Header files and develpment documentation for libanjuta.
98
99 %prep
100 %setup -q
101 #%patch0 -p1 NEEDS checking
102 %patch1 -p1
103 %patch2 -p0
104
105 %{__perl} -pi -e 's@^(packageplugindir=)lib/@$1%{_lib}/@' configure.in
106
107 %build
108 CXXFLAGS="%{rpmcflags} -fno-exceptions"
109 CFLAGS="%{rpmcflags} -fno-omit-frame-pointer"
110 %{__libtoolize}
111 %{__aclocal}
112 %{__autoheader}
113 %{__autoconf}
114 %{__automake}
115 %configure \
116         --with-html-dir=%{_gtkdocdir} \
117         --with-apr-config=%{_bindir}/apr-1-config \
118         --with-apu-config=%{_bindir}/apu-1-config \
119         --with-neon-config=%{_bindir}/neon-config \
120         --disable-static
121 %{__make}
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125
126 %{__make} install \
127         DESTDIR=$RPM_BUILD_ROOT \
128         gnomemenudir=%{_desktopdir}
129
130 # *.la not needed - *.so loaded through libgmodule
131 rm -f $RPM_BUILD_ROOT%{_libdir}/anjuta/lib*.la
132
133 rm -r $RPM_BUILD_ROOT%{_datadir}/mime-info
134
135 %find_lang %{name} --with-gnome
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %post
141 %scrollkeeper_update_post
142
143 %postun
144 %scrollkeeper_update_postun
145
146 %post   -n libanjuta -p /sbin/ldconfig
147 %postun -n libanjuta -p /sbin/ldconfig
148
149 %files -f %{name}.lang
150 %defattr(644,root,root,755)
151 %doc AUTHORS ChangeLog FUTURE NEWS README TODO doc/ScintillaDoc.html
152 %attr(755,root,root) %{_bindir}/*
153 %dir %{_libdir}/%{name}
154 %attr(755,root,root) %{_libdir}/%{name}/lib*.so*
155 %{_libdir}/%{name}/*.plugin
156 %{_pixmapsdir}/%{name}
157 %{_datadir}/%{name}
158 %{_datadir}/application-registry/*.*
159 %{_datadir}/mime/packages/*.*
160 %{_desktopdir}/*.desktop
161 %{_mandir}/man1/*
162 %{_omf_dest_dir}/%{name}
163 %{_sysconfdir}/gconf/schemas/*.*
164 %{_iconsdir}/*/*/*/*.*
165
166 %files -n libanjuta
167 %defattr(644,root,root,755)
168 %attr(755,root,root) %{_libdir}/*.so.*
169
170 %files -n libanjuta-devel
171 %defattr(644,root,root,755)
172 %{_includedir}/libanjuta-*
173 %attr(755,root,root) %{_libdir}/*.so
174 %{_libdir}/*.la
175 %{_pkgconfigdir}/*.pc
176 %{_gtkdocdir}/libanjuta
This page took 0.090677 seconds and 4 git commands to generate.