]> git.pld-linux.org Git - packages/anjuta.git/blob - anjuta.spec
- added patch to not rebuild system tags
[packages/anjuta.git] / anjuta.spec
1 Summary:        Gnome integrated development environment
2 Summary(pl):    Zintegrowane ¶rodowisko programowania dla Gnome
3 Summary(pt_BR): Ambiente de desenvolvimento integrado C e C++
4 Name:           anjuta
5 Version:        0.1.9
6 Release:        7
7 License:        GPL
8 Group:          Development/Tools
9 Source0:        http://anjuta.sourceforge.net/packages/%{name}-%{version}.tar.gz
10 Source1:        %{name}.desktop
11 Patch0:         %{name}-ac_am.patch
12 Patch1:         %{name}-no_systemtags.patch
13 URL:            http://anjuta.sourceforge.net/
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  bonobo-devel
17 BuildRequires:  gettext-devel
18 BuildRequires:  gnome-vfs-devel
19 BuildRequires:  gtk+-devel >= 1.2.0
20 BuildRequires:  intltool
21 BuildRequires:  libtool
22 BuildRequires:  libxml-devel
23 BuildRequires:  pkgconfig
24 BuildRequires:  scrollkeeper
25 BuildRequires:  gnomemm-devel
26 Requires:       gnome-libs-devel
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         _prefix         /usr/X11R6
30 %define         _mandir         %{_prefix}/man
31 %define         _omf_dest_dir   %(scrollkeeper-config --omfdir)
32
33 %description
34 Anjuta is a very versatile integrated development environment for C
35 and C++ GNU/Linux. Written in GTK/Gnome and written for GTK/Gnome, it
36 features many advanced programming tools and utilities. Besides many
37 other, it has project management, application wizards, onboard
38 interactive debugger, and a powerful source editor with source
39 browsing.
40
41 %description -l pl
42 Anjuta to wszechstronne zintegrowane ¶rodowisko programowania dla
43 jêzyka C oraz C++. Zosta³o napisane z wykorzystaniem tandemu
44 GTK/Gnome, w³a¶nie po to by go w takim otoczeniu u¿ywaæ. Miêdzy innymi
45 posiada zarz±dcê projektów, kreator aplikacji, wbudowany interaktywny
46 odpluskwiacz oraz edytor z mo¿liwo¶ci± przegl±dania ¼róde³.
47
48 %description -l pt_BR
49 O Anjuta é um ambiente de desenvolvimento integrado (IDE) versátil
50 para as linguagens C e C++. Foi escrito para o GTK/GNOME e tem uma
51 série de características de programação avançadas. Basicamente é uma
52 interface gráfica com o usuário para um conjunto de utilitários de
53 linha de comando e ferramentas para programação para o Linux. Estas
54 são geralmente executadas em um console em modo texto e podem ser não
55 amigáveis.
56
57 %prep
58 %setup  -q
59 %patch0 -p1
60 %patch1 -p1
61
62 %build
63 rm -f missing
64 %{__libtoolize}
65 %{__gettextize}
66 intltoolize --copy --force
67 xml-i18n-toolize --copy --force
68 aclocal -I macros
69 %{__autoconf}
70 %{__automake}
71 echo "all install:">plugins/sample1/Makefile.in
72 CXXFLAGS="%{rpmcflags} -fno-exceptions"
73 %configure \
74         --with-gnome
75 %{__make}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79 install -d $RPM_BUILD_ROOT%{_applnkdir}/Development \
80         $RPM_BUILD_ROOT%{_datadir}/%{name}/gnome
81
82 install %{SOURCE1} $RPM_BUILD_ROOT%{_applnkdir}/Development
83
84 %{__make} install \
85         DESTDIR=$RPM_BUILD_ROOT \
86         omf_dest_dir=%{_omf_dest_dir}/%{name}
87
88 %find_lang %{name} --with-gnome
89
90 %post   -p /usr/bin/scrollkeeper-update
91 %postun -p /usr/bin/scrollkeeper-update
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %files -f %{name}.lang
97 %defattr(644,root,root,755)
98 %doc README ChangeLog NEWS TODO
99 %attr(755,root,root) %{_bindir}/*
100 %dir %{_libdir}/anjuta
101 %attr(755,root,root) %{_libdir}/anjuta/lib*.so.*.*
102 %attr(755,root,root) %{_libdir}/anjuta/lib*.??
103 %{_omf_dest_dir}/%{name}
104 %{_datadir}/anjuta
105 %{_applnkdir}/Development/*
106 %{_pixmapsdir}/anjuta
This page took 0.037433 seconds and 4 git commands to generate.