]> git.pld-linux.org Git - packages/anjuta.git/blob - anjuta.spec
- support for gettext 0.11
[packages/anjuta.git] / anjuta.spec
1 %define         snap    20030319
2
3 Summary:        Gnome integrated development environment
4 Summary(pl):    Zintegrowane ¶rodowisko programowania dla Gnome
5 Summary(pt_BR): Ambiente de desenvolvimento integrado C e C++
6 Name:           anjuta
7 Version:        1.2.0
8 Release:        0.%{snap}.2
9 License:        GPL
10 Group:          Development/Tools
11 #Source0:       http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
12 Source0:        %{name}-%{version}-%{snap}.tar.bz2
13 Patch0:         %{name}-am.patch
14 Patch1:         %{name}-gettext.patch
15 URL:            http://anjuta.sourceforge.net/
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  glib2-devel >= 2.0.6
19 BuildRequires:  intltool
20 BuildRequires:  libglade2-devel >= 2.0.0
21 BuildRequires:  libgnomeprintui-devel >= 2.2.0
22 BuildRequires:  libgnomeui-devel >= 2.2.0
23 BuildRequires:  libtool
24 BuildRequires:  libzvt-devel >= 2.0.0
25 BuildRequires:  ncurses-devel
26 BuildRequires:  pcre-devel
27 BuildRequires:  pkgconfig
28 BuildRequires:  vte-devel >= 0.9.0
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Anjuta is a very versatile integrated development environment for C
33 and C++ GNU/Linux. Written in GTK/Gnome and written for GTK/Gnome, it
34 features many advanced programming tools and utilities. Besides many
35 other, it has project management, application wizards, onboard
36 interactive debugger, and a powerful source editor with source
37 browsing.
38
39 %description -l pl
40 Anjuta to wszechstronne zintegrowane ¶rodowisko programowania dla
41 jêzyka C oraz C++. Zosta³o napisane z wykorzystaniem tandemu
42 GTK/Gnome, w³a¶nie po to by go w takim otoczeniu u¿ywaæ. Miêdzy innymi
43 posiada zarz±dcê projektów, kreator aplikacji, wbudowany interaktywny
44 odpluskwiacz oraz edytor z mo¿liwo¶ci± przegl±dania ¼róde³.
45
46 %description -l pt_BR
47 O Anjuta é um ambiente de desenvolvimento integrado (IDE) versátil
48 para as linguagens C e C++. Foi escrito para o GTK/GNOME e tem uma
49 série de características de programação avançadas. Basicamente é uma
50 interface gráfica com o usuário para um conjunto de utilitários de
51 linha de comando e ferramentas para programação para o Linux. Estas
52 são geralmente executadas em um console em modo texto e podem ser não
53 amigáveis.
54
55 %prep
56 %setup -q
57 %patch0 -p1
58 %patch1 -p0
59
60 %build
61 CXXFLAGS="%{rpmcflags} -fno-exceptions"
62 #rm -f missing
63 #%%{__gettextize}
64 #intltoolize
65 #%%{__libtoolize}
66 #%%{__aclocal} -I /usr/share/aclocal/gnome2-macros
67 #%%{__autoheader}
68 #%%{__autoconf}
69 #%%{__automake}
70 ./autogen.sh
71 %configure \
72         --disable-static
73 %{__make}
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77
78 %{__make} install \
79         DESTDIR=$RPM_BUILD_ROOT \
80         gnomemenudir=%{_datadir}/applications
81
82 %find_lang %{name} --with-gnome
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %files -f %{name}.lang
88 %defattr(644,root,root,755)
89 %doc README ChangeLog NEWS TODO AUTHORS COPYING 
90 %doc FUTURE INSTALL doc/ScintillaDoc.html
91 %attr(755,root,root) %{_bindir}/*
92 %dir %{_libdir}/anjuta
93 %attr(755,root,root) %{_libdir}/anjuta/lib*.so*
94 %{_libdir}/anjuta/lib*.la
95 %{_pixmapsdir}/anjuta
96 %{_datadir}/anjuta
97 %{_datadir}/applications/*
98 %{_datadir}/mime-info/*
99 %{_datadir}/mimelnk/application/*
100 %{_mandir}/man1/*
This page took 0.095056 seconds and 3 git commands to generate.