]> git.pld-linux.org Git - packages/amanda.git/blob - amanda.spec
- %verify() for config files
[packages/amanda.git] / amanda.spec
1 # TODO
2 #  - as of setup-2.4.6-8:
3 #   service/protocol combination not in /etc/services: amandaidx/tcp
4 #   service/protocol combination not in /etc/services: amidxtape/tcp
5 #
6 # Conditional build:
7 %bcond_with     xfs     # with support for xfsdump 
8 #
9 Summary:        A network-capable tape backup solution
10 Summary(pl):    Sieciowo zorientowany system tworzenia kopii zapasowych
11 Name:           amanda
12 Version:        2.4.4p2
13 Release:        3
14 License:        BSD
15 Group:          Networking/Utilities
16 Source0:        http://dl.sourceforge.net/amanda/%{name}-%{version}.tar.gz
17 # Source0-md5:  95f772203801999bd4b96606859f8910
18 Source1:        %{name}-srv.crontab
19 Source2:        %{name}.inetd
20 Source3:        %{name}idx.inetd
21 Source4:        amidxtape.inetd
22 Source5:        %{name}.conf
23 Patch0:         %{name}-no_libnsl.patch
24 Patch1:         %{name}-no_private_libtool.m4.patch
25 Patch2:         %{name}-ac25x.patch
26 Patch3:         %{name}-chg-zd-mtx-sh.patch
27 Patch4:         %{name}-tar.patch
28 URL:            http://www.amanda.org/
29 BuildRequires:  autoconf >= 2.53
30 BuildRequires:  automake
31 BuildRequires:  cpio
32 BuildRequires:  dump
33 BuildRequires:  flex
34 BuildRequires:  gnuplot
35 BuildRequires:  libtool
36 BuildRequires:  readline-devel >= 4.2
37 BuildRequires:  rpmbuild(macros) >= 1.159
38 BuildRequires:  tar
39 %{?with_xfs:BuildRequires:      xfsdump}
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %define         _localstatedir  /var/lib
43 %define         _libexecdir     %{_libdir}/amanda
44
45 %description
46 AMANDA, the Advanced Maryland Automatic Network Disk Archiver, is a
47 backup system that allows the administrator of a LAN to set up a
48 single master backup server to back up multiple hosts to a single
49 large capacity tape drive. AMANDA uses native dump and/or GNU tar
50 facilities and can back up a large number of workstations running
51 multiple versions of Unix. Newer versions of AMANDA (including this
52 version) can use SAMBA to back up Microsoft(TM) Windows95/NT hosts.
53 The amanda package contains the core AMANDA programs and will need to
54 be installed on both AMANDA clients and AMANDA servers. Note that you
55 will have to install the amanda-client and amanda-server packages as
56 well.
57
58 %description -l pl
59 AMANDA jest sieciowo zorientowanym systemem tworzenia kopii
60 zapasowych. Umo¿liwia administratorowi sieci tworzenie kopii z kilku
61 hostów na jednej maszynie wyposa¿onej w pojemny dysk lub streamer.
62 Nowsze wersje programu umo¿liwiaj± zabezpieczanie zasobów Microsoft
63 Windows 95/98/NT/2000 przy u¿yciu protoko³u Samba. Ten pakiet zawiera
64 podstawowe pliki programu i powinien byæ zainstalowany zarówno na
65 serwerze jak i na kliencie. Pamiêtaj tak¿e o instalacji pakietów
66 amanda-client i amanda-server!
67
68 %package libs
69 Summary:        Amanda shared libraries
70 Summary(pl):    Biblioteki wspó³dzielone pakietu amanda
71 Group:          Networking/Utilities
72 Requires(pre):  /bin/id
73 Requires(pre):  /usr/bin/getgid
74 Requires(pre):  /usr/sbin/groupadd
75 Requires(pre):  /usr/sbin/useradd
76 Requires(postun):       /usr/sbin/groupdel
77 Requires(postun):       /usr/sbin/userdel
78 Requires(postun):       /sbin/ldconfig
79 Provides:       group(amanda)
80 Provides:       user(amanda)
81
82 %description libs
83 Amanda shared libraries.
84
85 %description libs -l pl
86 Biblioteki wspó³dzielone pakietu amanda.
87
88 %package client
89 Summary:        The client side of Amanda
90 Summary(pl):    Klient Amandy
91 Group:          Networking/Utilities
92 PreReq:         %{name}-libs = %{version}
93 PreReq:         rc-inetd
94 Requires(post,postun):  /sbin/ldconfig
95 Conflicts:      tar < 1.13
96
97 %description client
98 The Amanda-client package should be installed on any machine that will
99 be backed up by AMANDA (including the server if it also needs to be
100 backed up). You will also need to install the amanda package to each
101 AMANDA client. It requires at least one of dump and GNU tar installed.
102
103 %description client -l pl
104 Ten pakiet powinien byæ zainstalowany ma maszynach, z których
105 zawarto¶ci bêd± tworzone kopie zapasowe. Wymaga zainstalowanego co
106 najmniej jednego z pakietów dump i GNU tar.
107
108 %package server
109 Summary:        The server side of Amanda
110 Summary(pl):    Serwer Amandy
111 Group:          Networking/Utilities
112 PreReq:         %{name}-libs = %{version}
113 PreReq:         rc-inetd
114 Requires(post,postun):  /sbin/ldconfig
115 Requires:       gnuplot
116 Requires:       crondaemon
117 Requires:       /etc/cron.d
118 Requires:       mt-st
119 Requires:       mtx
120 Obsoletes:      amanda
121
122 %description server
123 The amanda-server package should be installed on the AMANDA server,
124 the machine attached to the device (such as a tape drive) where
125 backups will be written. You will also need to install the amanda
126 package to the AMANDA server. And, if the server is also to be backed
127 up, the server also needs to have the amanda-client package installed.
128
129 %description server -l pl
130 Ten pakiet powinien byæ zainstalowanych na maszynach, na których bêd±
131 magazynowane kopie zapasowe (lub do których podpiête s± urz±dzenia
132 typu streamer).
133
134 %prep
135 %setup -q
136 %patch0 -p1
137 %patch1 -p1
138 %patch2 -p1
139 %patch3 -p1
140 %patch4 -p1
141
142 %build
143 %{__libtoolize}
144 %{__aclocal}
145 %{__autoconf}
146 %{__automake}
147 %configure \
148         --disable-static \
149         --enable-shared \
150         --with-index-server=localhost \
151         --with-user=amanda \
152         --with-group=amanda \
153         --with-tape-device=/dev/null \
154         --with-ftape-rawdevice=/dev/null \
155         --with-changer-device=/dev/null \
156         --with-fqdn \
157         --with-smbclient=%{_bindir}/smbclient \
158         --with-bsd-security \
159         --with-buffered-dump \
160         --with-amandahosts \
161         --with-debugging=%{_localstatedir}/amanda/debug \
162         --with-gnutar-listdir=%{_localstatedir}/amanda/gnutar-lists \
163         --with-tmpdir=/var/tmp
164
165 %{__make}
166
167 %install
168 rm -rf $RPM_BUILD_ROOT
169 install -d $RPM_BUILD_ROOT%{_sysconfdir}/{amanda,cron.d,sysconfig/rc-inetd} \
170         $RPM_BUILD_ROOT%{_localstatedir}/amanda/gnutar-lists \
171         $RPM_BUILD_ROOT%{_mandir}/man1
172
173 %{__make} install \
174         DESTDIR=$RPM_BUILD_ROOT \
175         SETUID_GROUP=`id -g`
176
177 install %{SOURCE1} $RPM_BUILD_ROOT/etc/cron.d/amanda-srv
178 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amanda
179 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amandaidx
180 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amidxtape
181
182 install %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/amanda
183 install example/*.ps $RPM_BUILD_ROOT%{_localstatedir}/amanda
184
185 > $RPM_BUILD_ROOT%{_sysconfdir}/amandates
186
187 %clean
188 rm -rf $RPM_BUILD_ROOT
189
190 %triggerpostun -- amanda-libs < 2.4.2p2-3
191 /usr/sbin/chsh -s /bin/sh amanda
192
193 %triggerpostun -- amanda-libs < 2.4.2p2-12
194 /usr/sbin/usermod -G disk amanda
195
196 %pre libs
197 if [ -n "`/usr/bin/getgid amanda`" ]; then
198         if [ "`/usr/bin/getgid amanda`" != 80 ]; then
199                 echo "Error: group amanda doesn't have gid=80. Correct this before installing amanda-libs." 1>&2
200                 exit 1
201         fi
202 else
203         /usr/sbin/groupadd -g 80 amanda
204 fi
205 if [ -n "`/bin/id -u amanda 2>/dev/null`" ]; then
206         if [ "`/bin/id -u amanda`" != 80 ]; then
207                 echo "Error: user amanda doesn't have uid=80. Correct this before installing amanda-libs." 1>&2
208                 exit 1
209         fi
210 else
211         /usr/sbin/useradd -u 80 -G disk -d /var/lib/amanda -s /bin/sh \
212                 -c "Amanda Backup user" -g amanda amanda 1>&2
213 fi
214
215 %post   libs -p /sbin/ldconfig
216
217 %postun libs
218 /sbin/ldconfig
219 if [ "$1" = "0" ]; then
220         %userremove amanda
221         %groupremove amanda
222 fi
223
224 %post client
225 /sbin/ldconfig
226 if [ -f /var/lock/subsys/rc-inetd ]; then
227         /etc/rc.d/init.d/rc-inetd restart 1>&2
228 else
229         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server." 1>&2
230 fi
231
232 %postun client
233 /sbin/ldconfig
234 if [ -f /var/lock/subsys/rc-inetd ]; then
235         /etc/rc.d/init.d/rc-inetd restart
236 fi
237
238 %post server
239 /sbin/ldconfig
240 if [ -f /var/lock/subsys/rc-inetd ]; then
241         /etc/rc.d/init.d/rc-inetd restart 1>&2
242 else
243         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server." 1>&2
244 fi
245 if [ "$1" = "1" ]; then
246         echo "Don't forget to edit /etc/cron.d/amanda-srv." 1>&2
247 fi
248
249 %postun server
250 /sbin/ldconfig
251 if [ -f /var/lock/subsys/rc-inetd ]; then
252         /etc/rc.d/init.d/rc-inetd restart
253 fi
254
255 %files libs
256 %defattr(644,root,root,755)
257 %attr(755,root,root) %{_libdir}/libamanda*.so
258 %attr(755,root,root) %{_libdir}/libamtape*.so
259 %attr(770,amanda,amanda) %dir %{_libexecdir}
260 %attr(770,amanda,amanda) %dir %{_localstatedir}/amanda
261
262 %files server
263 %defattr(644,root,root,755)
264 %doc docs/*
265 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/amidxtape
266 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/amandaidx
267
268 %attr(750,amanda,amanda) %dir %{_sysconfdir}/amanda
269 %config(noreplace) %verify(not md5 mtime size) %attr(640,amanda,amanda) %{_sysconfdir}/amanda/*
270
271 %attr(664,amanda,amanda) %{_localstatedir}/amanda/*.ps
272
273 %config(noreplace) %attr(640,root,root) /etc/cron.d/amanda-srv
274
275 %attr(755,root,root) %{_libdir}/libamserver*.so
276 %attr(755,root,root) %{_libexecdir}/amindexd
277 %attr(755,root,root) %{_libexecdir}/amtrmidx
278 %attr(755,root,root) %{_libexecdir}/driver
279 %attr(4754,root,amanda) %{_libexecdir}/dumper
280 %attr(4754,root,amanda) %{_libexecdir}/planner
281 %attr(755,root,root) %{_libexecdir}/amcat.awk
282 %attr(755,root,root) %{_libexecdir}/amcleanupdisk
283 %attr(755,root,root) %{_libexecdir}/amidxtaped
284 %attr(755,root,root) %{_libexecdir}/amlogroll
285 %attr(755,root,root) %{_libexecdir}/amplot.awk
286 %attr(755,root,root) %{_libexecdir}/amplot.g
287 %attr(755,root,root) %{_libexecdir}/amplot.gp
288 %attr(755,root,root) %{_libexecdir}/amtrmlog
289 %attr(755,root,root) %{_libexecdir}/chg-chio
290 %attr(755,root,root) %{_libexecdir}/chg-chs
291 %attr(755,root,root) %{_libexecdir}/chg-juke
292 %attr(755,root,root) %{_libexecdir}/chg-manual
293 %attr(755,root,root) %{_libexecdir}/chg-mtx
294 %attr(755,root,root) %{_libexecdir}/chg-multi
295 %attr(755,root,root) %{_libexecdir}/chg-rait
296 %attr(755,root,root) %{_libexecdir}/chg-rth
297 %attr(755,root,root) %{_libexecdir}/chg-scsi
298 %attr(755,root,root) %{_libexecdir}/chg-zd-mtx
299 %attr(755,root,root) %{_libexecdir}/taper
300 %attr(755,root,root) %{_sbindir}/amadmin
301 %attr(4754,root,amanda) %{_sbindir}/amcheck
302 %attr(755,root,root) %{_sbindir}/amcheckdb
303 %attr(755,root,root) %{_sbindir}/amcleanup
304 %attr(755,root,root) %{_sbindir}/amdump
305 %attr(755,root,root) %{_sbindir}/amflush
306 %attr(755,root,root) %{_sbindir}/amgetconf
307 %attr(755,root,root) %{_sbindir}/amlabel
308 %attr(755,root,root) %{_sbindir}/amoverview
309 %attr(755,root,root) %{_sbindir}/amplot
310 %attr(755,root,root) %{_sbindir}/amreport
311 %attr(755,root,root) %{_sbindir}/amrmtape
312 %attr(755,root,root) %{_sbindir}/amstatus
313 %attr(755,root,root) %{_sbindir}/amtape
314 %attr(755,root,root) %{_sbindir}/amtapetype
315 %attr(755,root,root) %{_sbindir}/amtoc
316 %attr(755,root,root) %{_sbindir}/amverify
317 %attr(755,root,root) %{_sbindir}/amverifyrun
318 %{_mandir}/man8/amadmin.8*
319 %{_mandir}/man8/amanda.8*
320 %{_mandir}/man8/amcheck.8*
321 %{_mandir}/man8/amcheckdb.8*
322 %{_mandir}/man8/amcleanup.8*
323 %{_mandir}/man8/amdump.8*
324 %{_mandir}/man8/amflush.8*
325 %{_mandir}/man8/amgetconf.8*
326 %{_mandir}/man8/amlabel.8*
327 %{_mandir}/man8/amoverview.8*
328 %{_mandir}/man8/amplot.8*
329 %{_mandir}/man8/amreport.8*
330 %{_mandir}/man8/amrmtape.8*
331 %{_mandir}/man8/amstatus.8*
332 %{_mandir}/man8/amtape.8*
333 %{_mandir}/man8/amtapetype.8*
334 %{_mandir}/man8/amtoc.8*
335 %{_mandir}/man8/amverify.8*
336 %{_mandir}/man8/amverifyrun.8*
337
338 %files client
339 %defattr(644,root,root,755)
340 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/amanda
341 %attr(664,root,amanda) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/amandates
342 %attr(755,root,root) %{_libdir}/libamclient*.so
343 %attr(755,root,root) %{_libexecdir}/versionsuffix
344 %attr(755,root,root) %{_libexecdir}/amandad
345 %attr(4754,root,amanda) %{_libexecdir}/calcsize
346 %attr(4754,root,amanda) %{_libexecdir}/rundump
347 %attr(4754,root,amanda) %{_libexecdir}/runtar
348 %attr(4754,root,amanda) %{_libexecdir}/selfcheck
349 %attr(755,root,root) %{_libexecdir}/sendbackup
350 %attr(755,root,root) %{_libexecdir}/sendsize
351 %attr(755,root,root) %{_libexecdir}/patch-system
352 %attr(4754,root,amanda) %{_libexecdir}/killpgrp
353 %attr(755,root,root) %{_sbindir}/amdd
354 %attr(755,root,root) %{_sbindir}/ammt
355 %attr(755,root,root) %{_sbindir}/amrecover
356 %attr(755,root,root) %{_sbindir}/amrestore
357 %attr(770,amanda,amanda) %dir %{_localstatedir}/amanda/gnutar-lists
358 %{_mandir}/man8/amdd.8*
359 %{_mandir}/man8/ammt.8*
360 %{_mandir}/man8/amrecover.8*
361 %{_mandir}/man8/amrestore.8*
This page took 0.075586 seconds and 4 git commands to generate.