]> git.pld-linux.org Git - packages/amanda.git/blob - amanda.spec
- sane perms for libexecdir
[packages/amanda.git] / amanda.spec
1 #
2 # Conditional build:
3 %bcond_with     xfs     # with support for xfsdump 
4 #
5 Summary:        A network-capable tape backup solution
6 Summary(pl):    Sieciowo zorientowany system tworzenia kopii zapasowych
7 Name:           amanda
8 Version:        2.4.4p4
9 Release:        0.1
10 License:        BSD
11 Group:          Networking/Utilities
12 Source0:        http://dl.sourceforge.net/amanda/%{name}-%{version}.tar.gz
13 # Source0-md5:  3c1d80de30b97a892b7972781c5fb557
14 Source1:        %{name}-srv.crontab
15 Source2:        %{name}.inetd
16 Source3:        %{name}idx.inetd
17 Source4:        amidxtape.inetd
18 Source5:        %{name}.conf
19 Patch0:         %{name}-no_libnsl.patch
20 Patch1:         %{name}-ac25x.patch
21 Patch2:         %{name}-chg-zd-mtx-sh.patch
22 Patch3:         %{name}-tar.patch
23 URL:            http://www.amanda.org/
24 BuildRequires:  autoconf >= 2.53
25 BuildRequires:  automake
26 BuildRequires:  cpio
27 BuildRequires:  dump
28 BuildRequires:  flex
29 BuildRequires:  gnuplot
30 BuildRequires:  libtool
31 BuildRequires:  readline-devel >= 4.2
32 BuildRequires:  rpmbuild(macros) >= 1.159
33 BuildRequires:  tar
34 %{?with_xfs:BuildRequires:      xfsdump}
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         _localstatedir  /var/lib
38 %define         _libexecdir     %{_libdir}/amanda
39
40 %description
41 AMANDA, the Advanced Maryland Automatic Network Disk Archiver, is a
42 backup system that allows the administrator of a LAN to set up a
43 single master backup server to back up multiple hosts to a single
44 large capacity tape drive. AMANDA uses native dump and/or GNU tar
45 facilities and can back up a large number of workstations running
46 multiple versions of Unix. Newer versions of AMANDA (including this
47 version) can use SAMBA to back up Microsoft(TM) Windows95/NT hosts.
48 The amanda package contains the core AMANDA programs and will need to
49 be installed on both AMANDA clients and AMANDA servers. Note that you
50 will have to install the amanda-client and amanda-server packages as
51 well.
52
53 %description -l pl
54 AMANDA jest sieciowo zorientowanym systemem tworzenia kopii
55 zapasowych. Umo¿liwia administratorowi sieci tworzenie kopii z kilku
56 hostów na jednej maszynie wyposa¿onej w pojemny dysk lub streamer.
57 Nowsze wersje programu umo¿liwiaj± zabezpieczanie zasobów Microsoft
58 Windows 95/98/NT/2000 przy u¿yciu protoko³u Samba. Ten pakiet zawiera
59 podstawowe pliki programu i powinien byæ zainstalowany zarówno na
60 serwerze jak i na kliencie. Pamiêtaj tak¿e o instalacji pakietów
61 amanda-client i amanda-server!
62
63 %package libs
64 Summary:        Amanda shared libraries
65 Summary(pl):    Biblioteki wspó³dzielone pakietu amanda
66 Group:          Networking/Utilities
67 Requires(pre):  /bin/id
68 Requires(pre):  /usr/bin/getgid
69 Requires(pre):  /usr/sbin/groupadd
70 Requires(pre):  /usr/sbin/useradd
71 Requires(postun):       /usr/sbin/groupdel
72 Requires(postun):       /usr/sbin/userdel
73 Requires(postun):       /sbin/ldconfig
74 Provides:       group(amanda)
75 Provides:       user(amanda)
76
77 %description libs
78 Amanda shared libraries.
79
80 %description libs -l pl
81 Biblioteki wspó³dzielone pakietu amanda.
82
83 %package client
84 Summary:        The client side of Amanda
85 Summary(pl):    Klient Amandy
86 Group:          Networking/Utilities
87 PreReq:         %{name}-libs = %{version}-%{release}
88 PreReq:         rc-inetd
89 Requires(post,postun):  /sbin/ldconfig
90 Conflicts:      tar < 1.13
91
92 %description client
93 The Amanda-client package should be installed on any machine that will
94 be backed up by AMANDA (including the server if it also needs to be
95 backed up). You will also need to install the amanda package to each
96 AMANDA client. It requires at least one of dump and GNU tar installed.
97
98 %description client -l pl
99 Ten pakiet powinien byæ zainstalowany ma maszynach, z których
100 zawarto¶ci bêd± tworzone kopie zapasowe. Wymaga zainstalowanego co
101 najmniej jednego z pakietów dump i GNU tar.
102
103 %package server
104 Summary:        The server side of Amanda
105 Summary(pl):    Serwer Amandy
106 Group:          Networking/Utilities
107 PreReq:         %{name}-libs = %{version}-%{release}
108 PreReq:         rc-inetd
109 Requires(post,postun):  /sbin/ldconfig
110 Requires:       gnuplot
111 Requires:       crondaemon
112 Requires:       /etc/cron.d
113 Requires:       mt-st
114 Requires:       mtx
115 Obsoletes:      amanda
116
117 %description server
118 The amanda-server package should be installed on the AMANDA server,
119 the machine attached to the device (such as a tape drive) where
120 backups will be written. You will also need to install the amanda
121 package to the AMANDA server. And, if the server is also to be backed
122 up, the server also needs to have the amanda-client package installed.
123
124 %description server -l pl
125 Ten pakiet powinien byæ zainstalowanych na maszynach, na których bêd±
126 magazynowane kopie zapasowe (lub do których podpiête s± urz±dzenia
127 typu streamer).
128
129 %prep
130 %setup -q
131 %patch0 -p1
132 %patch1 -p1
133 %patch2 -p1
134 %patch3 -p1
135
136 # kill libtool.m4 copy
137 head -n 1013 acinclude.m4 > acinc.tmp
138 mv -f acinc.tmp acinclude.m4
139
140 %build
141 %{__libtoolize}
142 %{__aclocal}
143 %{__autoconf}
144 %{__automake}
145 %configure \
146         --disable-static \
147         --enable-shared \
148         --with-index-server=localhost \
149         --with-user=amanda \
150         --with-group=amanda \
151         --with-tape-device=/dev/null \
152         --with-ftape-rawdevice=/dev/null \
153         --with-changer-device=/dev/null \
154         --with-fqdn \
155         --with-smbclient=%{_bindir}/smbclient \
156         --with-bsd-security \
157         --with-buffered-dump \
158         --with-amandahosts \
159         --with-debugging=%{_localstatedir}/amanda/debug \
160         --with-gnutar-listdir=%{_localstatedir}/amanda/gnutar-lists \
161         --with-tmpdir=/var/tmp
162
163 %{__make}
164
165 %install
166 rm -rf $RPM_BUILD_ROOT
167 install -d $RPM_BUILD_ROOT%{_sysconfdir}/{amanda,cron.d,sysconfig/rc-inetd} \
168         $RPM_BUILD_ROOT%{_localstatedir}/amanda/gnutar-lists \
169         $RPM_BUILD_ROOT%{_mandir}/man1
170
171 %{__make} install \
172         DESTDIR=$RPM_BUILD_ROOT \
173         SETUID_GROUP=`id -g`
174
175 install %{SOURCE1} $RPM_BUILD_ROOT/etc/cron.d/amanda-srv
176 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amanda
177 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amandaidx
178 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amidxtape
179
180 install %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/amanda
181 install example/*.ps $RPM_BUILD_ROOT%{_localstatedir}/amanda
182
183 > $RPM_BUILD_ROOT%{_sysconfdir}/amandates
184
185 %clean
186 rm -rf $RPM_BUILD_ROOT
187
188 %triggerpostun -- amanda-libs < 2.4.2p2-3
189 /usr/sbin/chsh -s /bin/sh amanda
190
191 %triggerpostun -- amanda-libs < 2.4.2p2-12
192 /usr/sbin/usermod -G disk amanda
193
194 %pre libs
195 if [ -n "`/usr/bin/getgid amanda`" ]; then
196         if [ "`/usr/bin/getgid amanda`" != 80 ]; then
197                 echo "Error: group amanda doesn't have gid=80. Correct this before installing amanda-libs." 1>&2
198                 exit 1
199         fi
200 else
201         /usr/sbin/groupadd -g 80 amanda
202 fi
203 if [ -n "`/bin/id -u amanda 2>/dev/null`" ]; then
204         if [ "`/bin/id -u amanda`" != 80 ]; then
205                 echo "Error: user amanda doesn't have uid=80. Correct this before installing amanda-libs." 1>&2
206                 exit 1
207         fi
208 else
209         /usr/sbin/useradd -u 80 -G disk -d /var/lib/amanda -s /bin/sh \
210                 -c "Amanda Backup user" -g amanda amanda 1>&2
211 fi
212
213 %post   libs -p /sbin/ldconfig
214
215 %postun libs
216 /sbin/ldconfig
217 if [ "$1" = "0" ]; then
218         %userremove amanda
219         %groupremove amanda
220 fi
221
222 %post client
223 /sbin/ldconfig
224 if [ -f /var/lock/subsys/rc-inetd ]; then
225         /etc/rc.d/init.d/rc-inetd restart 1>&2
226 else
227         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server." 1>&2
228 fi
229
230 %postun client
231 /sbin/ldconfig
232 if [ -f /var/lock/subsys/rc-inetd ]; then
233         /etc/rc.d/init.d/rc-inetd restart
234 fi
235
236 %post server
237 /sbin/ldconfig
238 if [ -f /var/lock/subsys/rc-inetd ]; then
239         /etc/rc.d/init.d/rc-inetd restart 1>&2
240 else
241         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server." 1>&2
242 fi
243 if [ "$1" = "1" ]; then
244         echo "Don't forget to edit /etc/cron.d/amanda-srv." 1>&2
245 fi
246
247 %postun server
248 /sbin/ldconfig
249 if [ -f /var/lock/subsys/rc-inetd ]; then
250         /etc/rc.d/init.d/rc-inetd restart
251 fi
252
253 %files libs
254 %defattr(644,root,root,755)
255 %attr(755,root,root) %{_libdir}/libamanda*.so
256 %attr(755,root,root) %{_libdir}/libamtape*.so
257 %dir %{_libexecdir}
258 %attr(770,amanda,amanda) %dir %{_localstatedir}/amanda
259
260 %files server
261 %defattr(644,root,root,755)
262 %doc docs/*
263 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/amidxtape
264 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/amandaidx
265
266 %attr(750,amanda,amanda) %dir %{_sysconfdir}/amanda
267 %config(noreplace) %verify(not md5 mtime size) %attr(640,amanda,amanda) %{_sysconfdir}/amanda/*
268
269 %attr(664,amanda,amanda) %{_localstatedir}/amanda/*.ps
270
271 %config(noreplace) %attr(640,root,root) /etc/cron.d/amanda-srv
272
273 %attr(755,root,root) %{_libdir}/libamserver*.so
274 %attr(755,root,root) %{_libexecdir}/amindexd
275 %attr(755,root,root) %{_libexecdir}/amtrmidx
276 %attr(755,root,root) %{_libexecdir}/driver
277 %attr(4754,root,amanda) %{_libexecdir}/dumper
278 %attr(4754,root,amanda) %{_libexecdir}/planner
279 %attr(755,root,root) %{_libexecdir}/amcat.awk
280 %attr(755,root,root) %{_libexecdir}/amcleanupdisk
281 %attr(755,root,root) %{_libexecdir}/amidxtaped
282 %attr(755,root,root) %{_libexecdir}/amlogroll
283 %attr(755,root,root) %{_libexecdir}/amplot.awk
284 %attr(755,root,root) %{_libexecdir}/amplot.g
285 %attr(755,root,root) %{_libexecdir}/amplot.gp
286 %attr(755,root,root) %{_libexecdir}/amtrmlog
287 %attr(755,root,root) %{_libexecdir}/chg-chio
288 %attr(755,root,root) %{_libexecdir}/chg-chs
289 %attr(755,root,root) %{_libexecdir}/chg-disk
290 %attr(755,root,root) %{_libexecdir}/chg-iomega
291 %attr(755,root,root) %{_libexecdir}/chg-juke
292 %attr(755,root,root) %{_libexecdir}/chg-manual
293 %attr(755,root,root) %{_libexecdir}/chg-mcutil
294 %attr(755,root,root) %{_libexecdir}/chg-mtx
295 %attr(755,root,root) %{_libexecdir}/chg-multi
296 %attr(755,root,root) %{_libexecdir}/chg-null
297 %attr(755,root,root) %{_libexecdir}/chg-rait
298 %attr(755,root,root) %{_libexecdir}/chg-rth
299 %attr(755,root,root) %{_libexecdir}/chg-scsi
300 %attr(755,root,root) %{_libexecdir}/chg-zd-mtx
301 %attr(755,root,root) %{_libexecdir}/taper
302 %attr(755,root,root) %{_sbindir}/amadmin
303 %attr(4754,root,amanda) %{_sbindir}/amcheck
304 %attr(755,root,root) %{_sbindir}/amcheckdb
305 %attr(755,root,root) %{_sbindir}/amcleanup
306 %attr(755,root,root) %{_sbindir}/amdump
307 %attr(755,root,root) %{_sbindir}/amflush
308 %attr(755,root,root) %{_sbindir}/amgetconf
309 %attr(755,root,root) %{_sbindir}/amlabel
310 %attr(755,root,root) %{_sbindir}/amoverview
311 %attr(755,root,root) %{_sbindir}/amplot
312 %attr(755,root,root) %{_sbindir}/amreport
313 %attr(755,root,root) %{_sbindir}/amrmtape
314 %attr(755,root,root) %{_sbindir}/amstatus
315 %attr(755,root,root) %{_sbindir}/amtape
316 %attr(755,root,root) %{_sbindir}/amtapetype
317 %attr(755,root,root) %{_sbindir}/amtoc
318 %attr(755,root,root) %{_sbindir}/amverify
319 %attr(755,root,root) %{_sbindir}/amverifyrun
320 %{_mandir}/man8/amadmin.8*
321 %{_mandir}/man8/amanda.8*
322 %{_mandir}/man8/amcheck.8*
323 %{_mandir}/man8/amcheckdb.8*
324 %{_mandir}/man8/amcleanup.8*
325 %{_mandir}/man8/amdump.8*
326 %{_mandir}/man8/amflush.8*
327 %{_mandir}/man8/amgetconf.8*
328 %{_mandir}/man8/amlabel.8*
329 %{_mandir}/man8/amoverview.8*
330 %{_mandir}/man8/amplot.8*
331 %{_mandir}/man8/amreport.8*
332 %{_mandir}/man8/amrmtape.8*
333 %{_mandir}/man8/amstatus.8*
334 %{_mandir}/man8/amtape.8*
335 %{_mandir}/man8/amtapetype.8*
336 %{_mandir}/man8/amtoc.8*
337 %{_mandir}/man8/amverify.8*
338 %{_mandir}/man8/amverifyrun.8*
339
340 %files client
341 %defattr(644,root,root,755)
342 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/amanda
343 %attr(664,root,amanda) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/amandates
344 %attr(755,root,root) %{_libdir}/libamclient*.so
345 %attr(755,root,root) %{_libexecdir}/versionsuffix
346 %attr(755,root,root) %{_libexecdir}/amandad
347 %attr(4754,root,amanda) %{_libexecdir}/amqde
348 %attr(4754,root,amanda) %{_libexecdir}/calcsize
349 %attr(4754,root,amanda) %{_libexecdir}/killpgrp
350 %attr(755,root,root) %{_libexecdir}/patch-system
351 %attr(4754,root,amanda) %{_libexecdir}/rundump
352 %attr(4754,root,amanda) %{_libexecdir}/runtar
353 %attr(4754,root,amanda) %{_libexecdir}/selfcheck
354 %attr(755,root,root) %{_libexecdir}/sendbackup
355 %attr(755,root,root) %{_libexecdir}/sendsize
356 %attr(755,root,root) %{_sbindir}/amdd
357 %attr(755,root,root) %{_sbindir}/ammt
358 %attr(755,root,root) %{_sbindir}/amrecover
359 %attr(755,root,root) %{_sbindir}/amrestore
360 %attr(770,amanda,amanda) %dir %{_localstatedir}/amanda/gnutar-lists
361 %{_mandir}/man8/amdd.8*
362 %{_mandir}/man8/ammt.8*
363 %{_mandir}/man8/amrecover.8*
364 %{_mandir}/man8/amrestore.8*
This page took 0.051533 seconds and 4 git commands to generate.