]> git.pld-linux.org Git - packages/amanda.git/blob - amanda.spec
- reverse logick xfs support (by default build without xfs support).
[packages/amanda.git] / amanda.spec
1 # Conditional build:                                                                 
2 # _with_xfs     - without support for xfsdump
3
4 Summary:        A network-capable tape backup solution
5 Summary(pl):    Sieciowo zorientowany system tworzenia kopii zapasowych
6 Name:           amanda
7 Version:        2.4.2p2
8 Release:        14
9 License:        BSD
10 Group:          Networking/Utilities
11 Source0:        http://prdownloads.sourceforge.net/amanda/%{name}-%{version}.tar.gz
12 Source1:        %{name}-srv.crontab
13 Source2:        %{name}.inetd
14 Source3:        %{name}idx.inetd
15 Source4:        amidxtape.inetd
16 Source5:        %{name}.conf
17 Patch0:         %{name}-no_libnsl.patch
18 Patch1:         %{name}-am_fixes.patch
19 Patch2:         %{name}-bug18322.patch
20 Patch3:         %{name}-build_tapetype.patch
21 Patch4:         %{name}-no_private_libtool.m4.patch
22 Patch5:         %{name}-ac25x.patch
23 Patch6:         %{name}-chg-zd-mtx-sh.patch
24 URL:            http://www.amanda.org/
25 BuildRequires:  autoconf
26 BuildRequires:  automake
27 BuildRequires:  cpio
28 BuildRequires:  dump
29 %{!?_with_xfs:BuildRequires:    xfsdump}
30 BuildRequires:  flex
31 BuildRequires:  gnuplot
32 BuildRequires:  libtool
33 BuildRequires:  readline-devel >= 4.2
34 BuildRequires:  tar
35 BuildRequires:  samba-client
36 Prereq:         /sbin/ldconfig
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %define         _sysconfdir     /etc
40 %define         _localstatedir  /var/lib
41 %define         _libexecdir     %{_libdir}/amanda
42
43 %description
44 AMANDA, the Advanced Maryland Automatic Network Disk Archiver, is a
45 backup system that allows the administrator of a LAN to set up a
46 single master backup server to back up multiple hosts to a single
47 large capacity tape drive. AMANDA uses native dump and/or GNU tar
48 facilities and can back up a large number of workstations running
49 multiple versions of Unix. Newer versions of AMANDA (including this
50 version) can use SAMBA to back up Microsoft(TM) Windows95/NT hosts.
51 The amanda package contains the core AMANDA programs and will need to
52 be installed on both AMANDA clients and AMANDA servers. Note that you
53 will have to install the amanda-client and amanda-server packages as
54 well.
55
56 %description -l pl
57 AMANDA jest sieciowo zorientowanym systemem tworzenia kopii
58 zapasowych. Umo¿liwia administratorowi sieci tworzenie kopii z kilku
59 hostów na jednej maszynie wyposa¿onej w pojemny dysk lub streamer.
60 Nowsze wersje programu umo¿liwiaj± zabezpieczanie zasobów Microsoft
61 Windows 95/98/NT/2000 przy u¿yciu protoko³u Samba. Ten pakiet zawiera
62 podstawowe pliki programu i powinien byæ zainstalowany zarówno na
63 serwerze jak i na kliencie. Pamiêtaj tak¿e o instalacji pakietów
64 amanda-client i amanda-server!
65
66 %package libs
67 Summary:        Amanda shared libraries
68 Summary(pl):    Biblioteki wspó³dzielone pakietu amanda
69 Group:          Networking/Utilities
70 Prereq:         /usr/bin/getgid
71 Prereq:         /bin/id
72 Prereq:         /usr/sbin/groupadd
73 Prereq:         /usr/sbin/useradd
74 Prereq:         /usr/sbin/groupdel
75 Prereq:         /usr/sbin/userdel
76
77 %description libs
78 Amanda shared libraries.
79
80 %description libs -l pl
81 Biblioteki wspó³dzielone pakietu amanda.
82
83 %package client
84 Summary:        The client side of Amanda
85 Summary(pl):    Klient Amandy
86 Group:          Networking/Utilities
87 Prereq:         /sbin/ldconfig
88 Prereq:         rc-inetd
89 Prereq:         %{name}-libs = %{version}
90 Conflicts:      tar < 1.13
91
92 %description client
93 The Amanda-client package should be installed on any machine that will
94 be backed up by AMANDA (including the server if it also needs to be
95 backed up). You will also need to install the amanda package to each
96 AMANDA client. It requires at least one of dump and GNU tar installed.
97
98 %description client -l pl
99 Ten pakiet powinien byæ zainstalowany ma maszynach, z których
100 zawarto¶ci bêd± tworzone kopie zapasowe. Wymaga zainstalowanego co
101 najmniej jednego z pakietów dump i GNU tar.
102
103 %package server
104 Summary:        The server side of Amanda
105 Summary(pl):    Serwer Amandy
106 Group:          Networking/Utilities
107 Prereq:         rc-inetd
108 Prereq:         /sbin/ldconfig
109 Requires:       gnuplot
110 Requires:       crondaemon
111 Requires:       /etc/cron.d
112 Requires:       mt-st
113 Requires:       mtx
114 Prereq:         rc-inetd
115 Prereq:         %{name}-libs = %{version}
116
117 %description server
118 The amanda-server package should be installed on the AMANDA server,
119 the machine attached to the device (such as a tape drive) where
120 backups will be written. You will also need to install the amanda
121 package to the AMANDA server. And, if the server is also to be backed
122 up, the server also needs to have the amanda-client package installed.
123
124 %description server -l pl
125 Ten pakiet powinien byæ zainstalowanych na maszynach, na których bêd±
126 magazynowane kopie zapasowe (lub do których podpiête s± urz±dzenia
127 typu streamer).
128
129 %prep
130 %setup -q
131 %patch0 -p1
132 %patch1 -p1
133 %patch2 -p1
134 %patch3 -p1
135 %patch4 -p1
136 %patch5 -p1
137 %patch6 -p1
138
139 %build
140 libtoolize --copy --force
141 aclocal
142 autoconf
143 touch COPYING
144 rm -f missing
145 automake -a -c -f
146 %configure \
147         --disable-static \
148         --enable-shared \
149         --with-index-server=localhost \
150         --with-user=amanda \
151         --with-group=amanda \
152         --with-tape-device=/dev/null \
153         --with-ftape-rawdevice=/dev/null \
154         --with-changer-device=/dev/null \
155         --with-fqdn \
156         --with-smbclient=%{_bindir}/smbclient \
157         --with-bsd-security \
158         --with-buffered-dump \
159         --with-amandahosts \
160         --with-debugging=%{_localstatedir}/amanda/debug \
161         --with-gnutar-listdir=%{_localstatedir}/amanda/gnutar-lists \
162         --with-tmpdir=/var/tmp
163
164 %{__make}
165
166 %install
167 rm -rf $RPM_BUILD_ROOT
168 install -d $RPM_BUILD_ROOT%{_sysconfdir}/{amanda,cron.d,sysconfig/rc-inetd} \
169         $RPM_BUILD_ROOT%{_localstatedir}/amanda/gnutar-lists
170
171 %{__make} install \
172         DESTDIR=$RPM_BUILD_ROOT \
173         SETUID_GROUP=`id -g`
174
175 install %{SOURCE1} $RPM_BUILD_ROOT/etc/cron.d/amanda-srv
176 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amanda
177 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amandaidx
178 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amidxtape
179
180 install %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/amanda
181 install example/*.ps $RPM_BUILD_ROOT%{_localstatedir}/amanda
182
183 > $RPM_BUILD_ROOT%{_sysconfdir}/amandates
184
185 gzip -9nf docs/*
186
187 %clean
188 rm -rf $RPM_BUILD_ROOT
189
190 %triggerpostun -- amanda-libs < 2.4.2p2-3
191 /usr/sbin/chsh -s /bin/sh amanda
192
193 %triggerpostun -- amanda-libs < 2.4.2p2-12
194 /usr/sbin/usermod -G disk amanda
195
196 %pre libs
197 if [ -n "`/usr/bin/getgid amanda`" ]; then
198         if [ "`getgid amanda`" != "80" ]; then
199                 echo "Warning: group amanda haven't gid=80. Correct this before installing amanda-libs" 1>&2
200                 exit 1
201         fi
202 else
203         /usr/sbin/groupadd -g 80 -r -f amanda
204 fi
205 if [ -n "`/bin/id -u amanda 2>/dev/null`" ]; then
206         if [ "`/bin/id -u amanda`" != "80" ]; then
207                 echo "Warning: user amanda haven't uid=80. Correct this before installing amanda-libs" 1>&2
208                 exit 1
209         fi
210 else
211         /usr/sbin/useradd -u 80 -G disk -r -d /var/lib/amanda -s /bin/sh -c "Amanda Backup user" -g amanda amanda 1>&2
212 fi
213
214 %post libs -p /sbin/ldconfig
215
216 %postun libs
217 /sbin/ldconfig
218 if [ "$1" = "0" ]; then
219         /usr/sbin/userdel amanda
220         /usr/sbin/groupdel amanda
221 fi
222
223 %post client
224 /sbin/ldconfig
225 if [ -f /var/lock/subsys/rc-inetd ]; then
226         /etc/rc.d/init.d/rc-inetd restart 1>&2
227 else
228         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server" 1>&2
229 fi
230
231 %postun client
232 /sbin/ldconfig
233 if [ -f /var/lock/subsys/rc-inetd ]; then
234         /etc/rc.d/init.d/rc-inetd restart
235 fi
236
237 %post server
238 /sbin/ldconfig
239 if [ -f /var/lock/subsys/rc-inetd ]; then
240         /etc/rc.d/init.d/rc-inetd restart 1>&2
241 else
242         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server" 1>&2
243 fi
244 echo "Don't forget to edit /etc/cron.d/amanda-srv" 1>&2
245
246 %postun server
247 /sbin/ldconfig
248 if [ -f /var/lock/subsys/rc-inetd ]; then
249         /etc/rc.d/init.d/rc-inetd restart
250 fi
251
252 %files libs
253 %defattr(644,root,root,755)
254 %attr(755,root,root) %{_libdir}/libamanda*.so
255 %attr(755,root,root) %{_libdir}/libamtape*.so
256 %attr(770,root,amanda) %dir %{_libexecdir}
257 %attr(770,root,amanda) %dir %{_localstatedir}/amanda
258
259
260 %files server
261 %defattr(644,root,root,755)
262 %doc docs/*.gz
263 %config(noreplace) /etc/sysconfig/rc-inetd/amidxtape
264 %config(noreplace) /etc/sysconfig/rc-inetd/amandaidx
265
266 %attr(750,amanda,amanda) %dir %{_sysconfdir}/amanda
267 %config(noreplace) %attr(640,amanda,amanda) %{_sysconfdir}/amanda/*
268
269 %attr(664,amanda,amanda) %{_localstatedir}/amanda/*
270
271 %config(noreplace) %attr(640,root,root) /etc/cron.d/amanda-srv
272
273 %attr(755,root,root) %{_libdir}/libamserver*.so
274 %attr(755,root,root) %{_libexecdir}/amindexd
275 %attr(755,root,root) %{_libexecdir}/amtrmidx
276 %attr(755,root,root) %{_libexecdir}/driver
277 %attr(4754,root,amanda) %{_libexecdir}/dumper
278 %attr(4754,root,amanda) %{_libexecdir}/planner
279 %attr(755,root,root) %{_libexecdir}/amcat.awk
280 %attr(755,root,root) %{_libexecdir}/amcleanupdisk
281 %attr(755,root,root) %{_libexecdir}/amidxtaped
282 %attr(755,root,root) %{_libexecdir}/amlogroll
283 %attr(755,root,root) %{_libexecdir}/amplot.awk
284 %attr(755,root,root) %{_libexecdir}/amplot.g
285 %attr(755,root,root) %{_libexecdir}/amplot.gp
286 %attr(755,root,root) %{_libexecdir}/amtrmlog
287 %attr(755,root,root) %{_libexecdir}/chg-chio
288 %attr(755,root,root) %{_libexecdir}/chg-chs
289 %attr(755,root,root) %{_libexecdir}/chg-manual
290 %attr(755,root,root) %{_libexecdir}/chg-mtx
291 %attr(755,root,root) %{_libexecdir}/chg-multi
292 %attr(755,root,root) %{_libexecdir}/chg-rth
293 %attr(755,root,root) %{_libexecdir}/chg-scsi
294 %attr(755,root,root) %{_libexecdir}/chg-zd-mtx
295 %attr(755,root,root) %{_libexecdir}/selfcheck
296 %attr(755,root,root) %{_libexecdir}/taper
297 %attr(755,root,root) %{_sbindir}/amadmin
298 %attr(4754,root,amanda) %{_sbindir}/amcheck
299 %attr(755,root,root) %{_sbindir}/amcheckdb
300 %attr(755,root,root) %{_sbindir}/amcleanup
301 %attr(755,root,root) %{_sbindir}/amdump
302 %attr(755,root,root) %{_sbindir}/amflush
303 %attr(755,root,root) %{_sbindir}/amgetconf
304 %attr(755,root,root) %{_sbindir}/amlabel
305 %attr(755,root,root) %{_sbindir}/amoverview
306 %attr(755,root,root) %{_sbindir}/amplot
307 %attr(755,root,root) %{_sbindir}/amrmtape
308 %attr(755,root,root) %{_sbindir}/amreport
309 %attr(755,root,root) %{_sbindir}/amstatus
310 %attr(755,root,root) %{_sbindir}/amtape
311 %attr(755,root,root) %{_sbindir}/amtoc
312 %attr(755,root,root) %{_sbindir}/amverify
313 %attr(755,root,root) %{_sbindir}/tapetype
314 %{_mandir}/man8/amadmin.8*
315 %{_mandir}/man8/amrmtape.8*
316 %{_mandir}/man8/amtape.8*
317 %{_mandir}/man8/amtoc.8*
318 %{_mandir}/man8/amanda.8*
319 %{_mandir}/man8/amcheck.8*
320 %{_mandir}/man8/amcleanup.8*
321 %{_mandir}/man8/amdump.8*
322 %{_mandir}/man8/amflush.8*
323 %{_mandir}/man8/amlabel.8*
324 %{_mandir}/man8/amplot.8*
325 %{_mandir}/man8/amreport.8*
326 %{_mandir}/man8/amstatus.8*
327
328 %files client
329 %defattr(644,root,root,755)
330 %config(noreplace) /etc/sysconfig/rc-inetd/amanda
331 %attr(664,root,amanda) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/amandates
332 %attr(755,root,root) %{_libdir}/libamclient*.so
333 %attr(755,root,root) %{_libexecdir}/versionsuffix
334 %attr(755,root,root) %{_libexecdir}/amandad
335 %attr(4754,root,amanda) %{_libexecdir}/calcsize
336 %attr(4754,root,amanda) %{_libexecdir}/rundump
337 %attr(4754,root,amanda) %{_libexecdir}/runtar
338 %attr(4754,root,amanda) %{_libexecdir}/selfcheck
339 %attr(755,root,root) %{_libexecdir}/sendbackup
340 %attr(755,root,root) %{_libexecdir}/sendsize
341 %attr(755,root,root) %{_libexecdir}/patch-system
342 %attr(4754,root,amanda) %{_libexecdir}/killpgrp
343 %attr(755,root,root) %{_sbindir}/amrecover
344 %attr(755,root,root) %{_sbindir}/amrestore
345 %attr(770,amanda,amanda) %dir %{_localstatedir}/amanda/gnutar-lists
346 %{_mandir}/man8/amrecover.8*
347 %{_mandir}/man8/amrestore.8*
This page took 0.054443 seconds and 4 git commands to generate.