]> git.pld-linux.org Git - packages/aircrack-ng.git/blob - aircrack-ng.spec
BR zlib-devel
[packages/aircrack-ng.git] / aircrack-ng.spec
1 #
2 # TODO:
3 # - PLD it more
4 # - sbin/bin - change to bin?
5 # - finish ext_scripts bcond:
6 # -- check python related BR and R
7 # -- fix packaging python releated stuff
8 # -- create subpackage for airoscript
9 # -- fix directory for airoscript*.conf files
10 # -- fix installation of airoscript desktop files
11 #
12 # Conditional build:
13 %bcond_without  sqlite                  # build without sqlite support
14 %bcond_without  pcre                    # build without pcre support
15 %bcond_without  experimental
16 %bcond_with     ext_scripts             # build with extra scripts (NFY)
17
18 %define subver  rc2
19 %define rel     0.1
20 Summary:        Reliable 802.11 (wireless) sniffer and WEP/WPA-PSK key cracker
21 Summary(pl.UTF-8):      Pewny sniffer 802.11 (sieci bezprzewodowe) i łamacz kluczy WEP/WPA-PSK
22 Name:           aircrack-ng
23 Version:        1.2
24 Release:        %{subver}.%{rel}
25 License:        GPL
26 Group:          Applications/Networking
27 Source0:        http://download.aircrack-ng.org/%{name}-%{version}-%{subver}.tar.gz
28 # Source0-md5:  ebe9d537f06f4d6956213af09c4476da
29 URL:            http://www.aircrack-ng.org/
30 Patch0:         install.patch
31 Patch1:         pldflags.patch
32 BuildRequires:  libnl-devel
33 BuildRequires:  openssl-devel
34 %{?with_pcre:BuildRequires:     pcre-devel}
35 BuildRequires:  pkgconfig
36 %{?with_sqlite:BuildRequires:   sqlite3-devel}
37 BuildRequires:  zlib-devel
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 aircrack-ng is a set of tools for auditing wireless networks. It's an
42 enhanced/reborn version of aircrack. It consists of airodump-ng (an
43 802.11 packet capture program), aireplay-ng (an 802.11 packet
44 injection program), aircrack (static WEP and WPA-PSK cracking),
45 airdecap-ng (decrypts WEP/WPA capture files), and some tools to handle
46 capture files (merge, convert, etc.).
47
48 %description -l pl.UTF-8
49 aircrack-ng jest zestawem narzędzi do audytów sieci bezprzewodowych.
50 Jest to ulepszona/odnowiona wersja aircracka. Składa sie z programów
51 airodump-ng (do przechwytywania pakietów 802.11), aireplay-ng (do
52 wstrzykiwania pakietów 802.11), aircrack (do statycznego łamania WEP i
53 WPA-PSK), airdecap-ng (do odszyfrowywania przechwyconych plików
54 WEP/WPA) i paru narzędzi do obsługi plików przechwytów (merge,
55 convert, etc.).
56
57 %prep
58 %setup -q -n %{name}-%{version}-%{subver}
59 %patch0 -p1
60 %patch1 -p1
61
62 %build
63 %{__make} -j1 \
64         %{?with_experimental: experimental=true} \
65         %{?with_ext_scripts: ext_scripts=true} \
66         %{?with_pcre: pcre=true} \
67         %{?with_sqlite: sqlite=true} \
68         CC="%{__cc}" \
69         PLDFLAGS="%{rpmcppflags} %{rpmcflags}"
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}
74
75 %{__make} install \
76         %{?with_experimental: experimental=true} \
77         %{?with_ext_scripts: ext_scripts=true} \
78         %{?with_pcre: pcre=true} \
79         %{?with_sqlite: sqlite=true} \
80         prefix=%{_prefix} \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %files
87 %defattr(644,root,root,755)
88 %doc AUTHORS ChangeLog README test patches
89 %attr(755,root,root) %{_bindir}/aircrack-ng
90 %attr(755,root,root) %{_bindir}/airdecap-ng
91 %attr(755,root,root) %{_bindir}/airdecloak-ng
92 %{?with_sqlite:%attr(755,root,root) %{_bindir}/airolib-ng}
93 %attr(755,root,root) %{_bindir}/ivstools
94 %attr(755,root,root) %{_bindir}/kstats
95 %attr(755,root,root) %{_bindir}/makeivs-ng
96 %attr(755,root,root) %{_bindir}/packetforge-ng
97 %attr(755,root,root) %{_bindir}/wpaclean
98 %attr(755,root,root) %{_sbindir}/airbase-ng
99 %attr(755,root,root) %{_sbindir}/aireplay-ng
100 %attr(755,root,root) %{_sbindir}/airmon-ng
101 %attr(755,root,root) %{_sbindir}/airodump-ng
102 %attr(755,root,root) %{_sbindir}/airodump-ng-oui-update
103 %attr(755,root,root) %{_sbindir}/airserv-ng
104 %attr(755,root,root) %{_sbindir}/airtun-ng
105 %{_mandir}/man1/aircrack-ng.1*
106 %{_mandir}/man1/airdecap-ng.1*
107 %{_mandir}/man1/airdecloak-ng.1*
108 %{?with_sqlite:%{_mandir}/man1/airolib-ng.1*}
109 %{_mandir}/man1/besside-ng-crawler.1*
110 %{_mandir}/man1/ivstools.1*
111 %{_mandir}/man1/kstats.1*
112 %{_mandir}/man1/makeivs-ng.1*
113 %{_mandir}/man1/packetforge-ng.1*
114 %{_mandir}/man1/wpaclean.1*
115 %{_mandir}/man8/airbase-ng.8*
116 %{_mandir}/man8/aireplay-ng.8*
117 %{_mandir}/man8/airmon-ng.8*
118 %{_mandir}/man8/airodump-ng-oui-update.8*
119 %{_mandir}/man8/airodump-ng.8*
120 %{_mandir}/man8/airserv-ng.8*
121 %{_mandir}/man8/airtun-ng.8*
122 %{_mandir}/man8/besside-ng.8*
123
124 %if %{with experimental}
125 %attr(755,root,root) %{_bindir}/buddy-ng
126 %attr(755,root,root) %{_sbindir}/besside-ng
127 %attr(755,root,root) %{_sbindir}/easside-ng
128 %attr(755,root,root) %{_sbindir}/tkiptun-ng
129 %attr(755,root,root) %{_sbindir}/wesside-ng
130 %{_mandir}/man1/buddy-ng.1*
131 %{_mandir}/man8/easside-ng.8*
132 %{_mandir}/man8/tkiptun-ng.8*
133 %{_mandir}/man8/wesside-ng.8*
134 %endif
This page took 0.080042 seconds and 4 git commands to generate.