]> git.pld-linux.org Git - packages/adobe-flash.git/blob - adobe-flash.spec
- disable autoupdate
[packages/adobe-flash.git] / adobe-flash.spec
1 #
2 # Conditional build:
3 %bcond_with     license_agreement       # generates package
4 #
5 %define         _ver_major      9
6 %define         _ver_minor      0
7 %define         _ver_patch      21
8 %define         _ver_serial     78
9 %define         base_name       macromedia-flash
10 Summary:        Flash plugin for Netscape-compatible WWW browsers
11 Summary(pl):    Wtyczka Flash dla przeglĀ±darek WWW zgodnych z Netscape
12 %if %{with license_agreement}
13 Name:           %{base_name}
14 %else
15 Name:           %{base_name}-installer
16 %endif
17 %define         _rel 2
18 Version:        %{_ver_major}.%{_ver_minor}.%{_ver_patch}.%{_ver_serial}
19 Release:        %{_rel}%{?with_license_agreement:wla}
20 License:        Free to use, non-distributable
21 Group:          X11/Applications/Multimedia
22 %if %{with license_agreement}
23 #Source0:       http://download.macromedia.com/pub/labs/flashplayer9_update/FP9_plugin_beta_101806.tar.gz
24 Source0:        http://download.macromedia.com/pub/labs/flashplayer9_update/FP9_plugin_beta_112006.tar.gz
25 # NoSource0-md5:        3ab408f85ae6d8180cc913edf97bf3eb
26 %else
27 Source0:        license-installer.sh
28 # NoSource0-md5:        3ab408f85ae6d8180cc913edf97bf3eb
29 %endif
30 URL:            http://labs.adobe.com/technologies/flashplayer9/
31 %if %{with license_agreement}
32 BuildRequires:  rpmbuild(macros) >= 1.357
33 Requires:       browser-plugins >= 2.0
34 %else
35 Requires:       rpm-build-tools
36 %endif
37 Obsoletes:      flash-plugin
38 Obsoletes:      konqueror-plugin-macromedia-flash
39 Obsoletes:      mozilla-firefox-plugin-macromedia-flash
40 Obsoletes:      mozilla-plugin-macromedia-flash
41 ExclusiveArch:  %{ix86}
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %define         _sysconfdir     /etc/adobe
45
46 %description
47 Adobe(R) Flash(R) Player is the high-performance, lightweight, highly expressive
48 client runtime that delivers powerful and consistent user experiences across
49 major operating systems, browsers, mobile phones, and devices. Installed on
50 over 700 million Internet-connected desktops and mobile devices, Flash Player
51 enables organizations and individuals to build and deliver great digital
52 experiences to their end users.
53
54 %description -l pl
55 Wtyczka Flash dla przeglĀ±darek WWW zgodnych z Netscape.
56
57 %prep
58 %if %{with license_agreement}
59 %setup -q -n flash-player-plugin-%{_ver_major}.%{_ver_minor}.%{_ver_patch}.%{_ver_serial}
60 %endif
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64 %if %{without license_agreement}
65 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
66
67 sed -e '
68         s/@BASE_NAME@/%{base_name}/g
69         s/@TARGET_CPU@/%{_target_cpu}/g
70         s-@VERSION@-%{version}-g
71         s-@RELEASE@-%{release}-g
72         s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
73 ' %{SOURCE0} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
74
75 install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
76
77 %else
78
79 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_browserpluginsdir}}
80 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/mms.cfg
81 # http://www.adobe.com/cfusion/knowledgebase/index.cfm?id=16701594
82 AutoUpdateDisable=1
83 AutoUpdateInterval=0
84 EOF
85 install *.so $RPM_BUILD_ROOT%{_browserpluginsdir}
86
87 %endif
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %if %{without license_agreement}
93 %post
94 %{_bindir}/%{base_name}.install
95 %else
96 %post
97 %update_browser_plugins
98
99 %postun
100 if [ "$1" = 0 ]; then
101         %update_browser_plugins
102 fi
103 %endif
104
105 %files
106 %defattr(644,root,root,755)
107 %if %{without license_agreement}
108 %attr(755,root,root) %{_bindir}/%{base_name}.install
109 %{_datadir}/%{base_name}
110 %else
111 %doc *.txt
112 %dir %{_sysconfdir}
113 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mms.cfg
114 %attr(755,root,root) %{_browserpluginsdir}/*.so
115 %endif
This page took 0.262942 seconds and 4 git commands to generate.