]> git.pld-linux.org Git - packages/adobe-flash.git/blob - adobe-flash.spec
- use rpmbuild(macros) virtual, not direct package name
[packages/adobe-flash.git] / adobe-flash.spec
1 #
2 # Conditional build:
3 %bcond_with     license_agreement       # generates package
4
5 %define         ver_major       10
6 %define         ver_minor       1
7 %define         ver_patch       53
8 %define         ver_serial      64
9
10 %ifarch %{x8664}
11 %define         libmark         ()(64bit)
12 %else
13 %define         libmark         %{nil}
14 %endif
15
16 %define         base_name       adobe-flash
17 %define         rel 1
18 Summary:        Flash plugin for Netscape-compatible WWW browsers
19 Summary(pl.UTF-8):      Wtyczka Flash dla przeglądarek WWW zgodnych z Netscape
20 %if %{with license_agreement}
21 Name:           %{base_name}
22 %else
23 Name:           %{base_name}-installer
24 %endif
25 Version:        %{ver_major}.%{ver_minor}.%{ver_patch}.%{ver_serial}
26 Release:        %{rel}%{?with_license_agreement:wla}
27 Epoch:          1
28 License:        Free to use, non-distributable
29 Group:          X11/Applications/Multimedia
30 %if %{with license_agreement}
31 Source0:        http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_10_linux.tar.gz
32 # NoSource0-md5:        e4cb4d26124605a54c3d498cc440368f
33 NoSource:       0
34 #Source1:       http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-%{version}.linux-x86_64.so.tar.gz
35 # NoSource1-md5:        4a4561e456612a6751653b58342d53df
36 #NoSource:      1
37 %else
38 Source2:        http://svn.pld-linux.org/svn/license-installer/license-installer.sh
39 # Source2-md5:  329c25f457fea66ec502b7ef70cb9ede
40 %endif
41 URL:            http://www.adobe.com/products/flashplayer/
42 %if %{with license_agreement}
43 BuildRequires:  rpmbuild(macros) >= 1.357
44 BuildRequires:  sed >= 4.0
45 Requires:       browser-plugins >= 2.0
46 # dlopened by player
47 Requires:       libasound.so.2%{libmark}
48 Requires:       libcurl.so.4%{libmark}
49 %else
50 Requires:       rpm-build-tools >= 4.4.37
51 Requires:       rpmbuild(macros) >= 1.544
52 %endif
53 Provides:       browser(flash)
54 Provides:       macromedia-flash
55 Obsoletes:      flash-plugin
56 Obsoletes:      konqueror-plugin-macromedia-flash
57 Obsoletes:      macromedia-flash
58 Obsoletes:      mozilla-firefox-plugin-macromedia-flash
59 Obsoletes:      mozilla-plugin-macromedia-flash
60 ExclusiveArch:  %{ix86}
61 # %{x8664}
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 %define         _sysconfdir     /etc/adobe
65
66 # So that building package on AC system won't write package name dep that Th system can't understand (libstdc++4)
67 %define         _noautoreqdep   libstdc++.so.6
68
69 # No debuginfo to be stored
70 %define         _enable_debug_packages  0
71
72 %description
73 Adobe(R) Flash(R) Player for Linux - the next-generation client
74 runtime for engaging with Flash content and applications on Linux.
75
76 %description -l pl.UTF-8
77 Adobe(R) Flash(R) Player - środowisko nowej generacji do obsługi
78 treści i aplikacji we Flashu pod Linuksem.
79
80 %prep
81 %if %{with license_agreement}
82 %ifarch %{x8664}
83 %setup -q -T -c -b 1
84 %else
85 %setup -q -T -c -b 0
86 %endif
87
88 %build
89 s='LNX %{ver_major},%{ver_minor},%{ver_patch},%{ver_serial}'
90 v=$(strings libflashplayer.so | grep "$s")
91 if [ "$v" != "$s" ]; then
92         : wrong version
93         exit 1
94 fi
95 %endif
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99 %if %{without license_agreement}
100 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
101
102 sed -e '
103         s/@BASE_NAME@/%{base_name}/g
104         s/@TARGET_CPU@/%{_target_cpu}/g
105         s-@VERSION@-%{version}-g
106         s-@RELEASE@-%{release}-g
107         s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
108         s,@DATADIR@,%{_datadir}/%{base_name},g
109 ' %{SOURCE2} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
110
111 install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
112
113 %else
114
115 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_browserpluginsdir}}
116 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/mms.cfg
117 # http://www.adobe.com/cfusion/knowledgebase/index.cfm?id=16701594
118 # http://www.adobe.com/devnet/flashplayer/articles/flash_player_admin_guide.html
119 AutoUpdateDisable=1
120 AutoUpdateInterval=0
121 # OverrideGPUValidation=true
122 EOF
123 install *.so $RPM_BUILD_ROOT%{_browserpluginsdir}
124 %endif
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %if %{without license_agreement}
130 %post
131 %{_bindir}/%{base_name}.install
132 %else
133 %post
134 %update_browser_plugins
135
136 %postun
137 if [ "$1" = 0 ]; then
138         %update_browser_plugins
139 fi
140 %endif
141
142 %files
143 %defattr(644,root,root,755)
144 %if %{without license_agreement}
145 %attr(755,root,root) %{_bindir}/%{base_name}.install
146 %{_datadir}/%{base_name}
147 %else
148 %dir %{_sysconfdir}
149 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mms.cfg
150 %attr(755,root,root) %{_browserpluginsdir}/*.so
151 %endif
This page took 0.115842 seconds and 4 git commands to generate.