]> git.pld-linux.org Git - packages/adobe-flash.git/blob - adobe-flash.spec
- move mms.cfg to package as source
[packages/adobe-flash.git] / adobe-flash.spec
1 #
2 # Conditional build:
3 %bcond_with     license_agreement       # generates package
4
5 %ifarch %{ix86}
6 %define         ver             10.2.152.27
7 %define         libmark %{nil}
8 %endif
9 %ifarch %{x8664}
10 %define         ver             10.3.162.29
11 %define         libmark ()(64bit)
12 %endif
13
14 %define         base_name       adobe-flash
15 %define         rel 1
16 Summary:        Flash plugin for Netscape-compatible WWW browsers
17 Summary(pl.UTF-8):      Wtyczka Flash dla przeglądarek WWW zgodnych z Netscape
18 %if %{with license_agreement}
19 Name:           %{base_name}
20 %else
21 Name:           %{base_name}-installer
22 %endif
23 Version:        %{ver}
24 Release:        %{rel}%{?with_license_agreement:wla}
25 Epoch:          1
26 License:        Free to use, non-distributable
27 Group:          X11/Applications/Multimedia
28 %if %{with license_agreement}
29 #Source0:       http://download.macromedia.com/pub/labs/flashplayer10/flashplayer10_2_p2_32bit_linux_111710.tar.gz
30 #Source0:       http://fpdownload.macromedia.com/get/flashplayer/current/flash-plugin-%{version}-release.i386.rpm
31 Source0:        http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_10_linux.tar.gz
32 # NoSource0-md5:        e9fc57403796a4992474e4f25857ca14
33 NoSource:       0
34 ##Source1:      http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-%{version}.linux-x86_64.so.tar.gz
35 Source1:        http://download.macromedia.com/pub/labs/flashplayer10/flashplayer10_2_p3_64bit_linux_111710.tar.gz
36 # NoSource1-md5:        49b55c7eb8044453e5f6f2e4b3cb4084
37 NoSource:       1
38 Source2:        mms.cfg
39 %else
40 Source3:        http://svn.pld-linux.org/svn/license-installer/license-installer.sh
41 # Source3-md5:  329c25f457fea66ec502b7ef70cb9ede
42 %endif
43 URL:            http://www.adobe.com/products/flashplayer/
44 %if %{with license_agreement}
45 BuildRequires:  rpmbuild(macros) >= 1.357
46 BuildRequires:  sed >= 4.0
47 Requires:       browser-plugins >= 2.0
48 # dlopened by player
49 Requires:       libasound.so.2%{libmark}
50 Requires:       libcurl.so.4%{libmark}
51 %else
52 Requires:       rpm-build-tools >= 4.4.37
53 Requires:       rpmbuild(macros) >= 1.544
54 %endif
55 Provides:       browser(flash)
56 Provides:       macromedia-flash
57 Obsoletes:      flash-plugin
58 Obsoletes:      konqueror-plugin-macromedia-flash
59 Obsoletes:      macromedia-flash
60 Obsoletes:      mozilla-firefox-plugin-macromedia-flash
61 Obsoletes:      mozilla-plugin-macromedia-flash
62 ExclusiveArch:  %{ix86} %{x8664}
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %define         _sysconfdir     /etc/adobe
66
67 # So that building package on AC system won't write package name dep that Th system can't understand (libstdc++4)
68 %define         _noautoreqdep   libstdc++.so.6
69
70 # No debuginfo to be stored
71 %define         _enable_debug_packages  0
72
73 %description
74 Adobe(R) Flash(R) Player for Linux - the next-generation client
75 runtime for engaging with Flash content and applications on Linux.
76
77 %description -l pl.UTF-8
78 Adobe(R) Flash(R) Player - środowisko nowej generacji do obsługi
79 treści i aplikacji we Flashu pod Linuksem.
80
81 %prep
82 %if %{with license_agreement}
83 %ifarch %{x8664}
84 %setup -q -T -c -b 1
85 %else
86 %setup -q -T -c -b 0
87 %endif
88
89 %build
90 s=$(echo 'LNX %{version}' | tr . ,)
91 v=$(strings libflashplayer.so | grep '^LNX ')
92 if [ "$v" != "$s" ]; then
93         : wrong version
94         exit 1
95 fi
96 %endif
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100 %if %{without license_agreement}
101 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
102
103 sed -e '
104         s/@BASE_NAME@/%{base_name}/g
105         s/@TARGET_CPU@/%{_target_cpu}/g
106         s-@VERSION@-%{version}-g
107         s-@RELEASE@-%{release}-g
108         s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
109         s,@DATADIR@,%{_datadir}/%{base_name},g
110 ' %{SOURCE3} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
111
112 cp -p %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
113
114 %else
115
116 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_browserpluginsdir}}
117 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/mms.cfg
118 install -p *.so $RPM_BUILD_ROOT%{_browserpluginsdir}
119 %endif
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %if %{without license_agreement}
125 %post
126 %{_bindir}/%{base_name}.install
127 %else
128 %post
129 %update_browser_plugins
130
131 %postun
132 if [ "$1" = 0 ]; then
133         %update_browser_plugins
134 fi
135 %endif
136
137 %files
138 %defattr(644,root,root,755)
139 %if %{without license_agreement}
140 %attr(755,root,root) %{_bindir}/%{base_name}.install
141 %{_datadir}/%{base_name}
142 %else
143 %dir %{_sysconfdir}
144 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mms.cfg
145 %attr(755,root,root) %{_browserpluginsdir}/*.so
146 %endif
This page took 0.051664 seconds and 4 git commands to generate.