]> git.pld-linux.org Git - packages/adobe-flash.git/blob - adobe-flash.spec
- update x64 beta to 10.0.22.87
[packages/adobe-flash.git] / adobe-flash.spec
1 #
2 # Conditional build:
3 %bcond_with     license_agreement       # generates package
4 #
5 %ifarch %{x8664}
6 %define         ver_major       10
7 %define         ver_minor       0
8 %define         ver_patch       22
9 %define         ver_serial      87
10 %define         libmark         ()(64bit)
11 %else
12 %define         ver_major       10
13 %define         ver_minor       0
14 %define         ver_patch       15
15 %define         ver_serial      3
16 %define         libmark         %{nil}
17 %endif
18 %define         base_name       adobe-flash
19 %define         rel 1
20 Summary:        Flash plugin for Netscape-compatible WWW browsers
21 Summary(pl.UTF-8):      Wtyczka Flash dla przeglądarek WWW zgodnych z Netscape
22 %if %{with license_agreement}
23 Name:           %{base_name}
24 %else
25 Name:           %{base_name}-installer
26 %endif
27 Version:        %{ver_major}.%{ver_minor}.%{ver_patch}.%{ver_serial}
28 Release:        %{rel}%{?with_license_agreement:wla}
29 Epoch:          1
30 License:        Free to use, non-distributable
31 Group:          X11/Applications/Multimedia
32 %if %{with license_agreement}
33 Source0:        http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_10_linux.tar.gz
34 # NoSource0-md5:        afab0b40b0ae11445e2e90a4a9224a8a
35 Source1:        http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-10.0.22.87.linux-x86_64.so.tar.gz
36 # NoSource1-md5:        492d98d25886afcaf18252334d4ac4e2
37 %else
38 Source2:        license-installer.sh
39 %endif
40 URL:            http://www.adobe.com/products/flashplayer/
41 %if %{with license_agreement}
42 BuildRequires:  rpmbuild(macros) >= 1.357
43 BuildRequires:  sed >= 4.0
44 Requires:       browser-plugins >= 2.0
45 # dlopened by player
46 Requires:       libasound.so.2%{libmark}
47 Requires:       libcurl.so.4%{libmark}
48 %else
49 Requires:       rpm-build-tools
50 %endif
51 Provides:       browser(flash)
52 Provides:       macromedia-flash
53 Obsoletes:      flash-plugin
54 Obsoletes:      konqueror-plugin-macromedia-flash
55 Obsoletes:      macromedia-flash
56 Obsoletes:      mozilla-firefox-plugin-macromedia-flash
57 Obsoletes:      mozilla-plugin-macromedia-flash
58 ExclusiveArch:  %{ix86} %{x8664}
59 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61 %define         _sysconfdir     /etc/adobe
62
63 # So that building package on AC system won't write package name dep that Th system can't understand (libstdc++4)
64 %define         _noautoreqdep   libstdc++.so.6
65
66 # No debuginfo to be stored
67 %define         _enable_debug_packages  0
68
69 %description
70 Adobe(R) Flash(R) Player for Linux - the next-generation client
71 runtime for engaging with Flash content and applications on Linux.
72
73 %description -l pl.UTF-8
74 Adobe(R) Flash(R) Player - środowisko nowej generacji do obsługi
75 treści i aplikacji we Flashu pod Linuksem.
76
77 %prep
78 %if %{with license_agreement}
79 %ifarch %{x8664}
80 %setup -q -T -c -b 1
81 %else
82 %setup -q -T -b 0 -n install_flash_player_%{ver_major}_linux
83 %endif
84 %endif
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 %if %{without license_agreement}
89 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
90
91 sed -e '
92         s/@BASE_NAME@/%{base_name}/g
93         s/@TARGET_CPU@/%{_target_cpu}/g
94         s-@VERSION@-%{version}-g
95         s-@RELEASE@-%{release}-g
96         s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
97 ' %{SOURCE2} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
98
99 install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
100
101 %else
102
103 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_browserpluginsdir}}
104 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/mms.cfg
105 # http://www.adobe.com/cfusion/knowledgebase/index.cfm?id=16701594
106 # http://www.adobe.com/devnet/flashplayer/articles/flash_player_admin_guide.html
107 AutoUpdateDisable=1
108 AutoUpdateInterval=0
109 # OverrideGPUValidation=true
110 EOF
111 install *.so $RPM_BUILD_ROOT%{_browserpluginsdir}
112 %endif
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %if %{without license_agreement}
118 %post
119 %{_bindir}/%{base_name}.install
120 %else
121 %post
122 %update_browser_plugins
123
124 %postun
125 if [ "$1" = 0 ]; then
126         %update_browser_plugins
127 fi
128 %endif
129
130 %files
131 %defattr(644,root,root,755)
132 %if %{without license_agreement}
133 %attr(755,root,root) %{_bindir}/%{base_name}.install
134 %{_datadir}/%{base_name}
135 %else
136 %dir %{_sysconfdir}
137 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mms.cfg
138 %attr(755,root,root) %{_browserpluginsdir}/*.so
139 %endif
This page took 0.043343 seconds and 4 git commands to generate.