]> git.pld-linux.org Git - packages/adobe-flash.git/blob - adobe-flash.spec
- revert non-square md5
[packages/adobe-flash.git] / adobe-flash.spec
1 #
2 # Conditional build:
3 %bcond_with     license_agreement       # generates package
4
5 %ifarch %{x8664}
6 %define         ver_major       10
7 %define         ver_minor       2
8 %define         ver_patch       161
9 %define         ver_serial      22
10 %define         libmark         ()(64bit)
11 %else
12 %define         ver_major       10
13 %define         ver_minor       1
14 %define         ver_patch       82
15 %define         ver_serial      76
16 %define         libmark         %{nil}
17 %endif
18
19 %define         base_name       adobe-flash
20 %define         rel 1
21 Summary:        Flash plugin for Netscape-compatible WWW browsers
22 Summary(pl.UTF-8):      Wtyczka Flash dla przeglądarek WWW zgodnych z Netscape
23 %if %{with license_agreement}
24 Name:           %{base_name}
25 %else
26 Name:           %{base_name}-installer
27 %endif
28 Version:        %{ver_major}.%{ver_minor}.%{ver_patch}.%{ver_serial}
29 Release:        %{rel}%{?with_license_agreement:wla}
30 Epoch:          1
31 License:        Free to use, non-distributable
32 Group:          X11/Applications/Multimedia
33 %if %{with license_agreement}
34 Source0:        http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_10_linux.tar.gz
35 # NoSource0-md5:        7f122a6bf62403c2916f37df48c18768
36 NoSource:       0
37 #Source1:       http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-%{version}.linux-x86_64.so.tar.gz
38 Source1:        http://download.macromedia.com/pub/labs/flashplayer10/flashplayer_square_p1_64bit_linux_091510.tar.gz
39 # NoSource1-md5:        338e954c02ba6776b6b8a908e6f96b5f
40 NoSource:       1
41 %else
42 Source2:        http://svn.pld-linux.org/svn/license-installer/license-installer.sh
43 # Source2-md5:  329c25f457fea66ec502b7ef70cb9ede
44 %endif
45 URL:            http://www.adobe.com/products/flashplayer/
46 %if %{with license_agreement}
47 BuildRequires:  rpmbuild(macros) >= 1.357
48 BuildRequires:  sed >= 4.0
49 Requires:       browser-plugins >= 2.0
50 # dlopened by player
51 Requires:       libasound.so.2%{libmark}
52 Requires:       libcurl.so.4%{libmark}
53 %else
54 Requires:       rpm-build-tools >= 4.4.37
55 Requires:       rpmbuild(macros) >= 1.544
56 %endif
57 Provides:       browser(flash)
58 Provides:       macromedia-flash
59 Obsoletes:      flash-plugin
60 Obsoletes:      konqueror-plugin-macromedia-flash
61 Obsoletes:      macromedia-flash
62 Obsoletes:      mozilla-firefox-plugin-macromedia-flash
63 Obsoletes:      mozilla-plugin-macromedia-flash
64 ExclusiveArch:  %{ix86} %{x8664}
65 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
67 %define         _sysconfdir     /etc/adobe
68
69 # So that building package on AC system won't write package name dep that Th system can't understand (libstdc++4)
70 %define         _noautoreqdep   libstdc++.so.6
71
72 # No debuginfo to be stored
73 %define         _enable_debug_packages  0
74
75 %description
76 Adobe(R) Flash(R) Player for Linux - the next-generation client
77 runtime for engaging with Flash content and applications on Linux.
78
79 %description -l pl.UTF-8
80 Adobe(R) Flash(R) Player - środowisko nowej generacji do obsługi
81 treści i aplikacji we Flashu pod Linuksem.
82
83 %prep
84 %if %{with license_agreement}
85 %ifarch %{x8664}
86 %setup -q -T -c -b 1
87 %else
88 %setup -q -T -c -b 0
89 %endif
90
91 %build
92 s='LNX %{ver_major},%{ver_minor},%{ver_patch},%{ver_serial}'
93 v=$(strings libflashplayer.so | grep "$s")
94 if [ "$v" != "$s" ]; then
95         : wrong version
96         exit 1
97 fi
98 %endif
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102 %if %{without license_agreement}
103 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
104
105 sed -e '
106         s/@BASE_NAME@/%{base_name}/g
107         s/@TARGET_CPU@/%{_target_cpu}/g
108         s-@VERSION@-%{version}-g
109         s-@RELEASE@-%{release}-g
110         s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
111         s,@DATADIR@,%{_datadir}/%{base_name},g
112 ' %{SOURCE2} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
113
114 install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
115
116 %else
117
118 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_browserpluginsdir}}
119 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/mms.cfg
120 # http://www.adobe.com/cfusion/knowledgebase/index.cfm?id=16701594
121 # http://www.adobe.com/devnet/flashplayer/articles/flash_player_admin_guide.html
122 AutoUpdateDisable=1
123 AutoUpdateInterval=0
124 # OverrideGPUValidation=true
125 EOF
126 install *.so $RPM_BUILD_ROOT%{_browserpluginsdir}
127 %endif
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %if %{without license_agreement}
133 %post
134 %{_bindir}/%{base_name}.install
135 %else
136 %post
137 %update_browser_plugins
138
139 %postun
140 if [ "$1" = 0 ]; then
141         %update_browser_plugins
142 fi
143 %endif
144
145 %files
146 %defattr(644,root,root,755)
147 %if %{without license_agreement}
148 %attr(755,root,root) %{_bindir}/%{base_name}.install
149 %{_datadir}/%{base_name}
150 %else
151 %dir %{_sysconfdir}
152 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mms.cfg
153 %attr(755,root,root) %{_browserpluginsdir}/*.so
154 %endif
This page took 0.106005 seconds and 4 git commands to generate.