]> git.pld-linux.org Git - packages/adobe-flash.git/blob - adobe-flash.spec
- it provides macromedia-flash too
[packages/adobe-flash.git] / adobe-flash.spec
1 #
2 # Conditional build:
3 %bcond_with     license_agreement       # generates package
4 #
5 %define         _ver_major      9
6 %define         _ver_minor      0
7 %define         _ver_patch      31
8 %define         _ver_serial     0
9 %define         base_name       adobe-flash
10 Summary:        Flash plugin for Netscape-compatible WWW browsers
11 Summary(pl):    Wtyczka Flash dla przeglĀ±darek WWW zgodnych z Netscape
12 %if %{with license_agreement}
13 Name:           %{base_name}
14 %else
15 Name:           %{base_name}-installer
16 %endif
17 %define         _rel 1
18 Version:        %{_ver_major}.%{_ver_minor}.%{_ver_patch}.%{_ver_serial}
19 Release:        %{_rel}%{?with_license_agreement:wla}
20 License:        Free to use, non-distributable
21 Group:          X11/Applications/Multimedia
22 %if %{with license_agreement}
23 Source0:        http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_9_linux.tar.gz
24 # NoSource0-md5:        76b38231a68995935185aa42dfda9db7
25 %else
26 Source0:        license-installer.sh
27 # NoSource0-md5:        76b38231a68995935185aa42dfda9db7
28 %endif
29 URL:            http://www.adobe.com/products/flashplayer/
30 %if %{with license_agreement}
31 BuildRequires:  rpmbuild(macros) >= 1.357
32 Requires:       browser-plugins >= 2.0
33 %else
34 Requires:       rpm-build-tools
35 %endif
36 Provides:       macromedia-flash
37 Obsoletes:      flash-plugin
38 Obsoletes:      konqueror-plugin-macromedia-flash
39 Obsoletes:      macromedia-flash
40 Obsoletes:      mozilla-firefox-plugin-macromedia-flash
41 Obsoletes:      mozilla-plugin-macromedia-flash
42 ExclusiveArch:  %{ix86}
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %define         _sysconfdir     /etc/adobe
46
47 %description
48 Adobe(R) Flash(R) Player is the high-performance, lightweight, highly
49 expressive client runtime that delivers powerful and consistent user
50 experiences across major operating systems, browsers, mobile phones,
51 and devices. Installed on over 700 million Internet-connected desktops
52 and mobile devices, Flash Player enables organizations and individuals
53 to build and deliver great digital experiences to their end users.
54
55 %description -l pl
56 Wtyczka Flash dla przeglĀ±darek WWW zgodnych z Netscape.
57
58 %prep
59 %if %{with license_agreement}
60 %setup -q -n install_flash_player_%{_ver_major}_linux
61 %endif
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65 %if %{without license_agreement}
66 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
67
68 sed -e '
69         s/@BASE_NAME@/%{base_name}/g
70         s/@TARGET_CPU@/%{_target_cpu}/g
71         s-@VERSION@-%{version}-g
72         s-@RELEASE@-%{release}-g
73         s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
74 ' %{SOURCE0} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
75
76 install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
77
78 %else
79
80 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_browserpluginsdir}}
81 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/mms.cfg
82 # http://www.adobe.com/cfusion/knowledgebase/index.cfm?id=16701594
83 AutoUpdateDisable=1
84 AutoUpdateInterval=0
85 EOF
86 install *.so $RPM_BUILD_ROOT%{_browserpluginsdir}
87
88 %endif
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %if %{without license_agreement}
94 %post
95 %{_bindir}/%{base_name}.install
96 %else
97 %post
98 %update_browser_plugins
99
100 %postun
101 if [ "$1" = 0 ]; then
102         %update_browser_plugins
103 fi
104 %endif
105
106 %files
107 %defattr(644,root,root,755)
108 %if %{without license_agreement}
109 %attr(755,root,root) %{_bindir}/%{base_name}.install
110 %{_datadir}/%{base_name}
111 %else
112 %doc *.txt
113 %dir %{_sysconfdir}
114 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mms.cfg
115 %attr(755,root,root) %{_browserpluginsdir}/*.so
116 %endif
This page took 0.06993 seconds and 4 git commands to generate.