]> git.pld-linux.org Git - packages/adobe-flash.git/blob - adobe-flash.spec
- up to stable 10.0.12.36 (version from download page)
[packages/adobe-flash.git] / adobe-flash.spec
1 #
2 # Conditional build:
3 %bcond_with     license_agreement       # generates package
4 #
5 %define         ver_major       10
6 %define         ver_minor       0
7 %define         ver_patch       12
8 %define         ver_serial      36
9 %define         base_name       adobe-flash
10 %define         rel 1
11 Summary:        Flash plugin for Netscape-compatible WWW browsers
12 Summary(pl.UTF-8):      Wtyczka Flash dla przeglądarek WWW zgodnych z Netscape
13 %if %{with license_agreement}
14 Name:           %{base_name}
15 %else
16 Name:           %{base_name}-installer
17 %endif
18 Version:        %{ver_major}.%{ver_minor}.%{ver_patch}.%{ver_serial}
19 Release:        %{rel}%{?with_license_agreement:wla}
20 License:        Free to use, non-distributable
21 Group:          X11/Applications/Multimedia
22 %if %{with license_agreement}
23 Source0:        http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_10_linux.tar.gz
24 # NoSource0-md5:        4777665a6149af11233d8a000b89ffb1
25 %else
26 Source1:        license-installer.sh
27 %endif
28 URL:            http://www.adobe.com/products/flashplayer/
29 %if %{with license_agreement}
30 BuildRequires:  rpmbuild(macros) >= 1.357
31 BuildRequires:  sed >= 4.0
32 Requires:       browser-plugins >= 2.0
33 # apparently dlopened by player
34 Requires:       libasound.so.2
35 Requires:       libcurl.so.4
36 Requires:       libnss3.so
37 %else
38 Requires:       rpm-build-tools
39 %endif
40 Provides:       browser(flash)
41 Provides:       macromedia-flash
42 Obsoletes:      flash-plugin
43 Obsoletes:      konqueror-plugin-macromedia-flash
44 Obsoletes:      macromedia-flash
45 Obsoletes:      mozilla-firefox-plugin-macromedia-flash
46 Obsoletes:      mozilla-plugin-macromedia-flash
47 ExclusiveArch:  %{ix86}
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %define         _sysconfdir     /etc/adobe
51
52 # So that building package on AC system won't write package name dep that Th system can't understand (libstdc++4)
53 %define         _noautoreqdep   libstdc++.so.6
54
55 # No debuginfo to be stored
56 %define         _enable_debug_packages  0
57
58 %description
59 Adobe(R) Flash(R) Player for Linux - the next-generation client
60 runtime for engaging with Flash content and applications on Linux.
61
62 %description -l pl.UTF-8
63 Adobe(R) Flash(R) Player - środowisko nowej generacji do obsługi
64 treści i aplikacji we Flashu pod Linuksem.
65
66 %prep
67 %if %{with license_agreement}
68 %setup -q -n install_flash_player_%{ver_major}_linux
69 %endif
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73 %if %{without license_agreement}
74 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
75
76 sed -e '
77         s/@BASE_NAME@/%{base_name}/g
78         s/@TARGET_CPU@/%{_target_cpu}/g
79         s-@VERSION@-%{version}-g
80         s-@RELEASE@-%{release}-g
81         s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
82 ' %{SOURCE1} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
83
84 install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
85
86 %else
87
88 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_browserpluginsdir}}
89 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/mms.cfg
90 # http://www.adobe.com/cfusion/knowledgebase/index.cfm?id=16701594
91 # http://www.adobe.com/devnet/flashplayer/articles/flash_player_admin_guide.html
92 AutoUpdateDisable=1
93 AutoUpdateInterval=0
94 # OverrideGPUValidation=true
95 EOF
96 install *.so $RPM_BUILD_ROOT%{_browserpluginsdir}
97
98 # HACK: Try if new ABI is compatible
99 sed -i -e 's/libcurl\.so\.3/libcurl.so.4/g' $RPM_BUILD_ROOT%{_browserpluginsdir}/libflashplayer.so
100
101 %endif
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %if %{without license_agreement}
107 %post
108 %{_bindir}/%{base_name}.install
109 %else
110 %post
111 %update_browser_plugins
112
113 %postun
114 if [ "$1" = 0 ]; then
115         %update_browser_plugins
116 fi
117 %endif
118
119 %files
120 %defattr(644,root,root,755)
121 %if %{without license_agreement}
122 %attr(755,root,root) %{_bindir}/%{base_name}.install
123 %{_datadir}/%{base_name}
124 %else
125 %dir %{_sysconfdir}
126 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mms.cfg
127 %attr(755,root,root) %{_browserpluginsdir}/*.so
128 %endif
This page took 0.07683 seconds and 3 git commands to generate.