]> git.pld-linux.org Git - packages/abiword.git/blob - abiword.spec
- BR bonobo-devel
[packages/abiword.git] / abiword.spec
1 # TODO:
2 #    - split into subpackages (plugins)
3 #    - use external wv library
4 Summary:        AbiWord - advanced wordprocessor
5 Summary(pl):    AbiWord - zaawansowany procesor tekstu
6 Name:           abiword
7 Version:        1.0.1
8 Release:        1
9 License:        GPL
10 Group:          X11/Applications
11 Source0:        http://download.sourceforge.net/abiword/%{name}-%{version}.tar.gz
12 Source1:        %{name}.desktop
13 URL:            http://www.abisource.com/
14 BuildRequires:  Aiksaurus-devel
15 BuildRequires:  ImageMagick-c++-devel
16 BuildRequires:  ImageMagick-devel
17 BuildRequires:  ORBit-devel
18 BuildRequires:  autoconf
19 BuildRequires:  automake >= 1.5-8
20 BuildRequires:  bonobo-devel
21 BuildRequires:  bzip2-devel
22 BuildRequires:  expat-devel
23 BuildRequires:  gettext-devel
24 BuildRequires:  gnome-libs-devel
25 BuildRequires:  gnome-vfs-devel
26 BuildRequires:  libjpeg-devel
27 BuildRequires:  libpng-devel
28 BuildRequires:  libtool
29 BuildRequires:  libxml2-devel
30 BuildRequires:  libltdl-devel
31 BuildRequires:  pspell-devel
32 BuildRequires:  readline-devel
33 BuildRequires:  zipios++-devel
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         _prefix         /usr/X11R6
37 %define         _mandir         %{_prefix}/man
38 %define         _sysconfdir     /etc/X11/GNOME
39
40 %description
41 AbiWord is a free word processing program similar to Microsoft Word.
42 It is suitable for typing papers, letters, reports, memos, and so
43 forth.
44
45 %description -l pl
46 AbiWord jest darmowym procesorem tekstu podobnym do Microsoft Word.
47 Jest idealnym narzêdziem do pisania dokumentów, listów, raportów itp.
48
49 %prep
50 %setup -q
51
52 %build
53 cd abi
54 ./autogen.sh
55 gettextize --copy --force
56 if [ -f %{_pkgconfigdir}/libpng12.pc ] ; then
57         CPPFLAGS="`pkg-config libpng12 --cflags`"
58 fi
59 %configure CPPFLAGS="$CPPFLAGS" \
60         --enable-gnome \
61         --enable-bidi \
62         --with-pspell \
63         --with-libjpeg \
64         --with-libxml2 \
65         --with-expat
66 %{__make} -f GNUmakefile
67
68 cd ../abiword-plugins
69 find . -name autogen.sh -type f -exec /bin/sh -c "echo \"libtoolize --copy --force\" >> {}" ";"
70 ./autogen.sh; ./autogen.sh
71 %configure CPPFLAGS="$CPPFLAGS `%{_bindir}/gtk-config --cflags`" \
72         --prefix=%{_libdir}/AbiSuite \
73         --enable-gnome \
74         --with-bzip2 \
75         --with-ImageMagick \
76         --with-abiword=$PWD/../abi/
77 %{__make} -f GNUmakefile
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81 install -d $RPM_BUILD_ROOT{%{_bindir},%{_applnkdir}/Office/Wordprocessors,%{_pixmapsdir}}
82
83 %{__make} -C abi -f GNUmakefile install \
84         DESTDIR=$RPM_BUILD_ROOT
85 %{__make} -C abiword-plugins -f GNUmakefile install \
86         DESTDIR=$RPM_BUILD_ROOT
87
88 ln -sf %{_libdir}/AbiSuite/AbiWord/plugins  $RPM_BUILD_ROOT%{_datadir}/AbiSuite/AbiWord/plugins
89 ln -sf %{_bindir}/AbiWord $RPM_BUILD_ROOT%{_bindir}/abiword
90
91 install %{SOURCE1} $RPM_BUILD_ROOT%{_applnkdir}/Office/Wordprocessors
92 install $RPM_BUILD_ROOT%{_datadir}/AbiSuite/icons/abiword_48.png $RPM_BUILD_ROOT%{_pixmapsdir}
93
94 gzip -9nf abi/CREDITS.TXT
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %files
100 %defattr(644,root,root,755)
101 %doc abi/docs/*.abw abi/*.gz
102 %attr(755,root,root) %{_bindir}/*
103 %{_datadir}/AbiSuite
104 %dir %{_libdir}/AbiSuite
105 %dir %{_libdir}/AbiSuite/AbiWord
106 %dir %{_libdir}/AbiSuite/AbiWord/plugins
107 %attr(755,root,root) %{_libdir}/AbiSuite/AbiWord/plugins/*.so
108 %attr(755,root,root) %{_libdir}/AbiSuite/AbiWord/plugins/*.la
109 %{_applnkdir}/Office/Wordprocessors/*
110 %{_pixmapsdir}/*.png
This page took 0.046345 seconds and 4 git commands to generate.