]> git.pld-linux.org Git - packages/VirtualBox.git/blob - VirtualBox.spec
- dropped obsolete vboxnetflt_export.patch
[packages/VirtualBox.git] / VirtualBox.spec
1 #
2 # TODO:
3 # - Find how to compile with PLD CFLAGS/CXXFLAGS/LDFLAGS.
4 # - Package SDK.
5 # - Package utils (and write initscripts ?) for Guest OS.
6 # - Check License of VBoxGuestAdditions_*.iso, it's propably not GPL v2.
7 #   If so check if it is distributable.
8 #
9 # Conditional build:
10 %bcond_without  dist_kernel     # without distribution kernel
11 %bcond_without  kernel          # don't build kernel module
12 %bcond_without  userspace       # don't build userspace package
13 %bcond_with     verbose
14
15 %if %{without kernel}
16 %undefine       with_dist_kernel
17 %endif
18 %if "%{_alt_kernel}" != "%{nil}"
19 %undefine       with_userspace
20 %endif
21 %if %{without userspace}
22 # nothing to be placed to debuginfo package
23 %define         _enable_debug_packages  0
24 %endif
25
26 %define         rel             1
27 %define         pname   VirtualBox
28 Summary:        VirtualBox OSE - x86 hardware virtualizer
29 Summary(pl.UTF-8):      VirtualBox OSE - wirtualizator sprzętu x86
30 Name:           %{pname}%{_alt_kernel}
31 Version:        2.2.4
32 Release:        %{rel}
33 License:        GPL v2
34 Group:          Applications/Emulators
35 Source0:        http://download.virtualbox.org/virtualbox/%{version}/%{pname}-%{version}-OSE.tar.bz2
36 # Source0-md5:  b90176e3878ccfef2991322b2248dcb0
37 Source1:        http://download.virtualbox.org/virtualbox/%{version}/UserManual.pdf
38 # Source1-md5:  1f8ec67c1dbc0bcdfbbfbe26171eb098
39 Source2:        http://download.virtualbox.org/virtualbox/%{version}/VBoxGuestAdditions_%{version}.iso
40 # Source2-md5:  00e64c25f87155540a3d106c5257530f
41 Source3:        %{pname}-vboxdrv.init
42 Source4:        %{pname}-vboxadd.init
43 Source5:        %{pname}-vboxnetflt.init
44 Source6:        %{pname}-vboxvfs.init
45 Source7:        %{pname}.desktop
46 Source8:        %{pname}.sh
47 Source9:        mount.vdi
48 Patch0:         %{pname}-configure.patch
49 Patch1:         %{pname}-configure-spaces.patch
50 Patch2:         %{pname}-export_modules.patch
51 Patch3:         %{pname}-VBoxSysInfo.patch
52 URL:            http://www.virtualbox.org/
53 BuildRequires:  rpmbuild(macros) >= 1.379
54 %if %{with userspace}
55 %ifarch %{x8664}
56 BuildRequires:  gcc-multilib
57 BuildRequires:  glibc-devel(i686)
58 BuildRequires:  libstdc++-multilib-devel
59 %endif
60 %if "%{pld_release}" == "ac"
61 BuildRequires:  XFree86-devel
62 %else
63 BuildRequires:  xorg-lib-libXcursor-devel
64 BuildRequires:  xorg-lib-libXmu-devel
65 %endif
66 BuildRequires:  OpenGL-devel
67 BuildRequires:  QtGui-devel
68 BuildRequires:  QtNetwork-devel
69 BuildRequires:  SDL-devel >= 1.2.7
70 BuildRequires:  acpica
71 BuildRequires:  alsa-lib-devel >= 1.0.6
72 BuildRequires:  bash
73 BuildRequires:  bcc
74 BuildRequires:  bin86
75 BuildRequires:  gcc >= 5:3.2.3
76 BuildRequires:  libIDL-devel
77 BuildRequires:  libpng-devel >= 1.2.5
78 BuildRequires:  libstdc++-devel >= 5:3.2.3
79 BuildRequires:  libuuid-devel
80 BuildRequires:  libxml2-devel >= 2.6.26
81 BuildRequires:  libxslt-devel >= 1.1.17
82 BuildRequires:  libxslt-progs >= 1.1.17
83 BuildRequires:  pkgconfig
84 BuildRequires:  pulseaudio-devel >= 0.9.0
85 BuildRequires:  python-devel
86 BuildRequires:  qt4-build >= 4.2.0
87 BuildRequires:  qt4-linguist
88 BuildRequires:  sed >= 4.0
89 BuildRequires:  which
90 BuildRequires:  xalan-c-devel >= 1.10.0
91 BuildRequires:  xerces-c-devel >= 2.6.0
92 BuildRequires:  zlib-devel >= 1.2.1
93 BuildRequires:  libcap-static
94 %endif
95 %if %{with dist_kernel}
96 BuildRequires:  kernel%{_alt_kernel}-module-build >= 3:2.6.20
97 %endif
98 Requires(post,preun):   /sbin/chkconfig
99 Requires(postun):       /usr/sbin/groupdel
100 Requires(pre):  /usr/bin/getgid
101 Requires(pre):  /usr/sbin/groupadd
102 Suggests:       gxmessage
103 Provides:       group(vbox)
104 ExclusiveArch:  %{ix86} %{x8664}
105 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
106
107 %ifarch %{x8664}
108 %define         outdir  amd64
109 %else
110 %define         outdir  x86
111 %endif
112
113 %description
114 InnoTek VirtualBox OSE is a general-purpose full virtualizer for x86
115 hardware. Targeted at server, desktop and embedded use, it is now the
116 only professional-quality virtualization solution that is also Open
117 Source Software.
118
119 Some of the features of VirtualBox OSE are:
120
121 Modularity: VirtualBox OSE has an extremely modular design with
122 well-defined internal programming interfaces and a client/server
123 design. This makes it easy to control it from several interfaces at
124 once: for example, you can start a virtual machine in a typical
125 virtual machine GUI and then control that machine from the command
126 line. VirtualBox OSE also comes with a full Software Development Kit:
127 even though it is Open Source Software, you don't have to hack the
128 source to write a new interface for VirtualBox OSE.
129
130 Virtual machine descriptions in XML: the configuration settings of
131 virtual machines are stored entirely in XML and are independent of the
132 local machines. Virtual machine definitions can therefore easily be
133 ported to other computers.
134
135 %description -l pl.UTF-8
136 InnoTek VirtualBox OSE jest emulatorem sprzętu x86. Kierowany do
137 zastosowań serwerowych, desktopowych oraz wbudowanych jest obecnie
138 jedynym wysokiej jakości rozwiązaniem wirtualizacyjnym dostępnym
139 również jako Otwarte Oprogramowanie.
140
141 Przykładowe cechy VirtualBoksa:
142
143 Modularność: VirtualBox OSE jest wysoce zmodularyzowanym produktem z
144 dobrze zaprojektowanym wewnętrznym interfejsem programowym typu
145 klient/serwer. Dzięki temu można łatwo kontrolować go za pomocą
146 różnych interfejsów. Można na przykład uruchomić maszynę wirtualną z
147 poziomu interfejsu graficznego, a później kontrolować ją z linii
148 poleceń. VirtualBox OSE dostarcza również pełny pakiet deweloperski,
149 co pozwala stworzyć dowolny inny interfejs zarządzania maszyną
150 wirtualną.
151
152 Opisy maszyn wirtualnych w XML-u: konfiguracje poszczególnych maszyn
153 wirtualnych są w całości przechowywane w XML-u i są niezależne od
154 lokalnej maszyny. Dzięki temu można szybko i łatwo przenieść
155 konfigurację maszyny wirtualnej na inny komputer.
156
157 %package udev
158 Summary:        udev rules for VirtualBox OSE kernel modules
159 Summary(pl.UTF-8):      Reguły udev dla modułów jądra Linuksa dla VirtualBoksa
160 Release:        %{rel}
161 Group:          Base/Kernel
162 Requires:       udev-core
163
164 %description udev
165 udev rules for VirtualBox OSE kernel modules.
166
167 %description udev -l pl.UTF-8
168 Reguły udev dla modułów jądra Linuksa dla VirtualBoksa.
169
170 %package -n kernel%{_alt_kernel}-misc-vboxadd
171 Summary:        VirtualBox OSE Guest Additions for Linux Module
172 Summary(pl.UTF-8):      Moduł jądra Linuksa dla VirtualBoksa OSE
173 Release:        %{rel}@%{_kernel_ver_str}
174 Group:          Base/Kernel
175 Requires(post,postun):  /sbin/depmod
176 Requires:       dev >= 2.9.0-7
177 %if %{with dist_kernel}
178 %requires_releq_kernel
179 Requires(postun):       %releq_kernel
180 %endif
181 Provides:       kernel(vboxadd) = %{version}-%{rel}
182
183 %description -n kernel%{_alt_kernel}-misc-vboxadd
184 VirtualBox OSE Guest Additions for Linux Module.
185
186 %description -n kernel%{_alt_kernel}-misc-vboxadd -l pl.UTF-8
187 Moduł jądra Linuksa vboxadd dla VirtualBoksa OSE - dodatki dla systemu
188 gościa.
189
190 %package -n kernel%{_alt_kernel}-misc-vboxdrv
191 Summary:        VirtualBox OSE Support Driver
192 Summary(pl.UTF-8):      Moduł jądra Linuksa dla VirtualBoksa OSE
193 Release:        %{rel}@%{_kernel_ver_str}
194 Group:          Base/Kernel
195 Requires(post,postun):  /sbin/depmod
196 Requires:       dev >= 2.9.0-7
197 %if %{with dist_kernel}
198 %requires_releq_kernel
199 Requires(postun):       %releq_kernel
200 %endif
201 Provides:       kernel(vboxdrv) = %{version}-%{rel}
202
203 %description -n kernel%{_alt_kernel}-misc-vboxdrv
204 VirtualBox OSE Support Driver.
205
206 %description -n kernel%{_alt_kernel}-misc-vboxdrv -l pl.UTF-8
207 Moduł jądra Linuksa dla VirtualBoksa OSE - sterownik wsparcia dla
208 systemu głównego.
209
210 %package -n kernel%{_alt_kernel}-misc-vboxnetflt
211 Summary:        VirtualBox OSE Guest Additions for Linux Module
212 Summary(pl.UTF-8):      Moduł jądra Linuksa dla VirtualBoksa OSE
213 Release:        %{rel}@%{_kernel_ver_str}
214 Group:          Base/Kernel
215 Requires(post,postun):  /sbin/depmod
216 Requires:       dev >= 2.9.0-7
217 Requires:       kernel%{_alt_kernel}-misc-vboxdrv
218 %if %{with dist_kernel}
219 %requires_releq_kernel
220 Requires(postun):       %releq_kernel
221 %endif
222 Provides:       kernel(vboxnetflt) = %{version}-%{rel}
223
224 %description -n kernel%{_alt_kernel}-misc-vboxnetflt
225 VirtualBox OSE Network Filter Driver.
226
227 %description -n kernel%{_alt_kernel}-misc-vboxnetflt -l pl.UTF-8
228 Moduł jądra Linuksa dla VirtualBoksa OSE - sterownik filtrowania sieci
229 dla systemu głównego.
230
231 %package -n kernel%{_alt_kernel}-misc-vboxvfs
232 Summary:        Host file system access VFS for VirtualBox OSE
233 Summary(pl.UTF-8):      Moduł jądra Linuksa dla VirtualBoksa OSE
234 Release:        %{rel}@%{_kernel_ver_str}
235 Group:          Base/Kernel
236 Requires(post,postun):  /sbin/depmod
237 Requires:       dev >= 2.9.0-7
238 Requires:       kernel%{_alt_kernel}-misc-vboxadd
239 %if %{with dist_kernel}
240 %requires_releq_kernel
241 Requires(postun):       %releq_kernel
242 %endif
243 Provides:       kernel(vboxvfs) = %{version}-%{rel}
244
245 %description -n kernel%{_alt_kernel}-misc-vboxvfs
246 Host file system access VFS for VirtualBox OSE.
247
248 %description -n kernel%{_alt_kernel}-misc-vboxvfs -l pl.UTF-8
249 Moduł jądra Linuksa dla VirtualBoksa OSE - dostęp do plików systemu
250 głównego z poziomu systemu gościa.
251
252 %package -n kernel%{_alt_kernel}-misc-vboxvideo
253 Summary:        DRM support for VirtualBox OSE
254 Summary(pl.UTF-8):      Moduł jądra Linuksa dla VirtualBoksa OSE
255 Release:        %{rel}@%{_kernel_ver_str}
256 Group:          Base/Kernel
257 Requires(post,postun):  /sbin/depmod
258 Requires:       dev >= 2.9.0-7
259 %if %{with dist_kernel}
260 %requires_releq_kernel
261 Requires(postun):       %releq_kernel
262 %endif
263 Provides:       kernel(vboxvideo) = %{version}-%{rel}
264
265 %description -n kernel%{_alt_kernel}-misc-vboxvideo
266 DRM support for VirtualBox OSE.
267
268 %description -n kernel%{_alt_kernel}-misc-vboxvideo -l pl.UTF-8
269 Moduł jądra Linuksa dla VirtualBoksa OSE - sterownik obsługi DRM.
270
271 %package -n xorg-driver-input-vboxmouse
272 Summary:        X.org mouse driver for VirtualBox OSE guest OS
273 Summary(pl.UTF-8):      Sterownik myszy dla systemu gościa w VirtualBoksie OSE
274 Release:        %{rel}
275 Group:          X11/Applications
276 Requires:       xorg-xserver-server(xinput-abi) >= 4.0
277 Requires:       xorg-xserver-server(xinput-abi) < 5.0
278 Requires:       xorg-xserver-server >= 1.0.99.901
279
280 %description -n xorg-driver-input-vboxmouse
281 X.org mouse driver for VirtualBox OSE guest OS.
282
283 %description -n xorg-driver-input-vboxmouse  -l pl.UTF-8
284 Sterownik myszy dla systemu gościa w VirtualBoksie.
285
286 %package -n xorg-driver-video-vboxvideo
287 Summary:        X.org video driver for VirtualBox OSE guest OS
288 Summary(pl.UTF-8):      Sterownik grafiki dla systemu gościa w VirtualBoksie OSE
289 Release:        %{rel}
290 Group:          X11/Applications
291 Requires:       xorg-xserver-server(videodrv-abi) < 6.0
292 Requires:       xorg-xserver-server(videodrv-abi) >= 2.0
293 Requires:       xorg-xserver-server >= 1.0.99.901
294
295 %description -n xorg-driver-video-vboxvideo
296 X.org video driver for VirtualBox OSE guest OS.
297
298 %description -n xorg-driver-video-vboxvideo -l pl.UTF-8
299 Sterownik grafiki dla systemu gościa w VirtualBoksie OSE.
300
301 %prep
302 %setup -q -n %{pname}-%{version}_OSE
303 %patch0 -p1
304 %patch1 -p1
305 %patch2 -p1
306 %patch3 -p1
307
308 cat <<'EOF' > udev.conf
309 KERNEL=="vboxdrv", NAME="%k", GROUP="vbox", MODE="0660"
310 KERNEL=="vboxadd", NAME="%k", GROUP="vbox", MODE="0660"
311 EOF
312
313 install %{SOURCE1} .
314 sed 's#@LIBDIR@#%{_libdir}#' < %{SOURCE8} > VirtualBox-wrapper.sh
315
316 rm -rf PLD-MODULE-BUILD && mkdir PLD-MODULE-BUILD && cd PLD-MODULE-BUILD
317 ../src/VBox/Additions/linux/export_modules modules.tar.gz
318         tar -zxf modules.tar.gz && rm -f modules.tar.gz
319 ../src/VBox/HostDrivers/linux/export_modules modules.tar.gz --without-hardening && \
320         tar -zxf modules.tar.gz && rm -f modules.tar.gz
321 #./src/VBox/HostDrivers/Support/linux/Makefile:70:
322 #./PLD-MODULE-BUILD/vboxdrv/Makefile:70:
323
324
325 %build
326 %if %{with userspace}
327 ./configure \
328         --with-gcc="%{__cc}" \
329         --with-g++="%{__cxx}" \
330         --disable-hardening \
331         --disable-kmods
332
333 . ./env.sh && \
334 kmk -j1 %{?with_verbose:KBUILD_VERBOSE=3} USER=$(id -un)
335 %endif
336
337 %if %{with kernel}
338 cd PLD-MODULE-BUILD
339 %build_kernel_modules -m vboxadd -C vboxadd
340 %build_kernel_modules -m vboxdrv -C vboxdrv
341 %build_kernel_modules -m vboxnetflt -C vboxnetflt
342 cp -a vboxadd/Module.symvers vboxvfs
343 %build_kernel_modules -m vboxvfs -C vboxvfs -c
344 %build_kernel_modules -m vboxvideo -C vboxvideo_drm
345 cd ..
346 %endif
347
348 %install
349 rm -rf $RPM_BUILD_ROOT
350
351 %if %{with userspace}
352 install -d \
353         $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_desktopdir}} \
354         $RPM_BUILD_ROOT%{_libdir}/VirtualBox \
355         $RPM_BUILD_ROOT/sbin
356
357 install %{SOURCE9} $RPM_BUILD_ROOT/sbin/mount.vdi
358 install VirtualBox-wrapper.sh $RPM_BUILD_ROOT%{_libdir}/VirtualBox
359 for f in {VBox{BFE,Headless,Manage,SDL,SVC,Tunctl,XPCOMIPCD},VirtualBox}; do
360         install out/linux.%{outdir}/release/bin/$f $RPM_BUILD_ROOT%{_libdir}/VirtualBox/$f
361         ln -s %{_libdir}/VirtualBox/VirtualBox-wrapper.sh $RPM_BUILD_ROOT%{_bindir}/$f
362 done
363
364 install out/linux.%{outdir}/release/bin/VBox*.so \
365         $RPM_BUILD_ROOT%{_libdir}/VirtualBox
366 install out/linux.%{outdir}/release/bin/{VBox{DD,DD2}{GC.gc,R0.r0},VMM{GC.gc,R0.r0}} \
367         $RPM_BUILD_ROOT%{_libdir}/VirtualBox
368 install out/linux.%{outdir}/release/bin/VBoxSysInfo.sh \
369         $RPM_BUILD_ROOT%{_libdir}/VirtualBox
370
371 install -d $RPM_BUILD_ROOT%{_libdir}/VirtualBox/additions
372 install -d $RPM_BUILD_ROOT%{_libdir}/VirtualBox/nls
373
374 install %{SOURCE2} $RPM_BUILD_ROOT%{_libdir}/VirtualBox/additions/VBoxGuestAdditions.iso
375 cp -a out/linux.%{outdir}/release/bin/components $RPM_BUILD_ROOT%{_libdir}/VirtualBox
376 cp -a out/linux.%{outdir}/release/bin/nls/* $RPM_BUILD_ROOT%{_libdir}/VirtualBox/nls
377
378 install out/linux.%{outdir}/release/bin/additions/mountvboxsf           \
379         $RPM_BUILD_ROOT%{_bindir}
380
381 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{drivers,input}
382
383 install out/linux.%{outdir}/release/bin/additions/vboxmouse_drv_16.so   \
384         $RPM_BUILD_ROOT%{_libdir}/xorg/modules/input/vboxmouse_drv.so
385 install out/linux.%{outdir}/release/bin/additions/vboxvideo_drv_16.so   \
386         $RPM_BUILD_ROOT%{_libdir}/xorg/modules/drivers/vboxvideo_drv.so
387
388 install out/linux.%{outdir}/release/bin/VBox.png $RPM_BUILD_ROOT%{_pixmapsdir}/VBox.png
389 install %{SOURCE7} $RPM_BUILD_ROOT%{_desktopdir}/%{pname}.desktop
390
391 install -d $RPM_BUILD_ROOT/etc/udev/rules.d
392 install udev.conf $RPM_BUILD_ROOT/etc/udev/rules.d/virtualbox.rules
393 %endif
394
395 %if %{with kernel}
396 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
397 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/vboxdrv
398 install %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/vboxadd
399 install %{SOURCE5} $RPM_BUILD_ROOT/etc/rc.d/init.d/vboxnetflt
400 install %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/vboxvfs
401 %install_kernel_modules -m PLD-MODULE-BUILD/vboxadd/vboxadd -d misc
402 %install_kernel_modules -m PLD-MODULE-BUILD/vboxdrv/vboxdrv -d misc
403 %install_kernel_modules -m PLD-MODULE-BUILD/vboxnetflt/vboxnetflt -d misc
404 %install_kernel_modules -m PLD-MODULE-BUILD/vboxvfs/vboxvfs -d misc
405 %install_kernel_modules -m PLD-MODULE-BUILD/vboxvideo_drm/vboxvideo -d misc
406 %endif
407
408 %clean
409 rm -rf $RPM_BUILD_ROOT
410
411 %pre
412 %groupadd -g 221 -r -f vbox
413
414 %post
415 cat << 'EOF'
416 You must also install kernel module for this software to work:
417     kernel-misc-vboxdrv-%{version}-%{rel}@%{_kernel_ver_str}
418
419 Additionally you might want to install:
420     kernel-misc-vboxnetflt-%{version}-%{rel}@%{_kernel_ver_str}
421
422 On guest Linux system you might want to install:
423     kernel-misc-vboxadd-%{version}-%{rel}@%{_kernel_ver_str}
424     kernel-misc-vboxvfs-%{version}-%{rel}@%{_kernel_ver_str}
425     kernel-misc-vboxvideo-%{version}-%{rel}@%{_kernel_ver_str}
426
427 NOTE: for different kernel brands append after word kernel the brand, like:
428     kernel-desktop-misc-vboxdrv-%{version}-%{rel}@%{_kernel_ver_str}
429     kernel-laptop-misc-vboxdrv-%{version}-%{rel}@%{_kernel_ver_str}
430     kernel-vanilla-misc-vboxdrv-%{version}-%{rel}@%{_kernel_ver_str}
431     ...etc.
432
433 Depending on which kernel brand You use.
434
435 EOF
436
437 %postun
438 if [ "$1" = "0" ]; then
439         %groupremove vbox
440 fi
441
442 %post   -n kernel%{_alt_kernel}-misc-vboxadd
443 %depmod %{_kernel_ver}
444 /sbin/chkconfig --add vboxadd
445 %service vboxadd restart "VirtualBox OSE guest additions driver"
446
447 %postun -n kernel%{_alt_kernel}-misc-vboxadd
448 %depmod %{_kernel_ver}
449
450 %preun -n kernel%{_alt_kernel}-misc-vboxadd
451 if [ "$1" = "0" ]; then
452         %service vboxadd stop
453         /sbin/chkconfig --del vboxadd
454 fi
455
456 %post   -n kernel%{_alt_kernel}-misc-vboxdrv
457 %depmod %{_kernel_ver}
458 /sbin/chkconfig --add vboxdrv
459 %service vboxdrv restart "VirtualBox OSE driver"
460
461 %postun -n kernel%{_alt_kernel}-misc-vboxdrv
462 %depmod %{_kernel_ver}
463
464 %preun -n kernel%{_alt_kernel}-misc-vboxdrv
465 if [ "$1" = "0" ]; then
466         %service vboxdrv stop
467         /sbin/chkconfig --del vboxdrv
468 fi
469
470 %post   -n kernel%{_alt_kernel}-misc-vboxnetflt
471 %depmod %{_kernel_ver}
472 /sbin/chkconfig --add vboxnetflt
473 %service vboxnetflt restart "VirtualBox OSE Network Filter driver"
474
475 %postun -n kernel%{_alt_kernel}-misc-vboxnetflt
476 %depmod %{_kernel_ver}
477
478 %preun -n kernel%{_alt_kernel}-misc-vboxnetflt
479 if [ "$1" = "0" ]; then
480         %service vboxnetflt stop
481         /sbin/chkconfig --del vboxnetflt
482 fi
483
484 %post   -n kernel%{_alt_kernel}-misc-vboxvfs
485 %depmod %{_kernel_ver}
486 /sbin/chkconfig --add vboxvfs
487 %service vboxvfs restart "VirtualBox OSE guest additions VFS driver"
488
489 %postun -n kernel%{_alt_kernel}-misc-vboxvfs
490 %depmod %{_kernel_ver}
491
492 %preun -n kernel%{_alt_kernel}-misc-vboxvfs
493 if [ "$1" = "0" ]; then
494         %service vboxvfs stop
495         /sbin/chkconfig --del vboxvfs
496 fi
497
498 %post   -n kernel%{_alt_kernel}-misc-vboxvideo
499 %depmod %{_kernel_ver}
500
501 %postun -n kernel%{_alt_kernel}-misc-vboxvideo
502 %depmod %{_kernel_ver}
503
504 %if %{with userspace}
505 %files
506 %defattr(644,root,root,755)
507 %doc UserManual.pdf
508 %dir %{_libdir}/VirtualBox
509 %dir %{_libdir}/VirtualBox/additions
510 %dir %{_libdir}/VirtualBox/components
511 %dir %{_libdir}/VirtualBox/nls
512 %attr(755,root,root) %{_bindir}/mountvboxsf
513 %attr(755,root,root) %{_bindir}/VBox*
514 %attr(755,root,root) %{_bindir}/VirtualBox
515 %attr(755,root,root) /sbin/mount.vdi
516 %attr(755,root,root) %{_libdir}/VirtualBox/VBoxSVC
517 %attr(755,root,root) %{_libdir}/VirtualBox/VBoxBFE
518 %attr(755,root,root) %{_libdir}/VirtualBox/VBoxHeadless
519 %attr(755,root,root) %{_libdir}/VirtualBox/VBoxManage
520 %attr(755,root,root) %{_libdir}/VirtualBox/VBoxSDL
521 %attr(755,root,root) %{_libdir}/VirtualBox/VBoxTunctl
522 %attr(755,root,root) %{_libdir}/VirtualBox/VBoxXPCOMIPCD
523 %attr(755,root,root) %{_libdir}/VirtualBox/VBox*.so
524 %attr(755,root,root) %{_libdir}/VirtualBox/VirtualBox
525 %attr(755,root,root) %{_libdir}/VirtualBox/VirtualBox-wrapper.sh
526 %attr(755,root,root) %{_libdir}/VirtualBox/VBoxSysInfo.sh
527 %{_libdir}/VirtualBox/*.gc
528 %{_libdir}/VirtualBox/*.r0
529 %{_libdir}/VirtualBox/additions/*
530 %{_libdir}/VirtualBox/components/*
531 %lang(ar) %{_libdir}/VirtualBox/nls/*_ar.qm
532 %lang(bg) %{_libdir}/VirtualBox/nls/*_bg.qm
533 %lang(ca) %{_libdir}/VirtualBox/nls/*_ca.qm
534 %lang(cs) %{_libdir}/VirtualBox/nls/*_cs.qm
535 %lang(de) %{_libdir}/VirtualBox/nls/*_de.qm
536 %lang(el) %{_libdir}/VirtualBox/nls/*_el.qm
537 %lang(es) %{_libdir}/VirtualBox/nls/*_es.qm
538 %lang(eu) %{_libdir}/VirtualBox/nls/*_eu.qm
539 %lang(fi) %{_libdir}/VirtualBox/nls/*_fi.qm
540 %lang(fr) %{_libdir}/VirtualBox/nls/*_fr.qm
541 %lang(hu) %{_libdir}/VirtualBox/nls/*_hu.qm
542 %lang(id) %{_libdir}/VirtualBox/nls/*_id.qm
543 %lang(it) %{_libdir}/VirtualBox/nls/*_it.qm
544 %lang(ja) %{_libdir}/VirtualBox/nls/*_ja.qm
545 %lang(km_KH) %{_libdir}/VirtualBox/nls/*_km_KH.qm
546 %lang(ko) %{_libdir}/VirtualBox/nls/*_ko.qm
547 %lang(nl) %{_libdir}/VirtualBox/nls/*_nl.qm
548 %lang(pl) %{_libdir}/VirtualBox/nls/*_pl.qm
549 %lang(pt) %{_libdir}/VirtualBox/nls/*_pt.qm
550 %lang(pt_BR) %{_libdir}/VirtualBox/nls/*_pt_BR.qm
551 %lang(ro) %{_libdir}/VirtualBox/nls/*_ro.qm
552 %lang(ru) %{_libdir}/VirtualBox/nls/*_ru.qm
553 %lang(sk) %{_libdir}/VirtualBox/nls/*_sk.qm
554 %lang(sr) %{_libdir}/VirtualBox/nls/*_sr.qm
555 %lang(sv) %{_libdir}/VirtualBox/nls/*_sv.qm
556 %lang(tr) %{_libdir}/VirtualBox/nls/*_tr.qm
557 %lang(zh_CN) %{_libdir}/VirtualBox/nls/*_zh_CN.qm
558 %lang(zh_TW) %{_libdir}/VirtualBox/nls/*_zh_TW.qm
559 %{_pixmapsdir}/VBox.png
560 %{_desktopdir}/%{pname}.desktop
561
562 %files udev
563 %defattr(644,root,root,755)
564 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/virtualbox.rules
565
566 %files -n xorg-driver-input-vboxmouse
567 %defattr(644,root,root,755)
568 %attr(755,root,root) %{_libdir}/xorg/modules/input/vboxmouse_drv.so
569
570 %files -n xorg-driver-video-vboxvideo
571 %defattr(644,root,root,755)
572 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/vboxvideo_drv.so
573 %endif
574
575 %if %{with kernel}
576 %files -n kernel%{_alt_kernel}-misc-vboxadd
577 %defattr(644,root,root,755)
578 %attr(754,root,root) /etc/rc.d/init.d/vboxadd
579 /lib/modules/%{_kernel_ver}/misc/vboxadd.ko*
580
581 %files -n kernel%{_alt_kernel}-misc-vboxdrv
582 %defattr(644,root,root,755)
583 %attr(754,root,root) /etc/rc.d/init.d/vboxdrv
584 /lib/modules/%{_kernel_ver}/misc/vboxdrv.ko*
585
586 %files -n kernel%{_alt_kernel}-misc-vboxnetflt
587 %defattr(644,root,root,755)
588 %attr(754,root,root) /etc/rc.d/init.d/vboxnetflt
589 /lib/modules/%{_kernel_ver}/misc/vboxnetflt.ko*
590
591 %files -n kernel%{_alt_kernel}-misc-vboxvfs
592 %defattr(644,root,root,755)
593 %attr(754,root,root) /etc/rc.d/init.d/vboxvfs
594 /lib/modules/%{_kernel_ver}/misc/vboxvfs.ko*
595 %endif
596
597 %files -n kernel%{_alt_kernel}-misc-vboxvideo
598 %defattr(644,root,root,755)
599 /lib/modules/%{_kernel_ver}/misc/vboxvideo.ko*
600 %endif
This page took 0.067171 seconds and 4 git commands to generate.