]> git.pld-linux.org Git - packages/SFML.git/blob - SFML.spec
- unconditional noarch subpackages
[packages/SFML.git] / SFML.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4
5 Summary:        SFML - Simple and Fast Multimedia Library
6 Summary(pl.UTF-8):      SFML - prosta i szybka biblioteka multimedialna
7 Name:           SFML
8 Version:        2.1
9 Release:        7
10 License:        BSD-like
11 Group:          Libraries
12 Source0:        http://sfml-dev.org/download/sfml/2.1/%{name}-%{version}-sources.zip
13 # Source0-md5:  2de81448733f3f46964f23f41cd42e92
14 Patch0:         %{name}-glx.patch
15 URL:            http://sfml-dev.org/
16 BuildRequires:  OpenAL-devel
17 BuildRequires:  OpenGL-devel
18 BuildRequires:  cmake >= 2.8
19 %{?with_apidocs:BuildRequires:  doxygen}
20 BuildRequires:  freetype-devel >= 2
21 BuildRequires:  glew-devel
22 BuildRequires:  libjpeg-devel
23 BuildRequires:  libsndfile-devel
24 BuildRequires:  libstdc++-devel
25 BuildRequires:  xorg-lib-libX11-devel
26 BuildRequires:  xorg-lib-libXrandr-devel
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 SFML is a simple, fast, cross-platform and object-oriented multimedia
31 API. It provides access to windowing, graphics, audio and network. It
32 is written in C++, and has bindings for various languages such as C,
33 .NET, Ruby, Python.
34
35 %description -l pl.UTF-8
36 SFML to prosta, szybka, wieloplatformowa biblioteka multimedialna z
37 API zorientowanym obiektowo. Zapewnia dostęp do okienek, grafiki,
38 dźwięku i sieci. Jest napisana w C++ i ma dowiązania do różnych innych
39 języków, takich jak C, .NET, Ruby, Python.
40
41 %package devel
42 Summary:        Header files for SFML library
43 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SFML
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46 Requires:       OpenGL-devel
47 Requires:       libstdc++-devel
48
49 %description devel
50 Header files for SFML library.
51
52 %description devel -l pl.UTF-8
53 Pliki nagłówkowe biblioteki SFML.
54
55 %package apidocs
56 Summary:        SFML API documentation
57 Summary(pl.UTF-8):      Dokumentacja API biblioteki SFML
58 Group:          Documentation
59 BuildArch:      noarch
60
61 %description apidocs
62 API documentation for SFML library.
63
64 %description apidocs -l pl.UTF-8
65 Dokumentacja API biblioteki SFML.
66
67 %prep
68 %setup -q
69 %patch0 -p1
70
71 # use system files
72 %{__rm} -r src/SFML/Window/glext
73
74 %build
75 %cmake . \
76         %{?with_apidocs:-DSFML_BUILD_DOC=ON}
77 %{__make}
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81
82 %{__make} install \
83         DESTDIR=$RPM_BUILD_ROOT
84
85 # packaged as %doc
86 %{__rm} $RPM_BUILD_ROOT%{_datadir}/SFML/*.txt
87 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/SFML/doc
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %post   -p /sbin/ldconfig
93 %postun -p /sbin/ldconfig
94
95 %files
96 %defattr(644,root,root,755)
97 %doc license.txt readme.txt
98 %attr(755,root,root) %{_libdir}/libsfml-audio.so.*.*
99 %attr(755,root,root) %ghost %{_libdir}/libsfml-audio.so.2
100 %attr(755,root,root) %{_libdir}/libsfml-graphics.so.*.*
101 %attr(755,root,root) %ghost %{_libdir}/libsfml-graphics.so.2
102 %attr(755,root,root) %{_libdir}/libsfml-network.so.*.*
103 %attr(755,root,root) %ghost %{_libdir}/libsfml-network.so.2
104 %attr(755,root,root) %{_libdir}/libsfml-system.so.*.*
105 %attr(755,root,root) %ghost %{_libdir}/libsfml-system.so.2
106 %attr(755,root,root) %{_libdir}/libsfml-window.so.*.*
107 %attr(755,root,root) %ghost %{_libdir}/libsfml-window.so.2
108
109 %files devel
110 %defattr(644,root,root,755)
111 %attr(755,root,root) %{_libdir}/libsfml-audio.so
112 %attr(755,root,root) %{_libdir}/libsfml-graphics.so
113 %attr(755,root,root) %{_libdir}/libsfml-network.so
114 %attr(755,root,root) %{_libdir}/libsfml-system.so
115 %attr(755,root,root) %{_libdir}/libsfml-window.so
116 %{_includedir}/SFML
117 %{_pkgconfigdir}/sfml-all.pc
118 %{_pkgconfigdir}/sfml-audio.pc
119 %{_pkgconfigdir}/sfml-graphics.pc
120 %{_pkgconfigdir}/sfml-network.pc
121 %{_pkgconfigdir}/sfml-system.pc
122 %{_pkgconfigdir}/sfml-window.pc
123 %dir %{_datadir}/SFML
124 %{_datadir}/SFML/cmake
125
126 %if %{with apidocs}
127 %files apidocs
128 %defattr(644,root,root,755)
129 %doc doc/html/*
130 %endif
This page took 0.071065 seconds and 4 git commands to generate.