]> git.pld-linux.org Git - packages/R.git/blob - R.spec
- release 1
[packages/R.git] / R.spec
1 # TODO:
2 # - move perl R libraries to standard perl location
3 # - script for rpm to autoprovides/autorequires R internals
4 #
5 # Conditional build:
6 %bcond_without  gnome   # without GNOME support
7 #
8 Summary:        A language for data analysis and graphics
9 Summary(pl):    Jêzyk do analizy danych oraz grafiki
10 Name:           R
11 Version:        2.0.1
12 Release:        1
13 License:        Mixed (distributable), mostly GPL
14 Group:          Development/Languages
15 # CRAN master site: ftp://cran.r-project.org/pub/R/src/
16 Source0:        ftp://stat.ethz.ch/R-CRAN/src/base/R-2/%{name}-%{version}.tar.gz
17 # Source0-md5:  fb47b1fdef4323031e24d541a2f36b2b
18 # Source0-size: 10676072
19 Source1:        %{name}.desktop
20 URL:            http://www.r-project.org/
21 BuildRequires:  XFree86-devel
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 BuildRequires:  blas-devel
25 BuildRequires:  gcc-c++
26 BuildRequires:  gcc-g77
27 BuildRequires:  gettext-devel
28 BuildRequires:  libjpeg-devel >= 6b
29 BuildRequires:  libpng-devel >= 1.0.5
30 BuildRequires:  libstdc++-devel
31 BuildRequires:  libtool
32 BuildRequires:  libxml-devel
33 BuildRequires:  perl-base >= 1:5.6
34 BuildRequires:  readline-devel
35 BuildRequires:  tetex-latex
36 BuildRequires:  tetex-dvips
37 BuildRequires:  tetex-pdftex
38 BuildRequires:  zip
39 BuildRequires:  zlib >= 1.1.3
40 #BuildRequires: lpr
41 #Requires:      lpr
42 %{?with_gnome:BuildRequires:    gnome-libs-devel}
43 %{?with_gnome:BuildRequires:    ORBit-devel}
44 %{?with_gnome:BuildRequires:    libglade-gnome-devel}
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 A system for statistical computation and graphics. R consists of a
49 language plus a run-time environment with graphics, a debugger, access
50 to certain system functions, and the ability to run programs stored in
51 script files.
52
53 The design of R has been heavily influenced by two existing languages:
54 Becker, Chambers & Wilks' S and Sussman's Scheme. Whereas the
55 resulting language is very similar in appearance to S, the underlying
56 implementation and semantics are derived from Scheme.
57
58 %description -l pl
59 System do obliczeñ statystycznych i grafiki. R sk³ada siê z jêzyka
60 oraz ¶rodowiska uruchomieniowego z grafik±, debuggerem, dostêpem do
61 niektórych funkcji systemowych oraz mo¿liwo¶ci± uruchamiania programów
62 zapisanych w skryptach.
63
64 Jêzyk R by³ zainspirowany dwoma istniej±cymi jêzykami: S (Beckera,
65 Chambersa i Wilksa) oraz Scheme (Sussmana). R jest podobny do S, ale
66 implementacja i semantyka wywodzi siê ze Scheme.
67
68 %package base
69 Summary:        The R base distribution
70 Summary(pl):    Podstawowa dystrybucja R
71 License:        GPL v2 / LGPL
72 Group:          Development/Languages
73 Requires(post): textutils
74 Requires(post): perl-base
75 Provides:       R-cran-base
76 Provides:       R-cran-datasets
77 Provides:       R-cran-grid
78 Provides:       R-cran-graphics
79 Provides:       R-cran-grDevices
80 Provides:       R-cran-methods
81 Provides:       R-cran-utils
82 Provides:       R-cran-tcltk
83 Provides:       R-cran-splines
84 Provides:       R-cran-stats
85 Provides:       R-cran-stats4
86 Provides:       R-cran-tools
87
88 %description base
89 R is a language and run-time environment for carrying out interactive
90 statistical data analysis. It is not entirely dissimilar to the S
91 language developed at AT&T Bell Laboratories (and now Lucent
92 Technologies). Indeed, S users will find the environment quite
93 familiar and a good deal of S software will run without change under
94 R.
95
96 %description base -l pl
97 R jest jêzykiem i ¶rodowiskiem uruchomieniowym do interaktywnej
98 analizy danych statystycznych. R nie jest ca³kowicie zgodny z jêzykiem
99 S opracowanym w AT&T Bell Laboratiories (a teraz Lucent Technologies),
100 mimo to u¿ytkownicy S zauwa¿± zbli¿one ¶rodowisko, a du¿a czê¶æ
101 oprogramowania w S bêdzie dzia³a³a bez zmian w R.
102
103 %package recommended
104 Summary:        Recommended contributed packages for the R language
105 Summary(pl):    Zalecane dodatkowe pakiety do jêzyka R
106 Group:          Development/Languages
107 Requires:       R-cran-KernSmooth
108 Requires:       R-cran-VR
109 Requires:       R-boot
110 Requires:       R-cran-cluster
111 Requires:       R-cran-foreign
112 Requires:       R-cran-lattice
113 Requires:       R-cran-mgcv
114 Requires:       R-cran-nlme
115 Requires:       R-cran-rpart
116 Requires:       R-cran-survival
117 License:        GPL, free or free for non-commercial use
118 URL:            http://www.ci.tuwien.ac.at/R/
119 Requires(post,postun):  R-base
120 Requires(post,postun):  perl-base
121 Requires(post,postun):  textutils
122 Requires:       R-base = %{version}-%{release}
123
124 %description recommended
125 Packages which extend the capabilities of the R base distribution and
126 are distributed on the Comprehensive R Archive Network (CRAN).
127
128 %description recommended -l pl
129 Pakiety rozszerzaj±ce mo¿liwo¶ci podstawowej dystrybucji jêzyka R,
130 dystrubuowane w archiwum CRAN (Comprehensive R Archive Network).
131
132 %prep
133 %setup -q
134
135 # These files have the path for Perl hard-coded as /usr/local/bin/perl
136 # We need to remove them to avoid dependency problems
137 rm -f ./doc/keyword-test.orig ./etc/undoc/R-funs.orig ./etc/undoc/extrExamp.orig
138
139 %build
140 %{__aclocal} -I m4
141 %{__autoconf}
142 cp -f /usr/share/automake/config.* .
143 %configure \
144         --with%{!?with_gnome:out}-gnome \
145         --enable-R-shlib \
146         --enable-linux-lfs \
147         --with-zlib \
148         --with-bzlib \
149         --with-pcre \
150         --without-recommended-packages
151
152 %{__make}
153 %{__make} check
154 %{__make} docs
155 %{__make} help
156 %{__make} html
157 %{__make} info
158
159 %install
160 rm -rf $RPM_BUILD_ROOT
161 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/R,%{_includedir},%{_desktopdir}}
162
163 %{__make} install \
164         rhome=$RPM_BUILD_ROOT%{_libdir}/R \
165         mandir=$RPM_BUILD_ROOT%{_mandir} \
166         bindir=$RPM_BUILD_ROOT%{_bindir} \
167         
168
169 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
170
171 find $RPM_BUILD_ROOT%{_libdir}/R -name 'Makefile*' -exec rm -f {} \;
172 mv $RPM_BUILD_ROOT%{_libdir}/R/lib/libR*.so $RPM_BUILD_ROOT%{_libdir}
173 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/include $RPM_BUILD_ROOT%{_includedir}/R
174 ln -sf %{_includedir}/R $RPM_BUILD_ROOT%{_libdir}/R/include
175 rm $RPM_BUILD_ROOT%{_bindir}/%{name}
176 sed -i -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/%{name}
177 ln -sf %{_libdir}/%{name}/bin/%{name} $RPM_BUILD_ROOT%{_bindir}/%{name}
178
179 %clean
180 rm -rf $RPM_BUILD_ROOT
181
182 %post
183 (cd %{_libdir}/R/library; umask 022; cat */CONTENTS > ../doc/html/search/index.txt
184  R_HOME=%{_libdir}/R ../bin/Rcmd perl ../share/perl/build-help.pl --htmllist)
185 /sbin/ldconfig
186
187 %postun -p /sbin/ldconfig
188
189 %files base
190 %defattr(644,root,root,755)
191 %doc COPYRIGHTS FAQ NEWS README RESOURCES THANKS Y2K
192
193 %{_mandir}/man1/R.1*
194 %attr(755,root,root) %{_bindir}/R
195 %dir %{_libdir}/R
196 %{_libdir}/R/afm
197 %attr(755,root,root) %{_libdir}/R/bin
198 %attr(755,root,root) %{_libdir}/libR*.so
199 %{_libdir}/R/etc
200 %{_libdir}/R/include
201 %{_includedir}/R
202 %{_libdir}/R/share
203 %{_libdir}/R/AUTHORS
204 %dir %{_libdir}/R/library
205 # %{_libdir}/R/doc %except %{_libdir}/R/doc/html/{packages.html,search/index.txt}
206 %dir %{_libdir}/R/doc
207 %{_libdir}/R/doc/[KRm]*
208 %dir %{_libdir}/R/doc/html
209 %{_libdir}/R/doc/html/*.css
210 %{_libdir}/R/doc/html/[Ra-lr-u]*.html
211 %{_libdir}/R/doc/html/packages-head.html
212 %{_libdir}/R/doc/html/*.jpg
213 %dir %{_libdir}/R/doc/html/search
214 %{_libdir}/R/doc/html/search/[A-Z]*
215 %ghost %{_libdir}/R/doc/html/search/index.txt
216 %ghost %{_libdir}/R/doc/html/packages.html
217 %{_desktopdir}/*
218
219 %attr(755,root,root) %{_libdir}/%{name}/modules
220
221 %{_libdir}/%{name}/library/base
222 %{_libdir}/%{name}/library/datasets
223 %{_libdir}/%{name}/library/grid
224 %{_libdir}/%{name}/library/graphics
225 %{_libdir}/%{name}/library/grDevices
226 %{_libdir}/%{name}/library/methods
227 %{_libdir}/%{name}/library/utils
228 %{_libdir}/%{name}/library/tcltk
229 %{_libdir}/%{name}/library/splines
230 %{_libdir}/%{name}/library/stats
231 %{_libdir}/%{name}/library/stats4
232 %{_libdir}/%{name}/library/tools
233
234 %files recommended
This page took 0.5129 seconds and 4 git commands to generate.