]> git.pld-linux.org Git - packages/R.git/blob - R.spec
- fix build
[packages/R.git] / R.spec
1 # TODO:
2 # - move perl R libraries to standard perl location
3 #
4 # Conditional build:
5 %bcond_without  gnome   # without GNOME support
6 #
7 Summary:        A language for data analysis and graphics
8 Summary(pl):    Jêzyk do analizy danych oraz grafiki
9 Name:           R
10 Version:        2.0.1
11 Release:        0.1
12 License:        Mixed (distributable), mostly GPL
13 Group:          Development/Languages
14 # CRAN master site: ftp://cran.r-project.org/pub/R/src/
15 Source0:        ftp://stat.ethz.ch/R-CRAN/src/base/R-2/%{name}-%{version}.tar.gz
16 # Source0-md5:  fb47b1fdef4323031e24d541a2f36b2b
17 # Source0-size: 10676072
18 Source1:        %{name}.desktop
19 URL:            http://www.r-project.org/
20 BuildRequires:  XFree86-devel
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  blas-devel
24 BuildRequires:  gcc-c++
25 BuildRequires:  gcc-g77
26 BuildRequires:  gettext-devel
27 BuildRequires:  libjpeg-devel >= 6b
28 BuildRequires:  libpng-devel >= 1.0.5
29 BuildRequires:  libstdc++-devel
30 BuildRequires:  libtool
31 BuildRequires:  libxml-devel
32 BuildRequires:  perl-base >= 1:5.6
33 BuildRequires:  readline-devel
34 BuildRequires:  tetex-latex
35 BuildRequires:  tetex-dvips
36 BuildRequires:  tetex-pdftex
37 BuildRequires:  zip
38 BuildRequires:  zlib >= 1.1.3
39 #BuildRequires: lpr
40 #Requires:      lpr
41 %{?with_gnome:BuildRequires:    gnome-libs-devel}
42 %{?with_gnome:BuildRequires:    ORBit-devel}
43 %{?with_gnome:BuildRequires:    libglade-gnome-devel}
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 A system for statistical computation and graphics. R consists of a
48 language plus a run-time environment with graphics, a debugger, access
49 to certain system functions, and the ability to run programs stored in
50 script files.
51
52 The design of R has been heavily influenced by two existing languages:
53 Becker, Chambers & Wilks' S and Sussman's Scheme. Whereas the
54 resulting language is very similar in appearance to S, the underlying
55 implementation and semantics are derived from Scheme.
56
57 %description -l pl
58 System do obliczeñ statystycznych i grafiki. R sk³ada siê z jêzyka
59 oraz ¶rodowiska uruchomieniowego z grafik±, debuggerem, dostêpem do
60 niektórych funkcji systemowych oraz mo¿liwo¶ci± uruchamiania programów
61 zapisanych w skryptach.
62
63 Jêzyk R by³ zainspirowany dwoma istniej±cymi jêzykami: S (Beckera,
64 Chambersa i Wilksa) oraz Scheme (Sussmana). R jest podobny do S, ale
65 implementacja i semantyka wywodzi siê ze Scheme.
66
67 %package base
68 Summary:        The R base distribution
69 Summary(pl):    Podstawowa dystrybucja R
70 License:        GPL v2 / LGPL
71 Group:          Development/Languages
72 Requires(post): textutils
73 Requires(post): perl-base
74 Provides:       R-base
75 Provides:       R-datasets
76 Provides:       R-grid
77 Provides:       R-graphics
78 Provides:       R-grDevices
79 Provides:       R-methods
80 Provides:       R-utils
81 Provides:       R-tcltk
82 Provides:       R-splines
83 Provides:       R-stats
84 Provides:       R-stats4
85 Provides:       R-tools
86
87 %description base
88 R is a language and run-time environment for carrying out interactive
89 statistical data analysis. It is not entirely dissimilar to the S
90 language developed at AT&T Bell Laboratories (and now Lucent
91 Technologies). Indeed, S users will find the environment quite
92 familiar and a good deal of S software will run without change under
93 R.
94
95 %description base -l pl
96 R jest jêzykiem i ¶rodowiskiem uruchomieniowym do interaktywnej
97 analizy danych statystycznych. R nie jest ca³kowicie zgodny z jêzykiem
98 S opracowanym w AT&T Bell Laboratiories (a teraz Lucent Technologies),
99 mimo to u¿ytkownicy S zauwa¿± zbli¿one ¶rodowisko, a du¿a czê¶æ
100 oprogramowania w S bêdzie dzia³a³a bez zmian w R.
101
102 %package recommended
103 Summary:        Recommended contributed packages for the R language
104 Summary(pl):    Zalecane dodatkowe pakiety do jêzyka R
105 Group:          Development/Languages
106 Provides:       R-KernSmooth
107 Provides:       R-VR
108 Provides:       R-boot
109 Provides:       R-cluster
110 Provides:       R-foreign
111 Provides:       R-lattice
112 Provides:       R-mgcv
113 Provides:       R-nlme
114 Provides:       R-rpart
115 Provides:       R-survival
116 License:        GPL, free or free for non-commercial use
117 URL:            http://www.ci.tuwien.ac.at/R/
118 Requires(post,postun):  R-base
119 Requires(post,postun):  perl-base
120 Requires(post,postun):  textutils
121 Requires:       R-base = %{version}-%{release}
122 Obsoletes:      R-survival4
123 Obsoletes:      R-MASS
124 Obsoletes:      R-clus
125 Obsoletes:      R-class
126 Obsoletes:      R-nnet
127 Obsoletes:      R-spatial
128
129 %description recommended
130 Packages which extend the capabilities of the R base distribution and
131 are distributed on the Comprehensive R Archive Network (CRAN).
132
133 %description recommended -l pl
134 Pakiety rozszerzaj±ce mo¿liwo¶ci podstawowej dystrybucji jêzyka R,
135 dystrubuowane w archiwum CRAN (Comprehensive R Archive Network).
136
137 %package contrib
138 Summary:        Contributed packages for the R language
139 Summary(pl):    Dodatkowe pakiety do jêzyka R
140 License:        Mixed
141 Group:          Development/Languages
142 URL:            http://www.ci.tuwien.ac.at/R/
143 Requires(post,postun):  R-base
144 Requires(post,postun):  perl-base
145 Requires(post,postun):  textutils
146 Requires:       R-base = %{version}-%{release}
147 Requires:       R-VR
148 Provides:       R-acepack
149 Provides:       R-bootstrap
150 Provides:       R-date
151 Provides:       R-e1071
152 Provides:       R-fracdiff
153 Provides:       R-gee
154 Provides:       R-leaps
155 Provides:       R-oz
156 Provides:       R-polynom
157 Provides:       R-princurve
158 Provides:       R-quadprog
159 Provides:       R-xgobi
160 Obsoletes:      R-principal.curve
161
162 %description contrib
163 Packages which extend the capabilities of the R base distribution and
164 are distributed on the Comprehensive R Archive Network (CRAN).
165
166 %description contrib -l pl
167 Pakiety rozszerzaj±ce mo¿liwo¶ci podstawowej dystrybucji jêzyka R,
168 dystrubuowane w archiwum CRAN (Comprehensive R Archive Network).
169
170 %package mlbench
171 Summary:        Machine learning benchmarks
172 Summary(pl):    Testy wydajno¶ci uczenia maszyny
173 Group:          Development/Languages
174 License:        GPL
175 URL:            http://www.ics.uci.edu/~mlearn/MLRepository.html
176 Requires(post,postun):  R-base
177 Requires(post,postun):  perl-base
178 Requires(post,postun):  textutils
179 Requires:       R-base = %{version}-%{release}
180
181 %description mlbench
182 R package which contains a collection of real-world datasets and
183 functions for creating artificial datasets that work as benchmarks for
184 machine learning methods.
185
186 %description mlbench -l pl
187 Ten podpakiet R zawiera zestaw rzeczywistych danych i funkcji do
188 tworzenia sztucznych danych s³u¿±cych jako test wydajno¶ci metod
189 uczenia maszyny.
190
191 %prep
192 %setup -q
193
194 # These files have the path for Perl hard-coded as /usr/local/bin/perl
195 # We need to remove them to avoid dependency problems
196 rm -f ./doc/keyword-test.orig ./etc/undoc/R-funs.orig ./etc/undoc/extrExamp.orig
197
198 %build
199 %{__aclocal} -I m4
200 %{__autoconf}
201 cp -f /usr/share/automake/config.* .
202 %configure \
203         --with%{!?with_gnome:out}-gnome \
204         --enable-R-shlib \
205         --enable-linux-lfs \
206         --with-zlib \
207         --with-bzlib \
208         --with-pcre \
209         --without-recommended-packages
210
211 %{__make}
212 %{__make} check
213 %{__make} docs
214 %{__make} help
215 %{__make} html
216 %{__make} info
217
218 %install
219 rm -rf $RPM_BUILD_ROOT
220 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/R,%{_includedir},%{_desktopdir}}
221
222 %{__make} install \
223         rhome=$RPM_BUILD_ROOT%{_libdir}/R \
224         mandir=$RPM_BUILD_ROOT%{_mandir} \
225         bindir=$RPM_BUILD_ROOT%{_bindir} \
226         
227
228 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
229
230 find $RPM_BUILD_ROOT%{_libdir}/R -name 'Makefile*' -exec rm -f {} \;
231 mv $RPM_BUILD_ROOT%{_libdir}/R/lib/libR*.so $RPM_BUILD_ROOT%{_libdir}
232 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/include $RPM_BUILD_ROOT%{_includedir}/R
233 ln -sf %{_includedir}/R $RPM_BUILD_ROOT%{_libdir}/R/include
234 rm $RPM_BUILD_ROOT%{_bindir}/%{name}
235 sed -i -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/%{name}
236 ln -sf %{_libdir}/%{name}/bin/%{name} $RPM_BUILD_ROOT%{_bindir}/%{name}
237
238 %clean
239 rm -rf $RPM_BUILD_ROOT
240
241 %post
242 (cd %{_libdir}/R/library; umask 022; cat */CONTENTS > ../doc/html/search/index.txt
243  R_HOME=%{_libdir}/R ../bin/Rcmd perl ../share/perl/build-help.pl --htmllist)
244 /sbin/ldconfig
245
246 %postun -p /sbin/ldconfig
247
248 %files base
249 %defattr(644,root,root,755)
250 %doc COPYRIGHTS FAQ NEWS README RESOURCES THANKS Y2K
251
252 %{_mandir}/man1/R.1*
253 %attr(755,root,root) %{_bindir}/R
254 %dir %{_libdir}/R
255 %{_libdir}/R/afm
256 %attr(755,root,root) %{_libdir}/R/bin
257 %attr(755,root,root) %{_libdir}/libR*.so
258 %{_libdir}/R/etc
259 %{_libdir}/R/include
260 %{_includedir}/R
261 %{_libdir}/R/share
262 %{_libdir}/R/AUTHORS
263 %dir %{_libdir}/R/library
264 # %{_libdir}/R/doc %except %{_libdir}/R/doc/html/{packages.html,search/index.txt}
265 %dir %{_libdir}/R/doc
266 %{_libdir}/R/doc/[KRm]*
267 %dir %{_libdir}/R/doc/html
268 %{_libdir}/R/doc/html/*.css
269 %{_libdir}/R/doc/html/[Ra-lr-u]*.html
270 %{_libdir}/R/doc/html/packages-head.html
271 %{_libdir}/R/doc/html/*.jpg
272 %dir %{_libdir}/R/doc/html/search
273 %{_libdir}/R/doc/html/search/[A-Z]*
274 %ghost %{_libdir}/R/doc/html/search/index.txt
275 %ghost %{_libdir}/R/doc/html/packages.html
276 %{_desktopdir}/*
277
278 %attr(755,root,root) %{_libdir}/%{name}/modules
279
280 %{_libdir}/%{name}/library/base
281 %{_libdir}/%{name}/library/datasets
282 %{_libdir}/%{name}/library/grid
283 %{_libdir}/%{name}/library/graphics
284 %{_libdir}/%{name}/library/grDevices
285 %{_libdir}/%{name}/library/methods
286 %{_libdir}/%{name}/library/utils
287 %{_libdir}/%{name}/library/tcltk
288 %{_libdir}/%{name}/library/splines
289 %{_libdir}/%{name}/library/stats
290 %{_libdir}/%{name}/library/stats4
291 %{_libdir}/%{name}/library/tools
This page took 0.101034 seconds and 4 git commands to generate.