]> git.pld-linux.org Git - packages/R.git/blob - R.spec
- dropped SourceX-size
[packages/R.git] / R.spec
1 # TODO:
2 # - move perl R libraries to standard perl location
3 # - script for rpm to autoprovides/autorequires R internals
4 #
5 # Conditional build:
6 %bcond_without  gnome   # without GNOME support
7 #
8 Summary:        A language for data analysis and graphics
9 Summary(pl):    Jêzyk do analizy danych oraz grafiki
10 Name:           R
11 Version:        2.0.1
12 Release:        3
13 License:        Mixed (distributable), mostly GPL
14 Group:          Development/Languages
15 # CRAN master site: ftp://cran.r-project.org/pub/R/src/
16 Source0:        ftp://stat.ethz.ch/R-CRAN/src/base/R-2/%{name}-%{version}.tar.gz
17 # Source0-md5:  fb47b1fdef4323031e24d541a2f36b2b
18 Source1:        %{name}.desktop
19 URL:            http://www.r-project.org/
20 BuildRequires:  XFree86-devel
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  blas-devel
24 BuildRequires:  bzip2-devel
25 BuildRequires:  gcc-c++
26 BuildRequires:  gcc-g77
27 BuildRequires:  gettext-devel
28 BuildRequires:  libjpeg-devel >= 6b
29 BuildRequires:  libpng-devel >= 1.0.5
30 BuildRequires:  libstdc++-devel
31 BuildRequires:  libtool
32 BuildRequires:  libxml-devel
33 BuildRequires:  perl-base >= 1:5.6
34 BuildRequires:  readline-devel
35 BuildRequires:  tcl-devel
36 BuildRequires:  tetex-latex
37 BuildRequires:  tetex-dvips
38 BuildRequires:  tetex-pdftex
39 BuildRequires:  tk-devel
40 BuildRequires:  zip
41 BuildRequires:  zlib >= 1.1.3
42 #BuildRequires: lpr
43 #Requires:      lpr
44 %{?with_gnome:BuildRequires:    gnome-libs-devel}
45 %{?with_gnome:BuildRequires:    ORBit-devel}
46 %{?with_gnome:BuildRequires:    libglade-gnome-devel}
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 A system for statistical computation and graphics. R consists of a
51 language plus a run-time environment with graphics, a debugger, access
52 to certain system functions, and the ability to run programs stored in
53 script files.
54
55 The design of R has been heavily influenced by two existing languages:
56 Becker, Chambers & Wilks' S and Sussman's Scheme. Whereas the
57 resulting language is very similar in appearance to S, the underlying
58 implementation and semantics are derived from Scheme.
59
60 %description -l pl
61 System do obliczeñ statystycznych i grafiki. R sk³ada siê z jêzyka
62 oraz ¶rodowiska uruchomieniowego z grafik±, debuggerem, dostêpem do
63 niektórych funkcji systemowych oraz mo¿liwo¶ci± uruchamiania programów
64 zapisanych w skryptach.
65
66 Jêzyk R by³ zainspirowany dwoma istniej±cymi jêzykami: S (Beckera,
67 Chambersa i Wilksa) oraz Scheme (Sussmana). R jest podobny do S, ale
68 implementacja i semantyka wywodzi siê ze Scheme.
69
70 %package base
71 Summary:        The R base distribution
72 Summary(pl):    Podstawowa dystrybucja R
73 License:        GPL v2 / LGPL
74 Group:          Development/Languages
75 Requires(post): textutils
76 Requires(post): perl-base
77 Provides:       R-cran-base
78 Provides:       R-cran-datasets
79 Provides:       R-cran-grid
80 Provides:       R-cran-graphics
81 Provides:       R-cran-grDevices
82 Provides:       R-cran-methods
83 Provides:       R-cran-utils
84 Provides:       R-cran-tcltk
85 Provides:       R-cran-splines
86 Provides:       R-cran-stats
87 Provides:       R-cran-stats4
88 Provides:       R-cran-tools
89
90 %description base
91 R is a language and run-time environment for carrying out interactive
92 statistical data analysis. It is not entirely dissimilar to the S
93 language developed at AT&T Bell Laboratories (and now Lucent
94 Technologies). Indeed, S users will find the environment quite
95 familiar and a good deal of S software will run without change under
96 R.
97
98 %description base -l pl
99 R jest jêzykiem i ¶rodowiskiem uruchomieniowym do interaktywnej
100 analizy danych statystycznych. R nie jest ca³kowicie zgodny z jêzykiem
101 S opracowanym w AT&T Bell Laboratiories (a teraz Lucent Technologies),
102 mimo to u¿ytkownicy S zauwa¿± zbli¿one ¶rodowisko, a du¿a czê¶æ
103 oprogramowania w S bêdzie dzia³a³a bez zmian w R.
104
105 %package recommended
106 Summary:        Recommended contributed packages for the R language
107 Summary(pl):    Zalecane dodatkowe pakiety do jêzyka R
108 Group:          Development/Languages
109 Requires:       R-cran-KernSmooth
110 Requires:       R-cran-VR
111 Requires:       R-cran-boot
112 Requires:       R-cran-cluster
113 Requires:       R-cran-foreign
114 Requires:       R-cran-lattice
115 Requires:       R-cran-mgcv
116 Requires:       R-cran-nlme
117 Requires:       R-cran-rpart
118 Requires:       R-cran-survival
119 License:        GPL, free or free for non-commercial use
120 URL:            http://www.ci.tuwien.ac.at/R/
121 Requires(post,postun):  R-base
122 Requires(post,postun):  perl-base
123 Requires(post,postun):  textutils
124 Obsoletes:      R-contrib
125 Requires:       R-base = %{version}-%{release}
126
127 %description recommended
128 Packages which extend the capabilities of the R base distribution and
129 are distributed on the Comprehensive R Archive Network (CRAN).
130
131 %description recommended -l pl
132 Pakiety rozszerzaj±ce mo¿liwo¶ci podstawowej dystrybucji jêzyka R,
133 dystrubuowane w archiwum CRAN (Comprehensive R Archive Network).
134
135 %prep
136 %setup -q
137
138 # These files have the path for Perl hard-coded as /usr/local/bin/perl
139 # We need to remove them to avoid dependency problems
140 rm -f ./doc/keyword-test.orig ./etc/undoc/R-funs.orig ./etc/undoc/extrExamp.orig
141
142 %build
143 %{__aclocal} -I m4
144 %{__autoconf}
145 cp -f /usr/share/automake/config.* .
146 %configure \
147         --with%{!?with_gnome:out}-gnome \
148         --enable-R-shlib \
149         --enable-linux-lfs \
150         --with-zlib \
151         --with-bzlib \
152         --with-pcre \
153         --without-recommended-packages
154
155 %{__make}
156 %{__make} check
157 %{__make} docs
158 %{__make} help
159 %{__make} html
160 %{__make} info
161
162 %install
163 rm -rf $RPM_BUILD_ROOT
164 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/R,%{_includedir},%{_desktopdir}}
165
166 %{__make} install \
167         rhome=$RPM_BUILD_ROOT%{_libdir}/R \
168         mandir=$RPM_BUILD_ROOT%{_mandir} \
169         bindir=$RPM_BUILD_ROOT%{_bindir} \
170         
171
172 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
173
174 find $RPM_BUILD_ROOT%{_libdir}/R -name 'Makefile*' -exec rm -f {} \;
175 mv $RPM_BUILD_ROOT%{_libdir}/R/lib/libR*.so $RPM_BUILD_ROOT%{_libdir}
176 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/include $RPM_BUILD_ROOT%{_includedir}/R
177 ln -sf %{_includedir}/R $RPM_BUILD_ROOT%{_libdir}/R/include
178 rm $RPM_BUILD_ROOT%{_bindir}/%{name}
179 sed -i -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/%{name}
180 ln -sf %{_libdir}/%{name}/bin/%{name} $RPM_BUILD_ROOT%{_bindir}/%{name}
181
182 %clean
183 rm -rf $RPM_BUILD_ROOT
184
185 %post
186 (cd %{_libdir}/R/library; umask 022; cat */CONTENTS > ../doc/html/search/index.txt
187  R_HOME=%{_libdir}/R ../bin/Rcmd perl ../share/perl/build-help.pl --htmllist)
188 /sbin/ldconfig
189
190 %postun -p /sbin/ldconfig
191
192 %files base
193 %defattr(644,root,root,755)
194 %doc COPYRIGHTS FAQ NEWS README RESOURCES THANKS Y2K
195
196 %{_mandir}/man1/R.1*
197 %attr(755,root,root) %{_bindir}/R
198 %dir %{_libdir}/R
199 %{_libdir}/R/afm
200 %attr(755,root,root) %{_libdir}/R/bin
201 %attr(755,root,root) %{_libdir}/libR*.so
202 %{_libdir}/R/etc
203 %{_libdir}/R/include
204 %{_includedir}/R
205 %{_libdir}/R/share
206 %{_libdir}/R/AUTHORS
207 %dir %{_libdir}/R/library
208 # %{_libdir}/R/doc %except %{_libdir}/R/doc/html/{packages.html,search/index.txt}
209 %dir %{_libdir}/R/doc
210 %{_libdir}/R/doc/[KRm]*
211 %dir %{_libdir}/R/doc/html
212 %{_libdir}/R/doc/html/*.css
213 %{_libdir}/R/doc/html/[Ra-lr-u]*.html
214 %{_libdir}/R/doc/html/packages-head.html
215 %{_libdir}/R/doc/html/*.jpg
216 %dir %{_libdir}/R/doc/html/search
217 %{_libdir}/R/doc/html/search/[A-Z]*
218 %ghost %{_libdir}/R/doc/html/search/index.txt
219 %ghost %{_libdir}/R/doc/html/packages.html
220 %{_desktopdir}/*
221
222 %attr(755,root,root) %{_libdir}/%{name}/modules
223
224 %{_libdir}/%{name}/library/base
225 %{_libdir}/%{name}/library/datasets
226 %{_libdir}/%{name}/library/grid
227 %{_libdir}/%{name}/library/graphics
228 %{_libdir}/%{name}/library/grDevices
229 %{_libdir}/%{name}/library/methods
230 %{_libdir}/%{name}/library/utils
231 %{_libdir}/%{name}/library/tcltk
232 %{_libdir}/%{name}/library/splines
233 %{_libdir}/%{name}/library/stats
234 %{_libdir}/%{name}/library/stats4
235 %{_libdir}/%{name}/library/tools
236
237 %files recommended
This page took 1.956975 seconds and 4 git commands to generate.